Construction de ma CNC en Alu (Aide?)

  • Auteur de la discussion Juluan
  • Date de début
V
vres
Compagnon
Juste pour éclaircir : c'est 120W/80V = 1.5 A (et non pas 80/120)
120W consommés pour 100W délivrés, donc les moteurs ont un rendement de 80% environ. C'est cela l'ordre de grandeur, ou c'est juste un exemple ?
C'est valable pour les servo comme pour les pas à pas ?
merci, pour la rectification:wink:
C'est juste un exemple, 100W c'est vraiment beaucoup et ça serait vraiment impulsionnel. A l'arrêt il y a aussi la réduction de courant, et en rotation il faut ajouter les pertes fer.
Si le moteur ne delivre que 50W le rendement ne sera pas le même. Le rendement d'un moteur PàP n'est pas une valeur fixe
Pour le servomoteur c'est différent car il n'est pas alimenté en courant fixe, donc les pertes joules ne sont pas fixes comme sur le PàP, et peuvent même être nulle à l'arrêt.
 
Juluan
Juluan
Apprenti
A l'arrêt la seule chose qui consomme sur ton moteur c'est la résistance. Si ton moteur fait 2ohms et 5A la puissance est donc de 2X2X5 = 20W donc ton alimentation fait 40V elle va délivrer 20/40 = 0,5A.
Maintenant si ton moteur délivre une puissance de 100W ( 130kg de poussée a 5000mm/min) il va avoir une puissance totale de 120W donc ton alim va délivrer 120/40 = 3A. Maintenant si tu remplaces ton Alim 40V par une Alim 80V elle va délivrer pour la même configuration 80/120 = 1.5.
Tu vois que le courant de l'alim nest pas uniquement lié au courant du moteur.
Vu l'exemple que je t'ai donné,si tu comptes 200W par moteur tu as de la marge.

j’essaie d'appliquer ton calcul à ma situation mais je pense ne pas avoir les bonnes données, le résultat est plutôt rocambolesque.

Capture pap.JPG


C'est pas ces Ohms là dont tu dois parler je pense.
C'est une mesure à relever?


non, simplement le moteur ne donne pas sa toute puissance. Le drivers à une limite en courant, si elle est plus petite que le courant max du moteur, on a simplement moins de couple. En gros, on a dépenser de l'argent pour rien en achetant un trop gros moteur, mais cela fonctionne...
Inversement, si on a acheter un divers capable de déliver plus de courant que n'est capable d'absorber le moteur, il faut, par programmation, limiter le courant en sortie drivers, si non on risque de griller le moteur.

Clairement je suis dans la deuxième situation que tu explique. Et je crois que moteur driver sont déjà appareillés.
A vérifier.
 
V
vres
Compagnon
C'est pas ces Ohms là dont tu dois parler je pense.
si mais j'ai fait un grosse erreur j'ai fait 2X2X5 au lieu de 2X5X5 ( RI²) donc 50W. :oops:

Il faut lire :
A l'arrêt la seule chose qui consomme sur ton moteur c'est la résistance. Si ton moteur fait 2ohms et 5A la puissance est donc de 2X5X5 = 50W donc ton alimentation fait 40V elle va délivrer 50/40 = 1.25A
Maintenant si ton moteur délivre une puissance de 100W ( 130kg de poussée a 5000mm/min) il va avoir une puissance totale de 150W donc ton alim va délivrer 150/40 = 3.75 Maintenant si tu remplaces ton Alim 40V par une Alim 80V elle va délivrer pour la même configuration 150/40 = 1.875A
Tu vois que le courant de l'alim n'est pas uniquement lié au courant du moteur.
Vu l'exemple que je t'ai donné, si tu comptes 200W par moteur tu as de la marge.
 
Juluan
Juluan
Apprenti
si je prend tes valeurs on a 0.37X5.8X5.8 = 12.44W sans la reduction de courant.

Donc limite ce genre de moteur pourrait tourner qu'avec 12 ou 15W, je pensais que ça prenait plus que cela.
Je comprend mieux les choses, lorsque j’évoque les alims de 900w pour un seul moteur... :smt021
Je ne réalisais pas la consommation qu'un moteur pouvait avoir, j'imaginai beaucoup plus que cela.
 
V
vres
Compagnon
Oui mais c'est seulement à l'arrêt et encore avec une réduction de moité du courant tu divise encre cette puissance par 4.
Avec cette puissance tu ne fais rien tourner, il faut rajouter la puissance mécanique restituéé.

Prend une alim avec 200W ou 250W par moteur et tu seras tranquille.
 
Juluan
Juluan
Apprenti
Oui mais c'est seulement à l'arrêt et encore avec une réduction de moité du courant tu divise encre cette puissance par 4.
Avec cette puissance tu ne fais rien tourner, il faut rajouter la puissance mécanique restituée.

Prend une alim avec 200W ou 250W par moteur et tu seras tranquille.


Ha oui d'accord.
Merci pour la suggestion 200w / 250w, je prends note.
Maintenant je devrais pouvoir faire mon choix avec plus de stratégie.

Merci les gars.
 
Juluan
Juluan
Apprenti
Dernière acquisition, ma future armoire de commande, une belle boiboite inox achetée sur LBcoin. Double compartiment qui me permettra de séparer alimentations et cartes de contrôle. Et divers orifices pour une bonne ventilation que je vais assister par des ventilos de PC de récupération. Et même un compartiment pour installer un filtre pour l'entrée d'air.

Avec quelques trous supplémentaires, rails et autres bricoles je devrai pouvoir y installer tout électriques de ma CNC.
Je vais bien m'amuser. :wink:

P_20180503_222503.jpg


P_20180503_222610.jpg
 
Juluan
Juluan
Apprenti
Mon projet a grandement avancé. Je dirais même qu'il devrait bientot toucher a ca fin.
P_20180620_002746.jpg


Je suis en phase de tests et reglages, et je vais changer 2 ou 3 choses sur la machine.
J'ai deja rehaussé la course de l'axe Z, j'avais pris de la marge lors de la conception et je me suis rendu compte que je pouvais aisément l'exploiter. Je suis passé d'une course d'environ 150mm à 250mm. Ca laisse de quoi faire...

Par ailleurs, j'avais utilisé une seule et unique courroie pour piloter les deux VAB de l'axe X, avec plusieur poulies de guidage et une de tension, je me rends compte, enfin je pense, que cette methode tir trop sur les differentes chicanes, et avec la tension qu'il faut appliquer sur la courroie j'ai l'impression que ca reduit les capacités de couple du moteur en partie absorbée par tout ce systeme. Je vais donc passer en deux courroies je penses que le mouvement sera plus fluide ainsi. Qu'en dite vous?
P_20180618_024007.jpg


Le fameux systeme simple courroie que je vais changer.


J'ai aussi une petite question. Est ce que vous aussi vous entendez un petit bruit des billes de vos vis a billes en mouvement? J'ai beau les graisser, ca s'atténue un temps mais ca revient toujours. Je soupçonne une contrainte quelque par.
 
Momoclic
Momoclic
Compagnon
Bonjour,
Tu aurais pu mettre deux galets de moins, et une courroie plus courte. Un des deux galets restant assurerait la tension de la courroie.
Ce serait peut-être plus simple, moins de modifications, que de mettre deux courroies ?
 
J
Jmr06
Compagnon
Bonjour
+1 avec @Momoclic . Pourquoi tant de galets ? Normalement, un seul devrait suffire.
Je pense aussi que les galets ne doivent par être sur ressort mais être fixe, tendu une fois pour toute.
Enfin, on peut utiliser un galet si on utilise le dos lisse de la courroie, mais on doit prendre une poulie si on utilise la face dentée.
 
Juluan
Juluan
Apprenti
Oui effectivement trop de galets...
Pour le ressort c’est juste un rappel lorsque je desserre le tendeur c’est pas lui qui exerce la tension. C’est a faire a la main.
Toujours est il que ce systeme ne me plais pas au final, la platine support de galets est trop souple (alu 6mm), j’y observe des très légères flexions lors de la mise en vitesse du moteur. A mon gout ca tire trop avec tous ces retours d’angle prochent de 90°.


PS: une petite photo de mon sapin de noel. :lol:

P_20180712_160932.jpg
 
Dernière édition:
J
Jmr06
Compagnon
C'est très propre.
Les indicateurs surveillent les courant/tension en entrée des drivers ? C'est pour voir les surcharges éventuelles ?
 
ingenieu59
ingenieu59
Compagnon
Bonjour,

oui, c' est très propre .
Et, lorsque tu entendras des pertes de pas, tu verras si le voltage dégringole ou pas ou les ampères .
 
Algone
Algone
Ouvrier
Il est terrible ton boitier beau boulot, c'est simple à brancher tes afficheurs? En parallèle?
 
V
vres
Compagnon
On dirait un coffret d'imprimante Domino:smt104
Si tes drivers n'ont pas de condensateur en entrée, la mesure du courant peut être faussée.
 
Juluan
Juluan
Apprenti
Bonjour,

oui, c' est très propre .
Et, lorsque tu entendras des pertes de pas, tu verras si le voltage dégringole ou pas ou les ampères .
Merci pour le compliment, quand au pertes de pas, je ne sais pas je n'ai jamais vu encore comment cela pourrait se comporter.

Il est terrible ton boitier beau boulot, c'est simple à brancher tes afficheurs? En parallèle?
Les afficheurs sont simple à branché et en plus vraiment vraiment pas cher... https://fr.aliexpress.com/item/Mini...957.html?spm=a2g0s.9042311.0.0.27426c374HbDH9
Merci les :smileJap:

On dirait un coffret d'imprimante Domino:smt104
Si tes drivers n'ont pas de condensateur en entrée, la mesure du courant peut être faussée.
je viens de regarder les coffrets d'armoire pour imprimante DOMINO, c'est exactement ça et je ne le savais pas.
A100%20domino.png

Bon la mienne était complétement vide et pas de clavier, seul l’écran vert était présent je me suis même demandé si je pouvais en faire quelque chose mais.... non en faite, trop compliqué... (a vendre si ça intéresse quelqu'un)
En tous cas, merci pour l'info du coup, je sais ce qu'elle était avant.

Quand à l'histoire de condensateur, je ne savais pas. Perso quand j'ai vu que la tension affichée correspondait à celle des alim et celle de mon multimètre (un pouilleme d'erreur quand même, genre 24v sur affichage et 24.1v sur le multi) j'ai pas cherché plus loin.
Après, je n'ai pas pensé à comparer l’ampérage.
 
ingenieu59
ingenieu59
Compagnon
Bonjour,

c' est vrai que pour le prix, c' est très intéressant .
 
V
vres
Compagnon
Après, je n'ai pas pensé à comparer l’ampérage.
Le courant entre le driver et l'alimentation peut être très trituré en raison du découpage et du recyclage des décharges inductives. Il est difficilement mesurable avec un Ampèremètre classique. En revanche un condensateur va lisser le courant en amont et là la mesure sera possible.
 
ingenieu59
ingenieu59
Compagnon
Bonjour cncserv,

aurais-tu un petit branchement à nous communiquer ( ainsi que la capacité du condo ) pour voir l' intensité absorbée par les stepper motors .
 
Algone
Algone
Ouvrier
J'ai commandé les afficheurs et les condos au passage, je testerai ça très bientôt
 
Juluan
Juluan
Apprenti
Bonjour a tous, de retour parmis vous avec une cnc quasi operationnelle, après presque 2 ans d’efforts et de depenses je suis presque au bout. Hier je me suis penché sur le rattrapage de jeu ( backlash ) de mes axe via Mach3, j’y ai compensé 0.24mm en x
0.08mm en y
Et rien en z, du moins rien que mon comparateur puisse mesurer precisement.

Donc 0.24 en x cela m’a tout de meme interpelé, apres lecture de differents sujets sur les backlash, je penses qu’une intervention mecanique doit etre envisager pour reduir le jeu en X. J’ai d’abord pensé a doubler les ecrous en precontrainte. Mais je me suis demandé aussi si je ne pouvais pas essayer de contraindre legerement les ecrous en axe X, d’une vis par rapport a l’autre. Par exemple la vab droite contrainte legerement en + et celle de gauche legerement en -
Vous me suivez?

Vous en pensez quoi les experts?
 
E
el patenteux
Compagnon
Ca va mettre le portique de travers et bousiller l'équerage X et Y....................a moin que j'ai mal compris.
 

Sujets similaires

C
Réponses
46
Affichages
2 344
chene dinspiration
C
Atelier Vosgien
Réponses
18
Affichages
1 175
tchitchater
T
Haut