Déchargement du filament non voulu.

françois44

françois44

Modérateur
Bonjour à tous.

Je rencontre, depuis très peu de temps, un souci avec mon imprimante (Longer LK4 pro = Alfawise U30 pro).
Je n'ai jamais modifié le firmware de l'imprimante et mes paramètres dans Cura sont les mêmes depuis un moment.

Quand je lance une impression, au démarrage, la tête vient se positionner à son point de départ puis, juste ensuite, le filament est déchargé par l'extrudeur! Si je ne fais rien, l'impression démarre dès l'arrêt de l'extrudeur, sans bien sur déposer de filament.

La seule solution que j'aie, pour le moment, c'est de libérer l'extrudeur dès qu'il commence à tirer le filament, ensuite, je pousse le filament jusque dans la tête et dès que l'extrudeur s'arrête, je le relâche.

Mais j'aimerai surtout savoir ce qui a changé pour arriver à ce résultat.
 
MegaHertz

MegaHertz

Compagnon
Bonjour,

Apparement tu charges ton filament et derrière tu lances le Gode et c'est de là que vient ton soucis.
; -- START GCODE --
G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28 X0 Y0 ;move X/Y to min endstops
G28 Z0 ;move Z to min endstops
G1 Z1 F1000 ;move up slightly
G1 Y60.0 Z0 E9.0 F1000.0;intro line
Le premier mouvement d'extrusion demande un E9.0 mais vu qu'il n'y a pas de G92 E0 avant il peu très bien tourner en arrière si tu as fait plus de 9mm par exemple pour charger ton filament.
Si juste avant de lancer le print tu éteins et tu rallumes l'imprimantes ou si tu fais un RESET tu n'auras plus de problème.

Mais comment vraiment régler le problème ?
Dans le START GCode de ton slicer je te conseille de mettre un G92 E0 juste après le M82.
 
simplet

simplet

Compagnon
Bonjour,

Apparement tu charges ton filament et derrière tu lances le Gode et c'est de là que vient ton soucis.

Le premier mouvement d'extrusion demande un E9.0 mais vu qu'il n'y a pas de G92 E0 avant il peu très bien tourner en arrière si tu as fait plus de 9mm par exemple pour charger ton filament.
Si juste avant de lancer le print tu éteins et tu rallumes l'imprimantes ou si tu fais un RESET tu n'auras plus de problème.

Mais comment vraiment régler le problème ?
Dans le START GCode de ton slicer je te conseille de mettre un G92 E0 juste après le M82.
T'as été plus rapide que moi xD
 
françois44

françois44

Modérateur
Bonjour,

Apparement tu charges ton filament et derrière tu lances le Gode et c'est de là que vient ton soucis.

Le premier mouvement d'extrusion demande un E9.0 mais vu qu'il n'y a pas de G92 E0 avant il peu très bien tourner en arrière si tu as fait plus de 9mm par exemple pour charger ton filament.
Si juste avant de lancer le print tu éteins et tu rallumes l'imprimantes ou si tu fais un RESET tu n'auras plus de problème.

Mais comment vraiment régler le problème ?
Dans le START GCode de ton slicer je te conseille de mettre un G92 E0 juste après le M82.
Ça signifie que je dois éditer le code avant chaque impression?
Désolé si ma question semble naïve mais je n'ai encore jamais touché à ça. Le reset, il se fait comment? Ce problème est apparu brutalement, depuis que j'ai l'imprimante, je ne l'avais jamais rencontré et j'utilise toujours la même version de Cura.
 
simplet

simplet

Compagnon
Ça signifie que je dois éditer le code avant chaque impression?
Désolé si ma question semble naïve mais je n'ai encore jamais touché à ça. Le reset, il se fait comment? Ce problème est apparu brutalement, depuis que j'ai l'imprimante, je ne l'avais jamais rencontré et j'utilise toujours la même version de Cura.
Hello,
Normalement dans ton slicer tu as un onglet "script de démarrage" et c'est la dedans que tu édites, ensuite tu enregistre ton profil et plus besoin de l'éditer dans le future.
 
S

speedjf37

Compagnon
Bonjour,

Je rencontre, depuis très peu de temps, un souci avec mon imprimante (Longer LK4 pro = Alfawise U30 pro).
Je n'ai jamais modifié le firmware de l'imprimante et mes paramètres dans Cura sont les mêmes depuis un moment.
Si possible comparer des fichiers Gcode Avant/Après problème.(sauver le Gcode avant de regénérer avec le slicer )

Cura est lancé directement ou à travers un autre logiciel (Repetier chez moi).

Y a t'il eu des mises à jour récemment ?

PS) Il est évident que les déplacements en manuel sont toujours corrects (vérifiés) (sens + longueur)*

JF
 
MegaHertz

MegaHertz

Compagnon
Ça signifie que je dois éditer le code avant chaque impression?
Désolé si ma question semble naïve mais je n'ai encore jamais touché à ça. Le reset, il se fait comment? Ce problème est apparu brutalement, depuis que j'ai l'imprimante, je ne l'avais jamais rencontré et j'utilise toujours la même version de Cura.
Bonjour,

Le Start GCode que tu as dans ton fichier vient de la partie notée 4 dans la partie réglage imprimante de Cura :
Ultimaker-Cura-custom-printer-parameters.png


Dans Start GCode tu ajoutes juste un G92 E0 avant le premier G1 et ça devrait résoudre ton petit problème.
 
françois44

françois44

Modérateur
Merci beaucoup pour tous ces éclaircissements!
J'ai enfin trouvé le start-code, mais il y a déjà un G92 E0 au-dessus du premier G1...

; LONGER Start G-code
G21 ; metric values
G90 ; absolute positioning
M82 ; set extruder to absolute mode
M107 ; start with the fan off
G92 E0 ; Reset Extruder
G28 ; Home all axes
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
G92 E0 ; Reset Extruder
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish

Et dans le fichier que j'ai mis ce matin, après "end of start-code, il y a encore deux G92 E0
 
simplet

simplet

Compagnon
mais le fichier que tu as poster c'est pris sur la bécanne ? Si oui, c'est un script qu'il lis avant de lire le Gcode, il te faut le modifier
 
MegaHertz

MegaHertz

Compagnon
Voici un copier collé des premières lignes du GCode que tu as envoyé :
;FLAVOR:Marlin
;TIME:4235
;Filament used: 1.13181m
;Layer height: 0.1
;MINX:88.725
;MINY:81.677
;MINZ:0.2
;MAXX:145.72
;MAXY:132.938
;MAXZ:14.8
;Generated with Cura_SteamEngine 4.4.0
M140 S60
M105
M190 S60
M104 S200
M105
M109 S200
M82 ;absolute extrusion mode
; -- START GCODE --
G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28 X0 Y0 ;move X/Y to min endstops
G28 Z0 ;move Z to min endstops
G1 Z1 F1000 ;move up slightly
G1 Y60.0 Z0 E9.0 F1000.0;intro line
G1 Y100.0 E21.5 F1000.0 ;continue line
G92 E0 ;zero the extruded length again
G1 F80
;Put printing message on LCD screen
M117 Printing...
; -- end of START GCODE --

Pas la moindre trace du commentaire
; LONGER Start G-code
Pas non plus la moindre trace d'un G92 E0 avant le premier G1

Le start GCode que tu as trouvé dans Cura n'est pas celui de l'imprimante utilisée quand tu as slicé ce fichier.
Peut être que la longer n'est pas l'imprimante selectionnée ?
 
françois44

françois44

Modérateur
Le "vrai" start-code c'est celui posté en second.
 
MegaHertz

MegaHertz

Compagnon
J'ignore pourquoi le start GCode utilisé par Cura ne correspond pas à celui que tu as mais le fait est que dans le fichier qui te pose le problème de la marche arrière de l'extrudeur il manque un G92 E0 et il y'a d'autres différences.
Ci dessous j'ai mis côte à côte le start GCode qu'on a dans le fichier et celui que tu as dans les settings
1648536022379.png


J'ai lancé Cura (4.13.1) et il n'est pas possible d'éditer le start GCode si on a pas selectionné l'imprimante.
Le Start GCode que tu as ne peut être que celui de l'imprimante selectionnée, même si tu en as défini plusieurs.

Le GCode que tu as extrait ne correspond pas à celui qu'il a utilisé pour produire le fichier.
Est ce que tu as lancé le slice depuis Cura ou est ce que tu as utilisé un logiciel qui utillise Cura (Repetier Host par exemple) ?

Une autre possibilité c'est un plugin de Cura qui viendrait interferer avec le comportement normal.

Re-slices voir le bidule et vérifies dans le GCode si tu retrouves la ligne
; LONGER Start G-code
 
françois44

françois44

Modérateur
Le slice a été lancé depuis cura directement (une seule imprimante enregistrée, pas de plugins.
Ce soir je n'ai pas le temps mais demain je ferai d'autres essais.

Merci pour tous ces conseils.
 
françois44

françois44

Modérateur
Bon, j'ai résolu mon souci d'une façon beaucoup plus simple... j'ai mis à jour Cura! Et depuis plus de déchargement de filament imprévu. :wink:
Par-contre, il me reste un petit soucis (existant déjà auparavant). Malgré un bon réglage du levelling, j'ai toujours un petit phénomène d'écrasement des premières couches.
J'ai imprimé le cube de test classique (20x20x20) j'ai 19.99 en X, 20.01 en Y et 19.66 en Z... mes couches à la base font 20.26 de large.

Y a t'il un moyen d'améliorer ça autre qu'imprimer sur un radeau?
 
MegaHertz

MegaHertz

Compagnon
Bonjour,

-0.34mm en Z ça me parait effectivement beaucoup.

Les 0.13mm de pate d'éléphant c'est normal avec une couche autour de 0.25mm.
Le défaut de pate d'éléphant est en général de la moitié de la hauteur de couche.
Si c'est plus que ça ça veut dire que ta première couche est trop écrasée.
Pour compenser ce défaut il y'a le setting 'Initial layer horizontal expansion'

Ton défaut en Z peut avoir plusieurs explications.

Le nombre de pas en Z
Je viens de regarder sur Github : c'est 400 à l'origine.
Tu peux peut être ajouter un M92 Z400 dans ton start GCode.
En Z il ne faut surtout pas s'amuser à calibrer parce qu'on a une vis sans fin et que le nombre de pas dépend directement du pas de la vis.

Setting d'arrondi
Dans Cura il y'a un setting pour décider de comment le slicer va arrondir en Z.
Tu peux choisir de dépasser, rester en dessous ou être médian
En anglais le setting s'appelle 'Slicing tolerance'
Par défaut il est à Middle : c'est censé être la meilleur précision.

Réglage du BL-TOUCH
Si tu utilises l'autolevelling il suffit que le capteur soit mal réglé et qu'il enclenche un peu au dessus de l'extrémité de la buse pour avoir une première couche trop écrasée.
Pour vérifier ça tu fais un levelling manuel et ensuite un levelling auto.
Sur les points que tu as utilisé en manuel le levelling auto doit indiquer 0 dans l'idéal et en tout cas pas plus de .1 ou -.1.
Si ça dépasse +-0.1 il faudra régler (petite vis sur le capteur ?)
 
Dernière édition:
MegaHertz

MegaHertz

Compagnon
Vérifies voir le Z que tu as sur la dernière couche dans le GCode

Comment faire ?
Tu ouvres le fichier dans un éditeur (Wordpad, notepad...) et tu vas à la fin.
Tu remontes jusqu'à ce que tu croises un commentaire avec ;LAYER:

Si je reprends le fichier que tu avais fourni et que je retrouve la derbière couche je lis :

;MESH:NONMESH
G0 F600 X102.184 Y107.892 Z14.8
G0 F7200 X102.373 Y108.044
;TIME_ELAPSED:4234.967662
;LAYER:146
G1 F2100 E1126.78524
;TYPE:WALL-OUTER

;LAYER:146
est la dernière couche du fichier
Juste au dessus tu as un MESH:NONMESH qui correspond à la mise à hauteur pour cette couche.
Dans le fichier que tu avais fourni la hauteur programmée était de 14.8
 
françois44

françois44

Modérateur
Merci beaucoup pour tous ces conseils. Je "digère" tout ça et je reviens donner des nouvelles...
 

Sujets similaires

G
Réponses
42
Affichages
661
Nico91
Nico91
simplet
Réponses
143
Affichages
5 067
MegaHertz
MegaHertz
D
Réponses
40
Affichages
1 402
Doctor_itchy
D
T
Réponses
22
Affichages
851
MegaHertz
MegaHertz
R
Réponses
20
Affichages
498
Hubert86
H
usitour
Réponses
27
Affichages
1 178
MegaHertz
MegaHertz
B
Réponses
2
Affichages
1 253
bru42
B
M
Réponses
12
Affichages
2 101
Gege063
Gege063
J
Réponses
13
Affichages
1 373
jackouille07
J
tranquille
Réponses
55
Affichages
19 856
J-Max
J-Max
V
Réponses
213
Affichages
44 914
Korgar
Korgar
Haut