Probléme TB6600/Nema17

  • Auteur de la discussion Gaamma
  • Date de début
Gaamma
Gaamma
Nouveau
Bonjour à tous.:)

J’ai un souci avec mon TB6600 (version boitier) et mon moteur PaP Nema-17 (17HS1352-P4130).

J’ai testé plusieurs schémas de connexion sur mon Arduino Uno, mais ! Rien à faire il ne tourne pas correctement.
Niveau logiciel j’utilise GRBL-2.
Symptômes du moteur sur les différents tests : tremblement, très peu puissant, changement de direction,

Je dois avoir un problème de réglages des petits interrupteurs situés sur le TB6600, je me suis référé à la fiche technique du moteur et le tableau imprimé sur le TB6600 et cela a fonctionné sur un test de rotation gauche / droite sur l’Arduino.

J’ai donc voulu testé l’axe Y de ma CNC avec cette configuration de rotation gauche /droite, qui avait l’air de fonctionner, et là ! Je me suis rendu compte du manque de puissance, tremblement.

Le chariot monté sur l’axe Y que j’ai voulu testé avec le moteur, lui fonctionne très bien, et glisse parfaitement sur son rail sans résistance.

Je suis un peu perdu et de l’aide serait bienvenue.

Merci par avance et bonne journée:)
 
jpbbricole
jpbbricole
Compagnon
Bonjour Gaamma

Je ne connais, malheureusement, pas le TB6600 mais GRBL, je peux t'aider.
Niveau logiciel j’utilise GRBL-2.
Je ne connais pas cette version, c'est 0.9x ou 1.1x ?
Dans le programme qui sert de console GRBL, fais la commande $$ puis poste le résultat afin que l'on puisse vérifier les paramètres GRBL.

Cordialement
jpbbricole
 
Gaamma
Gaamma
Nouveau
Merci à vous pour vos réponses.:-D

Oui c’est bien la version 1.1, de grbl
Je n’arrive pas à copier le résulta de ($$) ?? copier/collé ne fonctionne pas.:sad:

Pour le tb6600 j’en n’ais acheté 4 et 4 nema-17, ça serais c.. que cela ne fonctionne pas ensembles !!:sad::sad::sad::sad:

« 4A, beaucoup trop pour un Nema17, mais tu peux régler l’ampérage: inférieur a 2A un nema17 rarement supérieur a 2A après, tu affine.»

comment fait-vous ça :?::?:

Grand Merci à Vous pour votre aide:wavey:

Seb.
 
Gaamma
Gaamma
Nouveau
programmes:
UniversalGcodeSender /grbl

Pour info je suis nouveau dans le monde de la CNC, j’adore bricolé et j'ai trouvé ce projet sympa , j’ai les photos de l’avancement de ma CNC ici : https://photos.app.goo.gl/eSpCymhV3e1e6Yx28
J’ai suivi strictement les plans de MakerMan ici : mais pas très clair au niveau du schéma électrique
Voila ! Si ça peu vous aidez sur mon problème.
Bonne soirée à tous
 
H
Hubert86
Compagnon
Quel arduino? deja le Uno avec le grbl 1.1, il reste plus beaucoup de mémoire, pour le uno faut la V0.9. La version 1.1 pour le méga 2560 mais la les entrées sont différentes que pour l' Uno. UGS c'est ce que j'utilise. Si t'utilise pas de laser, y a pas beaucoup d'amélioration par rapport a la V0.9. pour l'intensité c' est marqué dessus switch 123 et pour le pas 456,. Intensité je mettrai: 1,2 A puis 1,8 A, a voir. Pour les pas: 1/2 si plus tu peux perdre des pas, mais bon a toi d'affiner.
 
Dernière édition:
Gaamma
Gaamma
Nouveau
bonjour a tous...
c'est un UNO, ok pour la version 0.9
pour l'intensité, je joins une photo de mon tb6600.
je sais pas trop quoi faire...et j'ai peur d’abîmé quelque chose!
merci à vous pour votre aide..
20180806_074718.jpg
20180806_073635.jpg
 
jpbbricole
jpbbricole
Compagnon
deja le Uno avec le grbl 1.1, il reste plus beaucoup de mémoire, pour le uno faut la V0.9. La version 1.1 pour le méga 2560....
GRBL 1.1 est fait, entre autre, pour le UNO, seul le Nano pose problème, il faut enlever le bootstrap pour libérer de la mémoire. D'ailleurs sur le site GRBL wiki flashing, tout les test sont faits avec un UNO. Perso je ne pense pas que la version GRBL puisse influencer sur la bonne marche des MPAP.
Je n’arrive pas à copier le résulta de ($$) ??
Il est important d'avoir ces paramètres, c'est là que se règlent les paramètres de commande de tes moteurs comme la vitesse.
Avec GRBL 1.1, et UGS 2.0 Classic ou Platform,:
Command: $$
Clic dans la fenête Console, ctrlA, ctrlC (tout sélectionner et copier) et coller dans le post.

Cordialement
jpbbricole
 
Gaamma
Gaamma
Nouveau
Ok pour GRBL




**** Connected to COM6 @ 115200 baud ****
Grbl 1.1f ['$' for help]

$0 = 10 (Step pulse time, microseconds)
$1 = 25 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 0 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 3 (Status report options, mask)
$11 = 0.020 (Junction deviation, millimeters)
$12 = 0.002 (Arc tolerance, millimeters)
$13 = 0 (Report in inches, boolean)
$20 = 0 (Soft limits enable, boolean)
$21 = 0 (Hard limits enable, boolean)
$22 = 0 (Homing cycle enable, boolean)
$23 = 0 (Homing direction invert, mask)
$24 = 50.000 (Homing locate feed rate, mm/min)
$25 = 500.000 (Homing search seek rate, mm/min)
$26 = 250 (Homing switch debounce delay, milliseconds)
$27 = 1.000 (Homing switch pull-off distance, millimeters)
$30 = 1000 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 0 (Laser-mode enable, boolean)
$100 = 250.000 (X-axis travel resolution, step/mm)
$101 = 250.000 (Y-axis travel resolution, step/mm)
$102 = 250.000 (Z-axis travel resolution, step/mm)
$110 = 500.000 (X-axis maximum rate, mm/min)
$111 = 500.000 (Y-axis maximum rate, mm/min)
$112 = 500.000 (Z-axis maximum rate, mm/min)
$120 = 10.000 (X-axis acceleration, mm/sec^2)
$121 = 10.000 (Y-axis acceleration, mm/sec^2)
$122 = 10.000 (Z-axis acceleration, mm/sec^2)
$130 = 200.000 (X-axis maximum travel, millimeters)
$131 = 200.000 (Y-axis maximum travel, millimeters)
$132 = 200.000 (Z-axis maximum travel, millimeters)
ok
 
jpbbricole
jpbbricole
Compagnon
J'ai contrôlé avec mes paramètres, j'ai les mêmes (Nema17 driver A4988).
Pourrais-tu nous montrer le schéma de câblage ainsi que la position des switches.

Cordialement
jpbbricole
 
Gaamma
Gaamma
Nouveau
j'ai suivi le schéma si dessous, mais comme ct pas clair au niveau des connections sur le tb6600
j'ai laisser tombé .


la seul fois ou ça a peu prés bien fonctionné : "je me suis référé à la fiche technique du moteur et le tableau imprimé sur le TB6600 et cela a fonctionné sur un test de rotation gauche / droite sur l’Arduino."
après j'ai pas trop insisté de peur de cramé quelque chose.
merci à vous
shemas.jpg
20180806_102407.jpg
 
H
Hubert86
Compagnon
je suis d"accord, pour le fonctionnement des pas a pas, mais c'etait plutot dans le but d'une certaine globalité. j'utilise des UNO et le programme me dit très peu de mémoire dispo, donc nativement pas assez de mémoire sans des bidouillages, hein.
Maintenant pour le courant, bah tiens pas compte de ce que j'ai dit pour les switchs, sur le tien c'est inversé. Mais l' idée est la même, commence par désaccoupler ton moteur si ce n'est déjà fait. positionne tes switchs pour un 1 A, et progresse jusqu'a ce que ça soit correct; mais dépasse pas 2A de plus regarde je crois que tu as inverse pulse et direction.
 
Gaamma
Gaamma
Nouveau
OK! j'ai re testé le schéma (sur feuille a carreau ) et avec GRBL
parti de: 0.5A switche sur: S4 on/S5 on/S6 on
1A switche sur: S4 on/S5 off/S6 on
1.5A switche sur: S4 on/S5 on/S6 off
2A switche sur: S4 on/S5 off/S6 off
mais rien a faire! le moteur ne tourne pas , il vibre plus ou moins fort sur certaines position.
sur la position 1.5A switche sur: S4 on/S5 on/S6 off , Pas réglé sur 8: S1 on/S2 on/S3 off . c'est la ou il y a le plus de réaction du moteur.
j'ai aussi inversé PUL/DIR , et testé tous les Pas ..
je suis désespéré ... lol
merci à vous..
 
Gaamma
Gaamma
Nouveau
pour l'alim, c'est une alim de pc un peu modifier 480w.
après j'ai une autre alim en 12v / 6/8 A, mais j'ai pas testé avec.
 
H
Hubert86
Compagnon
Heu, une question toute bête les liaisons moteur/TB tu es sure de tes branchements. De plus tu as bien désaccouplé ton moteur. J'ai une alime 12V 5A pour les 3 Nema 17 de ma cnc ça va très bien, mais avec des alimes pc autant que je me souvienne, j'ai eu quelques pbl...
Si tu as un multimètre (tout bricoleur, se doit d'en avoir un) tu peux tester tes enroulements, une valeur de quelques ohms, et les deux identiques.
 
Dernière édition:
Gaamma
Gaamma
Nouveau
oui je suis sur des liaisons moteur/Tb, j'ai bien compris le sens des bobines .
par contre "désaccouplé le moteur" ??????

20180806_160638.jpg


20180806_160749.jpg
 
Gaamma
Gaamma
Nouveau
pour l'alim j'ai crue comprendre que cela fonctionné aussi sur 12 v?
vais testé avec mon autre alim 12v 6/8 A.
merci à vous..
 
H
Hubert86
Compagnon
Bah, vu les photos il est désaccouplé, mais tu prends des fils pour faire la jonction, le contact est bon? 3,5 ohms c'est ça. Je confirme les miens fonctionnent avec une alime 12v/5A . Mais c'est pas une alime de PC. Mais comme je l'ai dit pour les nema17, habituellement on utilise pas ce type de driver, faudrai un retour d'expérience TB6600 avec nema17. Le réglage du courant est assez pointu, sur les drivers A4988 le réglage se fait avec un potar. 1/10eme a droite ou a gauche et ça marche plus correctement.
 
Dernière édition:
Gaamma
Gaamma
Nouveau
Bonjour à tous.:-D

GRAND MERCI à vous pour votre aide, vos conseils, et votre réactivité.

Grasse à vous j’ai réussi à faire tourner mon 1er moteur de gauche a droite avec GRBL.

J’ai maintenant bien compris le réglage du TB6600. (enfin la base!)

J’ai réglé les A sur 2A (sur 1.5A ça marche aussi) et le Pas sur 1.

Mon chariot ce déplace bien sur l’axe Y et le moteur a du couple.:)

Pour info je n’ais rien touché au schéma (sauf l’inversion de pul/dir) et j’ai changé l’alim pour une 12v en 6/8 A

Encore merci, je vais pouvoir reprendre la pose des moteur sur ma cnc entres autre ! J’ai encore pas mal de boulot.

J’aurais surement encore besoin d’aide :tumbsupe:

Bonne journée à vous
OMEGA
 
Gaamma
Gaamma
Nouveau
a oui... j'ai aussi branché le moteur directement sur le tb6600 sans raccord.
 
H
Hubert86
Compagnon
Ben voila, mais l'inversion c'était super important, merci pour ton retour, souvent on aide et pas de retour du coup on sait pas.
Mais tu auras a modifier les paramètres, que t'as fait ressortir JPBBRICOLE. Si ça marche a 1.5A prends cette valeure tes moteurs souffriront moins. Si pbl rien ne t'empêche de changer maintenant que tu maitrise.
 

Sujets similaires

JPDB 15
Réponses
14
Affichages
906
JPDB 15
JPDB 15
Gedeon Spilett
Réponses
88
Affichages
7 703
Gedeon Spilett
Gedeon Spilett
S
Réponses
21
Affichages
878
dubleu
dubleu
AleXXi
Réponses
141
Affichages
5 300
F
K
Réponses
41
Affichages
1 206
K
tristan12
Réponses
19
Affichages
674
Dardar88
Dardar88
A
Réponses
28
Affichages
2 569
boucqueneau
boucqueneau
D
Réponses
17
Affichages
2 554
Florent07
Florent07
Haut