BERTHIEZ 1M - Probléme de connexion num 760F

N

Nicoala

Nouveau
Bonjour,
tout nouveau sur ce site je vais commencer par vous saluer toutes et tous.
Voila j'ai ce jour passé une grande partie de mon temps à essayer de me connecter sur un tour berthiez 1m équipé d'un NUM 760F. Avant d eme lancer dans la bataille j'ai regardé votre forum et demandé des conseils à un de mes collègues ayant déjà fait clea.
mon objectif était de recharger un sous programme %9006 dans la CN.
J'ai donc commencé par créer un cable DB9 vers Sub D25 comme ci dessous:
1712080934501.png


Jusqu'ici pas de soucis, j'ai ensuite sortie une console siemens en ma possession équipée d'un port série référencé com1 et j'ai installé dessus le logiciel NUMCOM.

Puis.... et bien pas moyen de me connecter à la num 760F, j'ai connecté mon sub D25 ici, sur le connecteur DNC de la carte process:
1712081101815.png



J'ai passé la CN en mode chargement avec choix 4 , programme par DNC puis appui sur le bouton départ cycle
1712081229460.png
qui passe au vert:

1712081172324.png


et ensuite essai d'envoi ou de récupération de programme sans aucune réussite.
Mon port com est en 9600 baud( le cavalier sur la carte process aussi), 7 bit de donné, 1 bit d'arrêt et parité paire.

Malgré tout cela je n'ai aucune communication avec la NUM, le seul moment ou je parviens à envoyer quelque chose c'est quand je supprime l'option analyse de flux, mon PC envoi les données mais rien ne se passe sur la CN, l'affichage ne bouge pas et je ne vois pas de ligne de données arriver.

J'ai essayé d'autre logiciel tel que numtrans ou DNC précision mais même topo rien ne fonctionne.

Je pense que mes paramétrage de COM ne sont pas bons donc auriez vous les paramétrage à rentrer pour un fonctionnement de mon port série, baud, nombre de bit, nombre de bits d'arrêt, gestion des DTS, DCS, taille des paquets d'envoi etc... ?
ou si vous avez d'autres idées je serais heureux d'échanger avec vous sur l'ensemble de mes essais non concluant...

nicolas
 
B

bernard-odile

Compagnon
Bonjour
il me semble qu'il faut choisir ruban "0 "
 
N

Nicoala

Nouveau
Bonjour
il me semble qu'il faut choisir ruban "0 "
J'ai également essayé mais sans réussite. La console siemens est en Windows XP. J'ai commandé un convertisseur USB série pour tenter avec mon PC en W10 mais j'ai un doute...
 
L

laurent12100

Ouvrier
as tu essayer de décharger un programme pour voir si déja un sens fonctionne ?


edit
 
Dernière édition:
L

laurent12100

Ouvrier
par contre il m'arrive de ne plus arriver envoyer ou recevoir de prog, il me faut appuyer ou soulever la prise, je pense que les pin femelle s’oxyde et les contact ne sont pas foufou
 
L

laurent12100

Ouvrier
la c'est cimco (sous linux) mais sinon j'ai aussi XP avec numtrans qui fonctionne parfaitement
 
N

Nicoala

Nouveau
la c'est cimco (sous linux) mais sinon j'ai aussi XP avec numtrans qui fonctionne parfaitement
OK, Bon ben toujours pareil aucun résultat positif...
Avec APA10 ou numtrans aucune résultats.

Je ne sais plus quoi essayer, enfin si je vais mettre mon PC Windows 7 avec convertisseur et regarder ce qui passe sur le port série.
 
L

laurent12100

Ouvrier
peut être la prises de la machine qui est oxydé

peut être essai de la démonter et de faire des testes de continuité au multimètre
 
N

Nicoala

Nouveau
OK, je viens de me brancher sur lec/per et j arrive à recevoir des trucs de la cn mais j'ai un message d erreur disant que le signal de fin n'arrive pas... je recommence avec mon PC xp et numtrans ...
 
N

Nicoala

Nouveau
Et quand je clic sur oui j'ai rien dans comme data...
1712164106305.png
 
B

bernard-odile

Compagnon
Tu fais CN vers PC ? 1 seul prog ou tous ? essaye 1 seul prog . Et avec APA10 , je connais pas les autres logiciels
 
N

Nicoala

Nouveau
Tu fais CN vers PC ? 1 seul prog ou tous ? essaye 1 seul prog . Et avec APA10 , je connais pas les autres logiciels
oui cn vers pc.
je lance uniquement déchargement programme courant sur ruban.
je suis sur mon pc en windows 7 je ne peux pas lancer APA malheureusement. mon PC xp ne fonctionne pas.
 
N

Nicoala

Nouveau
Alors petit bilan des essais du jour. Ma console Siemens en xp avec port série ne veut rien savoir, aucune réception ni émission avec les logiciels, numcom, numtrans, apa10, cncdisk et dncprecision.
Avec mon PC en Windows 7 + convertisseur usb rs232 j arrive à faire un transfert CN vers mon PC avec dncprecision et cncdisk. A noter que cncdisk m'a été donné par le client qui a retrouver cela dans ses archives....Ouf...
Bref par contre pour les deux logiciels j'arrive à transférer de la cn à mon PC mais en résumé je ne récupère rien car ça plante à la fin car ça attend le caractère de fin de transfert --> QUEL EST CE CARACTERE ?? si vous savez ??
Par contre de raz le bol j'ai tenté un transfert PC vers CN et la !!! Paf ça fonctionne !!! Mais seulement avec le logiciel cncdisk, avec le dncprecision ça ne fonctionne pas , je pense un soucis de paramétrage car ce logiciel permet de tout paramétrer des trames d'envoi... pour ce qui est des autres logiciels cela ne fonctionne pas mon PC est trop récent.

Donc pour continuer à profiter de vos connaissances si vous connaissez les caractères de clôture d'un transfert cn à PC je suis preneur afin d'essayer de paramétrer dncprecision avec précision.. (jeu de mots de fin de journée j avoue...)
 
B

bernard-odile

Compagnon
Bonjour .
je me rappelle pas avoir eu ce genre de soucis avec APA10 . Bon si tu as depanné c'est deja bien . Bon courage
 
N

Nicoala

Nouveau
Bonjour

C'est un programme en Iso que tu transfères . As-tu bien à la fin du programme la fin du fichier le x-off
Bonjour,
comment je peux voir cela sur la CN? comment visualiser le programme?
car mon problème vient du transfert entre la CN et le PC.
 
B

Bricoleur_69

Compagnon
Bonjour

Ton programme source est bien quelque part pour le transférer sur ta CN : sur ton micro , sur un ruban (donc tu as une source) .
Donc il suffit de l'éditer
 
N

Nicoala

Nouveau
Bonjour

Ton programme source est bien quelque part pour le transférer sur ta CN : sur ton micro , sur un ruban (donc tu as une source) .
Donc il suffit de l'éditer
Les opérateurs chargent les programmes pièces à partir de gedix un logiciel commun au machines.
mais les sous programmes style %9006 ou utilitaires machines ne sont présents nul part..; justement maintenant que j'ai réussi à faire repartir la machine ils voudraient bien que je sauvegarde l'ensemble des utilitaires + prog automate+ sous programme + "tout ce que je peux sauvegarder" ... Mais la com ne fonctionne pas dans le sens Cn --> PC...
Je vais essayer fin de semaine avec un windows 98, je vais récupérer un PC.
 
J

Jean 47

Nouveau
avez vous une copie de votre programme, la communniquation en com est capricieuse! peut etre ce probleme de ponctuation!

nos machines chez dassault nous faisait des caprices :) envoyer moi votre code je penses pouvoir vous aider, j'ai commencé avec les bande à trous aux arts!

NUM à été rachete par GE!, de quel année date votre controleur? j ai quelque amis qui ont travaillé à Rueil je pourrais vous aider à retrouver le manuel
 

Sujets similaires

L
Réponses
7
Affichages
1 773
PHANOU59380
P
B
Réponses
2
Affichages
571
Bertitou
B
A
Réponses
3
Affichages
1 585
titi t16
titi t16
laurent du beausset
Réponses
6
Affichages
1 187
laurent du beausset
laurent du beausset
D
Réponses
16
Affichages
4 106
DELTA-IO
D
Haut