Mikron WF2/3DCM... encore un retrofit Linuxcnc/Mesa

Bruno26
Bruno26
Compagnon
25 Fev 2015
1 181
FR-26 Drôme
  • Auteur de la discussion
  • #31
Merci encore gaston48, t'es incollable! J'ai arrêté de suivre les fils en arrivant quelque part derrière les ventilos des variateurs. C'est cohérent, donc si tout va bien ça ne devrait pas poser de problèmes.

A+
 
bendu73
bendu73
Compagnon
18 Sept 2013
1 226
SAVOIE
Salut,

Ahhh un schéma! Pas des moindres, le vario!

A premiere vue je dirai que tes +/-10V sont ceux que j'ai nommé X,Y et Z. Les T c'est tes tachymètre (facile
les G20, ce sont des dynamos en soit).

Regarde ou est reprit le relais K300, il va vers les page B04 et B05. Surement un sécu, il y en a tellement sur ces machines. Il te faut trouvé le enable de ton driver, pour le faire démarrer, peut être les bornes 8 et 1 qui active les axes... La il faut tester, tu tentes de comprendre l'activation, puis tu simules un signal avec une pile 1,5V au borne des ref ( les +/-10V) :wink:

upload_2017-7-25_8-28-16.png
 
Bruno26
Bruno26
Compagnon
25 Fev 2015
1 181
FR-26 Drôme
  • Auteur de la discussion
  • #33
Je n'ai vu que ce matin ta remarque sur poster les schéma élec...

Mikron WF 2-3 DCM elec_Page_09.jpg


Mikron WF 2-3 DCM elec_Page_10.jpg


Mikron WF 2-3 DCM elec_Page_11.jpg


Mikron WF 2-3 DCM elec_Page_12.jpg


Mikron WF 2-3 DCM elec_Page_13.jpg


Mikron WF 2-3 DCM elec_Page_14.jpg


Mikron WF 2-3 DCM elec_Page_15.jpg


Mikron WF 2-3 DCM elec_Page_16.jpg


Mikron WF 2-3 DCM elec_Page_17.jpg


Mikron WF 2-3 DCM elec_Page_18.jpg


Mikron WF 2-3 DCM elec_Page_20.jpg
 
Bruno26
Bruno26
Compagnon
25 Fev 2015
1 181
FR-26 Drôme
  • Auteur de la discussion
  • #34
Les commandes des variateurs sont bien ce que tu as marqué en rouge. Par contre les pin 8 et 1 (celles côte à côte) sont plutôt des sorties des variateurs.
K300 commande en partie K61 qui active apparemment les moteurs.

A+
 
Bruno26
Bruno26
Compagnon
25 Fev 2015
1 181
FR-26 Drôme
  • Auteur de la discussion
  • #36
Ouah, excellent! Merci encore pour cette trouvaille :-D:-D
Bon faut peut-être que je potasse un peu aussi la doc de la 7i77 (que je n'ai pas encore).
 
Bruno26
Bruno26
Compagnon
25 Fev 2015
1 181
FR-26 Drôme
  • Auteur de la discussion
  • #37
Bon je me suis trompé au sujet des pin de sortie et enable des axes. Grace à la dernière doc de gaston48, il faut que je relie la pin X21-6 aux entrées enable X11-8, X21-8 et X31-8. Normalement c'est l'automate qui fait cette liaison quand il est près.
Les pins X12-1,... sont une intégrale du carré de l'intensité des moteurs et déclenchent une erreur.
C'est tentant de mettre déjà le jus...

A+
 
L
laurentl38
Compagnon
21 Jan 2008
508
il me rappelle un système avec un empilage de billes poussées
Par exemple sur les Hermle, c'est un circuit de bille pour le blocage de la broche et pour la table universelle c'est un circuit de cylindre ...
Assez sympa comme système à l'utilisation est super efficace au serrage ...
 
Bruno26
Bruno26
Compagnon
25 Fev 2015
1 181
FR-26 Drôme
  • Auteur de la discussion
  • #40
Salut à tous,

J'ai mis le jus! J'ai d'abord relié les fils qu'il faut pour activer les variateurs des axes, ce que devait faire l'automate.

Avant de mettre l'inter général sur On j'avais appuyé sur l'arrêt d'urgence.

Les ventilos se mettent de suite en route, je respire un coup, j'enlève l'arrêt d'urgence, j'appui sur Feed On, ça fait bzzz un peu partout, les axes ne bronchent pas. Avec ma pile 1.5v j'applique une consigne sur chaque variateur et ça bouge sur tous les axes

Y'a un peu des sales bruits de mécanique quand la table descend (pas à la remontée) et un peu sur l'axe X. Mais bon y'a pas d'huile dans le circuit de graissage alors j'ai pas fait mumuse longtemps.

J'ai même pu mettre en route la broche!

A+
 
W
wapiti
Ouvrier
30 Déc 2015
481
pyrénées (milieu)
Salut Bruno,
Bravo pour la réussite; avec ta pile 1.5v tu as simulé le signal de sortie de ta future mesa, donc tes drivers (ce que tu as appellé variateur) et tes moteurs fonctionnent..?. c'est ça?
 
Bruno26
Bruno26
Compagnon
25 Fev 2015
1 181
FR-26 Drôme
  • Auteur de la discussion
  • #42
Yes! Les 3 moteurs fonctionnent, donc aussi les drivers!
Trop content!
Très bientôt j'essayerai les règles en utilisant la carte d'interpolation récupérée dans la TNC.

A+
 
Bruno26
Bruno26
Compagnon
25 Fev 2015
1 181
FR-26 Drôme
  • Auteur de la discussion
  • #43
Salut,
J'ai essayé la commande de la boite de vitesse via le pupitre. Ca marche... presque! Il y a 3 petits moteur à courant continu pour commander la boîte.
IMG_0050.JPG

Un des moteurs a un fonctionnement aléatoire, la plupart du temps il ne bouge pas.
Apparemment c'est pas le moteur qui est en cause mais sa commande par cette carte:

IMG_0051.JPG


Le problème vient à priori d'une des boîtes noires. Pas trouvé plus de doc sur cette carte.
Gaston48, t'aurai pas encore un document magique sur cette carte?
Bon, c'était juste pour faire mumuse cet essai!
A+.
 
Dernière édition:
G
gaston48
Compagnon
26 Fev 2008
9 509
59000
Non là je n'ai rien, en théorie tu aurais 3 combinaisons de 3 soit 3 puissance 3 vitesses possibles
27. Tu en as que 12 en réalité. Il faudrait voir la méthode de décodage des positions de chaque
moteur, éliminer les positions inutiles, pour aboutir à un tableau de combinaison associé à une vitesse.
la vitesse courante peut être déduite, la vitesse cible est annoncé, il faut faire un petit algo pour
sélectionner les manœuvres les plus directes et nécessaires pour aller de la vitesse A à la vitesse B.
Un bon petit sujet arduino ou composant userspace linuxcnc ou les deux ...:-D
 
Bruno26
Bruno26
Compagnon
25 Fev 2015
1 181
FR-26 Drôme
  • Auteur de la discussion
  • #45
Là où ça se corse c'est que pendant un changement de vitesse le broche de broche est parfois commandé un instant, il y a d'ailleurs un capteur optique sur la poulie d'entrée de la boîte, sans doute quand une vitesse a du mal à passer. Mais comment le bazar détecte que la vitesse ne passe pas? L'intensité de commande qui augmente?
Je vais faire plus simple pour l'instant. C'est le moteur de gauche qui est foireux, il n'y a en fait que 2 positions utiles, la 2 en dessous de 200tr/min et la 3 au dessus. Autrement dit ça ne change pas à chaque vitesse et en enlevant le rotor du moteur ça sera plus facile de tourner ça à la main.
Mais j'y reviendrai peut-être plus tard, quand le reste sera ok. Pour ma culture je vais voir ce que c'est le composant userspace...

Il faut que je me décide sur comment changer le soufflet du Z, sur le longitudinal il a carrément disparu, j'en ai retrouvé les restes dans l'armoire.
Il faut que je me décide aussi sur comment réagencer le pupitre. J'ai un écran tactile qui va bien mais il est un poil plus large que le pupitre.

Merci et a+.
 
La dernière réponse à ce sujet date de plus de 6 mois
Haut