Le petit nouveau à besoin d'aide pour sa 1er CNC !

  • Auteur de la discussion arily
  • Date de début
arily
arily
Nouveau
Personne ne peut m'aider? :-( snif je suis bloqué

J'ai lu que nions et port // n'était pas génial mais c'est pour le moment histoire de voir mes moteurs tourner :)
 
L
louloute30
Compagnon
J'ai une mini solution d'appoint, juste histoire de voir si tes moteurs et ta carte répond :

Connecte tout, puis une fois les moteurs alimentés, débranches ton port LPT, et avec ton doigt, passe le sur les connectiques de la fiche LPT.
Normalement, les moteurs devraient s'affoler entièrement (du genre: 2 pas ds un sens, puis 3 dans l'autre... etc...)

Si ils bougent, alors je te conseille d'utiliser mach3 (même version gratuite qu'on trouve partout sur internet) pour vérifier plus en profondeur l'ensemble du système (Déplacement correct, bonne réponse de la carte ...). Ensuite si ça fonctionne, il ne te restera qu'à trouver la solution sur NINOS.

Parce que là, on peut tout imaginer comme solution et ne jamais rien trouver...
 
arily
arily
Nouveau
Salut!

Merci pour ta réponse!

J'ai essayé de faire la manip que tu m'as indiqué je branche donc l'alim, la carte et les moteurs sont sous tension, je débranche le DB25 je passe mes doigts sur les broches mais rien ne ce passe même si je passe directement mes doigts sur le borniez DB25 de la carte! Ce qui est étrange c'est quand la carte est relié a l'ordi et le tout sous tension, lorsque je change un paramètre du port LTP ben la tout les moteurs bouge un coup.

Snif snif je vais essayer de voir si le gars du magasin informatique ne ma refilé un câble croisé mais je ne pense pas...
 
arily
arily
Nouveau
Salut à tous!

Bon après quelques essai ca marche!!!!!!!
j'arrive à faire tourner mes moteurs via NINOS!!!! HAAA je suis content :lol:

enfaite mon port LPT n'était pas sur la bonne configue par rapport à NINOS en y réfléchissant bien c'est tout bête enfaite :)

Voili voilou!à bientot!
 
L
louloute30
Compagnon
Ahhhhhh,,, très bonne nouvelle: Je sais à quel point c'est vraiment frustrant de ne pas la voir fonctionner !!! :x :x :x :mad: :mad: :mad:

Tant mieux pour toi; Et au passage, ce serait super de nous faire voir une petite vidéo !

Merci à bientôt
 
arily
arily
Nouveau
Yes ca roule pour la vidéo mais bon ca sera une vidéo comme il y en as beaucoup sur le net :)

Les moteurs posé sur le bureau et qui tourne lol
je met ça sur youtube de suite :wink:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!EDIT!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Et voila

 
Dernière édition par un modérateur:
arily
arily
Nouveau
Salut a tous!
Je suis toujours sur ma fraiseuse hey hey demain normalement je commence mes supports moteur!

Je me posais une question! Je voudrais faire ou trouver une boite pour mettre mon alim et ma carte de commande a l'intérieur et je voudrais en façade les fiches pour brancher les moteurs d'ou ma question qu'utilisé vous en connectique pour les moteur pas a pas? Mes moteurs possède 6 fils j'ai déjà trouvé du câble pour rallonger les câbles moteur mais les connectiques alors la je sèche :wink:

Merci a tous! A bientôt!
 
E
Edge540
Apprenti
Pour la boite de commande tu peux récupérer un boitier dePC par exemple. Pour les connecteurs de tes moteurs des DIN 6 broches peuvent faire l'affaire si tes moteurs ne consomment pas trop d'intensité.
Tu peux trouver ça sur le net (Ebay, Conrad, magazin d'electronique en ligne.....etc)
Bon courage le but est proche :supz:
 
arily
arily
Nouveau
Yes merci!

Je prend note :wink:

pour les poulie courroies switch de fin de course etc.. ca sera pour plus tar pu les moyens pour le moment!

++
 
L
louloute30
Compagnon
Poulies courroies, c'est vrai, c'est un budget (env 100€ au bas mot suivant ce dont tu as besoin)

Pour les fins de courses, à 5€ sur ebay il doit y en avoir, mais ce n'est pas obligatoire d'en avoir mieux vaut avoir des butées...
 
O
OrOoX
Compagnon
Je dirais même des fins de courses ET des butées.

Les fins de courses sont là pour prévenir la casse après tout, les butées n'arrêterons pas les moteurs mais la machine ( z'avez compris ? :partyman: )
 
arily
arily
Nouveau
Salut salut!!!

Merci pour vos réponse du 28 septembre...... je n'ai pas été notifié des réponses :cry:

Qu'entendez vous par BUTEES ????? genre des blocs qui arrêterais le portique d'un bout et de l'autre de la table au cas ou ça va trop loin? et les fin de courses c'est les switchs à donc 5€ sur EBAY " un petit liens ne serait pas de refus :wink:"
D'ailleurs pour les swichts on ma dit que seul 3 suffisent?? une en X- une en Y- et une en Z+??? pouvez vous me confirmer svp.

Sinon voici deux trois news de la CNC " qui n'avance pas vite je vous l'accorde :supz: " je me suis sorti un coup les doigts du C.... et j'ai fait mes supports moteurs aujourd'hui!!



Me reste à démonter la CN pour faire quelques trous dans mes tubes pour visser mes supports et ensuite poulies courroies etc.... " étant donné que j'ai trouvé du boulot à 100 bornes de chez moi ça va ralentir encore plus les choses! dispo que les week-end!"

Sinon une question concernant NINOS.
Je vois sur les sites la version 4 à la vente qui passe donc par le port USB de l'ordi je me demandais si la version "3 si je dit pas de bêtise" qui passe par le port LPT de l'ordi était encore à la vente?? sinon je devrais encore débourser 100€ pour l'adaptateur USB vers LPT :roll:

Merci de m'avoir lu! à bientôt!
 
L
louloute30
Compagnon
Salut, butée à gauche, et switch (ou interrupteur fin de course) à droite. Comme tu peux imaginer, un bloc d'alu ou autre fera très bien l'affaire pour les butées
Pour NINOS, désolé, aucune idées.

m41.jpg
 
arily
arily
Nouveau
A yes nickel! Merci beaucoup!

Pas bête les butées de porte :wink: hop la idée subtilisé! :)

Tout a l'heure j'ai démonté la bête et commencé a percer mes tubes...
Je pense que je vais changer et améliorer deux trois trucs il faut que je regarde :wink:

A oui encore une question! Pour câbler les fin de courses il y as deux fil je pense un rouge un noir donc le rouge sur une des pin 11 ou 12 ou 13 ou 15 ou 16 ( de mémoire) et le noir au " ground" de la carte? Du coup tout les noirs seront au ground de la carte? Pareil pour l'arrêt d'urgence je pense ???

Merci encore!
 
laurentdu31
laurentdu31
Nouveau
Re:

TiTTaN a dit:
Comme je vais bientot acheter mon electronique:
Donc je vais prendre ca:

1Xhttp://cgi.ebay.fr/CNC-Stepper-Moto...516?pt=LH_DefaultDomain_0&hash=item27b4aa712c
+
4Xhttp://cgi.ebay.fr/CNC-NEMA23-Stepp...478?pt=LH_DefaultDomain_0&hash=item27b4aa7106
+
1Xhttp://cgi.ebay.fr/24V-14-6A-CNC-St...378?pt=LH_DefaultDomain_0&hash=item27b402e602

Je vais demarrer seulement sur 3 axes puis 4 plus tards, c est pour ca que je prends 4 drivers: pour les frais de ports

Juste une question: L alim fait 14,6A, elle est pas un peu juste pour 4 Drivers(4,2Ax4= 16,8A) ??

Bonjour à tous,

J'envisage le même montage pour numériser ma X2, quelqu'un pourrait il me dire s'il existe une possibilité de commander manuellement, sans passer par le port parallèle pour faire des essais ?

Merci
 
laurentdu31
laurentdu31
Nouveau
Re: Re:

laurentdu31 a dit:
TiTTaN a dit:
Comme je vais bientot acheter mon electronique:
Donc je vais prendre ca:

1Xhttp://cgi.ebay.fr/CNC-Stepper-Moto...516?pt=LH_DefaultDomain_0&hash=item27b4aa712c
+
4Xhttp://cgi.ebay.fr/CNC-NEMA23-Stepp...478?pt=LH_DefaultDomain_0&hash=item27b4aa7106
+
1Xhttp://cgi.ebay.fr/24V-14-6A-CNC-St...378?pt=LH_DefaultDomain_0&hash=item27b402e602

Je vais demarrer seulement sur 3 axes puis 4 plus tards, c est pour ca que je prends 4 drivers: pour les frais de ports

Juste une question: L alim fait 14,6A, elle est pas un peu juste pour 4 Drivers(4,2Ax4= 16,8A) ??

Bonjour à tous,

J'envisage le même montage pour numériser ma X2, quelqu'un pourrait il me dire s'il existe une possibilité de commander manuellement, sans passer par le port parallèle pour faire des essais ?

Merci

Salut à tous,

Après pas mal de déboires comme les moteurs qui tournent toujours dans le même sens, les axes mal reconnus... avec ma carte type :

http://cgi.ebay.fr/Carte-Interface-Usb-Cnc-5-Axes-Stepper-Driver-Ma560-Ma860H-2M542-/360560074441?pt=FR_YO_MaisonJardin_Bricolage_ElectroniqueComposants&hash=item53f30e1ec9

J'ai envie de me laisser tenter par celles ci beaucoup plus simples :

http://cgi.ebay.fr/CNC-5-Axis-Breakout-Board-For-Stepper-Driver-Controller-mach3-/121044437390?pt=LH_DefaultDomain_0&hash=item1c2ecf898e

ou celle ci :

http://cgi.ebay.fr/ws/eBayISAPI.dll?ViewItem&item=180653820783&ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649

Merci de me donner votre avis.

A+ :-D
 
Dernière édition par un modérateur:
ellogo67
ellogo67
Compagnon
Re: Re:

Bonjour :-D
laurentdu31 a dit:
J'envisage le même montage pour numériser ma X2, quelqu'un pourrait il me dire s'il existe une possibilité de commander manuellement, sans passer par le port parallèle pour faire des essais ?

oui, tout à faire, il suffit d'utiliser un générateur d'impulsions à la place de la carte interface pour commander directement les drivers.

On en parle ici et ici. :smt003
 
laurentdu31
laurentdu31
Nouveau
Je te remercie beaucoup pour ta réponse, que penses tu des petites cartes contrôleur que j'envisage d'acheter pour piloter mes drivers 2M542 ?

J'ai lu ton post dans lequel tu parles aussi de mésaventures avec des cartes chinoises sauf que je suis incapable de modifier la mienne, et pour une vingtaine d'euros je préfère changer de modèle si je gagne en fiabilité.

J'ai bien retenu ta préférence pour un modèle équipé de coupleurs optiques (je ne sais pas ce que c'est !)

A bientôt
 
ellogo67
ellogo67
Compagnon
J'ai une préférence pour la première car elle a beaucoup plus d'options que les autres. :mrgreen:

Elle a entre autres un connecteur 15 broches pour pouvoir commander, justement, tes moteurs manuellement, via un générateur. :wink:
Ne me demande pas comment fonctionne-t-elle dans ce mode, je ne l'ai jamais eu entre les mains.
Faudra que tu voies ça avec la documentation qui sera fournies avec la carte. :smt003
 
laurentdu31
laurentdu31
Nouveau
Merci, je vais la commander, par ailleurs je suis en train de tester le pilotage d'un moteur sur l'axe X avec mach3 et en mode manuel que je clic sur X+ ou X- le moteur tourne toujours dans le même sens ? bizarre non
 
laurentdu31
laurentdu31
Nouveau
C'est encore moi désolé, j'utilise des moteurs à 4 fils que j'ai branché sur des drivers 2M542 :
rouge sur A+
vert sur A-
jaune sur B+
bleu sur B-

ça te semble être le bon montage ?
 
ellogo67
ellogo67
Compagnon
Ben ... si tu ne donnes pas la référence du moteur, ça va être dur de vérifier. :smt003
 
laurentdu31
laurentdu31
Nouveau
Désolé : 57BYGH3918 ( http://www.selectronic.fr/media/pdf/61575.pdf ) en fait il a 4 fils et semble donc être bipolaire, du coup je me demande si mon branchement est bon et si mon problème de rotation toujours dans le même sens ne viendrait pas de là.
 
Dernière édition par un modérateur:
ellogo67
ellogo67
Compagnon
laurentdu31 a dit:
ça te semble être le bon montage ?
Pour moi, c'est comme cela que je les aurais branchés. :supz:

Je ne vois pour l'instant qu'une seule chose. :smt017
L'affectation des touches du clavier pour le X+ et X- est la même. :smt104

Vérifie dans tes paramètres Mach3 si c'est cela.
 
laurentdu31
laurentdu31
Nouveau
J'ai vérifié, elles sont différentes et lorsque j'appuie sur l'une ou l'autre, le compteur X augmente ou diminue.

c'est pareil si j'active les commande manuels avec tab et que je clique sur x+ ou x- , le moteur tourne toujours dans le même sens !!!
 
E
Guest
Bonjour

Si ca arrive a tourner dans un sens cela devrait tourner dans l'autre normalement.
Est-ce que le fil "DIR" est bien branché ?
 
T
topette79200
Apprenti
bonsoir
avec cette carte sur l'axe y les indications de la doc sont erroné . il faut inverser step et dir : en realité il faut pin 3 pour dir et pin 16 pour step dans ports et pin config de mach3.sinon des copies écrans de tes réglages (config) mach3
a+
 
laurentdu31
laurentdu31
Nouveau
sortiesmoteurs.jpg


Pour le moment je n'ai connecter que X pour essais et découverte du logiciel et le fil dir est bien branché.

J'ai seulement débranché le fil ena + qui me mettait le 2M542 en mode alarm.

merci pour vos conseils
 
laurentdu31
laurentdu31
Nouveau
J'ai trouvé !! :partyman:

en consultant la notice de ma carte le X Dir est au pin 14 quand j'avais 3 ! Vous m'avez mis la puce à oreille avec l'erreur sur l'axe Y .

merci pour votre aide en tout cas et à bientôt
 
T
topette79200
Apprenti
si tu as la carte que tu cites plus haut alors ce ne sont pas les bons pins de mis (a moins que le constructeur n'est tout changé). pour axe X : pin 14 (XD sur la carte) pour DIR et pin 2 (XS sur la carte) pour STEP
a+
(on a du editer en meme temps) :lol:
 

Sujets similaires

M
Réponses
7
Affichages
402
meruem95
M
Haut