Générateur de pulses pour PAP

  • Auteur de la discussion vibram
  • Date de début
Mcar

Mcar

Compagnon
On suit avec intérêt tes évolutions :smt023

Et tu peux communiquer avec le module ?
pas encore essayé mais en toute logique oui puisque il y a le bouton upload Parameters
1618595508077.png
 
wika58

wika58

Compagnon
Et l'interface Hardware ?

Thierry évoquait un doute sur celui fourni...
 
S

speedjf37

Compagnon
le soft fonctionne sur mon PC du bureau et pas sur celui de l'atelier

Bonsoir,

En partant de la capture du soft:

Le module
La Doc
Le Soft

Edit : Si quelqu'un arrive a faire fonctionner le PL2303 sur W10 , je veux bien la recette

JF
 
Mcar

Mcar

Compagnon
J'abandonne :smt022
j'ai réussi à faire reconnaitre le driver , il m'a bien ouvert un port com, le logiciel reconnaît le port et le module
mais impossible d'envoyer les paramètres à la carte, erreur de transfert qui me dit :smt013

c'est bien dommage car ça me parait vraiment puissant comme système
 
Dardar88

Dardar88

Compagnon
Si quelqu'un arrive a faire fonctionner le PL2303 sur W10 , je veux bien la recette
Est ce que vous avez regardé le Youtube la :
https://www.usinages.com/threads/generateur-de-pulses-pour-pap.143022/post-1809866

il y a un probleme avec w10 mais il semble que l'on peut le corriger

dommage ,a deux doigts d'y arriver


si c'est de l'USB => rs232 ,il doit y avoir un parametre d'handshaking a modifier ,Xon/Xoff ,bit de parité et vitesse de transfert sur le port
com concerné ...non ? vu qu'il n'y a qu'une fonction RX TX ,de plus sont ils croisé ou droit.... tant que le 5vdc et le ground sont respectés
il n'y a pas de risque a permuter les ligne de transfert data. (ah ,c'est c... je me serais bien amusé moi aussi a faire les tests)
 
Dernière édition:
Mcar

Mcar

Compagnon
bon j'ai tout fait , encore ce matin je suis dessus
même avec le driver Prolific 3.3.2.105 l'ordi reconnait le port, le logiciel reconnait le port également mais impossible de parametrer la carte via le soft.
1618648432941.png

port reconnu par le soft
1618648487259.png


1618648511082.png


parametres du port
1618648558506.png


si tu as une idee ?
 
Mcar

Mcar

Compagnon
tant que le 5vdc et le ground sont respectés
il n'y a pas de risque a permuter les ligne de transfert data. (ah ,c'est c... je me serais bien amusé moi aussi a faire les tests)
fait, pareil pas de connexion avec la carte :mad:
 
Dardar88

Dardar88

Compagnon
si tu as une idee ?
:smt017 ,et pourtant t'as tout fais bien... ,j'aurais fait pareil ,reste la solution d'utiliser une petite interface FTDI dediée USB/RS232 et de boucler
quelque chose comme DCD DTR ...???
- l'astuce qui consiste a installer un petit condo dans la ligne RTS
https://dr-gomi.blog4ever.com/ftdi-2303-for-atmega-sketch-upload-some-problems-resolved

il n'y a pas que prolific qui marche dans ce type d'interfacage , SILABS est performant ,c'est ce que j'utilise pour uploader les arduino mini
(avec l'astuce condo), ou si tu as une arduino UNO qui traine ....peut etre un plan B FTDI maison ?

P1011063.JPG
 
Dernière édition:
Dardar88

Dardar88

Compagnon
bon j'ai tout fait , encore ce matin je suis dessus
En fait ,le cable qui t'as ete livré avec semble etre deja une interface FTDI avec la puce Prolific , ce que je n'avais pas vu et que je n'ai pas
eu lors de ma commande...

un commentaire traduit d'un client allemand mecontent de ce type de cable acheté ici :
https://www.amazon.fr/PL2303HX-Adaptateur-RS232-câble-téléchargement/dp/B07QX66Y95/ref=asc_df_B07QX66Y95/?tag=googshopfr-21&linkCode=df0&hvadid=411244541196&hvpos=&hvnetw=g&hvrand=7096240612999095910&hvpone=&hvptwo=&hvqmt=&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=1006094&hvtargid=pla-772944961631&psc=1&tag=&ref=&adgrpid=91875334200&hvpone=&hvptwo=&hvadid=411244541196&hvpos=&hvnetw=g&hvrand=7096240612999095910&hvqmt=&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=1006094&hvtargid=pla-772944961631#customerReviews


Pour que le câble fasse quoi que ce soit, une résistance de 10k devait être connectée entre RxD et TxD. Un câble décent n'a besoin de rien de tel, il passe sans aucun problème.
Je ne peux que déconseiller de l'acheter, la situation du pilote pour Windows est également plus un pari ici, qui est très probablement une réplique chinoise.
La pièce va directement à la poubelle, elle a causé suffisamment de problèmes.

en dehors de l'histoire du cable ,un bon tuto de "mise a jour" retroactive du driver prolific :

les avis sont très partagés concernant les cables copiés chinois de chez Prolific , il y a même des puces qui fument !

-------------------------------------------------------

Sinon ,changer de puce de com et s'orienter vers du ch340 , ça ne devrait pas modifier la com avec la carte du moment que c'est
du FTDI ( il faudra reinstaller un driver dedié)
https://www.ebay.fr/itm/Module-USB-...5&algv=default&_trksid=p2047675.c100009.m1982

il est moitié moins cher ailleurs ,mais le delai est plus long (en esperant que l'objet soit bien en France)

desolé pour ce vrac de floppée d'infos , on ne sait jamais...
 
Dernière édition:
Mcar

Mcar

Compagnon
fait même la resistance 10kO ça ne marche pas
j'ouvre une dispute
 
E

enguerland91

Compagnon
Bonsoir,
Est ce que quelqu'un aurait la correspondance des bornes des modules XY-DCK11 en particulier du connecteur de gauce qui a 7 bornes alors que le schéma donné plus haut concernant le module DKC 1A n'a que 6 bornes.
Du côté droit( 5 broches au lieu de 4) les indications en chinois sont doublées des indications en anglais mais le connecteur à 7 broches les repaires sont en chinois seulement.
 
Dardar88

Dardar88

Compagnon
Du côté droit( 5 broches au lieu de 4) les indications en chinois sont doublées des indications en anglais mais le connecteur à 7 broches les repaires sont en chinois seulement.
Sans te garantir que ce soit ça ,comme il y a un regulateur de tension sur ces interfaces ,certaines ont une pin de connection supplementaire 5 vdc pour fournir le Driver ou un capteur
 
E

enguerland91

Compagnon
Sans te garantir que ce soit ça ,comme il y a un regulateur de tension sur ces interfaces ,certaines ont une pin de connection supplementaire 5 vdc pour fournir le Driver ou un capteur
Oui c'est indiqué sur le connecteur 5 broches mais c'est pour le connecteur 7 broches que les indications sont uniquement en chinois
XY-DCK11.jpg
 
Dardar88

Dardar88

Compagnon
mais c'est pour le connecteur 7 broches
2 pins pour le potar externe + 1 pour le commun + 4 entrées : 2 pour start/stop et 2 pour fdc 1 et 2

le branchement du potar se fait uniquement sur 2 pins : 1 pin au milieu + pin sur un cote ,la troisieme patte reste en l'air .
 
Dernière édition:
E

enguerland91

Compagnon
2 pins pour le potar externe + 1 pour le commun + 4 entrées : 2 pour start/stop et 2 pour fdc 1 et 2

le branchement du potar se fait uniquement su 2 pins : 1 pin au milieu + pin sur un cote ,la troisieme patte reste en l'air .
Tu ne réponds pas à ma question
 
wika58

wika58

Compagnon
Non, ce n'est pas le même... :smt047
Relis bien le post...:siffle:

Et j'ai d'autres priorités pour le moment...
Garder ma petite fille... et faire une tour à fraisiers... :roll:

Et si tu veux de l'aide sur ce forum (qui n' en manque pas), il va falloir que tu t'adaptes...
 
Dernière édition:
Dardar88

Dardar88

Compagnon
1618841242068.png


comme le chinois se lit de bas en haut ,ça fait:

- ADJ (pour ajustement par potentiometre externe )
- grd (pour ground)
- GRD (pour GROUND)
- STA (pour START)
- ST (pour STOP)
- FX (Fin de Course X)
- ZHX (Zebut de Ha Fin de Course X)

tu pourras verifier ma traduction en regardant de très près ce qui est inscrit a la base du connecteur :mrgreen:
 
E

enguerland91

Compagnon
Non, ce n'est pas le même... :smt047
Relis bien le post...:siffle:

Et j'ai d'autres priorités pour le moment...
Garder ma petite fille... et faire une tour à fraisiers... :roll:

Et si tu veux de l'aide sur ce forum (qui n' en manque pas), il va falloir que tu t'adaptes...
Tu as oublié une activité qui te prends beaucoup de temps : faire des commentaires désobligeants bien que l'on ne s'adresse pas à toi et à choisir des émoticônes
 
E

enguerland91

Compagnon
Voir la pièce jointe 703044

comme le chinois se lit de bas en haut ,ça fait:

- ADJ (pour ajustement par potentiometre externe )
- grd (pour ground)
- GRD (pour GROUND)
- STA (pour START)
- ST (pour STOP)
- FX (Fin de Course X)
- ZHX (Zebut de Ha Fin de Course X)

tu pourras verifier ma traduction en regardant de très près ce qui est inscrit a la base du connecteur :mrgreen:
Merci beaucoup. Effectivement avec une bonne loupe on déchiffre ces anotations.
 
wika58

wika58

Compagnon
Aah ce n'est pas à moi qui tu t'adresses...



Tu as oublié une activité qui te prends beaucoup de temps : faire des commentaires désobligeants...
Ca doit être l'âge... et 15 ans de forum...

Tu trouves que JE suis désobligeant...
Et toi tu débarques sur un post avec de grandes vérités sur les gens qui ne comprennent rien aux CNC...
La rampe d'accélération ne peut pas être définie une fois pour toute... doit être ajustée selon le nombre de pas à parcourir...
C'est bien la notion que n' assimilent pas les gens qui avec leur cnc font la course à la vitesse...
alors qu'on ne parle pas de ça...

Tu t'adresses aux membres qui te répondent en écrivant :
Tu ne réponds pas à ma question

Et tu me demandes "cordialement" où j' en suis avec mon module alors qu'il n'a rien avoir du tout avec celui de Marco...
 
Dernière édition:
wika58

wika58

Compagnon
Coucou tous le monde,

Je prends enfin le temps pour essayer le dernier module que j'ai acheté.

J'ai tout raccordé et mis sur le Driver du MPAP de mon Z.

Mais ça ne fonctionne pas.

A la mise sous tension j'ai la LED D2 qui est allumée.
IMG_20210423_181709.jpg


Et si j appuie sur Start, rien ne se passe... :smt022
 
Mcar

Mcar

Compagnon
Patrick, avec du matériel diffèrent, à la vue de ton expérience, de la mienne, je crois que la meilleure méthode pour piloter un moteur pap reste bien l'arduino.
en tout cas on aura essayé. :hang:
 
wika58

wika58

Compagnon
Je ne baisse pas encore les bras.
J'ai envoyé un msg au vendeur...

Oui l'Arduino est Top quand on fait une application spécifique.
Mais avoir un module autonome qui pourrait piloter un MPAP pour de la "simple" avance auto ce serait cool.
 
dh42

dh42

Compagnon
Salut,

Si ça peut aider ?



++
David
 

Sujets similaires

D
Réponses
11
Affichages
577
Dubois laurent
D
DY74
Réponses
14
Affichages
796
JLuc69
JLuc69
S
Réponses
10
Affichages
956
sweex59
S
laurent du beausset
Réponses
5
Affichages
415
pinou29
pinou29
Y
Réponses
15
Affichages
1 437
ygicq
Y
Haut