Mach3 Moteur fonctionnent en manuel mais grincent a faible vitesse en auto

Ddrenard2979
Nouveau
13 Juin 2018
8
  • Auteur de la discussion
  • #1
Bonjour à tous

Menuisier en hobby je construit un portique mixte fraiseuse-plasma (config ci-dessous)
Je viens de remplacer mes moteurs drivers et alims des axes y et x Pour une raison de couple
Sous mach3 après réglages fonctionnent parfaitement quand je déplace avec les curseurs de déplacement (donc en vitesse max 1200 mm/min)
Quand je déplace avec une commande en vitesse plus lente style F200 ou F300 ils grondent et vibrent à m'en déchausser les plombages, les déplacement sont exacts par rapport aux cotes affichées .
D'où vient le problème? pourquoi en déplacement joystick ça fonctionne nickel et pas en mode programme?
Mauvais réglage de mes drivers? (4OO pas par tour pour des moteurs de 1,8°/pas)
Mauvais réglage de mes moteurs?
Un truc que j'ai oublié dans ma config mach3? voir fichiers joints
Merci de me dépanner je deviens JOB, elle fonctionnait avec mes nema 23 mais depuis le changement je n'arrive plus à régler mes 3 nvx nema 34


FT de la bestiole
2M40 par 1M50 utile
vis pas de 5 mm
X 1x nema 34 avec 1 driver DM860A et alim réglée en 60v
Y 2x nema 34 avec 2 driver DM860A et 2 alims réglées en 60v
Z 1x nema 23 avec 1 driver M335 et alim réglée en 30v
Broche 2,2KW refroidie par air avec son vatiateur PWM
carte contrôleur XHC MK4 usb (matos chinois)
pc portable sous win 7 pro
Logiciel de commande mach3 avec licence Version R3.042.020

config gen.jpg


engine port and pines.jpg


motor.png


usb.jpg
 
CNCSERV
Compagnon
27 Décembre 2007
4 995
FR-28360
Mauvais réglage de mes drivers? (4OO pas par tour pour des moteurs de 1,8°/pas)
C'est peu, le demi pas ça grogne c'est normal, passe a 1600 step/rev avec une resolution de 320 dans Mach3

50 mm.s-² en accélération c'est très peu aussi les accélérations doivent être interminables.

1200 mm/min,

il te faut 2 minutes pour faire la longueur en X ???

elle fonctionnait avec mes nema 23 mais depuis le changement je n'arrive plus à régler mes 3 nvx nema 34
Oui les NEMA23 sont fait pour les vis à billes au pas de 5, les NEMA34 ont trop d'inertie, il sont moins dynamiques et tournent souvent moins vite.
pour le couple des moteurs de 3Nm suffissent très largement.
 
Ddrenard2979
Nouveau
13 Juin 2018
8
  • Auteur de la discussion
  • #3
Tout d'abord un grand merci pour votre réponse rapide, je découvre ce magnifique forum et ça fait plaisir de voir une telle réactivité .
Je découvre la multitude de sujets et je suis certain qu'une partie de mes réponses se trouvent ici je vais chercher un peu avant de prendre du temps aux autres. Mais merci beaucoup.

-Oui il faut 2 min pour le Y (pas mis dans l'ordre dans ma description Y 2M40 et X 1M50) C'est la vitesse max de mes anciens moteurs (raison du changement) je comptais bien augmenter cette vitesse. J'aimerai arriver à 4000 histoire de pas perdre trop de temps. La tête (x et z)pèsera dans les 25kg Je dois encore monter ma nvlle broche (pour le moment une défonceuse BOSCH)

-Je vais tester cela ce soir en passant a 1600 .Puis-je monter plus haut en résolution sur ce type de moteur? et est-ce nécessaire?
-Quand vous parlez d'accélération interminable que voulez-vous dire par là?
-Mach3 est parfois capricieux et si on ne sort pas du prog les paramètres ne s’appliquent pas ..... j'ai perdu pas mal de cheveux sur le coup.
Nous sommes bien d'accord que si je passe en mode manuel et rentre la ligne suivante G00 Y500 la vitesse de déplacement doit être ma vitesse max, soit la vitesse se trouvant dans mes params moteurs . Or ici elle est ultra lente .....
-Mes drivers sont à 7A mis à part les risques de chauffe, ça peut avoir un effet sur les vibrations à basse vitesse ?
(je parles de vibrations, je devrais plutôt dire HURLEMENTS :wink: )

Bonne journée à vous
 
Ddrenard2979
Nouveau
13 Juin 2018
8
  • Auteur de la discussion
  • #4
C'est peu, le demi pas ça grogne c'est normal, passe a 1600 step/rev avec une resolution de 320 dans Mach3

50 mm.s-² en accélération c'est très peu aussi les accélérations doivent être interminables.

1200 mm/min,

il te faut 2 minutes pour faire la longueur en X ???


Oui les NEMA23 sont fait pour les vis à billes au pas de 5, les NEMA34 ont trop d'inertie, il sont moins dynamiques et tournent souvent moins vite.
pour le couple des moteurs de 3Nm suffissent très largement.
 
CNCSERV
Compagnon
27 Décembre 2007
4 995
FR-28360
Puis-je monter plus haut en résolution sur ce type de moteur? et est-ce nécessaire?
Oui et non, au dela du 1/8 de pas il n'y a pas vraiment de différence et on monte en fréquence pour rien.

J'aimerai arriver à 4000 histoire de pas perdre trop de temps.
Normalement avec les drivers qu tu as tu devrais pouvoir aller à 6000, il y a vraiment un problème de choix de moteur.

Mes drivers sont à 7A mis à part les risques de chauffe, ça peut avoir un effet sur les vibrations à basse vitesse ?
C'est la cause un moteur de 7A c'est beaucoup trop sur une méchante VàB pas de 5mm, je ne sais pas de combien est leur couple.

En demi pas chaque impulsion génère 0.7 fois le couple de maintient. Si tu as des 6 Nm comme je ne serai pas surpris, en gros chaque impulsion génère donc une poussée de 500kgs, tu m'étonne que ça vibre. C'est pas des moteurs c'est des marteaux-piqueur
 
Ddrenard2979
Nouveau
13 Juin 2018
8
  • Auteur de la discussion
  • #6
Oui et non, au dela du 1/8 de pas il n'y a pas vraiment de différence et on monte en fréquence pour rien.

Ok je vais donc ne pas dépasser le 1/8


Normalement avec les drivers qu tu as tu devrais pouvoir aller à 6000, il y a vraiment un problème de choix de moteur.

Je vais devoir acheter mes fraises à la NASA à cette vitesse et mettre un spoiler sur le X . Je vais rester raisonnable ...


C'est la cause un moteur de 7A c'est beaucoup trop sur une méchante VàB pas de 5mm, je ne sais pas de combien est leur couple.


En demi pas chaque impulsion génère 0.7 fois le couple de maintient. Si tu as des 6 Nm comme je ne serai pas surpris, en gros chaque impulsion génère donc une poussée de 500kgs, tu m'étonne que ça vibre. C'est pas des moteurs c'est des marteaux-piqueur

Encore pire .... des 12 Nm !!!! J'ai craqué du slip mais c'était une affaire j'ai eu les 3 moteurs + drivers + alim neufs dans l'emballage pour 100€
En résumé je dois ...
Diminuer l'ampérage .... Agmenter la vitesse... Augmenter l'accélération .... ou récupérer ces moteurs pour motoriser une péniche mais ça me ferait mal :(
et cette histoire de commande G00 tu as déjà eu le cas ?
 
CNCSERV
Compagnon
27 Décembre 2007
4 995
FR-28360
.... ou récupérer ces moteurs pour motoriser une péniche mais ça me ferait mal :(
Oui oui, et tu pourras même faire du ski nautique derriere.
Pourtant ces moteurs ne sont pas faits pour ta machine.
Prends des NEMA23 entre 2 et 3Nm et un courant entre 5 et 6A et tu pourras multiplier tes vitesses par 5 ou 6.
 
Manuforg
Ouvrier
11 Octobre 2014
420
Tournai 7500 (Belgique)
Slt, je pense que c'est peut être a cause du fait que tu n'a pas mis d'angle dans le fonction CV (constant velosity) Ducoup le moteur s’arrête a chaque point du parcoure avec une accélération et un décélération pour chaque point. Plein de points, donc plein de sacades!
Lis bien comment utiliser cette fonction de mach3, c'est assez important pour avoir des usinages bien fluides, mais précis.
Voici la notice en Anglais malheureusement.
Sinon diminue ton accélération.
Ou alors c'est un problème complètement différent :wink:.
 
Fichiers joints
Manuforg
Ouvrier
11 Octobre 2014
420
Tournai 7500 (Belgique)
Nous sommes bien d'accord que si je passe en mode manuel et rentre la ligne suivante G00 Y500 la vitesse de déplacement doit être ma vitesse max, soit la vitesse se trouvant dans mes params moteurs . Or ici elle est ultra lente
Si les moteurs n’atteigne pas la vitesse demandé, c’est soit que tu as atteind la vitesse max de la configuration des axes, soit que tu as atteind la limite de fréquence de la configuration mach3 ou de ta carte de contrôle (100khz).
 
Ddrenard2979
Nouveau
13 Juin 2018
8
Si les moteurs n’atteigne pas la vitesse demandé, c’est soit que tu as atteind la vitesse max de la configuration des axes, soit que tu as atteind la limite de fréquence de la configuration mach3 ou de ta carte de contrôle (100khz).
Bonjour et merci
Ce qui me tracasse c'est que si j'utilise les curseurs de déplacement, ou le joystick mes moteurs tournent comme des horloges à 1200 mm/min donc vitesse max actuelle dans les params moteurs (j'ai chronométré c'est exact si on prends en considération accélé et décélé )
c'est juste que quand je diminue la vitesse avec une commande ou quand j'utilise une commande G0 Y500 (ils ne tournent pas a plein régime comme demandé par G0 et en plus ils vibrent)
 
Ddrenard2979
Nouveau
13 Juin 2018
8
Oui oui, et tu pourras même faire du ski nautique derriere.
Pourtant ces moteurs ne sont pas faits pour ta machine.
Prends des NEMA23 entre 2 et 3Nm et un courant entre 5 et 6A et tu pourras multiplier tes vitesses par 5 ou 6.

ci dessous mes anciens moteurs ... ça va être faiblard non ?

Modèle 57BYGH56-401A
Arbre Arbre Unique (Diamètre:6.35mm; Longeur:21mm)
Courant Nominal 2.8A/Phase
Angle de Pas 1.8°±5%
Phase 2 Phases
Résistance de Phase 0.9x(1+10%)Ω/Phase
Inductance de phase 2.5x(1+20%)mH/Phase
Couple de Maintien 1.26Nm (Environ. 175 Oz-in)
Couple de Postionnement 300gf.cm
Poids 0.7Kg/Pièce
 
Ddrenard2979
Nouveau
13 Juin 2018
8
Slt, je pense que c'est peut être a cause du fait que tu n'a pas mis d'angle dans le fonction CV (constant velosity) Ducoup le moteur s’arrête a chaque point du parcoure avec une accélération et un décélération pour chaque point. Plein de points, donc plein de sacades!
Lis bien comment utiliser cette fonction de mach3, c'est assez important pour avoir des usinages bien fluides, mais précis.
Voici la notice en Anglais malheureusement.
Sinon diminue ton accélération.
Ou alors c'est un problème complètement différent :wink:.
Hahaaaa du bon anglais .... je vais y regarder ça sera peut-être une solution à mon problème .... merci beaucoup
 
CNCSERV
Compagnon
27 Décembre 2007
4 995
FR-28360
ci dessous mes anciens moteurs ... ça va être faiblard non ?

Modèle 57BYGH56-401A
Arbre Arbre Unique (Diamètre:6.35mm; Longeur:21mm)
Courant Nominal 2.8A/Phase
Angle de Pas 1.8°±5%
Phase 2 Phases
Résistance de Phase 0.9x(1+10%)Ω/Phase
Inductance de phase 2.5x(1+20%)mH/Phase
Couple de Maintien 1.26Nm (Environ. 175 Oz-in)
Couple de Postionnement 300gf.cm
Poids 0.7Kg/Pièce
Faible mais mieux que tes gros moteurs.
Cette histoire de vitesse constante ou stop exact me surprendra toujours, mais ce problème est le même avec un NEMA23 ou un NEMA34.
Pour info 1200 mm/min a 80 pas/mm c'est 1600hz, donc une très basse fréquence et si tu dois encore baisser accélération tu ira plus vite a la scie sauteuse.
 
Dernière édition:
Ddrenard2979
Nouveau
13 Juin 2018
8
Faible mais mieux que tes gros moteurs.
Cette histoire de vitesse constante ou stop exact me surprendra toujours, mais ce problème est le même avec un NEMA23 ou un NEMA34.
Pour info 1200 mm/min a 80 pas/mm c'est 1600hz, donc une très basse fréquence et si tu dois encore baisser accélération tu ira plus vite a la scie sauteuse.
merciiiiiiiiiiiii !!!! MERCI POUR VOS CONSEILS A TOUS
ma titinne ronronne, ça glisse comme une paire de ski neuve sur de la poudreuse !!!!!
Comme conseillé j'ai
-Passé de 400 à 1600 pas/tour
-passé mes drivers à 4,2 A au lieu de 7,8A
-Vitesse actuelle à 4000mm/min accélération à 100
ça broute plus du tout et ça couple à mort ..... avais oublié de fermer la porte de l'armoire élec ..... pas de casse mais juste ....
Encore le X a changer .... me reste un moteur en rade mais maintenant je connais les réglages ... plus qu'à tester ses limites et tester la précision.
Installer ma nvlle broche pour remplacer ma pauvre défonceuse et param mes fin de courses et limites ....puis des tonnes de choses à faire mais ça fait plaisir :)
Merci pour la réactivité du groupe :)
Je vais garder quand même mes moteurs de péniche et peut-être ajouter des chenilles sur ma table histoire de lui donner une utilité supplémentaire... elle à plus de CV que ma 3008 loooool
Merci encore
 
La dernière réponse à ce sujet date de plus de 6 mois
Haut