CNC G-code et GRBL, mettre le pied à l’étrier

  • Auteur de la discussion jpbbricole
  • Date de début
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 204
Corsier-sur-Vevey (Vaud)
  • Auteur de la discussion
  • #76
Mets moi quand même le message d'erreur complet pour trouver quelle bibliothèque pose problème.
 
S
sabeldom
Ouvrier
30 Déc 2017
376
re-
J'ai repris à Zéro, lancer débug, changer de port en 13, avant avec 15 celà fonctionnait et plus d'erreurs, je ne comprends pas ce qui c'est passé!!! demain je vais voir la suite
OUFF!! bonne soirée
Merci excuses i de t'avoir mis en recherche
je commençais à désespérer. ( Ce n'était pas le jour un ami Horloger nous a quitté, il m'avait fait ces adieux il y a un mois)
Bonne soirée
Dom
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 204
Corsier-sur-Vevey (Vaud)
  • Auteur de la discussion
  • #78
Pas de soucis, bonne nuit.
 
S
sabeldom
Ouvrier
30 Déc 2017
376
RE-
Je suis encore dessus, quand je tape depuis la fenêtre moniteur arduino $$ voila ce qu'il me donne et après c'est cela qui me bloque l'ensemble, un conflit?
Maintenant je vais aller au dodo
Merci @+
1532988820628.png
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 204
Corsier-sur-Vevey (Vaud)
  • Auteur de la discussion
  • #80
Salut Dom

Bien dormi?
Tu n'avais pas aussi Candle d'ouvert?

Cette commande, $$ fais la dans Candle.

Bonne journée
jpbbricole
 
S
sabeldom
Ouvrier
30 Déc 2017
376
Bonjour
Dormi moyen!
Candle était effectivement ouvert
. je regarde la suite.
Merci @+
 
S
sabeldom
Ouvrier
30 Déc 2017
376
Re-
Suite au 2 $$
Réponse:
$0=10 (step pulse, usec); $1=25 (step idle delay, msec); $2=0 (step port invert mask:00000000); $3=0 (dir port invert mask:00000000); $4=0 (step enable invert, bool); $5=0 (limit pins invert, bool); $6=0 (probe pin invert, bool); $10=3 (status report mask:00000011); $11=0.010 (junction deviation, mm); $12=0.002 (arc tolerance, mm); $13=0 (report inches, bool); $20=0 (soft limits, bool); $21=0 (hard limits, bool); $22=0 (homing cycle, bool); $23=0 (homing dir invert mask:00000000); $24=25.000 (homing feed, mm/min); $25=500.000 (homing seek, mm/min); $26=250 (homing debounce, msec); $27=1.000 (homing pull-off, mm); $100=250.000 (x, step/mm); $101=250.000 (y, step/mm); $102=250.000 (z, step/mm); $110=500.000 (x max rate, mm/min); $111=500.000 (y max rate, mm/min); $112=500.000 (z max rate, mm/min); $120=10.000 (x accel, mm/sec^2); $121=10.000 (y accel, mm/sec^2); $122=10.000 (z accel, mm/sec^2); $130=200.000 (x max travel, mm); $131=200.000 (y max travel, mm); $132=200.000 (z max travel, mm); ok
Tu veux un décodeur canal+
Merci @+
 
S
sabeldom
Ouvrier
30 Déc 2017
376
Re- info
J' ai pris les signaux au scope, ils arrivent sur dir au lieu de Step, donc pas au bonne endroit, faut que je regarde de nouveau le fichier
 
S
sabeldom
Ouvrier
30 Déc 2017
376
RE
info
J'ai fait une maquette en croisant les deux fils et cela tourne , le fichier est bien conforme à la modif, peut' être un petit bug,
Merci
à suivre...
 
S
sabeldom
Ouvrier
30 Déc 2017
376
Info.
le moteur chauffe, sans qu'il travail, peut' être après execution, les signaux dir et step ne sont pas au bon niveau logique? la tension Power est de 12v
Que penses tu?
 
S
sabeldom
Ouvrier
30 Déc 2017
376
La chauffe peut elle venir des + et des - sur le moteur polarisation pas respectés?
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 204
Corsier-sur-Vevey (Vaud)
  • Auteur de la discussion
  • #87
peut' être un petit bug,
Je pense que ta nouvelle version ne se télécharge pas, sinon les signaux seraient "redressés", je pense qu'il faudrait installer une version de l'IDE Arduino uniquement pour traiter ton GRBL. Télécharges la version ZIP, installes-la dans un répertoire dédié, mets le GRBL avec cpu_map.h corrigé dans les libraries et fait tout depuis cette version.
La chauffe peut elle venir des + et des - sur le moteur polarisation pas respectés?
Non, c'est le signal ENA qui reste actif (à 0)

A+
jpbbricole
 
La dernière réponse à ce sujet date de plus de 6 mois
Haut