Création d'un ECU OpenSource pour micro réacteur

J

j-pax

Compagnon
Excellent! Si c'est fonctionnel il ne reste plus qu'à numériser avec kicad en cms et faire une commande chez jlpcb. Attention le KMZ a un axe pour la détection, mais je pense que tu le sais.
Je n’avais pas vu qu’il y avait un axe a respecter pour le kmz , je l’ai placé comme sur le capteur Xicoy... Utiliser les cms oui , mais pas trop petits.
 
F

FLCV71

Apprenti
hello,
Commande groupée , oui je suis partant aussi . si il y a montabilité sur du KJ66 en terme de taille de platine .
Le stock n'est jamais de trop en cas de crash moteur car je suis qu'au début de cette aventure.
 
A

Aero66

Ouvrier
J'ai egalement un ecu Xicoy tout neuf , j’attends juste les condensateurs pour faire un test du montage en conditions réelles. C’est une excellente idée de faire une commande groupée , je suis également interressé. Il serait bien que la plaque du pcb soit suffisamment grande pour pouvoir être redécoupée a la forme voulue.
Si tu as besoin d'aide pour le paramétrage du Xicoy n'hésite pas, je commence à bien le connaitre.
Je pense que tu vas tester en mode manuel au départ, ce mode est très très simple à programmer et ne te posera pas de soucis particulier.
 
J

j-pax

Compagnon
Super , si ça coince , je te demanderai. Pour tester juste les rpm , il ne doit pas être nécessaire de tout programmer , non ? Si je je branche l’accu , le gsu et le récepteur , je dois avoir l’affichage des rpm ?
 
A

Aero66

Ouvrier
Super , si ça coince , je te demanderai. Pour tester juste les rpm , il ne doit pas être nécessaire de tout programmer , non ? Si je je branche l’accu , le gsu et le récepteur , je dois avoir l’affichage des rpm ?
Oui il faut juste connecter le capteur et tu auras les tours.
Pour le démarrage manuel il faut juste programmer le voltage de démarrage de la pompe, la vitesse de montée en puissance de la pompe jusqu'aux ralenti, rpm ralenti, rpm plein gaz. C'est fait en 3 minutes chrono.
 
J

j-pax

Compagnon
Effectivement , ça a l’air simple. Je ne sais pas encore sur quel moteur je vais mettre l’ecu xicoy ( g booster 80 ”reconstruit” , kingtech ou Kj66 ).
 
A

Aero66

Ouvrier
Effectivement , ça a l’air simple. Je ne sais pas encore sur quel moteur je vais mettre l’ecu xicoy ( g booster 80 ”reconstruit” , kingtech ou Kj66 ).
Il en est où le gbooster? Tu as mis une roue jetjoe si je me souviens bien? Il fonctionne bien?
 
J

j-pax

Compagnon
A l’heure actuelle , il tourne. Je ne l’ai pas poussé très fort car il n’est pas encore équilibré. J’ai refait l’entrée d'air , l’arbre , le tunnel , les roulements , le circuit carb , changé le rotor du compresseur et mis la roue de turbine jetjoe. Le capteur rpm était optique , je l’ai remplacé par le kmz et aimant.
20240108_212328.jpg
 
A

Aero66

Ouvrier
Un bon plan pour les capteurs de température.
Après avoir testé un bon nombre de thermocouple, aucune version à bas cout ne fonctionnait avec l'ecu Xicoy, lors du démarrage kérostart il y avait un problème de température qui indiquait une mesure totalement farfelue durant tout le temps de fonctionnement de la bougie.

Problème résolu avec ce capteur blindé : https://fr.aliexpress.com/item/1005...st_main.5.21ef5e5bhFnmhc&gatewayAdapt=glo2fra

6 à 7 fois moins cher que le thermocouple vendu par Xicoy. Testé à l'instant, fonctionnement parfait en mode kérostart. A voir sa durée de vie désormais, mais je ne suis pas trop inquiet.

Il faudrait trouver un bon plan pour les bougies kérostart désormais, ce n'est pas faute de chercher. (42 euros la bougie)
 
J

j-pax

Compagnon
Merci beaucoup pour l'information , je regardais ces sondes depuis quelque temps sans savoir laquelle acheter. Pour le capteur rpm , il fonctionne également sur l'ecu Xicoy ( testé uniquement à faibles vitesses).
 
A

Aero66

Ouvrier
Merci beaucoup pour l'information , je regardais ces sondes depuis quelque temps sans savoir laquelle acheter. Pour le capteur rpm , il fonctionne également sur l'ecu Xicoy ( testé uniquement à faibles vitesses).
Tu as testé jusqu'à quelle vitesse à peu près?
 
J

j-pax

Compagnon
Pour l'instant , je ne l”ai testé que sur une perceuse a quelques milliers de tours. Mais je vais le tester sur le g-Booster dès que je peux.
 
A

Aero66

Ouvrier
Pour l'instant , je ne l”ai testé que sur une perceuse a quelques milliers de tours. Mais je vais le tester sur le g-Booster dès que je peux.
Ok.
Souvent les problèmes de capteurs arrivent sur les régimes élevés. Le GBooster en 8kg doit être dans les 160 000 rpm plein gaz, cela nous donnera une très bonne idée du fonctionnement du capteur. Tiens nous au courant.
 
J

Joachim

Ouvrier
Pour les bougies, j'ai trouvé ça sur ali, il faudrait les passer au chalumeau voir si elles aiment, ça doit etre possible de la tuber peu être.

Sinon il y a celle là que j'ai testé au rouge, qui marche bien et qui est prevu pour être dans une flamme. Par contre elle est un peu grosse.
 
J

j-pax

Compagnon
Ok.
Souvent les problèmes de capteurs arrivent sur les régimes élevés. Le GBooster en 8kg doit être dans les 160 000 rpm plein gaz, cela nous donnera une très bonne idée du fonctionnement du capteur. Tiens nous au courant.
Aujourd’hui , essai du capteur rpm sur le G-booster. Je ne pousse pas a plus de 80000 tr/min car le moteur n’est pas équilibré. Ca fonctionne bien aux bas régimes mais quand je pousse les gaz , ça commence a déconner. L’info de vitesse disparait puis revient sur le gsu. En fait je pense que le pcb ne convient pas , il est trop souple ( bakélite peu épaisse + trous tous les 2,5 mm) et celui-ci doit vibrer ( il n'était fixé que par une vis a une extrémité). Il n'y avait aucun équipement électrique près du moteur , je ne pense pas que ce soit un parasitage. le schéma électrique est celui de Xicoy , je ne vois pas pourquoi il ne conviendrai pas...
 
J

j-pax

Compagnon
Bon , j’ai trouvé mon ânerie sur le circuit. La résistance cms marquée 470 (sur l’alim 5v du circuit d’origine), je l’ai prise pour une résistance de 470 ohms alors que sa valeur est de 47 ohms. Je corrige ça et je referai des essais demain.
 
Dernière édition:
A

Aero66

Ouvrier
Aujourd’hui , essai du capteur rpm sur le G-booster. Je ne pousse pas a plus de 80000 tr/min car le moteur n’est pas équilibré. Ca fonctionne bien aux bas régimes mais quand je pousse les gaz , ça commence a déconner. L’info de vitesse disparait puis revient sur le gsu. En fait je pense que le pcb ne convient pas , il est trop souple ( bakélite peu épaisse + trous tous les 2,5 mm) et celui-ci doit vibrer ( il n'était fixé que par une vis a une extrémité). Il n'y avait aucun équipement électrique près du moteur , je ne pense pas que ce soit un parasitage. le schéma électrique est celui de Xicoy , je ne vois pas pourquoi il ne conviendrai pas...
Tu peux essayer de fixer le capteur sur le banc de test et pas sur le moteur afin de limiter les vibrations. Le capteur xicoy est monté sur des silent blocs, mais j'ai déjà utilisé des capteurs sans silent bloc, cela ne change rien au bon fonctionnement.
Tu peux peut être aussi déporter le KMZ de la platine, afin que la platine ne subisse pas de vibration en la mettant plus loin du moteur.
Même sur des moteurs très déséquilibrés ( à mes début dans la discipline) je n'ai jamais eu de pb de capteur rpm.
Il faut aussi soigner l'alignement du capteur avec l'aimant, tout en étant le plus proche possible.
 
A

Aero66

Ouvrier
Bon , j’ai trouvé mon ânerie sur le circuit. La résistance cms marquée 470 (sur l’alim 5v du circuit d’origine), je l’ai prise pour une résistance de 470 ohms alors que sa valeur est de 47 ohms. Je corrige ça et je refai des essais demain.
Ah ben voila! Vivement la suite demain alors :wink:
 
A

Aero66

Ouvrier
C'était bien ça , maintenant le capteur fonctionne parfaitement (testé jusqu’a 80000 tr/min).
C'est une bonne chose. Ça avance petit à petit.
Faut que j'investisse dans quelques kmz tant que l'on arrive à les trouver à prix correct.
 
A

Aero66

Ouvrier

Salut Joachim,

Je remonte ce vieux message qui était en page deux du sujet actuel. Tu m'avais proposé ce schéma pour pouvoir monter un moteur plus puissant sans être limité par le fadec Xicoy, avec la possibilité de travailler sur du 3S (le fadec accepte que du 2S).
Je rencontre un problème pour mettre le démarrage automatique sur le turboprop que je fabrique. Lorsque je connecte la transmission à courroie, j'ai trop de frottement pour arriver à démarrer le réacteur avec le petit moteur brushed habituel. Je suis obligé de passer sur un bien plus gros moteur. Le fadec coupe le démarrage car il y a un trop gros pic d'intensité et il se met en sécurité.
Est ce que je peux utiliser le schéma ci dessus?
Le cahier des charges : gros moteur brushed (format 540) en 2S ou 3S si nécessaire, 25 000 rpm pour éviter un démarrage trop chaud, capacité de passer une grosse intensité.
 
J

Joachim

Ouvrier
Ca me semble bon, il va falloir tâtonner pour les résistances, je dirait r1 et r3 1k, et r2 plus faible 200 ohm peut être pour avoir une commutation franche. Pour le transistor, un irf44 ou buz11 devrait le faire, ça dépendra de ton moteur en fait. Les mosfet se mettent en parallèle plutot bien aussi. Je suppose que tu vas faire le montage en proto en premier.
Pour tester si le montage fonctionne, tu alimente l'optocoupleur, et le transistor devient passant, à tester avec une ampoule de voiture, c'est le plus sur.
 
F

FLCV71

Apprenti
Hello,
j'espère que tout le monde va bien , les beaux jours arrivent .
merci ''Aero 66'' d'avoir réouvert cette piste, je n'y avais pas pensé mais je risque que de rencontrer le même problème avec ma turbine ''JAKA....'' maison et le train de pignons à trainer.
 
A

Aero66

Ouvrier
Hello,
j'espère que tout le monde va bien , les beaux jours arrivent .
merci ''Aero 66'' d'avoir réouvert cette piste, je n'y avais pas pensé mais je risque que de rencontrer le même problème avec ma turbine ''JAKA....'' maison et le train de pignons à trainer.
Salut,

Avec le train de pignon il n'y aura que peu de frottements si tout est bien conçu. Avec les courroies il y a bien plus de friction à cause de leur mise sous tension.
Je comprends mieux maintenant pourquoi les PHT2 et 3 de chez jet cat ont un très très gros démarreur.
J'arrive à démarrer mon turboprop avec un brushless de 180gr à fort KV en 4S. Il ne faut pas arrêter le démarreur avant 25 000 rpm sinon ça ne s'auto entretien pas à cause des frictions des courroies.
Bonne nouvelle pour l'ecu Xicoy, on peut le faire fonctionner en mode kérostart tout en gérant "manuellement" le moteur de démarrage. Il suffit de mettre le démarreur sur un pota de la radio et de gérer le démarrage avec les tours programmés dans l'ecu. Le xicoy accepte de faire la sequence de cette manière, c'est top. Je mettrai une vidéo bientot.
 
F

FLCV71

Apprenti
Oui effectivement d'après calculs pour 2 courroies + 6 roulements tu dois avoir un rendement 0.83, mais c'est un système que j'affectionne pas trop car ca donne un effort de flexion non négligeable sur le bout d'arbre et vieillissement plus rapide du roulement juste derrière le compresseur.
Pour mon cas , j'ai déjà un rendement de 0.89 ( 6 roulements + 2 contacts ), c'est un peu mieux mais c'est pas comme un réacteur seul alors je verrai si je met un moteur bodybuildé comme même.
 

Sujets similaires

A
Réponses
22
Affichages
1 858
superjeanmi
S
J
Réponses
5
Affichages
746
Aero66
A
Papy54
Réponses
9
Affichages
527
Papy54
Papy54
lolo
Réponses
1
Affichages
831
lolo
F
Réponses
1
Affichages
341
mvt
biscotte74
Réponses
28
Affichages
972
Einzylinder
Einzylinder
F
Réponses
6
Affichages
1 151
ferdi26
F
Jacques T.
Réponses
130
Affichages
3 623
Jacques T.
Jacques T.
Castor24
Réponses
10
Affichages
697
wika58
wika58
A
Réponses
309
Affichages
23 553
Aero66
A
Haut