configuration des axes

  • Auteur de la discussion danyell
  • Date de début
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #1
bonjour a tous
je voudrais configurer mes axes en haut a droite
quand je mets tous les axes a 0.00 (axes machine aussi)
et que je fais un référencement des axes ils ne bougent pas
mais j'ai quand même les leds verte allumées
et si je déplace mes axes au centre de la table
et que je fais(aller a 0.00) dans l'écran automatique
les axes ne bougent pas mais grognent comme si ils étaient en butée
j'ai regardé la doc mach3 c'est très flou
pas de procédure pour le référencement
si quelqu'un pouvait me donner la procédure pas a pas depuis le départ
j'en serais ravi car a force de bidouiller je mélange tout
merci de vos conseils
cdt
 
PL50
PL50
Compagnon
7 Oct 2014
1 799
30Km de Cherbourg - Manche (50)
bonjour a tous
je voudrais configurer mes axes en haut a droite
quand je mets tous les axes a 0.00 (axes machine aussi)
et que je fais un référencement des axes ils ne bougent pas
mais j'ai quand même les leds verte allumées
et si je déplace mes axes au centre de la table
et que je fais(aller a 0.00) dans l'écran automatique
les axes ne bougent pas mais grognent comme si ils étaient en butée
j'ai regardé la doc mach3 c'est très flou
pas de procédure pour le référencement
si quelqu'un pouvait me donner la procédure pas a pas depuis le départ
j'en serais ravi car a force de bidouiller je mélange tout
merci de vos conseils
cdt
salut
peux tu nous dire de quelle type de machine tu parles?
portique?
photo?
as tu des capteurs de homing installés et déclarés comme tels dans mach3?
a+
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #3
slt
Machine à portique diy
Oui j.ai 3 capteurs mécanique reliés à ma carte
Par contre où faut il les déclarer dans Mach3?
Merci
 
PL50
PL50
Compagnon
7 Oct 2014
1 799
30Km de Cherbourg - Manche (50)
slt
Machine à portique diy
Oui j.ai 3 capteurs mécanique reliés à ma carte
Par contre où faut il les déclarer dans Mach3?
Merci
Dans les entrées à côté de x++ et x--
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #5
slt ça j'ai deja fait mais ça marche pas
je voudrais savoir comment je branche mes capteurs sur cette carte

end stop.jpg


usb motion card.jpg
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #6
pour que je puisse utiliser le referencement et les limites d'axes
merci pour vos reponses
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #7
est ce qu'il faut brancher le fil rouge sur entrée X home ou sur X++
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 986
FR-28360
Difficile de suivre les pistes (double face ?), ces switches sont prévu pour les imprimantes 3D qui sont en 5V, le contact doit être entre l'entrée et le 0V. Toi, il faut que le contact soit entre l'entrée et le 24V. Je pense donc que le vert doit âtre au +24V mais la Led ne fonctionnera pas.
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #9
quand je branche le vert sur 0 v et le rouge sur X home par exemple
la led s'allume quand je clic mais le fdc n'a aucun effet mon axe continue
de tourner
donc j'en conclu que je dois acheter de nouveaux fin de course ?
merci pour ta reponse
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 986
FR-28360
tu peux avoir une photo de l'autre face de la carte FdC ?
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #12
c'est ca que tu veux ?
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 986
FR-28360
oui, un peu bizzare cette carte. a l'origine la masse est sur le NC donc le + forcement sur le NO et la sortie sur COM qui est sur 0V quand le FdC est actionné et 24V quand le FdC est relaché. Avec une résistance de 1K je ne suis pas certain que la LED résiste bien longtemps au 24V.

Le branchement serait : +24V sur le Rouge, 0V sur le Noir et vert pour l'entée. Donc normal.
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #14
8d6b290acdfa7_8c6b4b24-3ba7-4225-a7f7-ab0abfb0fc94.jpg


Fonctionnalité:

Le kit Endstop mécanique est destiné aux imprimantes 3D RepRap ou aux machines CNC, il est pris en charge par l'électronique RepRap,
RAMPS 1.4 et d'autres cartes RepRap populaires.
Connexion personnalisée de haute qualité, utilisant du fil 22AWG, le fil de cuivre à l'intérieur est très épais,
peut être résistant au courant 2A, tension 300V.
Une couche isolante sur une large plage de températures, jusqu'à 80 degrés.
Pas facile à casser, pratique pour la prise, facilité d'utilisation, un côté est une prise intégrée.


Description de la connexion:
Ligne rouge reliant VCC (rampes de +)
Connectez le fil noir GND (rampes de -)
Connexion de la ligne verte SIGNAL (rampes en s)


Liste de
colisage : Endstop + 3PIN 70CM Cable For Endstop

sinon j'ai trouver ça qu'en pense tu ?
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #15
donc sur reglage des entrée c'est un contact normalement fermé ou ouvert ?
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #16
je viens de teste pour ref l'axe x
le fin de course n'arrete pas l'axe
je pense que je melange tout dans la configuration du référencement des axes
si tu pouvais me donner la procedure pas a pas ça serait genial
merci d'avance
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #18
oui oui ça c'est correct j'avais compris
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #19
j'ai reussis a faire le referencement des axes
mais le pb si je me deplace au milieu de la table et que je veux activer les limites (message:hors limites impossible d'activer les limites)
et si je veux faire un "aller a 0.00" la machine ne bouge pas
ça parle a quelqu'un ?
 
dh42
dh42
Compagnon
4 Sept 2009
5 843
Près de St Etienne (42)
Salut,

Dans les entrées à côté de x++ et x--
Tu n'a probablement pas déclaré tes limites min et max correctement ... et pour les contacts de référencement, ce ne sont pas les entrées X++ X-- etc, mais Home X, Home Y, Home Z.

par exemple, si en X ton switch est à droite, donc en X+, et que tu a une course de 400mm sur cet axe, Max: sera à 0 et min sera à -400

jette un œil sur ce sujet.


++
David
 
Dernière édition:
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #21
Mes fdc sont en haut à droite donc en X++ et Y++ donc comme toi David et le Z en haut donc Z++ egalement
C’est bon ?
Je rapproche donc ma broche en haut à droite je fais référencer dans l’écran automatique la il me fait 2fois le
Referencement avec un retour de 1 mm pour dégager le fin de course
Jusque là tout va bien.
ensuite je rentre mes limites donc X maxi 0.00 et mini - 330 pour Y meme chose maxi 0.00 mini -485 et là impossible d’activer mes limites message d’erreur.
Alors le fait d’avoir inversé le sens de l’axe pour pour venir toucher les fdc pour le referencement à une insidence sur le reglage
Des limites maxi et mini ? Si quelqu’un a une idée je suis preneur
Merci d’avance !
 
dh42
dh42
Compagnon
4 Sept 2009
5 843
Près de St Etienne (42)
Salut,
Alors le fait d’avoir inversé le sens de l’axe pour pour venir toucher les fdc pour le referencement à une insidence sur le reglage
Des limites maxi et mini ? Si quelqu’un a une idée je suis preneur
Non, aucun.

Tu peux faire une capture d'écran de la fenêtre des limites ?

Après référencement et juste avant de tenter d'activer tes limites, peux tu noter la valeur des coord XYZ en coord machine ; on verra tout de suite si les axes sont ou ne sont pas dans la plage des limites fixées.

Je ne connais pas la XHC, mais il se peut aussi que tu ai des réglages de limites dans le plugin de la carte ... à vérifier.

++
David
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #23
Bonsoir je vais faire ça dès que possible et egalement
Une capture d’écran des réglages de ma carte
Je ne comprends pas bien ta demande
Après referencement et juste avant De tenter d’activer les limites etc...
La valeur Des coordonnée Machine XYZ seront à 0.00
 
dh42
dh42
Compagnon
4 Sept 2009
5 843
Près de St Etienne (42)
La valeur Des coordonnée Machine XYZ seront à 0.00
le but c'est justement de vérifier si c'est bien le cas ! ... avec les cartes chinoises, je m'attends à tout ! elles sont spécialisées dans les bizarreries, en particulier avec le référencement et le palpage ...

++
David
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #25
bonjour
premiere capture apres referencement XYZ sont a 0.00
fenetre reglages limites et origines
et enfin reglages carte XHC

Capture 1.PNG


Capture.PNG


Capture2.PNG
 
dh42
dh42
Compagnon
4 Sept 2009
5 843
Près de St Etienne (42)
Salut,

Il y a un problème avec ton Z ; le minimum doit être à -45 et non pas à 45

++
David
 
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #27
Oui j’ai rectifier et refais les tests
Des que je bouge mes axes et que je fais un « aller à 0.00 »
Impossible l’axe x se mets grogner et s’éloigne par a coup
Vers la gauche au lieu d’aller vers le point 0.00 des coordonnées
Machine.
alors je me suis poser la question est ce que je n’aurai pas un beug
Sur cette version de Mach 3?
 
dh42
dh42
Compagnon
4 Sept 2009
5 843
Près de St Etienne (42)
alors je me suis poser la question est ce que je n’aurai pas un beug
Sur cette version de Mach 3?
C'est pas impossible ! .... je vois que tu a les menus en Français, donc c'est très probablement la version 3.043.066 qui est pas mal buguée ; malheureusement ce sont des bugs aléatoires, au sens ou ils n'apparaissent pas chez tout le monde pour une raison inconnue !!

Chez moi la 066 m'a toujours causé des problèmes, et sur 2 PC différents et 2 systèmes différents (XP et 7) le principal étant que parfois les macro ne fonctionnent pas du tout ou s'arrêtent en cours de route ... et sur Mach3, même si ça ne se voit pas, il y a pas mal de choses qui utilisent des macro en VBS (Visual Basic Script), notamment la plupart des codes M, le référencement, le palpage, etc ...

Le fabricant de ma carte d'axe (ESS) précise même qu'il ne faut pas l'utiliser et propose la 062 en téléchargement.

une liste (non exhaustive) des bugs courants sur cette version.

The latest release was Mach3 version 3.043.066. However, a number of people have had stability issues with their systems when using version .066. The .066 version has had these issues for some users:


  • MPG issues (we have seen this many times)
  • Pendent issues (we have seen this many times)
  • Feed hold issues
  • Homing issues
  • Macros not being fully run
  • VB buttons being ignored

If you are using v.066, we will tell you to install v.062 as the first step before we do anything else in term of support.
Dans les autres bugs que j'ai eu
- la broche qui ne redémarre pas après un changement d'outil ; logique, le M3 c'est une macro en VBS
- le palpage qui s'arrête en cours de route, même chose c'est aussi une macro VBS

Donc si tu a la 066, je te conseil de passer à la 062, ça ne peut pas nuire.


Des que je bouge mes axes et que je fais un « aller à 0.00 »
Impossible l’axe x se mets grogner et s’éloigne par a coup
Vers la gauche au lieu d’aller vers le point 0.00 des coordonnées
Machine.
Strange, d'autant plus que ce bouton, ce n'est pas du VBS mais un code OEM interne (17) ; par contre attention, ce bouton n’envoie pas au 0 machine mais au 0 pièce.

pour faire un retour au 0 machine , tu peux taper un G30 dans la ligne de saisie de Gcode sur l’écran "manuel"

sur ton plugin, je vois que tu a "dual stage" de coché pour le homing ; tu a 2 moteurs sur un axes et tu fait un "squarring" du portique ? (équerrage du portique via un double référencement)

si ce n'est pas le cas, essai "single stage", voir même "no homing" ; je ne connais pas la XHC, mais sur l'ESS si je désactive le homing dans le plugin alors il est totalement géré par Mach3 au lieu d'être géré par la carte.

Je sais aussi que sur les XHC USB il y avait un justement un bug avec le homing "double stage", mais ça date d'au moins un an, avec un peu de chance il ont corrigé le bug.

++
David
 
Dernière édition:
D
danyell
Apprenti
14 Déc 2019
115
  • Auteur de la discussion
  • #29
La version .......066 a t’elle été deboguee ?
celle que l’on trouve chez Jazial.fr en achetant la licence
Est t’elle bougée également ?
 
dh42
dh42
Compagnon
4 Sept 2009
5 843
Près de St Etienne (42)
nos messages se sont croisés .. :wink:

La version .......066 a t’elle été deboguee ?
Non, elle n'est même pas dans la liste des versions de Mach3 du "changelog" ..
 
Haut