Problème CNC Perte de X,Y ou Z en fin de programme

  • Auteur de la discussion avthierry
  • Date de début
A
avthierry
Nouveau
26 Mar 2018
15
  • Auteur de la discussion
  • #1
Bonjour,

J'ai un petit problème avec ma CNC
Quand j'arrive en fin de programme, le programme perds le point X,Y ou Z tout d'un coup et se décale.

Je ne vois pas quel est le problème.
Voici quelques photos

Est-ce que quelqu'un connait ce problème?

Merci

received_2045983905674435[1].jpeg


received_2045983899007769[1].jpeg


received_2045983885674437[1].jpeg


received_2045983859007773[1].jpeg


received_2045983795674446[1].jpeg


received_2045983762341116[1].jpeg


received_2045983742341118[1].jpeg


received_2045983692341123[1].jpeg


received_2045983689007790[1].jpeg


received_2045983705674455[1].jpeg
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 970
FR-28360
Bonjour
Sur la photo ta pièces était terminée ? le décalage c'est fait sur le retour au parking ?
En tout cas ce n'est pas un manque d'alimentation:mrgreen:
 
A
avthierry
Nouveau
26 Mar 2018
15
  • Auteur de la discussion
  • #3
Bonjour
Sur la photo ta pièces était terminée ? le décalage c'est fait sur le retour au parking ?
En tout cas ce n'est pas un manque d'alimentation:mrgreen:
C'est un peu aléatoire la dernière fois que ca c'est passé la pièce etait fini mais en revenant sur mon point 0 elle a déconné (j'avais eteint la broche pour ne pas avoir d'interférence)

Sur la photo c'était un autre test et non ce n'était pas fini

Merci
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 970
FR-28360
Ca me fait penser à un autre fil ou il y a des arrêts de moteurs avec la même carte.
C'est toujours sur les déplacement ?
Tu as essayé en réduisant la vitesse max ? quel est la tension de tes alimentations et les caractéristiques de tes moteurs ?
 
A
avthierry
Nouveau
26 Mar 2018
15
  • Auteur de la discussion
  • #5
bonjour,
voila les alimentations on 60v,les moteur
Technical Specifications
Part No.: 34HS5435C-37B2
Frame Size: NEMA34
Phase: 2 Phase
Step Angle: 1.8 degree
Current: 3.5A
Rated Voltage: 5.6V
Resistance: 1.6 Ohm/phase
Inductance: 22mH/phase
Holding torque: 1600oz-in (10.5N.m)
Detent torque: 24.5N.cm
Rotor inertia: 3600g.cm²
Number of wire leads: 4 (Red A+ ,Green A- ,Yellow B+ ,Blue B-)
Weight: 5kg
Length: 151mm
Front shaft length 37mm
The diameter for motor shaft is 14mm
491023894_o.jpg
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 970
FR-28360
Ce n'est pas trop surprenant tu as des moteurs de 10.5 N.m avec seulement 3.5A ce qui explique l'inductance énorme de 22mH.
Tu as quelle vitesse en rapide et quel est quel est le pas de tes vis ?
 
A
avthierry
Nouveau
26 Mar 2018
15
  • Auteur de la discussion
  • #7
le pas et de 5 la vitesse des rapide bonne question,
je ne trouve pas ou la diminuée sur mach3
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 970
FR-28360
A 50mm/s l'inductance des moteurs te bouffes presque 50V (LIω) pour rien avec les 5.6V bouffés aussi par la résistance il pas beaucoup de Volts utiles.

Comme ce n'est pas possible le courant de 3.5A ne peut pas être maintenu d'ou un forte chute du couple.
 
A
avthierry
Nouveau
26 Mar 2018
15
  • Auteur de la discussion
  • #10
oui j’ai bien les réglage de 3000 vitesse en mm/min 250 acc desole je suis juste mécano
et moi et elect ça fait deux
 
A
avthierry
Nouveau
26 Mar 2018
15
  • Auteur de la discussion
  • #11
juste, délai direction et sur 5 impulsion aussi sur 5 ? a quoi
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 970
FR-28360
Comme je le disais à 3000 mm/min (50mm/s) tes moteurs sont beaucoup trop inductifs pour conserver un peu de couple. il faut réduire ou alors changer les moteurs
 
A
avthierry
Nouveau
26 Mar 2018
15
  • Auteur de la discussion
  • #13
je regarde ça merci pour les info
 
A
avthierry
Nouveau
26 Mar 2018
15
  • Auteur de la discussion
  • #14
dite moi je ne pas bien compris je doit diminuée quoi alors parce-que j’ai acheter un kit complet moteur driver alim désolè pour les question un bête
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 970
FR-28360
la vitesse maximum, par exemple passer de 3000mm/min a 2000mm/min.
Il faut savoir que plus le moteur tourne vite et plus il lui faut de la tension. Si la tension du moteur arrive à la tension de l'alimentation, il va décrocher très vite.
Les moteurs trop coupleux peuvent aussi avoir des phénomènes de résonances si il n'ont pas assez d'inertie derrière, ça les fait décrocher. Le drivers moderne réduisent ce problème.


Les moteurs qui ont beaucoup de couple, on les utilises plus sur des entrainements à crémaillères, ou ils n'ont pas besoin de tourner très vite.
 
A
avthierry
Nouveau
26 Mar 2018
15
  • Auteur de la discussion
  • #16
de 2000 a 3000 la plus rien ne fonctionne ou très malles moteur bloc plus je diminue ça empire la je vient de mètre 4500 pour voir
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 970
FR-28360
Alors là je ne comprend pas, normalement ça limite seulement la vitesse maximale.
Tu n'as pas la possibilité de faire une vidéo ?
 
A
avthierry
Nouveau
26 Mar 2018
15
  • Auteur de la discussion
  • #18
je regarde ça de suite
 
A
avthierry
Nouveau
26 Mar 2018
15
  • Auteur de la discussion
  • #21
ça a 4500 demain je t’envoie a 2000 tu vas voir
 
Haut