Autres MultiCN Evaluation pour Arduino Uno

K

Kamusta

Apprenti
Bonjour,
Ah oui quand même, bon on est plus dans la même cour qu'avec un Arduino :eek:

Pour la machine c'est bon, j'avais encore changé, pratique Amazon, tu renvoies, ils remboursent :lol:.
J'ai essayé ce matin de mettre le sketch sur leur carte Camtool CNC v3.3 de la machine, le sketch se charge avec l'IDE d'Arduino !!!! :-D
Et...., ça communique avec MultiCN :smt038

Par contre j'ai un soucis, les End-stop ce sont des NO optiques et MultiCN n'a pas l'air d'apprécier, lorsque je fais le POM, il me renvoie les axes au max, même quand les End-stop sont actifs ?
Du coup mes moteurs broutent, lolll

Précisions:
Les end-stop renvoient 5V tant qu'ils ne sont pas actifs et renvoient 0V lorsqu'ils sont activés.
Ça a l'air d'être reconnu sur MultiCN, puisque les Leds X, Y, Z s'éteignent sur le tableau de bord, le changement d'état est donc bien pris en compte.
Et les Leds ne se rallument que si je bouge les axes pour désactiver le end-stop.

Bref, j'appelle au secours.
Dis moi si tu as besoin de fichiers et lesquels, merci.

A suivre donc, mais j'y arriverai :).

Bonne fin de weekend.
 
Dernière édition:
V

vres

Compagnon
Ça a l'air d'être reconnu sur MultiCN, puisque les Leds X, Y, Z s'éteignent sur le tableau de bord, le changement d'état est donc bien pris en compte.
Et les Leds ne se rallument que si je bouge les axes pour désactiver le end-stop.
Ça ce change dans la fenêtre de configuration, il faut prendre contact NC
 
K

Kamusta

Apprenti
Ça ce change dans la fenêtre de configuration, il faut prendre contact NC

Excuses, tu as dégainé plus vite que j'ai corrigé mon post.
Non, les contacts sont des NO optiques, si je les mets en NC alors là les moteurs souffrent et j'ai une erreur.
C'est bien en NO que ça marche.
Une idée pourquoi ça n’arrête pas l'axe au moment ou le end-stop s'active ?
Et pour les Leds du tableau de bord elles sont normalement éteintes ou allumées ?
 
V

vres

Compagnon
Ah oui, les switchs sont actifs a 0V sur Arduino.
Si tu dis que les axes partent vers le Max normalement si tu changes NO en NC tu dois partir dans l'autre sens non ?
Normalement les axes X et Y ne doivent pas bouger tant que le switch Z n'est pas atteins.
Les Leds sur le tableau de bord ne change pas en fonction du réglage NC ou NO il me semble. Je n'ai pas de MultiCN installé ici.
 
V

vres

Compagnon
Je viens d'installer MultiCN et de vérifier, Les Leds s'allument en NC, donc elle s'allument quand tu es sur le contact, il faut que tes contacts soient en NC.
 
V

vres

Compagnon
Un petite machine 5 axes à rétrofiter avec MultiCN.
De quoi m'occuper au frais a l'atelier pendant la canicule.
Même si mon interpolation fonctionnent très bien sur les courbes tout en respectant la trajectoire, je vais en profiter pour faire un lissage en prenant en compte jusqu'à 10 vecteurs contre 3 actuellement de façon avoir de meilleures tangentes sur les très très petits vecteurs qui peuvent faire une cassure de vitesse.
481607

481608
 
kooroshtux

kooroshtux

Nouveau
j'aurais juste une question si ce n'est pas trop indiscrette , tu as developpé ton logiciel sous quel language de programmation ?
 
V

vres

Compagnon
Depuis sa sortie, j'utilise Builder C++, c'est similaire a Delphi mais en C++. C'est un produit qui a été développé par Borland devenu Embarcadero depuis 2006.
 
F

fc3d

Apprenti
@CNCSERV ,

Bonjour, tout d'abord félicitations pour tout le travail que tu as accompli avec MultiCN. J'aimerais bien avoir tes connaissances, franchement bravo !
Dans le fablab de ma ville nous avons une vieille charly robot sans électronique ni fdc, il faut que je regarde si les moteurs sont en 4 ou 6 fils.
M'autorises tu à me servir de ton logiciel ? L'usage en sera fait au sein du makerspace, afin d'intéresser les quelques jeunes qui ne passent pas leurs temps que sur leurs téléphones..

Cdlt.
 
Dernière édition:
V

vres

Compagnon
Bonjour,
A partir du moment ou il n'y a pas de commerce il n'y a pas de souci.
C'est une version démo, j'ai fait très peu d'essais donc je ne garanti pas un fonctionnement 100% fiable.
Je suis en train de faire un firmware pour les petites cartes chinoises à base de STM32F10x pour une version MultiCN Starter abordable.
Ca devrait être prêt pour septembre.

C'est une CharlyRobot à portique Isel ?
 
F

fc3d

Apprenti
resalut et merci de ton accord.
Je ne sais pas si c'est un portique isel, de mémoire les guidages linéaires sont ronds. Il faut que j'aille voir pour en savoir plus.
 
M

matt07600

Apprenti
Bonjour, hier je me suis servi de ma Scripta mais j'ai un problème : souvent la machine se fige et Multicn m'indique "la machine ne répond plus", je suis alors obligé de débrancher l'arduino pour pouvoir relancer, j'ai revu mes connexions et tout me semble ok, je ne sais pas quoi faire, peut être supprimer la gestion de vitesse de broche par le logiciel ?
 
V

vres

Compagnon
C'est probablement un problème de connexion USB, la carte Arduino semble assez sensible. Tu utilises une Arduino authentique avec une puce FTDI ?
Les remèdes :
-Utiliser un câble USB avec ferrites.
-Raccorder les moins des alimentations à la masse et terre.
- voir le blindage du câble de broche.

Tiens moi au courant :wink:
 
M

matt07600

Apprenti
Merci pour tes remèdes, je vais tester ça, la carte Arduino est bien une authentique.@+
 
M

matt07600

Apprenti
De plus j'ai remarqué que pour que le pendant whb04 se connecte au premier lancement du logiciel après le démarrage du pc, il faut que je débranche et rebranche l'usb receiver.
 
V

vres

Compagnon
La télécommande est un périphérique HID, j'ai eu quelques fois des phénomènes un peu bizarres. Tu as une whb ou une HB?
Je n'ai pas finalisé le pilote pour la whb que je trouve moins pratique et je n'ai pas trouvé de sources pour gérer l'afficheur.
 
M

matt07600

Apprenti
J'ai une HB comme tu me l'avais conseillé :wink:, je me suis trompé dans le message précédent.
 
V

vres

Compagnon
Le plugin pour la HB-04B est prêt.
J'ai trouvé une affectation qui me convient presque.
L'afficheur est beaucoup moins complet que la HB-04 mais elle est beaucoup plus solide.
1572896156974.png


Il y a aussi un firmware qui avance bien pour cette jolie carte :
1572896381502.png
 
M

matt07600

Apprenti
Bonjour, je n'arrive pas a importer un fichier .plt avec les différentes "couches" de couleur et ainsi pouvoir choisir l'ordre d'usinage (pour usiner d'abord l’intérieur d'une rondelle par exemple), pourtant dans mon logiciel de découpe laser les différentes couleurs sont bien reconnu, tu utilise quelle suite logiciels pour dessiner tes dessin de découpe?
@+
 
V

vres

Compagnon
A vrai dire depuis les produits Vectric (Cut2D, Vcarve et Aspire) j'ai laisser tomber un peu le plt.
Pour le plt j'avais un module d'usinage qui permettait justement de faire les intérieurs en premier et définir un contour de fraise.
Je ne sais pas si je peux le recompiler pour la version Arduino.

Pour convertir le numéro de plume plt en couleur sur MultiCN, il faut cocher cette case:
1583583288876.png


Avec CorelDraw pour avoir un zéro plt qui correspond au zéro dessin, il faut définir au milieu de la page.
 
V

vres

Compagnon
Le module 2D pour plt :
1583584123089.png


Pour l'utiliser avec la version Arduino il faudrait que je refasse un rebuild complet.
 
M

matt07600

Apprenti
Pour convertir le numéro de plume plt en couleur sur MultiCN, il faut cocher cette case
Ok ça marche j'avais pas vu...
Après c'est sûr que si tu pouvais rajouter le module 2D pour plt ce serait bien car ça permettrait d'utiliser des fichiers standards mais cela dépend du boulot que ça représente...
Bonne journée
 
V

vres

Compagnon
Je vais faire une mise a jour incluant ce module en fin de semaine.
 
V

vres

Compagnon
Vu que le le Coronavirus m'oblige à rester sédentaire, je me suis remis au développement.
J'ai un peu mis de coté les cartes chinoises (bien que j'ai un firmware qui tourne)

Je viens de terminer de développer une Carte BOB universelle pouvant fonctionner avec le port LPT, Une Arduino UNO ou une Carte STM32_F4VE.
Elle est donc compatible avec les logiciels GRBL, Mach3, LinuxCNC, UCCNC... et carte UC100, SmoothStepper, USB ressource...
Et bien entendu MultiCN :mrgreen:

- Sorties 3 à 6 axes bufferisées sur connecteur HE14 (nappe) avec commun intercalé pour chaque signal évitant perturbation et diaphonie.
- 12 Sorties de puissance par relais statiques Omron 60V 0.5A , AC ou DC. Led sur chaque sortie.
- 12 Entrées optocouplées et filtrées 5 à 28V pouvant fonctionner en PNP ou NPN par groupe de 4. Led sur chaque entrée.
- 1 Sortie Analogique 0-10V (convertisseur PWM)
- 1 Entrée Analogique 0-10V,
- 1 Extension pour Ethernet avec carte STM32_F4VE ( pour MultiCN)
- 1 Extension pour carte extension pour servomoteur en 0-10V boucle fermée (MultiCN seulement.....dans un premier temps).
- 1 entrée alimentation facultative pour Arduino et STM32_F4VE.

Connectique débrochable pour faciliter le SAV.
Elle part en fabrication aujourd'hui en croisant les doigts pour que DHL fonctionne toujours normalement jusqu’à la réception:

Sans titre 2.jpg


Sans titre 3.jpg
 
G

gralo

Compagnon
Confinement oblige, je vais essaie de finir ma CN plasma en passant de mach3 à multiCN.

J'ai vue dans le script principal que tu avais déclaré l'axe X2, c'est prevu de faire une version Arduino avec un X1 et X2 ?(machine à portique) sans passer par ta nouvelle carte qui a l'air super!
 
V

vres

Compagnon
Pour l'Arduino le but était de faire une version démo.
Avec l'Arduino je suis très limité par la bande passante du port série et par le nombre de sorties disponibles.
Même avec ma carte il n'ai pas possible d'avoir 4 axes avec l'Arduino.
Les constantes du script principal, je les recopie dans tout les scripts.
 
J

JCHELI

Ouvrier
Bonjour a tous.

Une question pour CNCSERV, j ai une isel 2030 donc via rs 232 as tu une solution de la pilotee avec multicn?
J ai la possibilite je pense de trouve le protocole mais ci quelqun la ?
merci d avance jcd.
 
V

vres

Compagnon
Tu as quoi comme coffret ?
Souvent j'enlève les cartes moteur pour mettre des drivers modernes.
 
J

JCHELI

Ouvrier
Ce n' est pas un coffret mais une carte imc4 .
Anschlussbelegung.png
102651-3159509.jpg


J ai eu avec la machine avec un dongle isel pour GXmove de SELIAtec qui fonction bien.
jcd
 

Sujets similaires

S
Réponses
3
Affichages
4 647
speedjf37
S
P
Réponses
20
Affichages
1 633
speedjf37
S
midodiy
Réponses
26
Affichages
3 809
midodiy
midodiy
R
Réponses
55
Affichages
9 866
jacounet
jacounet
V
Réponses
9
Affichages
34 827
V
P
Réponses
6
Affichages
342
Doctor_itchy
D
D
Réponses
6
Affichages
1 585
Doctor_itchy
D
P
Réponses
18
Affichages
726
dh42
Haut