évolution cnc drivers externe DQ542MA

  • Auteur de la discussion ADT3D
  • Date de début
A
ADT3D
Apprenti
Bonjour à tous,
je viens de recevoir de nouveaux drivers tous neufs pour faire évoluer ma cnc, une tron+ équipée de 4 moteurs nema23 57HS64-3008 qui étaient pilotés par de petits pololu sur une shield.

J’ai donc :

-redirigé les infos step et dir sur les différents drivers.

-câblé les drivers avec les GND.

-ET ENFIN DEMARRE LE TOUT !!!!

Tout s’allume en vert et tous les moteurs tournent dans le bon sens.

Par contre je n’ai touché aucun réglage de signal sur les drivers et tous ceux-ci sont sur OFF, conséquence je pense du déplacement plus du tout aux dimensions demandées et très très lent de mes axes que je n’ai fais fonctionner que sur 5 impulsions dans les deux sens.

Il faut que je fasse les réglages de pas et d’intensités je pense et là je BEUG !!!

J’aimerais savoir :

-Mes moteurs ont 8 fils au départ et 4 à l’arrivée mais les liaisons sont cachées dans de belles gaines et donc je ne sais déterminer le type de connexion donc quelle PEAK appliquer aux drivers.

-Quel réglage de PULSE appliquer, il y a une quinzaine de possibilités sur les drivers !!!!!

Cette machine était déjà en état de marche et je débute dans ce domaine....

Merci d’éclairer ma petite lanterne.

Capture.PNG


Capture2.PNG


NEMA23 EN PLACE.PNG
 
A
ADT3D
Apprenti
J'imagine que le GRBL est important aussi, il devait être paramétré pour mes pololu?

Capture3.PNG


Capture4.PNG
 
A
ADT3D
Apprenti
il y a surement plus joli câblage, mais tout à l'air de fonctionner...

20210513_110758.jpg
 
O
Otatiaro
Compagnon
Salut,

Pas de câblage en série (fils qui arrivent sur le premier driver, puis repartent sur le deuxième, et ainsi de suite).
Il faut que tu fasses partir un fil de ton alim pour chaque driver.

Thomas.
 
A
ADT3D
Apprenti
Bonjour otatiaro,
je n'ai que 3 sorties sur mon alim 36V
Je peux faire cela mais il va me manquer une alim quand même?
merci pour ta réponse mais peux tu m'expliquer en quoi cela est gênant que je comprenne et avance intelligemment
 
A
ADT3D
Apprenti
il va me manquer une sortie ou il faut une deuxième alim?
 
Le Prolls
Le Prolls
Compagnon
Bonjour,

Tu peux mettre 2 fils par sortie d'alim ce n'est pas un problème...
 
A
ADT3D
Apprenti
bonjour le prolls,
Je vais faire cela si vous me le conseillez, mais une explication du pourquoi du comment....
 
A
ADT3D
Apprenti
ok c'est fais et toutes les led verte :-D
Des infos pour ces réglages?
 
Le Prolls
Le Prolls
Compagnon
Pour déterminer le type de connexion des PàP, il faut que tu mesures avec un multimetre en position ohmètre.

Tu sauras ainsi comment est fait le branchement sous les gaines, et tu en déduis le courant peak à régler.
 
A
ADT3D
Apprenti
ok alors là!!!
multimètre ok
méthode pour faire ceci?
Désolé mais il va falloir m'aiguiller un peu:ohwell:
J'ai 4 fils qu'il me semble avoir branché dans le bon sens aux drivers car ils bougent dans le bon sens
 
Le Prolls
Le Prolls
Compagnon
Je ne connait pas GBRL mais un paramètre 1600 revient dans ta liste c'est
peut être les nombre de micropas à régler en fonction sur le driver.
 
A
ADT3D
Apprenti
Non ca je sais, c'est la vitesse de déplacement des axes que je savais paramétrer
Pour info je te mets un pdf qui m'a bien aidé
 
Fichiers joints
  • PARAMÈTRES DU GRBL.pdf
    202.7 KB · Affichages: 5
Le Prolls
Le Prolls
Compagnon
Puisque tes moteurs tournent, tu as correctement identifié et câblé les bobines des moteurs.

Tu débranches les connecteurs des drivers et tu mesures sur les bornes correspondant aux enroulements
schématisés sur le driver
 
A
ADT3D
Apprenti
Les connecteurs n'ont pas l'air de sortir, mais j'ai 2.3 ohm entre les + et - à chaque fois.
Connecteurs branchés sur les drivers par contre
 
A
ADT3D
Apprenti
au fait cette nouvelle configuration non série des alims drivers sert à quoi?
 

Sujets similaires

S
Réponses
10
Affichages
317
sweex59
S
D
Réponses
68
Affichages
1 943
shodan47
shodan47
W
Réponses
54
Affichages
1 267
wapiti
W
Haut