CNC 3040Z-DQ - Paralell Port

M
Miserness
Nouveau
Bonjour,

Tout d'abord je suis extrêmement nouveau dans le monde des CNC. J'ai voulu me faire un petit plaisir en achetant une CNC 3040 sur Aliexpress. Sachant qu'il y avait besoin d'un paralell port pour l'utiliser j'ai donc commandé une carte PCI to Paralell Port. J'ai installé les drivers, acheté Mach3 car en réduc et tout branché le jour de l'arrivée de la fraiseuse.

Mais là, rien ne marche, le DriveTest de Mach3 me dis que rien n'est installé, malgré le fait que ma carte PCI to Paralell Port soit installé. J'ai lu le topic suivant, appliqué les conseils mais rien n'y fait (https://www.usinages.com/threads/presentation-cnc-3040z-4d.53285/)

J'ai effectué pleins de test mais rien n'y fait. Pour info, le boitier contient NT65-3X une Voici donc les divers liens des produits.

Fraiseuse: https://www.aliexpress.com/snapshot...rderId=8121229523410646&productId=33004076545
PCI to Paralell Port: https://www.amazon.fr/gp/product/B0...conversation.0.0.48663e5fiSgvb3&ie=UTF8&psc=1
Manuel que le fabricant m'a envoyé: https://drive.google.com/file/d/0B4...w?spm=a2g0s.imconversation.0.0.48663e5fiSgvb3

Précision:
Le boitier de controle est arrivé avec quelques vis extérieures défaites, mais je pense que ça n'a pas de lien, vu que tout le controle manuel fonctionne.
J'utilise une tour HP
 
H
Hubert86
Compagnon
Bon je ne suis pas un expert de mach3, j'utilise linux cnc, aussi en port parallèle. Mais pas une carte ajoutée. Dans le bios tu dois modifier certaine chose, notamment vérifier que ton port est bien reconnu, et qu'il est en bidirectionnelle. De plus dans mach3 regarde si le port est actif et que l'adresse du port correspond avec celle du bios.
 
M
Miserness
Nouveau
Je suis allé voir dans mon BIOS, aucun moyen de mettre en bidirectionnelle. Le port est pourtant bien detecté dedans. J'ai refait un DriverTest, ca ne donne rien
 
H
Hubert86
Compagnon
Et l'adresse du port coïncide t'elle avec l'adresse de mach3 "configuration/port entrée,sortie. L'adresse tu la trouve dans le bios a mon avis comme il s'agit de l'ajout d'une carte il n'est pas sure que ça soit une adresse standard.
 
PL50
PL50
Compagnon
Quand tu as installé mach3, l'installation du port parallèle était bien cochée ?
Tu as bien fait le redémarrage du pc après l'installation mais avant toute tentative de lancement de mach3 ?
A+
 
M
Miserness
Nouveau
Bonjour,

Désolé pour le temps de réponse. Oui j'ai checker la case port paralèlle, mais il me détecte aucun port. J'ai bien reboot avant de lancer Mach3.
 
M
Miserness
Nouveau
J'ai essayé avec une virtual machine de Windows XP, les drivers se sont installés mais ca ne marche tjr pas.. Je n'arrive pas à dual boot donc je suis bien coincé, j'ai vraiment besoin d'aide
 
H
Hubert86
Compagnon
Bon déjà si tu avais demandé avant d'acheter cette carte je te l'aurai déconseillé, car actuellement sur le marché, il existe des pc ancien avec des ports parallèles, qui coute presque rien. Il te faut un Pc dédié, pas un pc qui servent a tout, la ça ne marchera pas. Donc avant toute chose, tu dois faire ça, un pc dédié avec XP. Après, comme il s'agit d'une carte ajoutée. Dans gestionnaire de périphérique, pas dans le bios comme je te l'ai dit, il te faudra paramétrer ton port parallèle, LPT, et la tu auras l'adresse qui devra corresponde avec celle de mach3. Mais attention sous XP tu ne peux pas utiliser ces adresses, 0x278, ni 0x378 ni LPT1 afin d'éviter des conflits avec du matériel déjà existant, XP verrouille ces paramètres. Donc dans le gestionnaire de peripherique prendre LPT2 et mettre l'adresse en Hexadecimal qui correspond dans mach 3 en remplacement de l'adresse 0x278, ou 0x378, qui est aussi une adresse Hexadécimal. Voila, si tu n'as pas tout ça de bien, pas la peine d'aller plus loin. Ce qui ne veut pas dire que ça fonctionnera encore.
 
dh42
dh42
Compagnon
Salut,
Mais là, rien ne marche, le DriveTest de Mach3 me dis que rien n'est installé, malgré le fait que ma carte PCI to Paralell Port soit installé.

Tu utilise bien une version 32Bits de Windows ? , car sur une version 64Bits, le driver port // de Mach3 ne fonctionne pas.

et comme dis plus haut, si c'est une carte PCI-//, l'adresse du port indiqué par défaut dans Mach3 devra être modifiée. voir ici comment connaitre l'adresse du port // de ta carte (directement sous windows)


il te suffira ensuite de rentrer l'adresse trouvée à la place de celle d'origine de Mach3 (ox378)


... et aussi, toutes les cartes PCI-// ne fonctionnent pas avec Mach3 je ne me rappel plus qui, mais un forumeur à déjà eu ce problème .. rien à faire malgré toutes les tentatives de réglages

dans le pire des cas, si ça ne fonctionne pas, tu peux utiliser une carte d'axe USB-// qui se branche directement sur ta machine en port // et en USB coté PC, ainsi plus de problème de port //, de version de Windows et c'est utilisable avec un PC portable.



++
David
 
Dernière édition:

Sujets similaires

B
Réponses
11
Affichages
809
Bastounet
B
M1M1HRC10
Réponses
7
Affichages
36 281
M1M1HRC10
M1M1HRC10
CNC_FONTAINE
Réponses
15
Affichages
1 143
CNC_FONTAINE
CNC_FONTAINE
R
Réponses
10
Affichages
2 612
dh42
Haut