CNC 3018 pro connexion impossible avec alimentation

Y
Yoann13
Nouveau
Bonjour à tous,

Je suis artiste plasticien et pour un nouveau projet de création j'ai fait l'acquisition d'une CNC 3018 pro chinoise. Mon choix vers ce produit étant son faible coût puisque mes finances ne me permettent pas d'investir davantage.

Voici un lien vers le produit en question : https://fr.aliexpress.com/item/4001176512985.html?spm=a2g0s.12269583.0.0.13c44132RF2QqW

Rien ne manquait dans le colis et j'ai tout monté rapidement. Le problème étant à présent que je ne parvient pas à me connecter avec mon pc avec les logiciels fournis. Je suis totalement débutant et peu habitué à bidouiller informatiquement, totalement novice donc. Depuis une semaine je suis en discussion avec Aliexpress qui pour l'instant n'est d'aucune aide. Je vous fait donc part de mon problème et vous remercie par avance de bien vouloir m'aider.

La machine est fourni avec une petit controller offline (la mini manette qui permet de connecter une carte sd sans passer par l'ordi). Avec ça j'ai testé le déplacement sur les axes X,Y et Z et ça fonctionne. Les axes sont inversés mais ce n'est pas grave pour l'instant.

Aant pris soin de déconnecter le controller offline je relie ma machine par cable USB à mon ordi (pour info sous Windows 10 Family 64 bit / Version 20H2 version du système d'exploitation 19042.610) GRBL (version 0.8.4) fourni et Candle 1.1.7 également fourni. L'ordi détecte et se connecte à la machine sur le bon port USB (COM 3 en ce qui me concerne) réglé à 115200 baud (comme GRBL). Puis quand vient le moment d'allumer l'alimentation le logiciel (GRBL ou Candle) se déconnecte instantanément. Pour que GRBL ou Candle détecte à nouveau la machine je dois couper l'alimentation, déconnecter le port USB et recommencer. Mais toujours le même problème par la suite avec ce message d'erreur :

Erreur port serie 7: Un périphérique attaché au système ne fonctionne pas correctement.

Erreur port serie 11: Un périphérique attaché au système ne fonctionne pas correctement.

Erreur port serie 11: Un périphérique attaché au système ne fonctionne pas correctement.

J'ai fait une courte vidéo sur demande d'Aliexpress pour qu'ils voient le problème, la voici :
J'ai bien remarqué que je n'ai pas la dernière version de GRBL et après de nombreuses recherches sur le net je ne sais vraiment pas quoi faire. Mettre à jour GRBL ? Je ne sais pas trop comment faire étant donné que je ne comprend même pas quelle est la carte de ma cnc. J'ai inséré une photo de la carte en pièce jointe pour info.

Que me conseillez-vous ?

Merci encore
 
T
tgil
Nouveau
bonjours yoann
on ne voit pas quelle version de candle tu utilise mais avec GRBL 0.9 il faut CANDLE 1.0
voir la version candle au démarrage
supprimer les ports COM inutilement crées
bonne journée
 
Y
Yoann13
Nouveau
bonjours yoann
on ne voit pas quelle version de candle tu utilise mais avec GRBL 0.9 il faut CANDLE 1.0
voir la version candle au démarrage
supprimer les ports COM inutilement crées
bonne journée

J'utilise les versions logicielles fournies avec le CD d'install, soit Candle 1.1.7 avec GRBLcontrol (version 0.8.4). Le port COM utilisé est le COM 3 sur mon ordi. Il me semble que d'autres n'ont pas été créés. Voici en photo ce que j'ai dans mon gestionnaire de périphérique. Je ne vois pas d'autres port COM.

Je pense que ma version GRBLcontrol est trop vieille et que je devrais peut-être télécharger le version 1.1 notamment.
Je m'arrache les cheveux en tant que novice. J'ai téléchargé aussi OpenBuilds CONTROL v1.0.253 est dès l'allumage j'ai ceci :

[11:51:13] [ connect ] PORT INFO: Port is now open: COM3 - Attempting to detect Firmware

[11:51:13] [ connect ] Checking for firmware on COM3

[11:51:13] [ connect ] Detecting Firmware: Method 1 (Autoreset)

[11:51:15] [ connect ] Detecting Firmware: Method 2 (Ctrl+X)

[11:51:15] [ undefined ] Detected an unsupported version: Grbl 0.9j. This is sadly outdated. Please upgrade to Grbl 1.1 or newer to use this software. Go to http://github.com/gnea/grbl

[11:51:15] [ ] Grbl 0.9j ['$' for help]

[11:51:17] [ connect ] Firmware Detected: grbl version 0.9j on COM3

[11:51:19] [ $$ ] $0=10 (step pulse, usec) ;Step pulse time, microseconds

[11:51:19] [ $$ ] $1=25 (step idle delay, msec) ;Step idle delay, milliseconds

[11:51:19] [ $$ ] $2=0 (step port invert mask:00000000) ;Step pulse invert, mask

[11:51:19] [ $$ ] $3=5 (dir port invert mask:00000101) ;Step direction invert, mask

[11:51:19] [ $$ ] $4=0 (step enable invert, bool) ;Invert step enable pin, boolean

[11:51:19] [ $$ ] $5=0 (limit pins invert, bool) ;Invert limit pins, boolean

[11:51:19] [ $$ ] $6=0 (probe pin invert, bool) ;Invert probe pin, boolean

[11:51:19] [ $$ ] $10=3 (status report mask:00000011) ;Status report options, mask

[11:51:19] [ $$ ] $11=0.010 (junction deviation, mm) ;Junction deviation, millimeters

[11:51:19] [ $$ ] $12=0.002 (arc tolerance, mm) ;Arc tolerance, millimeters

[11:51:19] [ $$ ] $13=0 (report inches, bool) ;Report in inches, boolean

[11:51:19] [ $$ ] $20=0 (soft limits, bool) ;Soft limits enable, boolean

[11:51:19] [ $$ ] $21=0 (hard limits, bool) ;Hard limits enable, boolean

[11:51:19] [ $$ ] $22=0 (homing cycle, bool) ;Homing cycle enable, boolean

[11:51:19] [ $$ ] $23=0 (homing dir invert mask:00000000) ;Homing direction invert, mask

[11:51:19] [ $$ ] $24=25.000 (homing feed, mm/min) ;Homing locate feed rate, mm/min

[11:51:19] [ $$ ] $25=500.000 (homing seek, mm/min) ;Homing search seek rate, mm/min

[11:51:19] [ $$ ] $26=250 (homing debounce, msec) ;Homing switch debounce delay, milliseconds

[11:51:19] [ $$ ] $27=1.000 (homing pull-off, mm) ;Homing switch pull-off distance, millimeters

[11:51:19] [ $$ ] $100=400.000 (x, step/mm) ;X-axis steps per millimeter

[11:51:19] [ $$ ] $101=400.000 (y, step/mm) ;Y-axis steps per millimeter

[11:51:19] [ $$ ] $102=400.000 (z, step/mm) ;Z-axis steps per millimeter

[11:51:19] [ $$ ] $110=1500.000 (x max rate, mm/min) ;X-axis maximum rate, mm/min

[11:51:19] [ $$ ] $111=1500.000 (y max rate, mm/min) ;Y-axis maximum rate, mm/min

[11:51:19] [ $$ ] $112=1500.000 (z max rate, mm/min) ;Z-axis maximum rate, mm/min

[11:51:19] [ $$ ] $120=10.000 (x accel, mm/sec^2) ;X-axis acceleration, mm/sec^2

[11:51:19] [ $$ ] $121=10.000 (y accel, mm/sec^2) ;Y-axis acceleration, mm/sec^2

[11:51:19] [ $$ ] $122=10.000 (z accel, mm/sec^2) ;Z-axis acceleration, mm/sec^2

[11:51:19] [ $$ ] $130=200.000 (x max travel, mm) ;X-axis maximum travel, millimeters

[11:51:19] [ $$ ] $131=200.000 (y max travel, mm) ;Y-axis maximum travel, millimeters

[11:51:19] [ $$ ] $132=200.000 (z max travel, mm) ;Z-axis maximum travel, millimeters

[11:51:19] [ $$ ] ok

[11:51:19] [ $I ] [0.9j.20180122:CUSTOM]

[11:51:19] [ $I ] ok

Là je comprends pas trop car le rapport me dis que la version de GRBL est 0.9j alors que la version GRBLcontrol que j'ai est bien 0.8.4

Je pense donc à faire une mise à jour mais je ne sais pas comment faire. Sur le net je vois pas mal de personnes qui ont eu des erreurs en voulant faire une mise a jour de GRBL. D'autant plus que ma carte n'est pas une arduino mais une copie chinoise. Pour télécharger une version de GRBL j'ai remarqué qu'il fallait installé IDE arduino. Je ne sais pas si je peux l'utiliser avec une fausse arduino et d'autant plus que je ne sais rien sur ma carte. Surement inutile mais la voici en photo pour info.

Merci en tout cas d'essaer de m'aider

Port COM utilisé.jpg


copie arduino.jpg
 
Y
Yoann13
Nouveau
Nouveauté depuis ce matin, quand je connecte la CNC elle est reconnu par le port USB, je branche l'alim ça ne se déconnecte pas. J'effectue un déplacement manuel d'un des axes et là ça se déconnecte. J'ai tenté plusieurs fois et toujours pareil
 
greg_elec
greg_elec
Ouvrier
Sur la carte au dessus de U4 tu as un composant Noté F1 (c'est un fusible) , si tu arrive à le dessouder ce serait peut être là la source de tes problèmes.
Car ta carte renverrait du 5 Volt sur l'usb de l'ordi . Si tu n'est pas à l'aise avec un fer à souder on vas essayer une autre solution.
Es-tu prêt à sacrifier un câble USB ? si oui tu enlève proprement l'isolant du câble sur 2 cm ensuite tu accède au fil rouge et tu le coupe et tu l'isole .Ensuite tu essaye avec ce câble massacré modifié .

Si tu n'est pas loin de chez moi (nord 72) je peux te le faire
 
Y
Yoann13
Nouveau
Sur la carte au dessus de U4 tu as un composant Noté F1 (c'est un fusible) , si tu arrive à le dessouder ce serait peut être là la source de tes problèmes.
Car ta carte renverrait du 5 Volt sur l'usb de l'ordi . Si tu n'est pas à l'aise avec un fer à souder on vas essayer une autre solution.
Es-tu prêt à sacrifier un câble USB ? si oui tu enlève proprement l'isolant du câble sur 2 cm ensuite tu accède au fil rouge et tu le coupe et tu l'isole .Ensuite tu essaye avec ce câble massacré modifié .

Si tu n'est pas loin de chez moi (nord 72) je peux te le faire

Salut greg_elec,

T'es trop fort. Je viens de tester l'astuce du câble usb et ça fonctionne à présent. Si tu as un instant tu peux m'expliquer pourquoi ?
Merci beaucoup en tout cas
 
greg_elec
greg_elec
Ouvrier
Tout simplement la carte de la CNC envoie du 5V sur la prise USB du PC et ça le PC il aime pas !!!
 

Sujets similaires

O
Réponses
7
Affichages
295
Oldschool
O
B
Réponses
13
Affichages
348
B
Gamatquentin
Réponses
7
Affichages
510
Gamatquentin
Gamatquentin
F
Réponses
7
Affichages
2 243
Fabland
F
Haut