Advertisements

encore un qui voudrait bien utiliser EMC2 (resolu)

A
andre
Ouvrier
26 Mar 2008
253
aude
  • Auteur de la discussion
  • #1
bonsoir
j'ai essaye de monter linux avec emc2 (la bonne version 8....)enfin celle qui va bien
jusqu'a la config finale ok test de tous les axes ok
donc sauvegarde et la gros message d'erreur
debut de la galere solution trouvee sur le forum dans un post de poussin
qui raconte exactement la meme chose qui m'arrive et donne la solution
qui consiste a aller charger sur le net une mise a jour
2eme galere impossible de me connecter a internet avec mon ordi je
n'arrive pas a configurer le reseau
avec windows tout marche mais je n'aime pas mach3
rebelote sur le net je trouve la version 10.4 cnc content j'installe et la
re galere avec cette version je ne peux pas faire la config de la cnc la meme
que sur la version 8 sur la 10.4 message d'erreur sur la config du premier axe en cliquant sur le bouton test this axis
pourtant je suis adepte de linux mais completement nul pour ce genre d'os
je precise que j'utilise le wifi mais j'ai remonte mon ancien modem adsl
a cable pareil avec win no probleme avec linux que dalle

ordi: pross amd a 1,2 giga 1 giga re ram dde 120 giga
carte graphique ati radeon 7500

si quelqu'un peut m'aider gros merci d'avance
 
Advertisements
horsot
horsot
Compagnon
28 Mai 2009
768
Toulouse
Bonsoir andre,

Ben c'est ma soirée EMC2 aujourd'hui!

Je tenais à te féliciter pour ta CNC bois joli boulot! J'ai moi même un projet très similaire en cours (mais arrêté pour l'instant).

Si j'ai bien compris tu as la version ubuntu10.04 avec EMC2.4.4 (la dernière) que tu as téléchargé sur linuxcnc.org. C'est ça? Sinon va récupérer la dernière version que l'on parte sur de bonnes bases. :smt023

Pour ton problème de réseau ce n'est pas primordial si tu as la dernière version du CD d'EMC2. Quel est ton modem? N'as-tu pas une box (orange, free, sfr,...)? Ton réseau wifi est configuré comment (ouvert, WEP, WPA)? Quel est ton ordinateur (portable, fixe)?

Pour ton souci de configuration, quel est exactement ton message d'erreur dans stepconf? Peux-tu décrire ta configuration (drivers moteur, réductions, pas de vis, pignon, chaine,...)?

Bonne nuit

Xavier
 
A
andre
Ouvrier
26 Mar 2008
253
aude
  • Auteur de la discussion
  • #3
bonjour horsot et merci de ta reponse
oui c'est bien ubuntu 10.4 et emc2 2.4.4
mon modem live box en wifi mais possible de mettre l'ancien modem sans wifi
ordinateur fixe et dedie a ca il n'y a pas autre chose que linux et mc2
je mets des photos pour que tu vois les erreurs et aussi la machine
qui est configuree avec la notice du fabricant
cette machine est destinee a graver des circuits imprimes
encore merci de ton aide
je reviens j'ai l'impressios que le message n'est pas passe

DSCN2024.JPG


DSCN2023.JPG


DSCN2022.JPG
 
horsot
horsot
Compagnon
28 Mai 2009
768
Toulouse
Bonsoir,

Curieux ton bug, :???: Je regarde ça sur mon PC EMC2 ce soir et je te répond.

A ce soir

Xavier
 
horsot
horsot
Compagnon
28 Mai 2009
768
Toulouse
Re,

J'ai peut être trouvé la réponse sur le forum d'EMC2 :
http://www.linuxcnc.org/component/option,com_kunena/Itemid,20/func,view/catid,16/id,4080/lang,english/

Il (cmorley) dit que le problème doit venir de HAL qui doit déjà tourner sur ta machine ou une erreur HAL et qu'il faut ouvrir un terminal (application=>accessoire=>terminal) et taper "stepconf" (sans guillemets).
Apparemment en lançant stepconf de cette manière il marche :!: :?: :???:

Si chez toi ça ne marche toujours pas, fais un copier coller de l'erreur affiché dans le terminal (elle est plus détaillée).

Pour internet, as-tu une carte wifi dans ton PC? Pourquoi ne pas utiliser un câble réseau classique? Deux modems sur la même ligne téléphonique ne peuvent pas marcher.

N'oublies pas de nous tenir au courant.

Bonne soirée

Xavier
 
A
andre
Ouvrier
26 Mar 2008
253
aude
  • Auteur de la discussion
  • #6
bonjour horsot
j'ai fait ce que tu m'as dit ca marche toujours pas
j'ai essaye sur un autre ordi avec un dd vierge et ubuntu 10.4 cnc
le resultat est le meme
voici la photo des erreurs
d'apres le peu d'anglais que je crois comprendre il
manquerait quelque chose
pour internet j'ai une carte wifi dans l'ordi de la maison
pour l'atelier quand j'ai besoin d'internet je debranche la live box et j'utilise
l'ancien modem mais j'arrive pas a configurer linux pour le modem
ca c'est pas grave tant que je n'ai pas besoin d'internet a l'atelier
jusqu'a maintenant je fais les transferts avec une cle usb

DSCN2028.JPG


DSCN2025.JPG
 
horsot
horsot
Compagnon
28 Mai 2009
768
Toulouse
Bonsoir Andre,

Je vais être honnête, je ne sais pas résoudre ton problème. Il semblerait que le module noyau lié à HAL ne veuille pas se charger pour des questions de permissions.

Es-tu sûr d'avoir la version 2.4.4 et non la 2.4.3.1 (celle qui est livrée avec le Livecd)?

Il me semble d'après les captures (version noyau notamment) que tu n'as jamais fais de mise à jour d'Ubuntu n'aillant pas de connexion internet. Je ne sais pas si cela résoudra ton souci mais ça vaut le coup d'essayer.

Je te propose de mettre à jour EMC2 (et le reste) par le menu "Système=>Administration=>Gestionnaire de mise à jour". Pour cela il te faut internet, plusieurs solutions :
- Simple mais provisoire : déplacer la livebox et la brancher à ton PC avec un câble réseau. Ça devrait marcher de suite. (variante déplacer ton PC vers la livebox :wink: ).

- Essayer de faire marcher le wifi en cliquant sur l'icône réseau à coté de l'heure et choisir ton réseau domestique dans la liste. Sinon essayer d'installer ta carte réseau via "Système=>Administration=>Pilotes de périphériques" (il faut peut être un connexion internet).

Ton modem qui marche sous windows est de quelle marque, quelle connectivité (USB, réseau,...)?

Tiens moi au courant

Xavier

Edit : Ok la carte wifi n'est pas dans ce PC mais celui de la maison.
 
A
andre
Ouvrier
26 Mar 2008
253
aude
  • Auteur de la discussion
  • #8
bonsoir Xavier
je ne suis pas sur d'avoir la bonne version j'ai celle qui est avec
ubuntu 10.4 cnc
ce que j'ai telecharge est un fichier iso qui comprend tout je suppose que c'est la bonne version mais je vais verifier
avec ton conseil je vais essayer de monter internet
le modem a cable que je possede est celui dont je me servais il y a peu
je suis passe a la live box pour ne pas avoir de cable qui traine au milieu du
salon et pour pouvoir connecter facilement le portable
donc je vais debrancher la live pour pouvoir utiliser le modem
j'ai deja essaye sur cet ordi mais ca n'a pas marche
j'ai une carte wifi netgear mais sans driver pour linux donc c'est cuit
je te tiens au courant et encore merci de ton aide
andre
 
horsot
horsot
Compagnon
28 Mai 2009
768
Toulouse
Re,

Si tu as la version du CD disponible sur le site d'EMC2 tu as bien la 2.4.3.1 et non la dernière. Je ne sais pas si ça y joue mais je pense que ça vaut le coup d'essayer la mise à jour.

Sinon j'ai trouvé un mec qui avait le même souci que toi (avec la même version d'ailleurs) sur ce fil (en anglais) : http://www.mail-archive.com/emc-users@lists.sourceforge.net/msg22477.html
En bref (en français :wink: ):
- Ouvrir un terminal taper : "sudo gedit /etc/default/grub". C'est pour ouvrir un fichier de configuration avec les droit administrateurs. Il va donc demander ton mot de passe, il ne va pas s'inscrire lorsque tu le taperas, même pas d'étoiles c'est normal. Il faut se contenter de taper le mot de passe et la touche "Entrée". Cela va ouvrir un éditeur de texte avec le fichier de configuration "grub" ouvert.
- Trouve la ligne (ligne 9 normalement) : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
- La compléter pour avoir : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash lapic"
- Sauve la modification et ferme l'éditeur.
- Dans le terminal tappe : "sudo update-grub" pour que la modification soit prise en compte au prochain redémarage
- Redémarre le PC
Dire que j'avais vu ces messages mais je ne m'en souvenais plus... :???:


Pour ta carte wifi netgear, il y a des chances pour qu'elle marche sans à avoir installer quoique ce soit, il faut essayer.

Laisse tomber le modem "à cable" sous linux c'est souvent la croix et la bannière à faire marcher! Par contre se brancher directement à la livebox avec un cale réseau (pas USB) marchera sans rien avoir à faire.

Avec plaisir pour mon aide.

Courage, EMC2 en vaut la peine :wink:

Bonne soirée

Xavier
 
horsot
horsot
Compagnon
28 Mai 2009
768
Toulouse
Re,

Si les solutions précédentes ne marchent pas (mise à jour et grub), fais (pour mieux cerner le problème, ça ne réparera rien!):
- Relance stepconf (via le terminal ou le menu).
- Refais la séquence jusqu'à ce que ça bug.
- Ouvre un terminal, tape : "dmesg > Bureau/dmesg.txt"

Ça va te créer un fichier "dmesg.txt" sur le bureau que tu mettras en pièce jointe sur le forum. Ce fichier contiendra le journal du noyau linux et donc les messages décrivant pourquoi le noyau Linux a refusé le chargement du module "rtai_hal.ko".

Courage!

Xavier
 
A
andre
Ouvrier
26 Mar 2008
253
aude
bonjour Xavier
et oui c'est encore moi
apres bien des essais j'ai reussi a faire marcher internet avec ubuntu tu avais raison
avec la live box et un cable ca c'est mis a marcher
par contre ca a ete plus dur avec emc2
j'ai fait exactement ce que tu m'as dit et galere ca ne marche toujours pas
donc j'ai remonte l'ancienne version 8.?? qui ne marchait pas non plus mais comme maintenant j'ai internet j'ai fait une mise a jour et la miracle ca marche bien
comme mes differents linux sont sur des disques dur amovibles j'ai voulu ressayer la
10.4 et la en relisant ton post je me suis apercu que comme un c.. je n'avais pas execute
la derniere commande sudo update grub chose aussitot executee et redemerrage de l'ordi
et tout va tres bien tout fonctionne j'ai juste les points d'origine a regler ça je sais faire
maintenant il faut que je fasse un circuit imprime et la je sens que ça ne va pas etre evident
pour transformer un gerber ou dxf en un fichier que comprendra emc2
tu vois que grace a toi j'y suis arrive
encore merci Xavier et a plus
 
horsot
horsot
Compagnon
28 Mai 2009
768
Toulouse
Bonjour andre,

Content que ça ait marché! :-D

Pour info, le "lapic" est un gestionnaire d'interruption multiprocesseurs nécessaire à linux-rt. Tu dois avoir une option dans ton bios pour qu'il l'active par défaut (ligne contenant "APIC" => ENABLE) sans avoir besoin de configurer grub de le faire au démarrage (maintenant c'est fait).

Pourrais-tu éditer ton premier post en changeant le titre par "[Résolu] encore un qui voudrait bien utiliser EMC2" ça permettrait d'y voir plus clair lors des recherches.

Je mets le message d'erreur pour que les moteurs de recherches puissent l'indexer :
insmod: error inserting '/usr/realtime-2.6.32-122-rtai/modules/rtai_hal.ko': -1
Operation not permitted
Pour Gerber=>G-code je n'ai pas encore trouvé de solution miracle... :???: Tiens nous au courant si tu trouves!

Bonne continuation, n'hésites pas à nous faire part de tes critiques/retour d'expérience. :wink:

Xavier
 
B
Bth
Ouvrier
2 Fev 2009
487
Besançon25
Emc2

Bonsoir à tous et à toutes,

Beau travail !!!!!!!!!

Pour le Gerber en Gcode pour Emc2 je peux en faire 1 pour voir.

Thierry
 
A
andre
Ouvrier
26 Mar 2008
253
aude
bonjour a tous
bth
ok essaye et surtout apres explique comment tu as fait
j'ai un peu regarde mais ca semble un peu complique
a plus
andre
 
S
sylcel
Nouveau
16 Oct 2010
3
Lille
Bonjour,

Bizarrement, j'ai un problème que je croyais similaire mais j'ai fais les modifications que vous avez notées mais rien ne se passe au moment où je peux tester le paramêtrage dans STEPCONF.
De mon côté, je n'ai pas le message d'erreur mais impossible de faire tourner les moteurs, on les entends qu'ils récupèrent une impulsion mais pas possible de les déplacer.

Si vous avez une piste je suis preneur cela me permettra de quitter ubuntu 8 (avec le problème de connextion modem) vers la version 10.04.

Sylcel.
 
La dernière réponse à ce sujet date de plus de 6 mois
Advertisements
Haut