Réanination/Config CNC Verticale

  • Auteur de la discussion wilzy_X
  • Date de début
wilzy_X
wilzy_X
Nouveau
27 Sept 2020
3
Liege (Belgique)
  • Auteur de la discussion
  • #1
Bonjour à tous !

J'essaye de configurer une CNC qui traine dans les ateliers mutualisés ou je squatte et je galère sur quelques points.

La bête...
120181650_2474647846167425_7662984523196745494_n.jpg

Je ne sais pas si elle est commercialisée comme tel, je pense que le gars qui leur a vendu la machine a du adapter une machine horizontale lui-même pour qu'elle soit verticale. La surface de découpe fait un gros mètre sur un gros mètre et demi. Je ne suis pas sur de la puissance de la broche mais elle est "haute fréquence" me disent-ils.
Elle a fonctionné nickel quand le gars l'a amenée a l'atelier, personne n'y a jamais touché depuis.


Le controleur (je ne sais pas si c'est le bon terme) est un truc commercialisé par une société slovaque. Son petit nom semble être le "profi4" (Fiche sur le site de la boîte), avec en plus de ce qu'on aperçoit sur cette page un VFD dont je ne suis pas sûr du modèle (serait-ce un Huanyang ? Lien amazon... )
120159114_380032853362187_3606101718184173519_n.jpg

120290638_342059793798697_6865517386760285535_n.jpg

120195207_785064852258753_4447035153263318520_n-1.png



Il se fait que l'ordi qui etait livré avec la machine est mort. Apparement, il tournait avec mach3 sous winXP.
J'ai donc refait un ordi pour utiliser la machine, sur lequel j'ai foutu linuxCNC (ca m'a semblé être une bonne idée :D ).

Après une dizaine d'heures de recherches (je ne suis pas un habitué de la configuration de ce genre de machines) et de configuration a l'aide de Stepconf, j'arrive a faire bouger la machine comme il faut dans tous les sens, reste un peu de calibrage mais pour cela je devrais me débrouiller...
Il me reste un problème majeur : j'arrive a lancer la broche et l'arrêter depuis linuxCNC, mais impossible de controler la vitesse de rotation de la broche. La machine est connectée a l'ordi avec un port LPT ET un port usb.
D'après ce que j'ai cru comprendre, ca serait le port usb (relié a la carte a cote du port LPT, voir photo) qui sert a controler la vitesse de rotation de la broche.

Et la je cale, comment et ou dire a linuxCNC que la vitesse de rotation de la broche est controlee (en PWM?) via le port usb ???

Je joins la photo du cablage sur le VFD et le screenshot de la config des pins trouvee sur le site de la boite slovaque. Je précise que j'ai bien évidemment essayé de mettre la pwm broche sur la pin1, ca ne change rien

Si quelqu'un a une idée, je le remercie d'avance d'avoir pris la peine de me lire ! (Et si personne n'a d'idée mais a pris la peine de me lire quand même, merci aussi :D )

Bisous

Capture d’écran 2020-09-27 à 20.01.44.png
 
G
gaston48
Compagnon
26 Fev 2008
9 688
59000
Bonjour,
A mon avis le port USB ne sert que de complément d'alimentation 5V pour la carte .
Concernant Linuxcnc, tu affectes bien le PWM sur la pin 1 du port //
et la carte te fournit 2 modes de sortie de pilotage. Une sortie directe PWM qui recopie la pin 1 du port //
et une sortie filtrée 0-10 V . C'est cette sortie là que tu dois exploiter. Le petit potar bleu, s'il y a,
doit servir à ajuster la peine échelle 0 -10 V

ScreenShot175.jpg
ScreenShot176.jpg
 
wilzy_X
wilzy_X
Nouveau
27 Sept 2020
3
Liege (Belgique)
  • Auteur de la discussion
  • #3
Ok, merci beaucoup pour les éclairages !
Je pense tout doucement que je n'arriverai pas a gérer la vitesse de rotation de la broche avec linuxCNC, a moins d'ajouter une carte USB/RS485, de ce que j'ai compris. Ce n'est pas très grave en soi, pour l'instant je gèrerai la vitesse avec le potentiomètre.. On verra plus tard.

Par contre ma galère suivante : impossible de trouver le réglage du timing de mes pilotes, même après moulte recherches.
Les drivers sont des CW8060. Pour le moment j'ai laissé les valeurs par défaut de StepConf, à savoir :
Step time : 5000 ns
Valeur space d'un pas : 5000 ns
Direction Hold : 20000 ns
Réglage direction : 20000 ns.

Quelqu'un à une idée ?

120591843_3462691910456760_8235357612506370105_n.jpg
 
S
speedjf37
Compagnon
15 Oct 2009
2 274
indre et loire
Bonjour,

Cela fait doublon avec :

Cordialement JF
 
wilzy_X
wilzy_X
Nouveau
27 Sept 2020
3
Liege (Belgique)
  • Auteur de la discussion
  • #5
Hello,

En effet, j'ai posté sur les 2 forums..
Ca ne paraît pas incorrect, ce sont 2 forums différents, si cela pose problème, je peux virer le post d'ici..
(bien que ce forum-ci est plus clément quand on veut ajouter des images :)
 
G
gaston48
Compagnon
26 Fev 2008
9 688
59000
a moins d'ajouter une carte USB/RS485, de ce que j'ai compris
C'est l'avis de " l'autre forum " :wink: que je ne partage pas, commence par vérifier ce que je t'ai précisé
si le variateur a bien une commande en 0-10 V
et que la carte délivre bien du 0-10 V sur son port dédié
 
S
speedjf37
Compagnon
15 Oct 2009
2 274
indre et loire
C'est l'avis de " l'autre forum " :wink: que je ne partage pas, commence par vérifier ce que je t'ai précisé
si le variateur a bien une commande en 0-10 V
et que la carte délivre bien du 0-10 V sur son port dédié
Bonjour,

L’intérêt de la RS485 c'est le retour d'info du VFD et la libération des pins du port // pour d'autres usages (sonde , axe A , etc).

Cordialement JF
 
G
gaston48
Compagnon
26 Fev 2008
9 688
59000
L’intérêt de la RS485 c'est le retour d'info du VFD et la libération des pins du port // pour d'autres usages (sonde , axe A , etc).
C'est très intéressant je suis d'accord, mais peut être un peu prématuré pour une première mise en route .
 
Haut