Résolu UGS platform freeze en plein usinage

  • Auteur de la discussion meruem95
  • Date de début
M

meruem95

Apprenti
bonjour j'ai un probleme très embetant. J'utilise sur ma CNC (d'auto constructeur) UGS platform 2.0 avec une carte arduino uno officielle. J'ai deja fais des usinages de plusieurs heures sans probleme, mais lors de ma dernière tentatives (travail de 1h30) UGS platform s'est figé et ne répondait plus au bout de environ 15 min, j'ai donc relancé l'usinage du début mais ugs a figé a nouveau environ 10 minutes plus loin que la première fois. J'ai réessayé 3 ou 4 fois et à chaque fois ugs se fige un plus plus loin que la fois précédente. C'est vraiment embêtant de recommencer a chaque fois de zero sachant que la fraise avance dans le vide pour toute la partie du travail qui a deja été faite les fois précédentes.
J'ai essayé d'utilisé la dernière version de UGS et de reteleverser GRBl dans l'arduino mais pas d'amélioration.
Voila a quoi ressemble ugs après le freeze :
freeze.png

si vous avez des pistes pour trouver le problèmes ce sera apprécié merci. J'ai récemment modifié des elements de structures de la CNC pour ameliorer la rigidité mais je vois pas comment ca pourrait avoir une consequence la dessus
 
M

meruem95

Apprenti
J'ai aussi fais l'expérience de lancer l'usinage en gardant les moteurs éteints, avec uniquement le PC et larduino allumés, et il est allé jusqu'à la fin sans problème.
 
totoche974

totoche974

Ouvrier
bonjour

par curiosité, j'espère que tu n'a pas de TB6600 car si c'est le cas il y a beaucoup de merde avec ses modèles, chauffe surtout
teste en changeant les drivers si tu a du change

++
gilles
 
D

didierh

Ouvrier
hello
est-ce l'application qui bloque (menus, boutons, rafraichissement de l'interface etc...) qui ne répondent plus ou
c'est l'envoi du gcode vers la carte arduino et dans ce cas c'est la fraiseuse qui ne bouge plus ?
A+D
 
M

meruem95

Apprenti
bonjour

par curiosité, j'espère que tu n'a pas de TB6600 car si c'est le cas il y a beaucoup de merde avec ses modèles, chauffe surtout
teste en changeant les drivers si tu a du change

++
gilles
Non, mais juste pour dire j'en avais avant, l'un est tombé en panne et je les ai remplacé par des dm556, les mouvements sont devenu bien plus lisse beaucoup moins saccadé et c'est là que je me suis rendu compte que les tb6600 sont vraiment nul.
hello
est-ce l'application qui bloque (menus, boutons, rafraichissement de l'interface etc...) qui ne répondent plus ou
c'est l'envoi du gcode vers la carte arduino et dans ce cas c'est la fraiseuse qui ne bouge plus ?
A+D
Oui l'application complètement bloquée on peut plus rien faire. Les diodes TX RX de larduino allumées au jaune fixe. On peut seulement fermer l'appli et la redémarrer.

J'essayerai avec un câble USB différent pour voir ce que ça donne. Et je vais essayer d'isoler mon alim car elle est en contact direct avec la structure de la CNC

Merci pour vos réponses
 
greg_elec

greg_elec

Compagnon
Pour le câble USB prendre un court (moins de 1m) avec des ferrites et choisi un USB 1 ou 2 sur ton PC surtout pas USB 3 (prise bleue)
 
D

didierh

Ouvrier
Hello
changer le câble comme indiqué. Tu peux aussi utiliser une autre app pour envoyer ton gcode.
J'ai testé https://github.com/Denvi/Candle qui fait aussi le taf.
Ce que je trouve bizarre c'est que l'application "freeze" pour un problème de communication avec la carte (si le câble usb est en cause).
Dans un monde parfait on n'utilise pas le "thread" qui gère l'interface pour en même temps envoyer les données sur un canal quelconque (série via USB par exemple) - mais ne connaissant pas en détail comment UGS est développé, difficile de dire si c'est la communication qui est en cause ou bien le soft ou encore la carte arduino....
 
M

meruem95

Apprenti
J'ai changé de câble et plus de problème donc visiblement c'était le câble. Merci à tous
 
chtipanda

chtipanda

Apprenti
bonjour

par curiosité, j'espère que tu n'a pas de TB6600 car si c'est le cas il y a beaucoup de merde avec ses modèles, chauffe surtout
teste en changeant les drivers si tu a du change

++
gilles
personnellement j ai des tb6600 pas de probleme qu est qui te fait dire ça ?
 

Sujets similaires

D
Réponses
14
Affichages
596
drum22
D
Y
Réponses
5
Affichages
1 141
yann7177
Y
C
Réponses
15
Affichages
622
Papygraines
Papygraines
H
Réponses
7
Affichages
3 209
Yourix
Yourix
Le Prolls
Réponses
20
Affichages
991
Sebos38
Sebos38
Haut