réglage moteurs pas à pas sur Mach3

  • Auteur de la discussion zen102
  • Date de début
Z
zen102
Nouveau
Bonjour,

J’ai terminé l’usinage et le montage mécanique de ma cnc, (voir photo), je suis dans la phase de paramétrage, je vous ai déjà consulté pour le problème de sens de rotation du moteur le 08 octobre 2018, et je vous remercie encore pour l’aide que vous m’avez apporté.
Mon souci est le réglage de la vitesse et de l’accélération sur Mach3, c est vrais j ai consulté les discutions sur le forum concernant ce sujet et j ai appliqué les solutions qui s’approche à mon problème mais mon problème n’est toujours pas résolut :

Les données matérielles :
Moteur nema 23 couplé directement à l’avis (voir photo)
Caractéristiques:
Marque: jkm
Modèle: jk57hs76-2804.
Tension: 3.08V
Courant/phase: 2.8A

  • angle du pas 1.8°
  • max.force radiale 75N (20mm de la bride)
  • max.force axiale 15N

driver : HY-DIV268N-5A voir photo

vis à bille SFU 1605 (diamètre 16 pas 5mm) avec palier BF12 et BK12
Alimentation : à découpage 24V DC 17 A - 400W


Données Paramétrage :

Configuration des ports : 25KHz
Les pulses / rev : 1/8 courant à 3,3 A
Calcul de Pas/mm : 360° /angle du pas du moteur 1.8° = 200 pas
Pour 1/ 8 : 200 X8 = 1600
Pour un pas de vis 5 mm : 1600/5 = 320 pas /mm (en configuration auto des axes je trouve 316,66…)
Délai de Direction 2
Délais d’impulsion 5
Pour la vitesse : J ai mis au début 1500 mm/min et j ai varié le curseur entre 1200 à 3000 mm/min
pour l’accélération j ai varié le curseur pour des valeurs entre 120 mm/s2 et 500 mm/s2 et parfois plus et chaque fois que je tombe sur une courbe qui me semble correcte je fais des essais en déplacent les axes en mode manuel
Constatations :
En déplacent les axes je constate que j ai des pertes de pas et les moteurs bourdonnent, et ce phénomène est aléatoire il ne se produit pas toujours dans le même endroit ni au même nombre de déplacement.
Même quand je lance un programme d’essais genre usiner un carré, je constate aussi le même problème et parfois c est pire car en mode manuel par fois ca marche bien et en mode manuel mais quand je lance un programme les moteurs grognent et les vis se bloquent .

Questions :
Est-ce que le choix 1/8 en pulsion de driver est bonne ? car j ai essayé aussi ½ ¼ .
Est-ce que avec le type de driver et les moteurs que j’ai, on peut atteindre une vitesse de 3000 mm/min ?
Quelle est la vitesse maxi ou optimale à atteindre avec ces appareils?
Quelles sont les facteurs à prendre en considération pour choisir la vitesse optimale et l’accélération correspondante ?
Est-ce qu’il y a un indice de proportionnalité entre la vitesse et l’accélération lors de changement de vitesse ? ou une formule mathématique à appliquer au moteur pas à pas ?
Je vous remercie d’avance pour votre aide


20181120_153531.jpg


20181120_153600.jpg


20181120_153634.jpg


moteur-pas-a-pas-unipolaire-de-type-57bygh633.jpg


tb6600-driver-moteur-0250a-dc-1250v.jpg
 
D
dyson
Ouvrier
Salut,
Quel est le couple nominal des moteurs ?
Quel connexion/carte (port parallèle, carte usb ou Ethernet) ?
 
Z
zen102
Nouveau
Bonjour,

je vous remercie de votre collaboration
- le couple nominal je ne la connais pas mais les forces indiquées sur la fiche technique du moteur sont:
Modèle: jk57hs76-2804.
Tension: 3.08V
Courant/phase: 2.8A
  • angle du pas 1.8°
  • max.force radiale 75N (20mm de la bride)
  • max.force axiale 15N
- la connexion est par le port parallèle voir photo

CNC-5-Axis-Breakout.jpg
 
D
dyson
Ouvrier
  • angle du pas 1.8°
  • max.force radiale 75N (20mm de la bride)

ça, ce sont les efforts admissibles sur l'arbre moteur.

Avec Google, on trouve un couple de maintien de 1.89 Nm. C'est bon.

Par contre, le port parallèle limite la vitesse maxi de la machine et plus on monte en micro-pas et plus on est limité en vitesse.
3000 m/min en 1/8 de pas, je pense que c'est trop.

Il faut essayer en dégradant au maximum : 50mm/s² et vitesse max 1000 mm/min.

Ps: les drivers sont vraiment bas de gamme...
 
Z
zen102
Nouveau
bonjour,

merci de votre aide, vous avez raison pour les drivers j ai déjà cramé deux.
par contre pour la vitesse et l'accélération 1000 mm/min je pense que sont très très lentes, je n ai pas encore essayé car je bricole que le weekend et hier j ai voulu faire un teste mais j'ai regardé le match PSG.
 

Sujets similaires

gaston83
Réponses
0
Affichages
255
gaston83
gaston83
A
Réponses
7
Affichages
629
Airex
A
S
Réponses
31
Affichages
4 053
Speedmini
S
B
Réponses
42
Affichages
1 379
Dodore
Dodore
P
Réponses
28
Affichages
1 369
Dodore
Dodore
Fernand069
Réponses
8
Affichages
1 164
Fernand069
Fernand069
R
Réponses
15
Affichages
593
robine.alexandre90@gmail.
R
Mcar
Réponses
65
Affichages
2 785
Mcar
P
Réponses
9
Affichages
990
Vapomill
Vapomill
Haut