Résolu Problème avec réglage du palpeur d'outil

  • Auteur de la discussion minimarc
  • Date de début
M
minimarc
Nouveau
17 Juil 2014
14
  • Auteur de la discussion
  • #1
Bonsoir à tous.
j'ai encore besoin de votre aide.
j'ai fabriqué un outil de palpage (voir photo), celui-ci en lui-même ne pose pas de problème. Mach3 le détecte bien. Sa hauteur comme indiqué déclenche à 53.57 mm.
IMG_20191012_183637.jpg


Mon souci vient du réglage (qui pourtant n'a pas l'aire bien compliquée)

IMG_20191012_183407.jpg


Pendant le palpage, ma hauteur en Z change (ce qui est normal), mais pas de la bonne valeur.
Si je tangente en manuel sur mon palpeur, j'ai une valeur de 37, . mm, alors que je devrais retrouver 53.57 mm.
En plus après le palpage, l'outil remonte en automatique (normal), s'arrête (une seconde) puis repar en Z+ jusqu'à ma butée de fine course (ce qui n'est pas normal car cela déclenche l'arrêt d'urgence).
Je vous joins une image de la macro (je n'ai rien touché dedans)
Merci de votre aide car là, je n'y connais absolument RIEN!!
IMG_20191012_183457.jpg
 
dh42
dh42
Compagnon
4 Sept 2009
5 786
Près de St Etienne (42)
Salut,

Oui, il y a des chances que le pb vienne de la ; la macro d'origine fonctionne correctement en port // ou avec une carte d'interpolation USB ou Ethernet "correcte" (pas chinoise, quoi !), mais avec la plupart des cartes chinoises ça plante car le plugin de la carte ne gère pas toutes les options de Mach3.

++
David
 
M
minimarc
Nouveau
17 Juil 2014
14
  • Auteur de la discussion
  • #4
Bonsoir à tous est merci pour vos réponses.

j'ai modifié le scipt de la macro suivant les infos de AlGONE.

ZPALP = GETVAR(2002)

par

ZPALP = GETOEMDRO(802)

Et cela fonctionne parfaitement bien.

Pour info, effectivement je suis avec une carte chinoise type WXHC en USB qui fonctionne plutôt bien.

Encore merci pour votre aide.
 
J
jmlwood
Apprenti
19 Juin 2010
61
Bonjour,

Je souhaite créer des scripts pour les boutons existants ci-dessous, mais je n'y connais rien.
J'avais trouver des scripts sur internet mais ils ne fonctionnent pas correctement (instables, jamais 2 fois les mêmes mouvements sur la CN)
Je penses que c'est due à l'interface que j'utilise. J'utilise une petite interface UC100 qui permet la commande via USB plutôt que LPT1 (mon PC ne possède pas de port LPT1)

Ci-dessous ce que je souhaite créer (voir schéma en dessous du texte):
Bouton 1 (Y+) existant
1- mise en place de mon outil en haut de mon brut
2- sélection du diamètre de l'outil
3- impulsion sur le bouton / déplacement de la CN en Y négatif jusqu'au contact du brut
4- Déplacement en Y+ d'une distance variable (renseignement variable dans le script)
5- Mise à jour automatique de la coordonnée Y à + "distance variable dans le script" - (diamètre outil /2) afin que le centre de l'outil soit à 0.00 sur l'arrête du brut

Bouton 2 (X+) existant
1- mise en place de mon outil à droite de mon brut
2- sélection du diamètre de l'outil
3- impulsion sur le bouton / déplacement de la CN en X négatif jusqu'au contact du brut
4- Déplacement en X+ d'une distance variable (renseignement variable dans le script)
5- Mise à jour automatique de la coordonnée X à + "distance variable dans le script" - (diamètre outil /2) afin que le centre de l'outil soit à 0.00 sur l'arrête du brut

Bouton 3 (CENTRE) existant (recherche de centre intérieur)
1- mise en place approximative de mon outil au milieu d'un tube par exemple
2- sélection du diamètre de l'outil
3- impulsion sur le bouton / déplacement de la CN en X et Y positif/négatif jusqu'au contact du brut
4- Déplacement de l'outil en X0.00 et Y0.00
5- Mise à jour automatique de la coordonnée X0,00 / Y0.00

Bouton 4 (Y-) existant
1- mise en place de mon outil en bas de mon brut
2- sélection du diamètre de l'outil
3- impulsion sur le bouton / déplacement de la CN en Y positif jusqu'au contact du brut
4- Déplacement en Y- d'une distance variable (renseignement variable dans le script)
5- Mise à jour automatique de la coordonnée Y à - "distance variable dans le script" +( diamètre outil /2) afin que le centre de l'outil soit à 0.00 sur l'arrête du brut

Bouton 5 (X-) existant
1- mise en place de mon outil à gauche de mon brut
2- sélection du diamètre de l'outil
3- impulsion sur le bouton / déplacement de la CN en X positif jusqu'au contact du brut
4- Déplacement en X- d'une distance variable (renseignement variable dans le script)
5- Mise à jour automatique de la coordonnée X à - "distance variable dans le script" +( diamètre outil /2) afin que le centre de l'outil soit à 0.00 sur l'arrête du brut

1576665471552.png



Pourriez vous m'apporter votre aide?
Merci
 
Haut