Advertisements

MACH3FR Paramétrage palpeur

RUIZ Daniel
RUIZ Daniel
Nouveau
8 Octobre 2017
32
FEIGNEUX
  • Auteur de la discussion
  • #1
Bonjour à tous,


J’aurais besoin d’aide concernant la fonction palpeur de MACH3FR.

Je n’ai pas trouvé la solution en parcourant les différents posts concernant ce sujet sur le forum.

Cela fait pas mal de temps que je galère sur ce sujet sans avoir trouvé la solution.

- La hauteur de palpeur est réglée sur 10.00

-Les coordonnées de retour réglées sur 15.00

Photo ci jointe.

Je lance la fonction ‘’Palper sur place’’ la broche descend bien jusqu’à la sonde elle s’arrête bien et remonte à 15.00.

Dans l’écran principal ‘’Automatique’’ de MACH3 la valeur de Z est bien à +15.00

Lorsque je valide ‘’ALLER 0.0.0 le compteur de Z passe bien à 0.0.0

La broche descend à environ 1cm au-dessus du zéro ?????

Je pense que cela doit provenir d’un décalage ?

Etant débutant je ne maitrise pas bien les fonctions décalages.

Je joins également une photo de la macro du palpeur, pour information c’est une CNC chinoise USB.

2018-01-20_15h49_55.png


2018-01-20_15h48_29.png
 
Advertisements
Juluan
Juluan
Apprenti
5 Mai 2017
163
J'ai le même problème que toi, enfin j'avais le même problème que toi. Je crois avoir trouvé une solution, mais je ne sais pas si c'est la bonne et j'aimerai bien comprendre le pourquoi du comment... Ma cnc n'est pas fini, je suis au stade des réglages et des tests. J'ai installé ces derniers jours un palpeur tout simple à contact de mise à la masse, truc classique quoi... Lorsque j'ai fait mes essais, j'avais entré dans l’écran palpage:

Hauteur du palpeur "19,5" puisque c'est ça hauteur.
Coordonnée Z de la surface palpée "0" puisque pour moi le palpeur est posé directement sur la table martyr.
vitesse de palpage 500 mais on s'en moque pour le coup.
et
Coordonnée Z de retour "50"

Je lance le palpage sur place.
Ça marche nickel le Z remonte et j'ai bien les 50 de retour dans mon visu "Z".
Comme toi, je me dis j’envoie la machine à ZÉRO et elle devrai descendre affleure de la table martyr.
Comme toi le Z s’arrête environ 10mm avant la table.

Alors franchement je dois pas bien comprendre les libellés de la fenêtre palpage d'outil et j'aimerai bien que l'on m’explique clairement tous ça, mais du coup pour tester j'ai remplacé le "0" de la coordonnée Z de la surface palpée par "19.5" comme la hauteur du palpeur.
Et bien bingo, après palpage et "aller à zéro" mon outil descend bien affleure sur la table martyr.

Une âme charitable pourrait elle m'expliquer clairement le palpage avec mach3? Parce que dans ce cas, à quoi peut servir le libellé (Coordonnée Z de la surface palpée) si c'est la même chose que la hauteur du palpeur?
Moi pas bien comprendre... :smt021
 
C
coolyac
Nouveau
11 Juin 2014
22
C.I
Bonjour Juluan;

J'avais les mêmes problèmes quand j'ai reçu ma cnc. Quand j'ai remplacé "coordonnée z de la surface palpée" par la hauteur du palpeur, cela marchait comme voulu; sinon il y avait toujours un décalage égale à la hauteur de mon palpeur.
Quand je grave un circuit imprimé, je garde "coordonnée Z de la surface palpée" à 0 et hauteur à 0, et la fraise palpe directement sur le cuivre du pcb et c'est ok.
Je me demande si cette ligne ne signifierait-elle pas "Coordonnée Z du palpeur" ??
C'est ainsi que ça marche chez moi.
à+
 
Dernière édition:
Juluan
Juluan
Apprenti
5 Mai 2017
163
Bonjour Juluan;

J'avais les mêmes problèmes quand j'ai reçu ma cnc. Quand j'ai remplacé "coordonnée z de la surface palpée" par la hauteur du palpeur, cela marchait comme voulu; sinon il y avait toujours un décalage égale à la hauteur de mon palpeur.
Quand je grave un circuit imprimé, je garde "coordonnée Z de la surface palpée" à 0 et hauteur à 0, et la fraise palpe directement sur le cuivre du pcb et c'est ok.
Je me demande si cette ligne ne signifierait-elle pas "Coordonnée Z du palpeur" ??
C'est ainsi que ça marche chez moi.
à+
Oui effectivement même problème, mais pourquoi cette ligne signifierait "Cordonnée Z du palpeur"? Puisque la hauteur du palpeur c'est forcement ça coordonnée Z au final? Non?
 
C
coolyac
Nouveau
11 Juin 2014
22
C.I
Hello juluan;

Oui effectivement même problème, mais pourquoi cette ligne signifierait "Cordonnée Z du palpeur"? Puisque la hauteur du palpeur c'est forcement ça coordonnée Z au final? Non?
J'en sait rien, peut-être par rapport au zéro de la pièce ??
Et si je tenais mon palpeur à la main juste légèrement au dessus de la pièce, quelle serait la coordonnée Z du palpeur par rapport au zéro de celle-ci après le palpage ? ou encore si je pose mon palpeur dans un creux de ma pièce, donc en dessous de son zéro ?
C'est quoi la "surface palpée" ?, est-ce la surface que touche la fraise pendant cette opération de palpage ou est-ce la surface de la pièce en dessous du palpeur?
Que sais-je encore? "surface palpée" ? ou "surface à palper" ? ou "surface que je désir palper" ? ou "surface que je crois avoir palpée" ?

Avec la solution que nous avons tous les deux adoptée, cela ne revient-il pas à dire que la surface palpée serait le dessus du palpeur?
Et dans ce cas, la "coordonne Z de la surface palpée" n'est-elle pas la hauteur du palpeur par rapport au zéro de la pièce ?

Et bizarrement, c'est ce qui marche chez moi; pourquoi ??

Je me pose ces questions...
à+
 
Dernière édition:
Juluan
Juluan
Apprenti
5 Mai 2017
163
je suis certain qu'il y a une raison rationnelle à ce paramètre , mais ça m’échappe complétement.

Ou alors, est ce un paramètre à rentrer en fonction du brute de la pièces si l'on palpe a coté de la pièce elle même?
Dans ce cas si mon brute fait 50mm il faudrait entrer 19.5 (dans mon cas) pour la hauteur du palpeur et dans hauteur à palper il faudrait entrer 19.5+50??? Soit 69.5? ou juste 50mm??? Je ferai des test pour vérifier.
 
G
gaston48
Compagnon
26 Février 2008
9 072
59000
Bonjour,
Ça ne correspond pas à la hauteur du palpeur " à vide " ceux à comparateurs ?
 
G
gaston48
Compagnon
26 Février 2008
9 072
59000
J'aurais du dire comme ceux à comparateur, mais on peut imaginer une course à vide de 1 ou 2 mm
par exemple pour appliquer une force de contact minimale avant de declancher le contact à la hauteur de
référence.
Que se passe t il si tu rajoutes 1 ou 2 mm à cette" hauteur de palpeur " tel que 21.5 pour ta hauteur 19.5
 
Juluan
Juluan
Apprenti
5 Mai 2017
163
Bon, j’ai fait des essais, avec ce qui semblait bien marcher. Et bien ce ne marchait plus. Toujours un décalage ou encore le Z qui remontait a zero origine machine ou pire redescendait plus bas que le palpeur... aie aie aie... Une galère...
Alors je me suis penché plus sérieusement sur le sujet.
Apres avoir marqué mon palpeur et fait quelques trous dans ma table martyre je pense, j’espere avoir trouvé la bonne solution.

Déjà, votre carte est elle en port//, USB ou Ethernet?
Pour ma part je suis en Ethernet, qui visiblement souffre des mêmes problemes que l’USB, par rapport au palpage.

Il y a un sujet qui traite ce problème de décalage pour l’USB, et bien pour l’Ethernet c’est pareil.
https://www.usinages.com/threads/probleme-de-palpeur-en-z.92814/
Il faut remplacer dans les macro de palpage les lignes

ZPALP = GETVAR(2002)

par

ZPALP = GETOEMDRO(802)

J’ai fait ca pour chaque boutons (3) de palpage et meme sur celui zpalp2 de changement outils.

Et pour moi, ca marche nickel (pour l’instant), même en laissant a 0 le visu « coordonné z de la surface a palper » pour palper sur place, sur le brute.
Alors j’ai en suite testé en palpant a côté d’un brute de 15mm.
J’ajoute donc 15mm dans le visu cordonnée z de la surface a palper. Et....crack ca descend trop bas.
J’ai replongé dans la macro de palper sur place et j’ai modifié ce ci.


NOUVEAU Z = HPALPEUR + HSURFACE
par
NOUVEAU Z = HPALPEUR - HSURFACE

Et apres essai, cela semble bien fonctionner.
Je retesterai aujourd’hui pour valider definitivement ces modifs.
 
Dernière édition:
Manuforg
Manuforg
Ouvrier
11 Octobre 2014
420
Tournai 7500 (Belgique)
Je n'ai jamais rien compris a leurs macros de palpage. Pour ma part, je les ai refait directement.

NB:
- mon contact de palpeur est un normalement fermer, pour être certain qu'il fonctionne avant le démarrage de la procédure de palpage!
- Certaines variable ne sont pas utilisées.
- je suis en carte USb, mais je ne pense pas que ca change quelques chose.

Voici mes codes pour le "Palper sur place":

HPALPEUR = GETOEMDRO(1040)
HSURFACE = GETOEMDRO(1050)
NOUVEAUZ = HPALPEUR+HSURFACE
HFIN = GETOEMDRO(1051)
POSPALPX = GETOEMDRO(1010)
POSPALPY = GETOEMDRO(1011)
DECPALPX = GETOEMDRO(1020)
DECPALPY = GETOEMDRO(1021)
POSCOX = GETOEMDRO(1010)
POSCOY = GETOEMDRO(1011)
PALPX = POSPALPX + DECPALPX
PALPY = POSPALPY + DECPALPY
VPALP = GETOEMDRO(1060)
HSECU = GETOEMDRO(1051)
MsgBox("PRET?")
SLEEP(250)
CODE "g0z" & ZUP
CODE "G31Z-200 F"& VPALP
While ISMOVING()
SLEEP(250)
Wend
SETOEMDRO(802,NOUVEAUZ)
SLEEP(250)
CODE "g91g00z" & HSECU
CODE "g90"
While ISMOVING()
SLEEP(250)
Wend
CODE "F2000"
 
Juluan
Juluan
Apprenti
5 Mai 2017
163
Je t’avouerais que je ne comprend pas non plus le code, mais j’y suis un peu allé en tatonant.
Mon palpeur est normalement ouvert pour le coup.

Et avec ton code tu peux palper a côté du brut?
 
Dernière édition:
Juluan
Juluan
Apprenti
5 Mai 2017
163
Bon, j’ai fait des essais, avec ce qui semblait bien marcher. Et bien ce ne marchait plus. Toujours un décalage ou encore le Z qui remontait a zero origine machine ou pire redescendait plus bas que le palpeur... aie aie aie... Une galère...
Alors je me suis penché plus sérieusement sur le sujet.
Apres avoir marqué mon palpeur et fait quelques trous dans ma table martyre je pense, j’espere avoir trouvé la bonne solution.

Déjà, votre carte est elle en port//, USB ou Ethernet?
Pour ma part je suis en Ethernet, qui visiblement souffre des mêmes problemes que l’USB, par rapport au palpage.

Il y a un sujet qui traite ce problème de décalage pour l’USB, et bien pour l’Ethernet c’est pareil.
https://www.usinages.com/threads/probleme-de-palpeur-en-z.92814/
Il faut remplacer dans les macro de palpage les lignes

ZPALP = GETVAR(2002)

par

ZPALP = GETOEMDRO(802)

J’ai fait ca pour chaque boutons (3) de palpage et meme sur celui zpalp2 de changement outils.

Et pour moi, ca marche nickel (pour l’instant), même en laissant a 0 le visu « coordonné z de la surface a palper » pour palper sur place, sur le brute.
Alors j’ai en suite testé en palpant a côté d’un brute de 15mm.
J’ajoute donc 15mm dans le visu cordonnée z de la surface a palper. Et....crack ca descend trop bas.
J’ai replongé dans la macro de palper sur place et j’ai modifié ce ci.


NOUVEAU Z = HPALPEUR + HSURFACE
par
NOUVEAU Z = HPALPEUR - HSURFACE

Et apres essai, cela semble bien fonctionner.
Je retesterai aujourd’hui pour valider definitivement ces modifs.
Bon, cette configuration semble me convenir et plutot stable, après plusieurs essais aujourdhui.
 
La dernière réponse à ce sujet date de plus de 6 mois
Advertisements
Haut