CNC ts2518-b premiers pas

  • Auteur de la discussion Mortaurat
  • Date de début
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #1
Bonjour,
Je possède une CNC ts2518-b de longue date que je n'ai jamais réussi à faire fonctionner faute de port parallèle.
J'ai donc récemment investi dans un UC100 pour la piloter par USB.

Je souhaiterais en premier lieu commander manuellement la fraiseuse, afin de verifier que l'auto-home et les différents axes fonctionnent parfaitement.
J'ai donc installé et ouvert mach 3, configuré les PIN comme dans le manuel (voir page 18 : http://down.fmuser.net/FM Radio/English Manual-TS2518B CNCrouter.pdf ) puis, j'ai appuyé sur TAB pour faire apparaître la commande manuelle.

Cependant, rien ne se passe.
J'imagine qu'il doit y avoir une etape pour connecter la fraiseuse, ou quelque chose d'autre à faire.

Avez vous une idée ou un lien de tuto ?

Merci

Ps: j'ai déjà une expérience d'imprimante 3D, que j'ai assemblé moi même.
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #2
Bonjour,
J'ai en partie trouvé le problème.
Mes drivers UC100 ne sont pas compatibles avec l'UC100 que j'ai acheté.
Il s'agit probablement d'une daube chinoise, même si j'ai pris soin de l'acheter en europe.
Savez vous comment je peux faire ?

Merci
 
bendu73
bendu73
Compagnon
18 Sept 2013
1 226
SAVOIE
Bonjour,

Je ne comprend pas trop ton histoire de drivers? tu parles de driver moteur ou de driver de pc??
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #4
Je parle des drivers pc de l'uc100. Normalement il y'a un auto installer pour m'acheter, cependant, comme indiqué sur le site, cela ne marche pas avec les contrefaçons.
J'ai acheté dans le savoir une contrefaçon, comment la faire marcher ?
 
bendu73
bendu73
Compagnon
18 Sept 2013
1 226
SAVOIE
Dans les périphériques windows, est t-elle visible?
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #6
Visible mais drivers non installés.
 
bendu73
bendu73
Compagnon
18 Sept 2013
1 226
SAVOIE
Il faut trouver les drivers et les installer manuellement.
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #8
Je n'avais pas deviné ^^
Le problème est que je n'arrive pas à trouver les drivers pour cet UC100, les seuls que je trouve sur internet ne sont pas compatible. Typiquement, ces drivers : http://cncdrive.com/UC100.html Ne sont pas compatibles.
 
bendu73
bendu73
Compagnon
18 Sept 2013
1 226
SAVOIE
Il ne s'installe pas lorsque tu branche ta carte?
Le problème peut être aussi au niveau de la configuration sur Mach3. Mais sans la moindre de capture c'est dure de t'aider...
Il faudrait voir si les enables des axes etc...tester les entrés de fin de courses.
J'ai déjà eu un soucis, et c'était simplement une case à cocher "enable"...
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #10
Si ça ne marche pas, j'aurais beau faire tous les réglages du monde dans Mach3, ça ne marchera pas : http://hpics.li/6fff895

Je peux installer les drivers, pas de soucis, mach3 detecte le plugin de l'UC100, mais lorsque je selectionne l'UC100, il me dit que rien n'est connecté, ce qui est normal, vu que mes drivers d'UC100 ne sont pas installés.
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #11
Je précise quand je dis "je peux installer les drivers", je parle des drivers officiels de l'UC100, mais étant donné que le mien est une contrefaçon, ils ne sont pas compatibles
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #12
Le chinois qui m'a vendu l'UC100 a fini par me transmettre des drivers.
Je peux donc utiliser Mach3.
J'ai donc bien configuré les PIN comme indiqué dans le manuel utilisateur : http://down.fmuser.net/FM Radio/English Manual-TS2518B CNCrouter.pdf
Cependant, seul l'axe des X fonctionne en manuel, et toujours dans le même sens.
Avez vous une idée du problème ?

Je serais tenté de dire la configuration des PIN, mais j'ai bien programmé comme dans le manuel...

Merci
 
ingenieu59
ingenieu59
Compagnon
10 Sept 2013
3 485
cassel 59
Qu' as tu comme N° de pin devant tes axes ?

Généralement, c' est 2 ; 3 pour X
4 ; 5 pour Y
6 ; 7 pour Z
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #14
Bonjour,
Comme indiqué dans le manuel :
X : 16-17
Y : 4 - 5
Z : 6 - 7

Seul l'axe des X bouge, mais que dans un seul sens (peut importe si je clique sur x+ ou x-)
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #15
Bon,
Admettons que je veuille tout recabler. Vous me conseilleriez quoi comme kit de commande USB avec drivers ?

Merci
 
ingenieu59
ingenieu59
Compagnon
10 Sept 2013
3 485
cassel 59
Bonjour,

tu as essayé de changer le N° de pin dans mach 3 pour dir .
Tu ne risques absolument rien à essayer .

Essaies 8 et 9 pour le Y
10 et 11 pour le Z .

Le mieux étant d' avoir le pdf qui correspond à ton équipement .

Pour le kit , j' ai tout acheté chez cncdrive ( UC 300 et HDBB2 )
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #17
J'ai essayé toutes les pins.
J'ai mis les pins comme indiqué dans le pdf. Je vais regarder ton équipement.
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #18
J'ai effectué quelques recherches.
Pensez vous que mon problème puisse venir du fait que j'utilise une version 64 bits de windows ?

Je sais que pour les imprimantes 3D il existe des systèmes permettant de mettre le Gcode sur une carte SD et ensuite d'imprimer à partir de la carte.
Existe t'il la même chose pour les fraiseuses ?

Merci
 
ingenieu59
ingenieu59
Compagnon
10 Sept 2013
3 485
cassel 59
Bonjour,

64 bits, ça pourrait être une source de problèmes . Pour certains matériel , parce que pour d' autres, ça passe .

Moi, je reste en 32 bits .
 
bendu73
bendu73
Compagnon
18 Sept 2013
1 226
SAVOIE
Je sais que pour les imprimantes 3D il existe des systèmes permettant de mettre le Gcode sur une carte SD et ensuite d'imprimer à partir de la carte.
Existe t'il la même chose pour les fraiseuses ?
Ton Gcode tu le mets sur Mach3 en allant chercher le fichier dans un dossier, après libre à toi de mettre le périphérique de stockage que tu veux ( USB, SD, micro SD...etc).
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #21
J'ai enfin reussi à faire marcher la CNC.
Le problème etait mon UC100 chinois.
J'ai acheté un UC100 original, installé les drivers, et ça marche nickel.
Y'a plus qu'a faire le premier fraisage :)
 
M
Mortaurat
Nouveau
20 Juil 2017
35
  • Auteur de la discussion
  • #22
Bonjour,
quel logiciel me conseillez vous d'utiliser pour générer mon Gcode à partir d'un fichier stl ou dxf ?
Je veux un truc simple.

Pour l'impression 3D j'utilisais Slic3r qui permettait en 3 clics de générer le Gcode :)

Merci
 
rac
rac
Apprenti
20 Déc 2013
126
Moulins (03)
CAMBAM...
Dispo en démo 1000 Lignes de code
 
Haut