CNC à base d'une Mega2560, Ramps 1.4, Grbl et bCNC

  • Auteur de la discussion vol689
  • Date de début
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #1
Bonjour à tous

J'ai construit grâce à mon imprimante 3D, une petite CNC dans le but de pouvoir graver des PCB.
tout est monté, l'électronique en place, la liaison avec le PC établi.
Axe X ok
Axe Y ok
Axe Z problème, j'ai l'impression que les moteurs (2 Nema 17 synchronisé) saute des pas, je m'explique, le moteur commence à tourner et le chariot à s'élever puis le chariot s'arrête mais le moteur continu à tourner puis le chariot reprend de mouvement d'ascension.
Voici les testes que j'ai effectué.
Inversion moteur (problème identique)
inversion module driver (problème identique)
inversion câblage (problème identique)
inversion des pins entre les axes X et Z dans le programme (le problème change d'axe)
Je pense que cela proviens du programme de l'arduino.

Je ne trouve pas ou pourrait se situer la ligne erronée !

L'un d'entre vous aurait il eu le même problème ?

Merci d'avance pour votre aide
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 248
Corsier-sur-Vevey (Vaud)
puis le chariot s'arrête mais le moteur continu à tourner puis le chariot reprend de mouvement d'ascension
Quel type de transmission as tu pour avoir le chariot qui s'arrête mais le moteur qui tourne encore?
 
fred03800
fred03800
Compagnon
19 Mai 2009
543
Bonjour,
de Nema17, c'est petit est pas bien costaud, as tu un photo de ta machine pour que l'on ce rende mieux compte ?
 
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #4
Bonjour

La transmission s'effectue par une tige filetée sur tout les axes comme sur l'axe Z d'une imprimante 3D
Je posterais ce soir des photos de la machine, en fait je ne vais usiner que des circuit imprimé sur 0.04 de profond.

en fait il est difficile d'expliquer le phénomène, en fait quand je dit le moteur tourne encore c'est plus une expression, en fait la transmission débute le mouvement puis s'arrête et l'intensité du bruit du moteur augmente et devient un sifflement puis au bout de quelque dixième de secondes (le pas est de 5mm) la rotation reprend.

Merci pour votre aide

Cordialement
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 248
Corsier-sur-Vevey (Vaud)
Bonjour vol689
Est ce que le phénomène se produit toujours au même moment et qu'une fois par mouvement de l'axe?
Quelle version de GRBL?
 
Dernière édition:
victorjung
victorjung
Compagnon
12 Oct 2012
643
Nyon suisse
Salut,
J'ai moi meme fait une cnc principalement à base de pièces imprimées et motorisée en Nema17. J'étais partie sur des tiges filetées M8 mais j'ai changer X Y pour des courroies car les tiges c'était insupportablement lent et bruyant.
Ton problème ca m'a tout l'air d'être un souci de courant max réglé sur le driver de l'axe z. T'as essayé de régler les potentiometres?
Pour moi deux possibilités, courant réglé trop fort, le driver surchauffe et se coupe en sécurité puis reprend quand il a refroidit.
ou alors courant à peine suffisant pour que le moteur saute pas de pas au moindre effort.

Tu peux régler le potentiomètre du driver z jusqu'à avoir un un bon couple mais un moteur pas trop bruyant, pendant que tu lui demande un mouvement assez long pour voire comment ca se comporte.

Je pars du principe que le nombre de step/mm les accélérations et vitesses max sont bien réglées dans grbl.

finalement, mets des photos, on aime les photos!
 
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #7
Bonjour à tous

pour répondre aux questions :
c'est GRBL_RAMPS1_4 V1.1 que j'utilise avec
bCNC-master
python 2.7.11
pyserial3.01

le phénomène se produit à chaque fois qu'il y à une impulsion vers l'axe Z ou X ou Y en fonction des pins programmés, mais que sur un seul axe les autres fonctionnent sans problèmes.

J'ai déjà tenté de régler le driver de l'axe ne fonctionnant pas correctement, inverser les drivers, remplacer le drivers, le cablage, testé la connectivité mais comme le problème se déplace avec les inversion de pin dans le programme de l'arduino, je pense que c'est un problème de prog.

voici des photos
20160621_180045.jpg
20160621_180054.jpg
20160621_180100.jpg
20160621_180110.jpg
20160621_180119.jpg
20160621_180151.jpg
 
S
speedjf37
Compagnon
15 Oct 2009
2 218
indre et loire
Bonjour,

Les cartes électroniques Ramps etc me paraissent très (trop) près d'un moteur surtout sur la dernière photo.

Éloigner et séparer par un blindage (tôle métallique feuille d'alu etc) pour tester.

Cordialement JF
 
inmik
inmik
Apprenti
18 Sept 2010
242
Bonjour,

Je vote pour baisser l’accélération de 50% et faire encore des tests

Cordialement

Inmik
 
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #10
Bonjour

effectivement le moteur est pret de la carte, il est possible de poser un blindage, mais même quand le moteur est plus éloigné le problème subsiste

Merci pour l'info

Cordialement
Vol68
 
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #11
Salut à tous

j'ai déjà effectué des baisse de vitesse jusqu'à 0.1mm/s le le problème disparaît mais lorsque les chariot accélérés pour dégager la zone de travail le problème resurgit
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 248
Corsier-sur-Vevey (Vaud)
Salut vol89
Pourrais-tu mettre tes paramètres GRBL en ligne?
As-tu essayé avec un seul moteur du tandem, avec l'un, avec l'autre, sans mécanique sur ces 2 PAP, avec 1 seul PAP à vide?


jpbbricole
 
Dernière édition:
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #13
Bonjour

Oui j'ai déjà essayé et avec le ou les moteur de chaque axe, que l'axe soit motorisé en tandem ou non le phénomène apparaît (en tandem sur les deux PAP, en solo sur le PAP concerné) idem à vide

Voici les paramètres de GRBL

#define MICROSTEPS 16 // 16 --> all three jumpers installed
#define STEPS_PER_REV 200.0
#define MM_PER_REV 1.25 // 1.25 mm/rev leadscrew
#define Cyclone_XY_Gear_Ratio 21.0/21.0 // Number of gear teeth (motor/rod)
#define Cyclone_Z_Gear_Ratio 8.0/15.0 // Number of gear teeth (motor/rod) 8.0/15.0
#define DEFAULT_X_STEPS_PER_MM (STEPS_PER_REV*MICROSTEPS/(Cyclone_XY_Gear_Ratio*MM_PER_REV))
#define DEFAULT_Y_STEPS_PER_MM (STEPS_PER_REV*MICROSTEPS/(Cyclone_XY_Gear_Ratio*MM_PER_REV))
#define DEFAULT_Z_STEPS_PER_MM (STEPS_PER_REV*MICROSTEPS/(Cyclone_Z_Gear_Ratio*MM_PER_REV))
#define DEFAULT_X_MAX_RATE 5*60.0 // mm/min
#define DEFAULT_Y_MAX_RATE 5*60.0 // mm/min
#define DEFAULT_Z_MAX_RATE 2.5*60.0 // mm/min
#define DEFAULT_X_ACCELERATION (16.0*60*60) // 50*60*60 mm/min^2 = 50 mm/sec^2
#define DEFAULT_Y_ACCELERATION (16.0*60*60) // 50*60*60 mm/min^2 = 50 mm/sec^2
#define DEFAULT_Z_ACCELERATION (16.0*60*60) // 50*60*60 mm/min^2 = 50 mm/sec^2
#define DEFAULT_X_MAX_TRAVEL 168.0 // mm
#define DEFAULT_Y_MAX_TRAVEL 101.0 // mm
#define DEFAULT_Z_MAX_TRAVEL 50.0 // mm
#define DEFAULT_STEP_PULSE_MICROSECONDS 10
#define DEFAULT_STEPPING_INVERT_MASK 0
#define DEFAULT_DIRECTION_INVERT_MASK ((0<<X_AXIS)|(0<<Y_AXIS)|(1<<Z_AXIS))
#define DEFAULT_STEPPER_IDLE_LOCK_TIME 255 // msec (0-254, 255 keeps steppers enabled)
#define DEFAULT_STATUS_REPORT_MASK ((BITFLAG_RT_STATUS_MACHINE_POSITION)|(BITFLAG_RT_STATUS_WORK_POSITION))
#define DEFAULT_JUNCTION_DEVIATION 0.02 // mm
#define DEFAULT_ARC_TOLERANCE 0.002 // mm
#define DEFAULT_REPORT_INCHES 0 // false
#define DEFAULT_AUTO_START 1 // true
#define DEFAULT_INVERT_ST_ENABLE 0 // false
#define DEFAULT_INVERT_LIMIT_PINS 0 // false
#define DEFAULT_SOFT_LIMIT_ENABLE 1 // true
#define DEFAULT_HARD_LIMIT_ENABLE 0 // false
#define DEFAULT_HOMING_ENABLE 1 // true
#define DEFAULT_HOMING_DIR_MASK ((1<<X_AXIS)|(1<<Y_AXIS)|(0<<Z_AXIS)) // in Cyclone, z axis is left to move upwards, in case Z homing is triggered (there is no Z endstop!)
#define DEFAULT_HOMING_FEED_RATE 50.0 // mm/min (slower feed rate to "bump" the endstops)
#define DEFAULT_HOMING_SEEK_RATE 635.0 // mm/min (will saturate to MAX_RATE)
#define DEFAULT_HOMING_DEBOUNCE_DELAY 250 // msec (0-65k)
#define DEFAULT_HOMING_PULLOFF 0.0 // mm (distance that the axis move after homing)

Encore merci
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 248
Corsier-sur-Vevey (Vaud)
Voici les paramètres de GRBL
C'est les paramètres du programme par défaut mais il faut les paramètres d'utilisation qui sont obtenus par l'envoi de la commande GRBL $$

Bonne journée
jpbbricole
 
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #15
Bonsoir

Voici les parametres GRBL obtenu par $$

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.050 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=250.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=33.300 (x, step/mm)
$101=33.300 (y, step/mm)
$102=320.000 (z, step/mm)
$110=1000.000 (x max rate, mm/min)
$111=1000.000 (y max rate, mm/min)
$112=1000.000 (z max rate, mm/min)
$120=15.000 (x accel, mm/sec^2)
$121=15.000 (y accel, mm/sec^2)
$122=15.000 (z accel, mm/sec^2)
$130=200.000 (x max travel, mm)
$131=200.000 (y max travel, mm)
$132=200.000 (z max travel, mm)
ok

Cordialement
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 248
Corsier-sur-Vevey (Vaud)
Bonsoir vol689
Est ce juste une pareille différence?
upload_2016-6-22_18-33-54.png

jpbbricole
 
Nomadsoul
Nomadsoul
Apprenti
26 Avr 2014
77
Alsace
Bonjour,

J'ai connu un problème similaire avec grbl, cela venait du step pulse qui était trop court et lors de certaine manœuvre l'arduino allait trop vite pour le driver...


a+
 
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #18
Bonsoir

comme l'a précisé JPBBRICOLE oui effectivement il semblerait que le paramètre #define DEFAULT_Z_STEPS_PER_MM 320 ne soit pas correcte, mais je ne parviens pas à le modifier, j'ai modifier les paramètre utilisateur et les paramètres par défaut à #define DEFAULT_Z_STEPS_PER_MM 33.3 mais il ne change pas dans bCNC

Si quelqu'un avait une idée ?

Merci

Cordialement
Vol689
 
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #19
le step pulse est le même Nomadsoul
et pour les trois axes et fonctionne pour les deux autres axes

Merci pour ton aide
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 248
Corsier-sur-Vevey (Vaud)
mais je ne parviens pas à le modifier
Ces paramètres ne doivent pas êtres modifiées dans le source, mais depuis la console GRBL (UGS ou autre) avec la commande:
$102=33.300
et faire $$ pour controler
Bonne soirée
jpbbricole
 
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #21
Merci JPBBRICOLE, quel nouille je suis effectivement tu as raison

Merci
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 248
Corsier-sur-Vevey (Vaud)
Salut vol689
Alors bon usinage avec ta belle CNC.
Comme je ne suis pas capable d'en faire autant et que cela me fait envie, quand j'aurai fini la numérisation de mon tour, je crois bien que je vais m'en acheter une petite (aux yeux bridés!)

Cordialement
jpbbrcole
 
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #23
Salut jpbbricole, j'ai regardé longtemps les machines du commerce du type micro fraiseuse, mais comme je ne suis pas fraiseur et que je ne compte réaliser que des circuit imprimé, après avoir acheté une imprimante 3D et réalisé des pièces durant 2 ans, j'ai décidé il n y a pas très longtemps à tenter la fabrication.

en tout cas merci pour ton aide et aux autres membres

Cordialement
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 248
Corsier-sur-Vevey (Vaud)
j'ai décidé il n y a pas très longtemps à tenter la fabrication.
Belle aventure!
je suis aussi un inconditionnel de l'imprimante 3D, qui permet vraiment de monter de plusieurs crans nos possibilités de créations (ou bricolages). je suis entrain de terminer la numérisation de mon tour Proxxon et de sa DRO et vais m'attaquer à une machine à scanner les livres (le prototype, en bois est déjà fait).

l'imagination au pouvoir!

A bientôt
jpbbricole
 
Nomadsoul
Nomadsoul
Apprenti
26 Avr 2014
77
Alsace
vais m'attaquer à une machine à scanner les livres (le prototype, en bois est déjà fait).

l'imagination au pouvoir!

A bientôt
jpbbricole
Cool, avec détection OCR ? ou juste sous forme d'image ? Tu nous fera un topic stp ?:mrgreen:
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 248
Corsier-sur-Vevey (Vaud)
Tu nous fera un topic stp
Oui, si ça ne sort pas du cadre du forum. (je me renseignerai)
Oui, je fais l'OCR avec le programme ABBYY FineReader 12 Pro, payant mais très puissant.
La bête est actuellement en grande partie en bois
upload_2016-6-25_12-35-49.png

et j'ai déjà fait la nouvelle potence
upload_2016-6-25_12-37-1.png
[div=none][arrow][/arrow][/div][div=none][arrow][/arrow][/div]
Mais je vais cesser de polluer le post de vol689 et ouvrirai un nouveau topic en temps voulu.
J'allais oublier, le tout, bien sûr, piloté par un Arduino!

Cordialement
jpbbricole
 
Dernière édition:
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #27
Pas de souci, pas de risque de me gêner, avec ce genre de sujet très intéressant.
 
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #28
Bon au boulot, il faut maintenant que je conçoive un système me permettant de maintenir la plaque cuivrée.

Au fait l'un d'entre vous à t'il déjà installé un laser de découpe ?

Merci

Cordialement
vol689
 
V
vol689
Nouveau
20 Juin 2016
14
  • Auteur de la discussion
  • #29
Bonjour à tous

Ok ça marche, maintenant un autre probleme surgit, la calibration du programme bCNC, je ne comprends pas comment indiquer à la machine les coordonnées du point Zéro, la taille de la table etc.
Est ce que quelqu'un utilise déjà ce système ?

Merci
Vol68
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 248
Corsier-sur-Vevey (Vaud)
la calibration du programme bCNC
Malheureusement, je n'utilise pas encore bCNC... Ce sera pour plus tard pour faire du PCB avec laser et chimie. Je vais le télécharger pour voire.
Ok ça marche, maintenant
C'est super!
autre probleme surgit
Sans ça celà n'aurait plus de charme!
la taille de la table etc.
Sauf erreur, c'est les paramètres GRBL 130 131 132
Pour le réglage fin du point 0 regarde ceci:
GRBL Probe Command (G38.2)
A extrapoler pour les 3 axes.

Bonne soirée

jpbbricole
 
Sujets similaires Forum Date
Machines laser
Discussions générales sur la conception
Projets de fraiseuse et portique d'usinage CNC
Machines CNC d'autoconstructeurs type portique lég
Projets de fraiseuse et portique d'usinage CNC
Projets de fraiseuse et portique d'usinage CNC
Electronique spécifique CNC
Conversion de fraiseuses conventionnelles
Projets de fraiseuse et portique d'usinage CNC
Machines CNC d'autoconstructeurs type portique lég
Projets de fraiseuse et portique d'usinage CNC
Projets de fraiseuse et portique d'usinage CNC
Projets de fraiseuse et portique d'usinage CNC
Projets de fraiseuse et portique d'usinage CNC
Projets d'autres machines CNC
Haut