Macro (script) qui change de comportement ???

  • Auteur de la discussion DakotaSport07
  • Date de début
DakotaSport07

DakotaSport07

Apprenti
y avait un screenset de swiss
Je les télécharger son screen set, je les même essayer juste pour voir, mais je voulais absolument garder la version de Mach.fr. alors j'ai pas regarder longtemps.
Mais la je vais prendre le temps de regarder toute les autre Mach3. J'aimerais bien garder tout ce que j'ai. Je suis habituer avec Mach3.fr par ce que justement il est en français et je le connait plus que les autre version. Mais la avec tout ce que je découvre, je pense plus a d'autre version ou carrément un autre logiciel.
Mais avant je vais encore recommencer de zéro. Je vais réinitialisé mon PC de nouveau et je le branche plus sur le net. windows veut toujours prendre les mise a jours et je crois que le problème vient peut être de la. J'ai remarquer que, plus mon pc prend des mise a jours, plus mon pc vas mal.
il est pas venue avec un Windows 10 d'origine, et il est probablement pas fait pour. Si j'ai encore mon le windows OEM de ce pc je pense partir de la. Mais de mémoire le cd marche plus. en tout cas, a suivre. présentement je suis en train de regarder mes quatre cd chinois, il on tous des Mach3 dedans. deux on les version .066 avec le screen set 1040. un est de la version .063, et une de version .041. la j'ai installer le .041 pour voir et après avoir tout paramètre je veut l'essayer pour voir comment je vais trouver ça en englais. :wink:
 
DakotaSport07

DakotaSport07

Apprenti
la macro peut faire référence à des DRO
Oui, en plein ça, dans mach3.fr j'ai trouver des erreur comme ça, les code OEM de certain dro, ne coïncide pas avec la charte.
Pour que les script que je télécharge parfois pour qu'il fonctionne J'ai du ajuster les codes de mach3 avec le script que j'essais.
C'est pour cela que quand j'ai trouver ses charte de code je capotais bin raide. J'ai compris bien des chose.
 
DakotaSport07

DakotaSport07

Apprenti
J'avais placer dans un panier d'achat ce matin chez CNCdrive Kft pour voir comment sa me couterais aux totale avec les frai de postage et tout. et normalement en indiquant tes renseignement personnel sa donne le cout de transport, mais la en cliquant sur commande, elle a partie. sans rien savoir.
a la place j'ai eu un message que quel qu'un va communiquer avec moi.
Je pensais que jamais qu'il allais me répondre, bien il me demande 173 euro pour ma commande hahahahaha. Une chance qui avait pas un no de carte. j'Étais fais a l'os hahahahahaha.
en tout cas, je sait comment sa coute maintenant! voici ce qui me réclame, AXBB-E ethernet motion controller and breakout board combo (x1): 149 EUR Shipping with DHL express (x1): 24 EUR Value Added Tax (VAT, 0%): 0 EUR --- Total: 173 Euro --- All items in stock!
Alors j'ai convertie les euro en dollars CAN = 240.06 exactement. reste a ajouté les taxes, mais je sait pas quel % mettre. les douanes vont prendre les taxe de ou, de Europe ou bien du Canada? Québec ses 15% pour la tva et la tvq. l'Europe ses quoi, j'ai par retenu comment? Je commence a croire que sa serais moins cher chez cnc drive.
 
dh42

dh42

Compagnon
Salut,

Quand on commande chez CNCdrive depuis la France, c'est 27% de TVA, donc pas la TVA Francaise à 20% mais celle de Hongrie, j'imagine qu'il en ira de même pour toi.

++
David
 
DakotaSport07

DakotaSport07

Apprenti
Salut,

Quand on commande chez CNCdrive depuis la France, c'est 27% de TVA, donc pas la TVA Francaise à 20% mais celle de Hongrie, j'imagine qu'il en ira de même pour toi.

++
David
Salut David, Bon matin!
C vrai, c'est l'après midi pour toi. moi il est 10:40.

Pas sur d'avoir bien compris, je prend 20%?
Si oui, alors on dit, 149 euro + 24 euro pour DHL = 173 euro, eeeee je calcule la taxe sur ce montant j'imagine? le montant en euro, pour le 20%?
Si oui, 173 + 20% sa donne 34.60 a additionner, pour un grand totale de 207.60 euro toujours.
le taux de change sur internet présentement est de 1.3876, alors 207.60 euro donne 288.08 Can.
Manque les frais de dédouanement. la dernière fois que j'ai payé ses frais avec une commande, je croie, ma couté 20 Dollars Can, pour une commande en provenance des USA, mais sa fait une couple d'année déjà.
Alors elle me couterais dans les environ de 310 a 330 dollars, contre 340 a 350 je croie que j'avais dit.
Dépendamment de l'erreur de calcule a cause des frais de douane qui est incertaine, j'économise de 10 a 40 dollars. Si j'ai tout faux, corrige moi stp ok :)

Tien, je fait le même manège avec cnc4pc. Alors le prix afficher est de 251.46 Can + 32.28 de postage usps = 283.74. la taxe le plus élever aux usa est de 11.5%
Par ce que le taux de taxe est différent pour beaucoup d'état. alors 283.74 + 11.5% donne 32.63 a additionner, pour un totale de 316.37 dollars Can.
Même chose pour les frais de douane je mes mettre 20 dollar. Alors finalement sa revient aux même prix si j'ai bien calculer.
Au mieux, une différence de 10 dollars a cause de la taxe US que je sait pas.

Dans mon email ce matin ses Paypal qui me réclame 173 euro, je me questionne a savoir. on t'il le pouvoir de m'obliger a payé ce montant???
Première fois que ça m'arrive une tel situation!
 
dh42

dh42

Compagnon
le prix c'est 149€ HT + 27% de TVA hongroise, soit 189.23€ TTC + le port ...SI tu l'achète chez CNCdrive, si tu l'achète aux USA, je suppose que ce sera la TVA US.

++
David
 
dh42

dh42

Compagnon
Dans mon email ce matin ses Paypal qui me réclame 173 euro, je me questionne a savoir. on t'il le pouvoir de m'obliger a payé ce montant???

aucune idée, mais ça veux certainement dire que tu a effectivement commandé quelque chose non ?

je peux t'aider pour la technique, mais le business, ce n'est pas mon rayon :wink:

++
David
 
DakotaSport07

DakotaSport07

Apprenti
Salut! encore moi!

Bon! après presque qu'un chiffre de nuit, finalement j'ai pas réinitialiser mon pc.
Par contre, a l'aide de la recherche Windows, j'ai supprimer TOUT ce qui ce rattachais de proche et de loin a Mach3, qui étais situé sur le disque dur.
Cette procédure enlèvent tout ce qui s'y rattache. Alors il faut penser de sauvegarder ce que l'on veux garder.

J'ai réinstaller Mach3, la version que ma fourni le vendeur de ma machine qui est la R3.041. Première fois que je l'installe.
Pour cette fois j'ai penser différemment.
A la place de choisir moi même tout ce que je croie être le mieux et a date, je me suis dit, qu'il serais peut être mieux de prendre ce qui ma été fournie a l'achat de ma machine.
Et vue que mon pc date de 14 ans "déjà" :shock: , et que ce n'est plus une bombe comparativement a celui de mon bureau, je me suis dit, raison de plus pour prendre ce qui ma été fournie. (Prendre Les chose de mon temps.) Bin, pas trop loin en arrière quand même, par ce que sa existais probablement pas encore.

Une fois l'installation fait, J'ai redémarrer et tout le tralala. Reconfigurer le tout manuellement, ( fait tellement de fois que je le fait que je la connait par cœur.)
Démarré ma machine et voir comment sa ce passe.

Coté axes, comme d'habitude tout vas bien, toute mes contacts aussi, référencement #1, broche rien a dire, la pompe de liquide de refroidissement démarre comme avant, la pompe de liquide de coupe répond a la demande. Le tout, fonctionne comme avant. Rien a dire de négatif sur cette version de Mach3.
J'ai tester un fichier que j'ai conçu sur Fusion360, ( un bras de suspension arrière pour mon RC) et tout va bien de ce côté la aussi. Impeccables. toute les étape d'usinage fonctionne comme il ce doit.

Une fois tout ça fait, j'ai vérifier qu'est-ce qui a comme scripts dans les boutons de palpage. Bien, absolument rien. Seul le message que tout le monde doit connaître! "No implémented" quel que chose comme ça.

Alors j'ai commencer par l'installation des scripts de ma manivelle sans fil XHC.
Une fois terminer je teste pour voir, et la aussi tout fonctionne #1.

Alors, J'ai fait comme j'avais déjà fait, j'ai pris la script de palpage de ma manivelle M930, et je les copier dans le fichier du bouton "tool zero" ou "zero tool" je sait plus, je les renommé hier pour "changement outil" Cette manipulation était seulement pour un test de script dans cette version de Mach. Et elle fonctionne exactement comme sur ma manivelle, ses comme logique ses un script, alors ses du pareil au même.
PS: et sa bog pas. Comme je remarque a l'instant, les scripts de ma manivelle fourni par XHC on toujours bien fonctionné. Bien y en a pas des tonnes avec ma manivelle il en a trois. Une pour le palpage simple pour trouver le zéro pièces, une pour "ALL Home" référencer, et une pour "ALL Work" Le 0,0,0 pièces.

Et dans mon décorticage de CD chinois, j'ai trouver une surprise étonnante! un fichier .ZIP nommé script. Je te dit! J'ai faillit tomber en bas de ma chaise.
Je l'avait probablement vue et ouvert il y a 2ans voir plus, mais j' y connaissais absolument rien dans ce temps la. Alors comme je me connait, si sa me dit rien je passe tout droit, et j'ai oublié avec le temps ce qui avait sur ses CD.

Alors, après ouverture de cette surprise, j'y découvre en autre ( ce qui ma le plus intéresser) 4 script de palpage pour le X+, X-, Y+ et Y-.
Et oui, 4 script de palpage... et devine quoi! elle fonctionne parfaitement. Je les est découvertes sur le CD OEM de ma machine.
Je te dit, j'en revient pas encore!
Et il y a plus, deux script pour trouver le centre de l'intérieur et une autre pour l'extérieur d'un tube ou quel que chose comme ça.
J'ai tester, mais elle ne fonctionne pas correctement. Après palpage des deux faces, les axes parte en zéro machine.

Bon, je vais arrêter la. Reste a profité de cette surprise! :)

A+
_______________________________________________________________________________________________

Je saute peut être trop vite sur une conclusion! mais tout ce brouhahas pour dire que, les script sur YT, fonctionne pas vraiment. Pas pour ma machine en tout cas. Je pence que les carte chinoise n'on peut être pas la capacité de lire des script trop compliquer.
Par ce que ses pas les script les plus simple que l'on trouve sur YT.

Et les 4 script que j'ai installer, ses pas ce que j'aurais voulue avoir, par ce que ses un peux plus de manipulation avec les axes pour un repositionnement, mais si sa marche, je vais prendre ça. Mieux ça qui marche que qu'une formule 1 qui marche pas.
 
Dernière édition:
DakotaSport07

DakotaSport07

Apprenti
tu a effectivement commandé quelque chose non ?
On dirais bien!
j'ai hésiter a cliquer, mais je voulais savoir combien elle couterais incluent le transport.
C'est pas comme je suis habituer de voir et de faire. Les boutiques en générale on peut connaitre les frais de postage en remplissent tes coordonné, adresse et tout, et juste avant de passer a la caisse tu sait combien vas te couté ton transport que ta choisi.
Exactement comme j'ai fait avec cnc4PC.
Mai eux, sa marche pas pareil. Je trouve pas ça correct leur manière de faire mes bon...

J'ai envoyer toute mes excuse par email a CNC drive, je lui est expliquer ce que je vient de dire,
en ajoutant que, présentement je magasine seulement. et un gros MERCI pour votre compréhension.
Reste a voir comment il va prendre ça.

A+ :wink:
 
P

pascalp

Compagnon
Pour les quelques boutiques où j'ai acheté et où les frais de ports étaient communiqués ultérieurement, la commande était validée uniquement si ceux-ci étaient acceptés de manière formelle.
 
Algone

Algone

Compagnon
Salut DakotaSport07, j'ai moi aussi eu récemment des soucis de scripts notamment le palpage d'outil en Z avec Mach3 et ma carte controleuse USB chinoise, alors que ça fait 4 ans que ça fonctionnait sans soucis, du jour au lendemain quand je lance le script, il essai de palper en A, alors que j'ai que 3 axes. J'ai pas encore pu chercher d'où ça vient, si j'ai une piste je t'en ferai part.
 
DakotaSport07

DakotaSport07

Apprenti
Salut DakotaSport07, j'ai moi aussi eu récemment des soucis de scripts notamment le palpage d'outil en Z avec Mach3 et ma carte controleuse USB chinoise, alors que ça fait 4 ans que ça fonctionnait sans soucis, du jour au lendemain quand je lance le script, il essai de palper en A, alors que j'ai que 3 axes. J'ai pas encore pu chercher d'où ça vient, si j'ai une piste je t'en ferai part.
Salut!
Juste pour dire comme ça, Si sa fonctionnais avant, d'après moi c'est pas une question de Script. Ses presque certain que c'est autre chose.
Un Script qui change de comportement, me semble donc que sa devrais pas exister.
Et tu peut me croire quand je dit que je connait ça des Script qui change de comportement.

Moi Je vois pratiquement une seul possibilité, (vu que ça la fonctionner 4 ans sans problème), je dirais que la faute vient de la carte de commande.
Mais j'ai pas de boule de cristal moi non plus hihihi :)

Me concernant, j'ai remarquer que ce sont seulement les Script télécharger sur YT qui fonctionne mal. Les Script OEM de ma carte de commande et ma MPG on toujours bien fonctionner, mais il m'en manquais pour sonder en X / Y. Mais j'ai trouver.

Et en ce qui concerne un Script de changement d'outil, je suis incapable d'en trouver un qui fonctionne avec ce que j'ai, et/ou ses moi qui sait pas comment faire pour que sa fonctionne correctement. Et la, j'avoues avoir atteint mes capacité pour installer un Script de changement d'outil.

Je vient dans apprendre dernièrement sur la complexité d'un tel Script, et je suis vraiment dans l'incapacité dans écrire un. C'est Vraiment complexe a écrire.

A+, et bonne continuation!
 
Dernière édition:
DakotaSport07

DakotaSport07

Apprenti
Salut TLM!

Hier j'ai acheter le "screenset 2010" comme dh42 m'avais déjà proposé.
Bien, avant d'acheter j'ai été voir de quoi il avait l'air, et j'ai découvert que ce "screenset" est bilingue, un GROS + pour moi, qu'il fonctionne sur un seul écran principale, a première vue de ce coté, sa me semble un négatif, mais bon, mais le plus "hot" ses qu'il inclus, tout les Script de palpage que j'ai besoin.
Et dans la même foulée, j'ai commander l' AXBB-E.
Maintenant, avec tout ça, j'ai beaucoup de lecture a faire, et du travail prévu coté armoire.

A oui, sa peut servir pour ceux qui ne savent pas! j'ai appris que les câble internet ne sont pas tous pareil. A par les cottes de vitesse (Cat 5 etc.) il y a deux type différent de câble, qui concerne la position des fils brancher sur les prise J45. Le type linéaire et le type croisé. L'AXBB-E a besoin d'un câble de type croisé.
Comme indiquer dans le manuel (crossover cable) Sa semble pas le câble internet normal, et j'ai trouver sur Amazon. Voici le lien pour ceux que sa intéresse.

Histoire a suivre.
 
S

schum22

Ouvrier
Salut,

Non l'AXBBE-E n'a pas besoin de câble croisé, que se soit en mode via un routeur ou directement sur un PC (j'ai testé les 2 configurations).

  • Soit tu as un réseau "complet" avec un serveur DHCP notamment, et du coup ton PC et la carte prennent un adresse IP et peuvent communiquer (par exemple 192.168.1.20 et 192.168.1.21).
  • Soit tu n'as que ton PC et ta carte de connecté et il faut que ton PC soit en IP fixe en 10.10.10.10 et la carte prend par défaut si pas de DHCP l'IP 10.10.10.11 .

Voir la doc
It also must be noted here that if the LAN network card or the router where the AXBB-E is connected to supports MDI/MDIX auto cross functionality then it does not matter if the cable used is a Patch cable or a Crossover cable, because the MDI/MDIX function will detect the cable type.

PS : depuis déjà 20 ans la majorité des équipements savent tous seul se passer des câbles croisés.

Seb
 
DakotaSport07

DakotaSport07

Apprenti
Salut,

Non l'AXBBE-E n'a pas besoin de câble croisé, que se soit en mode via un routeur ou directement sur un PC (j'ai testé les 2 configurations).

  • Soit tu as un réseau "complet" avec un serveur DHCP notamment, et du coup ton PC et la carte prennent un adresse IP et peuvent communiquer (par exemple 192.168.1.20 et 192.168.1.21).
  • Soit tu n'as que ton PC et ta carte de connecté et il faut que ton PC soit en IP fixe en 10.10.10.10 et la carte prend par défaut si pas de DHCP l'IP 10.10.10.11 .

Voir la doc


PS : depuis déjà 20 ans la majorité des équipements savent tous seul se passer des câbles croisés.

Seb
Salut!
Alors ils on mis c'est instruction carrément pour rien dans leur manuel si sa date de 20 ans, et que maintenant ses inutile de soulever la question?
Qui aujourd'hui vas utiliser un PC de plus de 20Ans? Même moi j'ai plus mon PC qui fonctionnais sous Windows "Millénum edition" et je suis très conservateur.
anyway...

Tes en train de me dire que Je me suis cassé la tête pour rien pour comprendre tout sa et me trouvé un câble croisé?

Alors j'ai des questions:
1: Le câble croisé que je vient de me commander va tu faire pareil?
2: est-ce obligatoire d'avoir dans mon PC une carte internet brancher sur un port PCI? Si pas obliger, pourquoi le spécifier? et que va être la différence?
(Il est écrit), "L'ordinateur de contrôle doit avoir au moins une connexion LAN, de "préférence" une carte réseau LAN connectée au port PCI, PCI-e ou PCMCIA du PC." NOTE: Mon PC n'a pas de carte LAN connecté sur un port PCI/PCIe, il est sur la carte mère. ET je pensais a en mettre une. Est que la aussi je me
casse la tête pour rien, ou je doit en mettre une?
3: ET si le port LAN sur ma carte Mère convient, comment savoir que mon PC possède la technologie MDI/MDIX? par Test erreur? année de construction? ou on peut le voir a quel que par dans le PC?

PS: Je vais brancher ma carte AXBB directement a mon PC.

Merci si tu peut m'informer de tout ça.

A+

En passent! t'est satisfait de la carte de commande AXBB?
Est tu capable de me dire a l'avance si cette carte va être capable de comprendre tout les Scripts de palpage contenue dans le screenset 2010?
A ton avis, est-ce que je remplace ma carte de commande XHC pour rien?
Par ce que je le fait en raison qu'il mes impossible de trouver des Script qui fonctionne. Et personnellement je crois plus, que le problème vient des Script que de ma carte de commande.

Excuse moi pour ce déluge de question. :|
 
Dernière édition:
S

schum22

Ouvrier
En passent! t'est satisfait de la carte de commande AXBB?
Est tu capable de me dire a l'avance si cette carte va être capable de comprendre tout les Scripts de palpage contenue dans le screenset 2010?
A ton avis, est-ce que je remplace ma carte de commande XHC pour rien?
Par ce que je le fait en raison qu'il mes impossible de trouver des Script qui fonctionne. Et personnellement je crois plus, que le problème vient des Script que de ma carte de commande.
Salut,

Pour l'instant je débute aussi donc je n'ai pas encore de vrai retour d'expérience.

Et pour tes scripts ne je suis pas cabale de répondre.

Seb
 
S

schum22

Ouvrier
Alors j'ai des questions:
1: Le câble croisé que je vient de me commander va tu faire pareil?
2: est-ce obligatoire d'avoir dans mon PC une carte internet brancher sur un port PCI? Si pas obliger, pourquoi le spécifier? et que va être la différence?
(Il est écrit), "L'ordinateur de contrôle doit avoir au moins une connexion LAN, de "préférence" une carte réseau LAN connectée au port PCI, PCI-e ou PCMCIA du PC." NOTE: Mon PC n'a pas de carte LAN connecté sur un port PCI/PCIe, il est sur la carte mère. ET je pensais a en mettre une. Est que la aussi je me
casse la tête pour rien, ou je doit en mettre une?
3: ET si le port LAN sur ma carte Mère convient, comment savoir que mon PC possède la technologie MDI/MDIX? par Test erreur? année de construction? ou on peut le voir a quel que par dans le PC?

PS: Je vais brancher ma carte AXBB directement a mon PC.
Oublie ton câble croisé ça ne sert pas idem pour le MDI/MIDX (c'est la même chose mais coté de ton switch)

Et oui ton PC ethernet intégré est parfait pour ça.
 
DakotaSport07

DakotaSport07

Apprenti
Oublie ton câble croisé ça ne sert pas idem pour le MDI/MIDX (c'est la même chose mais coté de ton switch)

Et oui ton PC ethernet intégré est parfait pour ça.
Merci beaucoup! Content d'apprendre que j'ai pas besoin d'ajouté une carte LAN.
A+
 

Sujets similaires

D
Réponses
0
Affichages
516
diabolomix
D
S
Réponses
5
Affichages
276
schum22
S
J
Réponses
0
Affichages
535
jmlwood
J
DakotaSport07
Réponses
54
Affichages
1 695
dh42
S
Réponses
13
Affichages
546
Snoopile
S
S
Réponses
3
Affichages
278
Stef1305
S
M.Dufilet
Réponses
10
Affichages
687
M.Dufilet
M.Dufilet
Haut