Macro (script) qui change de comportement ???

  • Auteur de la discussion DakotaSport07
  • Date de début
DakotaSport07

DakotaSport07

Apprenti
Bonjour tlm !

Pourquoi une script de palpage change de comportement?
Pourquoi une journée cette script fonctionne très bien et le lendemain elle écrase ma sonde 3D sur mon étaux ??? :(

PS: heureusement elle n'est pas détruite. La script avais une limite en Z négatif. Sans cela, elle serais probablement plate comme une crêpe...
Je doit remplacer la tige (évidement elle a plier) et l'intérieur c'est enfoncer sans rien casé. la carte électronique étant supporter par un support de plastique qui lui est supporter dans son boitier par des petite pattes très très courte, qui on permis un décrochage, et sans doute "dans mon cas" sauvé la carte.
Après un remontage, je les rebrancher et elle semble fonctionner normalement.
Mai j'ai absolument besoin d'une script fiable.

Merci si vous avez des réponses, par ce que la, je pence que je vais abandonner Mach3.
J'ai trop de difficulté avec les macro (script) je suis en train de tout brisé a cause des macro qui change toujours de comportement. Peut importe la script que j'essais, sa fonctionne jamais bien ou pas du tout.

Si vous avez des suggestion pour faire fonctionner une fraiseuse (autre qu'un autre programme qui doit fonctionner avec des script) dite toujours.
Hier soir j'ai commencer a regarder pour un control hors ligne, mais je doit approfondir la chose si je vais être capable ou pas de me servir de ça.

OU! Quel qu'un a t'il une script de palpage en X,Y,Z qui fonctionne toujours, a vendre ?
Finalement je suis pas capable d'en écrire. Vraiment trop compliquer pour moi :(

Merci encore beaucoup beaucoup beaucoup pour votre aide. :wink:

20220321_102211[1].jpg
 
dh42

dh42

Compagnon
Salut,

Tu utilise quelle version de Mach3 ? ; la dernière (3.043.066) est connue pour avoir des problèmes de fonctionnement avec les scripts ; il faut utiliser la 3.043.062 pour éviter les problèmes

Autre question, tu utilise quoi comme carte d'axe ? ... Avec certaines cartes, il faut modifier le script de palpage d'origine car il utilise des fonctions qui ne sont pas gérées correctement avec certaines cartes ? (si tu peux mettre ton script de palpage, histoire de voir ce qu'il y a dedans)

++
David
 
DakotaSport07

DakotaSport07

Apprenti
Salut,

Tu utilise quelle version de Mach3 ? ; la dernière (3.043.066) est connue pour avoir des problèmes de fonctionnement avec les scripts ; il faut utiliser la 3.043.062 pour éviter les problèmes

Autre question, tu utilise quoi comme carte d'axe ? ... Avec certaines cartes, il faut modifier le script de palpage d'origine car il utilise des fonctions qui ne sont pas gérées correctement avec certaines cartes ? (si tu peux mettre ton script de palpage, histoire de voir ce qu'il y a dedans)

++
David
Bonjour David!
Et que je suis content de te voir :smt055

J'utilise la version anglais .062 "comme tu me la suggéré a mes début" télécharger sur (Newfangled Machsupport.com) avec le jeux d'écran de Jazial en français de la version .066. Don j'ai modifier l'apparence des boutons de la fenêtre palper ( pour une question esthétique).

La carte est de marque XHC, model MK4-V_USB.

Et voici le script que j'ai pris sur YouTube et que j'ai adapter pour mes besoins. "Comme expliquer dans la vidéo". ( Entre autre; Réglage de l'épaisseur de la plaque tactile a 0mm et réglage des paroi aussi a 0mm, vue que je n'utilise pas de plaque tactile, mais une sonde automatique qui détecte les contacts par l'entremise du mécanisme électronique interne, pas besoin de distance ou d'épaisseur, ces direct sur le brut. ( Et quand sa fonctionne bien, sa marche super bien ! :)

Info supplémentaire rapport aux script de palpage en générale, mais surtout celle-ci en particulier est; quand elle fait le palpage en X et en Y, elle ne se déplace pas juste dans ses axes, elle peut "AUSSI a l'occasion" faire bouger d'autre axes, et évidement il ne faut pas, et ce problème et aléatoire. Comme écraser la sonde sur mon étau, plutôt que de remonté juste après le palpage en Z.

Et Voici le lien YT pour les vidéos: https://www.youtube.com/playlist?list=PL_Hv2En5db7iDNX_Zlf1wSJflD7Vn1tgJ

Merci beaucoup David!

20220321_120226[1].jpg
 

Fichiers joints

  • Script de palpage xyz.txt
    4.2 KB · Affichages: 24
Dernière édition:
dh42

dh42

Compagnon
Salut,

Donc c'est OK pour la version de Mach3

Dans le script, il n'y a pas les instructions non reconnues par les cartes Chinoises, donc ça aussi en principe c'est bon.

Note qu'avec une carte d'axe, le G31 (palpage) n'est plus géré par Mach3 mais par la carte elle-même. Sur MB il y a un gars qui à pleins de problèmes bizarres avec cette carte, en particulier des pertes de coordonnées G5x sur son Z (son Z = 0 "perdu" alors qu'il viens de le faire), ce qui se traduit par pas mal de "rentre dedans", ainsi que des blocages moteurs intempestifs. On a cherché un moment ce qui pouvait produire ces bizarreries en soupçonnant ... l'utilisateur ... qui était un débutant, mais à l'évidence il n'y est pour rien, les soupçons se sont aussi portés sur le Gcode produit par fusion360 qui nécéssite une machine parfaitement référencée, mais la aussi ça s'est avéré une fausse piste. Il semble que la carte "perde" ses références de temps en temps, de manière aléatoire....

Pour ma part, avec la .062, je n'ai jamais eu le moindre problème avec le palpage (en Z uniquement, jamais utilisé le palpage en XY), que ce soit en port // direct (donc G31 géré par Mach3) ou avec mon ESS.

Le sujet en question.

++
David
 
DakotaSport07

DakotaSport07

Apprenti
Salut,

Donc c'est OK pour la version de Mach3

Dans le script, il n'y a pas les instructions non reconnues par les cartes Chinoises, donc ça aussi en principe c'est bon.

Note qu'avec une carte d'axe, le G31 (palpage) n'est plus géré par Mach3 mais par la carte elle-même. Sur MB il y a un gars qui à pleins de problèmes bizarres avec cette carte, en particulier des pertes de coordonnées G5x sur son Z (son Z = 0 "perdu" alors qu'il viens de le faire), ce qui se traduit par pas mal de "rentre dedans", ainsi que des blocages moteurs intempestifs. On a cherché un moment ce qui pouvait produire ces bizarreries en soupçonnant ... l'utilisateur ... qui était un débutant, mais à l'évidence il n'y est pour rien, les soupçons se sont aussi portés sur le Gcode produit par fusion360 qui nécéssite une machine parfaitement référencée, mais la aussi ça s'est avéré une fausse piste. Il semble que la carte "perde" ses références de temps en temps, de manière aléatoire....

Pour ma part, avec la .062, je n'ai jamais eu le moindre problème avec le palpage (en Z uniquement, jamais utilisé le palpage en XY), que ce soit en port // direct (donc G31 géré par Mach3) ou avec mon ESS.

Le sujet en question.

++
David
Je vient de terminer de lire le post que tu a mis ! Ayoye hein.
J'ai pas autant de problème. Les problèmes qui décrit, moi je les est seulement quand j'utilise les script de palpage. A par sa, j'ai pas eu de trouble d'usinage. Bien, a venir a date en tout cas...

A tu une idée David du pourquoi que j'ai des difficulté avec cette script si elle te semble correct?
Pourquoi la script de changement d'outil fonctionne correctement et pas celle du palpage en xyz?
Sa peut tu que la script du gars sur youtube soit conçu seulement pour un model de carte en particulier? La sienne?
Et toi, est tu capable de m'en écrire une script pour ma carte si ses le cas que chaque carte a besoin d'une script adapté?
Ou bien je doit remplacer la carte pour une de meilleur qualité, connue et testé? Ou je revient au même, une carte sans script?
Tu fonctionne avec quel model de carte toi? Ou, que me recommanderais tu?

Bon bin, je vais voir ce que tu vas me dire avec toute mes question. :)

A+ Mon ami !
 
dh42

dh42

Compagnon
A tu une idée David du pourquoi que j'ai des difficulté avec cette script si elle te semble correct?
Non, aucune, en principe s'il y a un bug dans le programme, ça merde à chaque fois, pas par intermittence.

Pourquoi la script de changement d'outil fonctionne correctement et pas celle du palpage en xyz?
Peut être bien parce qu'il n'utilise pas le G31 ?

Sa peut tu que la script du gars sur youtube soit conçu seulement pour un model de carte en particulier? La sienne?
Non, à part l'instruction qui ne marche pas avec les cartes Chinoises (qui n'est pas utilisée ici), il n'y a pas de "spécificité", ça devrait fonctionner sur toutes les cartes.

Et toi, est tu capable de m'en écrire une script pour ma carte si ses le cas que chaque carte a besoin d'une script adapté?
Non, je ne suis plus chez moi et je n'ai plus la CN à dispo, donc impossible de tester (et en plus je n'ai pas de palpeur 3D)

Ou bien je doit remplacer la carte pour une de meilleur qualité, connue et testé? Ou je revient au même, une carte sans script?
Tu fonctionne avec quel model de carte toi? Ou, que me recommanderais tu?
Je ne peux pas avoir de certitude, je soupçonne la carte, mais ça reste une supposition. Les pannes aléatoires c'est généralement compliqué à trouver, surtout à distance :mad:

Pour ma part j'ai un Ethernet SmoothStepper (ESS) + BoB Benezan, mais ce n'est pas donné ! (250€ pour l'ESS + 100€ pour la BoB)

Dans les cartes tout en un comme la tienne, il y a l'AXBB-E de CNC drive qui à l'air pas mal, mais c'est dans les 200€ TTC (et c'est de l'Ethernet, ce qui ne gâche rien !)

++
David
 
DakotaSport07

DakotaSport07

Apprenti
en principe s'il y a un bug dans le programme, ça merde à chaque fois, pas par intermittence.
Oui c'est logique. Mon installation peut tu être en cause?
J'ai vue dans plusieurs vidéo que les gars qui construise leur armoire on toujours des câble isolé avec un blindage en aluminium dans le câble, et de tous rattacher ce blindage a l'armoire en métal.

Moi j'ai aucun câble blindé et une armoire en bois.
Je me suis reconstruit une armoire complète de la même manière que l'originale, sans câble blindé et j'ai toujours eu des problème aléatoire. (Mais seulement en utilisant les macro de palpage.) Ces pour cela que j'ai mis cette possibilité de problème de coté. En plus, j'ai un cousin qui travail dans l'électronique et il ma aidé beaucoup a brancher un relais sur mon ancienne carte, et il avais besoin d'info sur la carte en question, et j'ai appris grâce a lui, ce que veut dire avoir des port d'entré et de sortie son "Optoisolé". il ma expliquer que cette conception protège la carte contre les parasites électrique, par ce que les composantes qui gères les signaux ne ce touche pas directement, Autrement le courent passe pas directement dans ses composantes. Alors je me suis dit, raison de plus pour ne pas capoté sur les parasite. Mais qui sait, ses peut être la le problème. T'en pense quoi ?
 
DakotaSport07

DakotaSport07

Apprenti
je soupçonne la carte, mais ça reste une supposition
Je crois que ses le plus probable. Mais j'ai vraiment peur d'avoir le même problème avec une autre carte. C'est pour cela que je pense a allez en "OFF LIGNE" Mais encore la, si sa prend des scripts, je suis encore dans la misère. ( Je déteste les Script )
 
DakotaSport07

DakotaSport07

Apprenti
j'ai un Ethernet SmoothStepper (ESS) + BoB Benezan
Je savait pas que j'avait un deux en un ! Je croyais que c'était toute pareille les carte de commande cnc.

La j'ai commencer a éplucher les specs de l'AXBB-E. Pour l'instant, elle est dans un panier d'achat dans une boutique aux USA. CNC4PC. J'ai passer proche de cliquer sur commande, mais j'ai repenser a ma crainte, " ET SI" j'ai le même problème avec cette carte.
Alors j'ai rebrousser chemin. je vais tenter dans savoir plus sur cette carte avant. Je doit traduire en français d'abord si je veut comprendre quel que chose.
Savoir ce qu'on sait pas. avec les deux model chinois que j'ai acheter, sa revient a dire que j'aurais cette carte a la place. Mais bon, qui est fait est fait.

Elle revient a 350$ 360$ environ, incluent les taxes le taux de change ( OUPS) y a pas de taux de change, j'ai garder en mémoire en us, mais en fait, il on l'option en dollar Canadien. les frais de transaction et le transport par la poste US.
Avoir la certitude que sa règlerais le problème de script de palpage, je la commanderais tout de suite pendant que je le peut. :)

En tout cas, pour toute suite je vais regarder une couple de vidéo YT. y doit surement en exister. elle a sortie en 2019. et la dernière mise a jours date aussi de 2019, alors elle fonctionne surement bien. :)

Bon bin, A + David, et encore Merci!
 
Dernière édition:
D

dyson

Compagnon
Y a déjà un problème dans ton script, c'est les temps d'attente : sleep(1) c'est un un temps d'attente de 1 milliseconde... autant dire que ça n'a strictement aucun effet. Il faut mettre sleep(1000) et voir si tu as toujours les mêmes problèmes.
 
dh42

dh42

Compagnon
Pour le temps d'attente sleep(1), oui j'avais vu, mais à l'endroit ou il est ça ne pose pas de probleme (dans la boucle While IsMoving) ; ça fonctionne même sans le sleep, ça sert juste à ne pas complètement bloquer Windows lorsque ça tourne en boucle. Ceux qui sont importants ce sont ceux qui sont après la mise à jour de la DRO (sleep(250)) .... tu peux toujours essayer de les passer à 500 pour voir si ça améliore les choses.

pour l'achat de l'AXBB-E, je te conseille de la prendre directement chez CNCdrive, ça te coutera moins cher (les frais de port depuis les USA sont conséquents) ... chez CNCdrive, c'est 149€ + 27% de TVA + 20€ de frais de port > ce qui fait le tout à ~210€

++
David
 
DakotaSport07

DakotaSport07

Apprenti
Y a déjà un problème dans ton script, c'est les temps d'attente : sleep(1) c'est un un temps d'attente de 1 milliseconde... autant dire que ça n'a strictement aucun effet. Il faut mettre sleep(1000) et voir si tu as toujours les mêmes problèmes.
Salut! Oui, je l'avait vue aussi ce (sleep 1). Je me suis interroger quand j'ai appris que c'étais des milliseconde, me suis demander pourquoi il a mis un temps d'un milliseconde, je me suis dit la même chose que toi ( sa sert tu a quel chose vraiment) :smt017 Je vais essayé en le mettent a 1000, je crois que j'ai déjà tenter le coup avec un (sleep 250) mais je suis pas sur, alors on vas tenter le coup avec 1000 des fois. Comme on dit, sa coute rien d'essayer :) Et merci dyson !
 
dh42

dh42

Compagnon
Je vais essayé en le mettent a 1000

Non, surtout pas, sinon ça va être pire car Mach3 attendra 1s entre chaque boucle(*) ; en principe tu peux même le supprimer. C'est celui à 250 que tu peux essayer d'augmenter.

* la boucle While Ismoving - wend sert à attendre que les axes arrêtent de bouger avant de passer à la suite. Si tu le met à 1000, ça ne testera qu'une fois par seconde.

++
David
 
DakotaSport07

DakotaSport07

Apprenti
je te conseille de la prendre directement chez CNCdrive, ça te coutera moins cher
Oui mais, CNC drive doit être situer en Europe si le prix est en euro? Par ce que moi je demeure aux Québec! Je vais vérifier quand même des fois, mais je doute que je vais payer moins cher, que de commander au USA.
 
dh42

dh42

Compagnon
Oui mais, CNC drive doit être situer en Europe si le prix est en euro? Par ce que moi je demeure aux Québec! Je vais vérifier quand même des fois, mais je doute que je vais payer moins cher, que de commander au USA.

Ah OK, je ne savais pas ...

Oui, CNCdrive est en Europe de l'Est, je ne me rappelle plus dans quel pays (Hongrie peut être)

++
David
 
DakotaSport07

DakotaSport07

Apprenti
Non, surtout pas, sinon ça va être pire car Mach3 attendra 1s entre chaque boucle(*) ; en principe tu peux même le supprimer. C'est celui à 250 que tu peux essayer d'augmenter.

* la boucle While Ismoving - wend sert à attendre que les axes arrêtent de bouger avant de passer à la suite. Si tu le met à 1000, ça ne testera qu'une fois par seconde.

++
David
Ok dacord! je vais faire cela alors, Merci encore :)
 
DakotaSport07

DakotaSport07

Apprenti
Ah OK, je ne savais pas ...

Oui, CNCdrive est en Europe de l'Est, je ne me rappelle plus dans quel pays (Hongrie peut être)

++
David
Pas problème David! :wink:

La, je suis en train de traduire en Français le guide de l'utilisateur de l'AXBB-E.
Et ce matin, j'ai envoyer un message aux vendeur de chez cnc4pc pour savoir si les script son inclus avec l'achat de leur logiciel UCCNC pour la fonction "sonde".
Dans une vidéo que j'ai vue hier soir sur YT. un gars montre toute les étapes d'installation, programmation du logiciel UCCNC, et une chose est certaine, ses que cette carte et leur logiciel est capable de contrôlé DEUX sonde, de trois type différent.
Vue que j'écoute en sous titre les vidéo YT (pour avoir le Français), le gars donne les trois différent type de sonde. Et, la traduction en sous titre dit, qu'elle contrôle les sonde de "touche", les sonde "volante", et les sonde "fixe".
J'en conclus que la sonde de touche est la sonde Z zéro pour trouver le zéro pièces,
la sonde volante serais probablement une sonde 3D, que j'ai.
et la sonde fixe serais comme les nôtres. Je croie que la, on peut pas trop se trompé. Une sonde fixé sur la table pour les changement d'outil.
Hâte qui me réponde a ce sujet. :)
 
Dernière édition:
dh42

dh42

Compagnon
Sur UCCNC il y a plein de fonctions de palpages déjà programmées, il semble plus avancé que Mach3 ... et il a l'avantage d'être toujours développé et bien moins cher.

Sans titre-1.jpg


Sans titre-2.jpg


Sans titre-3.jpg


et ce qui ne gâche rien, il peut lire le fichier de config Mach3 directement. (réglages moteurs, E/S, etc)

++
David
 
DakotaSport07

DakotaSport07

Apprenti
Sur UCCNC il y a plein de fonctions de palpages déjà programmées, il semble plus avancé que Mach3 ... et il a l'avantage d'être toujours développé et bien moins cher.

Voir la pièce jointe 766446

Voir la pièce jointe 766447

Voir la pièce jointe 766448

et ce qui ne gâche rien, il peut lire le fichier de config Mach3 directement. (réglages moteurs, E/S, etc)

++
David
Salut!

Oui, En plein ça. Je trouve aussi a première vue qu'il a l'air très bien leur logiciel. En le voyant, je me suis toute suit dit, "on dirais une version de Mach3"
Et oui ta entièrement raison pour lire le fichier config de Mach3, j'ai écouté ce matin une autre vidéo, et ce gars le démontre dans sa vidéo comment faire.
Je commence a trouver ça très très intéressant tout sa.

En même temps, je vient de recevoir un message de cnc4pc.
Il ma écrit, (Les scrips de sonde ne sont pas vraiment associés à la sonde ou à AXBB, mais au logiciel de contrôle que vous utilisez.
Que prévoyez-vous d’utiliser ? Il existe plusieurs scrips et sorciers.

Je lui est répondu,
J'utilise Mach3.fr et aucun script pour faire fonctionner une sonde 3D.

Avez-vous des Script 3D pour Mach3?

Votre logiciel UCCNC a t'il les scripts fournis?

Je vient de remarquer que tes photos sont des capture d'écran?
Ta télécharger une version démo?
Je vient de voir en haut qui est écrit "running in demo mode"!
_________________________________________________________________________

(y a plein de fonctions de palpages déjà programmées.)
Bin oui, je vient de voir sa WOW!
Et ses sur que sa control les sonde 3D. (MOBILE PROBE)
Et en plus, je vient tout juste de recevoir une confirmation a cette question du gars de la vidéo YT.
"Oui, vous pouvez utiliser un système de sonde 3D". veuillez vous référer au manuel à la page 45, 46 (lien manuel en bas) il est préférable de télécharger le logiciel et de le tester. vous pouvez utiliser le logiciel en mode démo. faites attention aux séances de 10 min Lien : logiciel et manuel https://cncdrive.com/UCCNC.html
 
Dernière édition:
dh42

dh42

Compagnon
Oui, En plein ça. Je trouve aussi a première vue qu'il a l'air très bien leur logiciel. En le voyant, je me suis toute suit dit, "on dirais une version de Mach3"

Oui, le programmeur s'est bien inspiré de Mach3, il y a pas mal de réglages qui ont le même nom.

Il dispose aussi d'une fonction de numérisation (digitize) qui doit probablement s'utiliser avec un palpeur 3D (et qui semble gérer le Ø de la boule du palpeur) et il y a aussi la gestion des couteaux rotatifs motorisés (découpe vinyle)

Le soft (et les cartes) gèrent aussi le M10/M11 pour le laser, la THC pour les découpeurs plasma, le rattrapage de jeu des vis, le taraudage rigide...

Je vient de remarquer que tes photos sont des capture d'écran?
Ta télécharger une version démo?

Oui, pour explorer un peu et pour aider un gars à configurer sa machine ; bien sûr je ne peux pas le tester "en vrai" vu qu'il ne fonctionne qu'avec les cartes CNCdrive.

Pour un soft à 55€ il semble très complet, le seul truc qui manque encore, comparé à Mach3, c'est la gestion du tournage. Il me semble qu'il y a des offres carte + soft.

J'utilise Mach3.fr et aucun script pour faire fonctionner une sonde 3D.

Oui, sur le Mach3 officiel (FR ou non), il n'y a que le palpage en Z, sinon il n'est pas impossible qu'il y ai des fonctions plus avancées sur le "Screenset 2010", par contre je crois qu'il est payant.

En principe, il est également possible de créer ses propres écrans et ses propres scripts avec UCCNC aussi, mais je n'ai pas exploré cette piste.

L'avantage si tu prends une carte CNCdrive, c'est que tu peux la faire fonctionner aussi bien avec Mach3 qu'avec UCCNC.

++
David
 
Dernière édition:
P

pascalp

Compagnon
Pour "moderniser" mon contrôleur port // en usb et pouvoir continuer à utiliser Mach3, j'ai acheté l'adaptateur UC100usb. Il est compatible Mach3-4 et UCCNC, à l'occasion je pourrais jeter un coup d’œil à UCCNC mais jusqu'à présent pour ma modeste utilisation Mach3 convient.
 
DakotaSport07

DakotaSport07

Apprenti
Il dispose aussi d'une fonction de numérisation (digitize)
a, c cool sa! ses quel que chose d'intéressant, ses comme faire un copie/collé j'imagine. (Comme dirais les DuPont & DuPont dans Tintin!)
Je dirais même plus, TRÈS intéressant! hihihi
____________________________________________________________________

le Ø de la boule du palpeur peut être indiquer dans Mach3fr, je les fait!
_____________________________________________________________________

(il y a aussi la gestion des couteaux rotatifs motorisés)
Oui, je sais plus ou j'ai vue, mais ses ce que je me disais qui avait aussi cette option.
______________________________________________________________________

(il ne fonctionne qu'avec les cartes CNCdrive)
Je pensais justement a le télécharger pour l'essayer avec ma machine. :(
_______________________________________________________________________

(est la gestion du tournage)
Pour l'instant moi j'ai pas besoin, mais ils vont peut être l'avoir plus tard.
Et peut être qu'il l'ont dans un "Package" séparément. Ils vende tout séparer dans leur boutique.
________________________________________________________________________

(L'avantage si tu prends une carte CNCdrive, c'est que tu peux la faire fonctionner aussi bien avec Mach3 qu'avec UCCNC.)
Oui, en plein ça. J'ai vue sa aussi.
Mais les scripts que j'ai pour Mach3 von t'elle fonctionner? avec une AXBB! la est la question.
Et personnellement je doute qu'elle fonctionne. et Si oui, je vais vraiment être surpris! Mais en même temps, je vais savoir qu'est-ce qui fonctionnais pas :wink:

Si le vendeur me dit que les script sont dans leur logiciel UCCNC, je vais prendre ça, même si il est en anglais. Mach3 a pas de script OEM pour mes besoin, et pas une seul que j'ai tenter fonctionne, alors il faut que je trouve quelque chose plug and play, pas le choix, je sais pas comment en créer. et pour comprendre tout les boutons, je vais finir par les comprendre. j'en connait pas mal des terme en anglais maintenant, je me débrouillerais pour le reste. Et il a ici :wink:
 
DakotaSport07

DakotaSport07

Apprenti
Pour "moderniser" mon contrôleur port // en usb et pouvoir continuer à utiliser Mach3, j'ai acheté l'adaptateur UC100usb. Il est compatible Mach3-4 et UCCNC, à l'occasion je pourrais jeter un coup d’œil à UCCNC mais jusqu'à présent pour ma modeste utilisation Mach3 convient.
Salut!
Tu vient de faire penser a quel que chose! mais dit moi avant si je comprend bien stp.
Non, sa me donne rien finalement, sa fonctionnera pas plus mon affaire.

Désolé, Je sait plus quoi penser pour que tout ce que j'ai fonctionne #1 :(
 
DakotaSport07

DakotaSport07

Apprenti
Salut!
Bon! je vient de modifier quel que peu ma macro, et devine quoi! Je suis cramper en deux hahahahaha
imagine toi quel par en sens inverse. elle palpe en Z+ hahahahaha J'ai vraiment un bog a quel que par :smt017
et J'ai seulement retirer la ligne (sleep 1) et augmenter les (sleep 250) a 500.

C'est incompréhensible, c'est pas logique pas une seconde, sa devrais même pas paraitre a l'œil ses changement.

J'ai vue sur une vidéo, d'un gars, qui écrit ses macro (script) en G-code, ses faisable ou ses une vidéo pour fourré le monde?
 
Dernière édition:
dh42

dh42

Compagnon
a, c cool sa! ses quel que chose d'intéressant, ses comme faire un copie/collé j'imagine. (Comme dirais les DuPont & DuPont dans Tintin!)
Je dirais même plus, TRÈS intéressant! hihihi

c'est comme ce que j'avais bidouillé avec Mach3, c'est pour scanner des objets 3D avec le palpeur.


Si le vendeur me dit que les script sont dans leur logiciel UCCNC

Oui, les scripts de palpage font parti du soft, ils sont associés aux 3 écrans que j'ai mis en capture, en principe tu ne devrais rien avoir à bidouiller.

++
David
 
dh42

dh42

Compagnon
Salut!
Bon! je vient de modifier quel que peu ma macro, et devine quoi! Je suis cramper en deux hahahahaha
imagine toi quel par en sens inverse. elle palpe en Z+ hahahahaha J'ai vraiment un bog a quel que par :smt017
et J'ai seulement retirer la ligne (sleep 1) et augmenter les (sleep 250) a 500.

C'est incompréhensible, c'est pas logique pas une seconde, sa devrais même pas paraitre a l'œil ses changement.

J'ai vue sur une vidéo, d'un gars, qui écrit ses macro (script) en G-code, ses faisable ou ses une vidéo pour fourré le monde?

c'est bizarre ? ... d'un autre coté ça peut très bien être lié à une perte de coordonnées Z car le G31 ne palpe pas forcément vers le bas, il va jusqu'à la position absolue qui lui est donnée. par exemple un G31 Z-20 ira à la position -20, donc si le Z se trouvait à -40, il palpera en montant jusqu'à -20 ....

tu a essayé d'autre macros de palpage XY, il me semble qu'il y avait un screenset de swiss-stef (ou quelque chose comme ça) sur le forum avec des macros de palpage intégrées.

il ne faut pas oublier que souvent les macros sont dépendantes d'un screenset, si tu utilise une macro faite pour un screenset sur un autre, ça peut très bien ne pas fonctionner car la macro peut faire référence à des DRO utilisateur qui n'existent pas forcément sur le screenset en question.

++
David
 

Sujets similaires

D
Réponses
0
Affichages
516
diabolomix
D
S
Réponses
5
Affichages
276
schum22
S
J
Réponses
0
Affichages
535
jmlwood
J
DakotaSport07
Réponses
54
Affichages
1 695
dh42
S
Réponses
13
Affichages
546
Snoopile
S
S
Réponses
3
Affichages
278
Stef1305
S
M.Dufilet
Réponses
10
Affichages
687
M.Dufilet
M.Dufilet
Haut