Advertisements

Résolu Instabilité de la vitesse de la broche

  • Auteur de la discussion Christian67
  • Date de début
C
Christian67
Ouvrier
13 Mai 2012
264
Kogenheim
  • Auteur de la discussion
  • #1
J'ai un soucis de vitesse de la broche. Le pilotage de démarrage et arrêt, ainsi que la vitesse, se font via la Bob.
Pour le démarrage et l'arrêt, aucun soucis.
Pour la vitesse, ça se complique. Par exemple, lorsque je met 10000 en vitesse de consigne, la vitesse de la broche oscille grosso modo entre 9000 et 13000. Cette oscillation est présente quelle que soit la vitesse de consigne.
Pour ce pilotage, j'ai configuré la sortie 9 en "Borne Pas" sur la ligne "Broche" de l'onglet "Sorties moteurs" de la fenêtre "Ports et E/S".
Le signal va vers un convertisseur fréquence/tension qui me délivre une sortie 0/10v.
Cette tension est appliquée sur l'entrée 0/10v du variateur (AskPower série A131).
Dans la fenêtre "Configuration de la broche", j'ai mis 5 dans "Freq du PWM", et 0 dans "Rapport cyclique mini".
Quel paramètre n'est pas bon ?

Pour info : sous LinuxCNC, je n'avais pas ce problème de variation. La vitesse réelle était légèrement différente de la consigne, mais stable (à 100t/mn près), et le montage était tout à fait identique.

Merci d'avance pour votre aide.

Christian.
 
Advertisements
dh42
dh42
Compagnon
4 Septembre 2009
5 315
Près de St Etienne (42)
Salut,

j'ai mis 5 dans "Freq du PWM", et 0 dans "Rapport cyclique mini".
C'est certainement dépendant des caractéristiques de la carte 0-10v (ou de la BoB si c'est intégré)

Sur la doc de la mienne, ils disent que les instabilités de vitesse peuvent être dues à une fréquence trop basse pour le PWM. Ils conseillent un mini de 45 hz (BoB Benezan advanced pro)

Rapport cyclique mini à 0 devrait te permettre de faire descendre la broche à 0 RPM ; si tu le mettais à 10% par exemple, la broche s’arrêterait à 10% de la V maxi, soit 2400 RPM. (en théorie, ça permet de se passer du relais M/A)

++
David
 
C
Christian67
Ouvrier
13 Mai 2012
264
Kogenheim
  • Auteur de la discussion
  • #3
Parfait ! J'ai mis 50 en fréquence PWM, et ça ne varie plus.
J'ai également mis 10% en rapport cyclique mini, n'étant jamais descendu sous 3000 t/mn.
Merci beaucoup !

Christian.
 
dh42
dh42
Compagnon
4 Septembre 2009
5 315
Près de St Etienne (42)
en ce moment il y aune épidémie de PWM en cours de réglage (sur MB) ... et c'est pas toujours la joie apparemment !

cool si ça marche :wink:

++
David
 
La dernière réponse à ce sujet date de plus de 6 mois
Advertisements
Haut