Branchement et parametrage palpeur

  • Auteur de la discussion Jerome68270
  • Date de début
J

Jerome68270

Nouveau
Salut à tous,

J'essaye de connecter un palpeur à ma CN, mais il y a quelque chose que je ne comprend pas.
Soit mon câblage est mauvais, soit les paramètres sont mauvais, ou les deux.
J'aurai besoin de vos lumières s'il vous plaît.

J'utilise Druffel CNC comme logiciel de pilotage et ce n'est pas moi qui ai monté la CN.
Le gars qui a monté la CN a prévu un emplacement pour un palpeur, voir photo 1.
Donc un fil su 0V et 1 fil sur IN1.
J'ai soudé les fils sur la prise jack en fonction de ce que j'ai trouvé sur le net, voir photo 2.
J'ai donc soudé la masse, et j'ai soudé "signal droite" et "signal gauche" ensemble pensant que ça n'ai aucun incidence pour ce raccordement.
On a alors la masse qui va sur 0V et "signal droit" + "signal gauche" sur IN1.

Avec ce raccordement:
- lorsque je débranche la prise jack sur l'emplacement prévu: "input port signal" en "active" et Druffel n'active pas la fonction du palpeur. (photo 3)
- lorsque je branche la prise jack sur l'emplacement prévu: "input port diagnostic" en "low" et Druffel active la fonction du palpeur mais ne s'arrête pas au contact de la fraise sur le palpeur. (j'ai bien mit la pince croco sur la fraise) (photo 4)

Autre précision, lorsque le jack est branché, j'active la fonction plapeur, j'ai ma broche qui descend. Pendant que ma broche descend, je débranche la prise jack et là j'ai ma broche qui remonte et lorsque je rebranche le jack, il y a un contact qui se fait et donc la fonction palpeur est effective et ma broche descend de 5mm comme prévu (elle descend, parce qu'elle "palpe" en remontant)

Si vous avez les précieuses informations qui me permettent de faire fonctionner le palpeur, ce serait parfait!

Merci beaucoup

Photo 1.jpg


photo 2.jpg


Photo 3.jpg


Photo 4.jpg
 
dh42

dh42

Compagnon
Salut,

(j'ai bien mit la pince croco sur la fraise) (photo 4)

Je ne connais pas ton soft, mais visiblement il détecte bien quelque chose ...

Vu que tu parle d'une pince sur la fraise, je suppose que ce n'est pas un palpeur à switch mais un ou c'est la fraise qui sert de contact comme ci-dessous ?

attention, les couleurs sont trompeuses, la pince rouge doit se connecter sur le 0V de ton jack et le bloc sur INxx ; la pince sert à amener la masse sur la fraise, au cas ou elle n'y serait pas déjà (la carcasse de la machine est à la masse, donc la fraise aussi normalement ... sauf si tu a des roulements céramique)

Si ça fonctionne "à l'envers", c.a.d. que la LED dans la colonne "Value Now" est "active" quand il n'y a pas de contact entre la fraise et le bloc noir et "Low" quand il y a contact, tu dois pouvoir inverser le sens en cochant "No" dans la colonne "Invert" dans la ligne du probe. (enfin, je suppose que ça sert à ça ; ça doit être l'équivalent du "Active Low" dans Mach3)

mach3-cnc-z-axis-router-mill-zero-check-touch-plat.jpg


++
David
 

Sujets similaires

thierry74
Réponses
19
Affichages
1 319
Darback
D
V
Réponses
0
Affichages
141
Vic44
V
R
Réponses
20
Affichages
767
Hubert86
H
laurent du beausset
Réponses
6
Affichages
536
laurent du beausset
laurent du beausset
S
Réponses
93
Affichages
5 481
Begineur
B
L
Réponses
7
Affichages
1 843
françois44
françois44
Haut