Saccades en profilage 3D - CamBam - Mach3 - Aide SVP

  • Auteur de la discussion Citad
  • Date de début
C
Citad
Nouveau
13 Mar 2013
5
  • Auteur de la discussion
  • #1
Bonjour,

Mon problème est que je perds un temps fou sur mes usinages 3D de finition en mode ''Horizontal" et "Vertical".

Lorsque je crée mes fichiers Gcode grâce à CamBam, ce dernier ne crée pas de courbes dans le plan de mouvement de la fraise (XZ en "Horizontal" et YZ en "Vertical"), au lieu de ça il crée des tracés en lignes brisées, et ça occasionne une saccade terrible dans le mouvement de la fraise lors de l'usingae, je perds à peu près 50% de la vitesse d'avance programmée, et à cause des mouvements très brusques je perd également en précision.

Pour m'expliquer, voilà deux chemins d'outil, un en "Lignes de niveau - finition" ou on peut très bien voir les courbes créées (en vert) et l'autre en "Horizontal" ou il n'y a aucune courbe (que du bleu).

"Lignes de niveau - finition"

[div=left]
[/div]

"Horizontal"




Voilà j'espère que je suis assez clair :D

Je recherche tout type de solution, que ce soit un réglage dans CamBam pour pouvoir générer des courbes sur les plans XZ et YZ, ou une manipulation à faire sous Mach 3 pour éviter que la machine fasse une saccade entre chaque segment de chemin, ou n'importe quoi d'autre.

Si ça vous est utile que je filme la machine en action pour mieux comprendre les ''saccades'' je peux le faire sur demande :)

Pour gagner du temps je peux vous dire ce que j'ai déjà essayé :

"Plan de travail" sous CamBam, ça ne change strictement rien dans les faits.
"Mode de déplacement" sous CamBam, ça ne change rien non plus.
Vérifier le "Backlash" sous Mach 3, il est désactivé.

Je travail sous Shark Fx pour la 3D, j'exporte en STL pour CamBam (en 3DS c'est pareil).

Ma machine est une fraiseuse 6040 de chez CNC-Shop.

Voilà, je crois que tout est dit.

J'espère que vous pourrez m'aider :D

Merci d'avance pour vos réponses

Luca
 
domi.U&M
domi.U&M
Compagnon
25 Août 2011
2 105
région bordelaise
bonjour,

mach3 ne doit pas optimiser les trajectoires dictées par gcode. ( sinon vous ne seriez pas content le jour où il vous lisserait des facettes nécessaires, du genre facettes d'un écrou).

il n'y a donc que le générateur de gcode qui peut optimiser (donc, cambam si j'ai bien compris).

un spécialiste de cambam (je ne le suis pas) pourra certainement vous dire si c'est possible et si oui, comment faire. :wink:
 
C
Citad
Nouveau
13 Mar 2013
5
  • Auteur de la discussion
  • #3
Merci pour cette information, je ne parlais pas exactement d'un lissage ou d'une création de courbes sous Mach 3 mais plutôt d'une fonction pour "forcer" une vitesse constante. Mais je présume que si la vitesse n'es pas constante, c'est qu'elle ne peut pas l'être, faute de s'éloigner du tracé.

J'attends donc de voir si un expert de CamBam pourra m'aider :D
 
dh42
dh42
Compagnon
4 Sept 2009
5 824
Près de St Etienne (42)
Salut,

Je pense que tu a simplement oublier de régler "mode de déplacement" sur "vitesse constante" dans ton opération d'usinage 3D.(dans Cambam)
tu dois trouver un G64 vers le début du programme dans ton Gcode.

Si le problème persiste malgré le fait que tu soit en vitesse constante, vérifie (sous Mach3) que tu n'a pas activé le rattrapage de jeu logiciel, ça peut aussi faire des bizarreries.

Cambam ne génère jamais d'arcs sur les plans XZ et YZ, uniquement en XY.

++
David
 
C
Citad
Nouveau
13 Mar 2013
5
  • Auteur de la discussion
  • #6
Ah ! Super, j'essaie ça demain. Quant au mode de déplacement et au rattrapage de jeu, j'avais déjà écarté ces options.

En espérant que ça fonctionne,
Merci beaucoup !
 
C
Citad
Nouveau
13 Mar 2013
5
  • Auteur de la discussion
  • #7
Je viens de vérifier et de constater avec déception que les deux réglages cv dist tolerence et cv feedrate étaient déjà désactivés.

L'ordinateur est un celeron cadencé à 2.8Ghz et a 1.25Go de mémoire vive, mes fichiers 3D sont très fins et j'utilise une vitesse d'avance de 3000mm/m les saccades peuvent venir de ça ?
 
dh42
dh42
Compagnon
4 Sept 2009
5 824
Près de St Etienne (42)
Salut,

Oui, c'est possible, 3000 mm/min ça commence à être rapide pour une 6040 il me semble.

Il se peut aussi que ton fichier soit "trop détaillé", ce qui crée des lignes de quelques centièmes de mm de long.

Tu peux jouer sur cette précision et donc par la même occasion sur la longueur des traits produits (ainsi que la longueur du Gcode et le temps de calcul des parcours) en modifiant le paramètre "résolution" de ton opération 3D. Note "résolution" est exprimé en fraction du Ø de l'outil utilisé ; par ex une résolution de 0.01 avec une fraise de 3 donnera un "relevé de hauteur" de l'objet 3D tous les 0.01 x 3 = 3/100ime de mm.

Il m'est arrivé une fois de faire de la 3D à 2500/3000 mm/min, et je n'ai pas eu ce genre de saccades, mais la BZT est censée supporter des vitesses plus élevées que la 6040 ... si je me fie à la doc ..

++
David
 
J
jeramenemafraise
Ouvrier
6 Jan 2013
274
bonsoir a tous,
Oui des déplacements travail a 3 metres par minute ,ca commence a faire vite, et la mecanique n'aime pas trop .
les inerties pas bon ...

je sais que les cnc pro les rapides c'est de l'ordre des 10 metres ( G00) mais la mecanique s'use vite .

yves
 
J
jeramenemafraise
Ouvrier
6 Jan 2013
274
les grandes avances peuvent provoquer des " OVERSHOOT" comme disent les anglais.

yves
 
C
Citad
Nouveau
13 Mar 2013
5
  • Auteur de la discussion
  • #11
Très bien je vais remédier à ça, je vais commencer par générer des fichiers 3D moins détaillés, je verrai avec la résolution ensuite si ça ne change toujours rien, et si tout ça ne suffit pas, je baisserai la vitesse d'avance.

En tout cas un grand merci à tous pour vos réponses et conseils avisés.
 
Haut