Rétrofit électronique imprimante

  • Auteur de la discussion tronix
  • Date de début
T
tronix
Compagnon
Suite des aventures du rétrofit, je ne peux m'en occuper que le soir. Après m'être encore un peu battu avec les paramètres, j'ai un fonctionnement qui se rapproche de ce que je veux. Je suis quand-même un peu déçu de la façon dont ces paramètres sont gérés, et de façon plus générale par l'ergonomie, sans savoir si c'est propre à la version BigTreeTech, il faudra que je compare plus tard avec l'originale. En mode afficheur classique, c'est vite laborieux, et en mode graphique, on perd beaucoup de possibilités, il faut jongler avec les deux modes. J'ai l'habitude de faire des cartes avec serveur web pour tout ce qui est paramétrage, là, c'est le retour en arrière ! J'ai aussi quelques fonctionnements un peu curieux. Par exemple, avec un fichier de test de quelques lignes de GCode, le soft me dit qu'un code M140 est incorrect, alors qu'il n'y a rien de tel dans le fichier. Il faut aussi que je cherche une "sécurité" qui bloque de façon intempestive l'impression, visiblement au démarrage du ventilateur d'extrudeur et si la température est fixée à 210°C. La chute de température à ce moment doit dépasser des limites trop justes et tout s'arrête sur 2 messages d'erreur, et bien sûr c'est le premier qui ne reste que quelques secondes qui indique la cause réelle (thermal runaway ou un truc du genre). L'imprimante s'arrête alors, buzzer coincé à fond, il faut tout redémarrer pour l'arrêter. C'est quoi ce soft ?? A 200°C, la chute est un peu plus faible (logique) et ça passe. Plus quelques autres petits défauts de fonctionnement un peu crispants. Je ne sais pas ce que valent les autres softs, mais pour un truc qui existe depuis déjà quelques années, c'est un peu décevant, même si c'est du libre.
Sinon, côté bruit, la différence est toujours aussi nette, c'est bien plus silencieux !
 
Dernière édition:
T
tronix
Compagnon
Hier soir j'ai corrigé facilement le problème d'arrêt intempestif : le fichier config_adv.h révèle que l'impression s'arrête si l'erreur de température est supérieure à 4°C pendant plus de 40s. Passé à 120s et 8°C et plus de problème, la chute réelle va jusqu'à 11°C, et pour 8°C un temps de 60s suffirait.
Il faudra que je vérifie que le courant dans les moteurs est bien celui programmé (même fichier), avant de changer tous les connecteurs et de tester sur des impressions un peu plus longues. Je saurai alors si mes problèmes sont résolus ou si j'ai "perdu" mon temps.
 
T
tronix
Compagnon
Bonsoir,
premier retour suite au retrofit, encore dans un état "bricolage" avec la carte sur le côté et les connexions toujours avec des adaptateurs. Pas de mesure automatique du plateau, et encore moins de fin de filament. Mais cela fonctionne ! Avec le plateau bien réglé, cela suffit.
J'imprime plus vite qu'avant (déplacements), et avec des couches de 0.3mm (je n'y avais jamais pensé), ce qui fait que mes pièces ne demandent maintenant plus que de 8 à 24 heures. Et sur une centaine d'heures d'impression, je n'ai eu aucun problème de décalage. Je ne sais donc pas d'où venait le problème initial, soft, hard ou courant trop faible (conf fabricant), mais je pense sincèrement que la machine manquait de fiabilité à l'origine.
En impression 3D, il y a énormément de causes possibles de défauts de fonctionnement, et cela ne tolère pas trop le bricolage et l'à-peu-près. Beaucoup de machines du commerce ne fonctionnent pas parfaitement. Malgré l'apparente simplicité, se lancer dans la fabrication de sa propre machine peut réserver beaucoup de mauvaise surprises.
 

Sujets similaires

Y
Réponses
8
Affichages
634
Francis.
Francis.
SuperSpinach
Réponses
9
Affichages
522
SuperSpinach
SuperSpinach
Woz
Réponses
35
Affichages
1 897
Korgar
Korgar
R
Réponses
11
Affichages
513
-R-M-Y-
R
Haut