Problème gravure CNC 3018 pro sur LaserGRBL

A
AntoineDgt
Nouveau
9 Fev 2021
5
  • Auteur de la discussion
  • #1
Bonjour à tous et toutes,

Je me permets de vous solliciter car je n’ai pas trouvé de réponse précise à mon problème malgrés plusieurs recherches. 
Je suis encore novice dans l’usage de ma cnc 3018pro et je viens de me lancer dans la gravure laser 7.5W (sur lasergrbl). 


J’ai d’ailleurs suivi ces 2 tutos pour tout bien paramétrer : 
https://www.youtube.com/watch?v=YnFNFEdmPjU&t=1017s

https://www.youtube.com/watch?v=pCmazk-yTVo&t=1358s

Tout s’est bien passé pour ce qui est des fichiers de test .nc afin de régler la focale, vitesse et puissance du laser … MAIS ^^
 dès que je suis passé sur un fichier image, les ennuis ont commencés. A un certain moment de la gravure, le moteur de l’axe x se bloque ? Ou en tout cas se met à forcer dans le vide (alors que l’axe est normalement très fluide et graissé) puis redémarre en décalant la gravure. 

Ce que je ne comprend pas, c’est que tout se passe bien avec les fichiers de test en gcode mais dès que je passe sur une gravure image (même convertie en gcode), ça foire à un moment. Pour ce qui est d'une simple découpe ça à l'air d'aller bizarrement.

Merci beaucoup d’avance pour vos conseils !

voila ma config sur grbl ->
$0=10 (Step pulse time)
$1=25 (Step idle delay)
$2=0 (Step pulse invert)
$3=2 (Step direction invert)
$4=0 (Invert step enable pin)
$5=0 (Invert limit pins)
$6=0 (Invert probe pin)
$10=1 (Status report options)
$11=0.010 (Junction deviation)
$12=0.002 (Arc tolerance)
$13=0 (Report in inches)
$20=0 (Soft limits enable)
$21=0 (Hard limits enable)
$22=0 (Homing cycle enable)
$23=0 (Homing direction invert)
$24=25.000 (Homing locate feed rate)
$25=500.000 (Homing search seek rate)
$26=250 (Homing switch debounce delay)
$27=1.000 (Homing switch pull-off distance)
$30=1000 (Maximum spindle speed)
$31=0 (Minimum spindle speed)
$32=1 (Laser-mode enable)
$100=800.000 (X-axis travel resolution)
$101=800.000 (Y-axis travel resolution)
$102=800.000 (Z-axis travel resolution)
$110=1000.000 (X-axis maximum rate)
$111=1000.000 (Y-axis maximum rate)
$112=600.000 (Z-axis maximum rate)
$120=5000.000 (X-axis acceleration)
$121=5000.000 (Y-axis acceleration)
$122=5000.000 (Z-axis acceleration)
$130=200.000 (X-axis maximum travel)
$131=200.000 (Y-axis maximum travel)
$132=200.000 (Z-axis maximum travel)



IMG_3037.JPG


grbl_settings1.PNG


grbl_settings5.PNG


grbl_settings3.PNG


grbl_settings4.PNG


grbl_settings2.PNG


grbl_settings6.PNG
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 326
Corsier-sur-Vevey (Vaud)
Bonjour Antoine

Mets le fichier de G-code qui cause ce problème, en pièce jointe.

Cordialement
jpbbricole
 
A
AntoineDgt
Nouveau
9 Fev 2021
5
  • Auteur de la discussion
  • #4
merci pour votre réponse, désolé je n'avais pas moyen de mettre le fichier en pièce jointe donc j'ai directement collé le code ! Mais en soit le problème n'est pas spécifique à ce fichier, cela se produit dès que je tente une gravure à partir d'une image. Je me suis demandé si ça pouvait être une question de vitesse ou non ?
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 326
Corsier-sur-Vevey (Vaud)
Bonjour Antoine

$110=1000.000 (X-axis maximum rate)
Il semblerai que l'axe X "sature" lors des déplacements rapides (G0), j'essayerai de diminuer le paramètre $110 à 800 pour voire.

$110=800

Cordialement
jpbbricole
 
Dernière édition:
D
DavidH
Apprenti
15 Mai 2017
143
78
" A un certain moment de la gravure, le moteur de l’axe x se bloque ? Ou en tout cas se met à forcer dans le vide (alors que l’axe est normalement très fluide et graissé) puis redémarre en décalant la gravure. "

Salut, ce que tu décris semble correspondre à le décrochage du moteur, essayais de diminuer la vitesse maximal (sur l axe x)

David
 
D
DavidH
Apprenti
15 Mai 2017
143
78
Edit: je n'ai pas vu le message de jpbbricole - je dis la même chose que lui - je pense qu'il a fait juste un "typo" en écrivant "axe Z" au lieux de X.
 
A
AntoineDgt
Nouveau
9 Fev 2021
5
  • Auteur de la discussion
  • #9
Merci beaucoup messieurs pour vos réponses et veuillez m'excuser par ailleurs du délai de la mienne !
Il semblerait que le problème vienne en effet de la, bien joué !!
La seule chose maintenant est que la gravure me parait bien plus énervée (ça brûle pas mal, niveaux de gris pas top et ça laisse un dépôt noir sur contreplaqué de 3) maintenant que la vitesse est ralentit, malgré le fait de baisser la puissance du laser. J'imagine qu'en bidouillant un peu avec la hauteur sur l'axe Z je devrait arriver à un résultat satisfaisant au cours de mes tests.
 
S
speedjf37
Compagnon
15 Oct 2009
2 475
indre et loire


Ce que je ne comprend pas, c’est que tout se passe bien avec les fichiers de test en gcode mais dès que je passe sur une gravure image (même convertie en gcode), ça foire à un moment.
Bonjour,

En mode Gcode les vitesses sont gérée par tracé.
En mode Image il y un balayage de la zone à graver.

Il faut régler la vitesse max dans GRBL avant décrochement du moteur (-20%).
Il faut peut être aussi régler le courant des drivers moteurs pour avoir le max sans rendre les moteurs trop chaud (pouvoir mettre la main dessus sans se bruler).

Cordialement JF
 
A
AntoineDgt
Nouveau
9 Fev 2021
5
  • Auteur de la discussion
  • #11
Salut JF et merci pour la précision,
pour GRBL c'est ce qui a été fait grâce à JPB et David, par contre pour les drivers moteurs, j'avoue que je ne vois pas trop comment régler ça ^^
(je vérifierais mais je ne crois pas qu'ils chauffent à ce point lorsque la cnc tourne)
 
Haut