MACH3 VFD Vitesse

  • Auteur de la discussion Pickyinter
  • Date de début
P

Pickyinter

Nouveau
Bonjour à tous, décidemment Mach3 me complique la vie, je viens de me rendre compte que quelque soit la commande SNNNN M3 la vitesse de ma broche est 24 000 rpm soit le maxi. le problème dans un G CODE la commande SNNNN M3 semble être ignorée malgré que l'afficheur de Spindle speed indique la bonne vitesse mais en réalité la broche tourne à 24 000 rpm.
Je suis capable de modifier la vitesse à partir de la control box mais du fait que je n'arrive pas à la sauvegarder lorsque je relance F5 la vitesse est de 24 000 rpm.
 
dh42

dh42

Compagnon
Salut,

Si c'est un variateur intégré dans le controleur comme sur l'image, il se peut qu'il y ai un inter en façade pour sélectionner: commande via le soft ou via le clavier du vario.

71Os-+uW2wL._AC_SX425_.jpg


Je ne connais pas ces modèles, mais sur la plupart des vario tu peux avoir la commande vitesse via le vario ou via le soft, mais pas les 2 en même temps, donc si ta commande de vitesse fonctionne depuis le clavier du vario c'est qu'elle n'est pas paramétrée pour un pilotage via le soft ... il faudrait mettre une photo de ton controleur, si quelqu'un à le même il pourra t'en dire plus que moi.

Sur les vario séparés, c'est un paramétrage dans le vario pour sélectionner le pilotage via le soft ou le vario

++
David
 
Squal112

Squal112

Ouvrier
Bonjour à tous, décidemment Mach3 me complique la vie, je viens de me rendre compte que quelque soit la commande SNNNN M3 la vitesse de ma broche est 24 000 rpm soit le maxi. le problème dans un G CODE la commande SNNNN M3 semble être ignorée malgré que l'afficheur de Spindle speed indique la bonne vitesse mais en réalité la broche tourne à 24 000 rpm.
Je suis capable de modifier la vitesse à partir de la control box mais du fait que je n'arrive pas à la sauvegarder lorsque je relance F5 la vitesse est de 24 000 rpm.
Quelle est la machine, la carte de contrôle Mach3, le driver ou VFD du moteur de broche ?
On manque d'informations précises pour pouvoir t'aider.

Quel type de pilotage accepte le variateur ou le driver de broche, 0-10V ? Signal PWM ? bus de terrain (RS-485, Modbus) ?

Comment as-tu paramétrer Mach3 pour le pilotage de la broche ?
 
dh42

dh42

Compagnon
Sebos38

Sebos38

Ouvrier
Salut,

Si c'est un variateur intégré dans le controleur comme sur l'image, il se peut qu'il y ai un inter en façade pour sélectionner: commande via le soft ou via le clavier du vario.

Voir la pièce jointe 757129

Je ne connais pas ces modèles, mais sur la plupart des vario tu peux avoir la commande vitesse via le vario ou via le soft, mais pas les 2 en même temps, donc si ta commande de vitesse fonctionne depuis le clavier du vario c'est qu'elle n'est pas paramétrée pour un pilotage via le soft ... il faudrait mettre une photo de ton controleur, si quelqu'un à le même il pourra t'en dire plus que moi.

Sur les vario séparés, c'est un paramétrage dans le vario pour sélectionner le pilotage via le soft ou le vario

++
David
Bonsoir , je suis d'accord avec David , il doit y a voir un paramètre à régler au variateur de fréquence , pour choisir entre le clavier ou l'entrée analogique 0-10 V ,
as tu la notice du variateur ? c'est surement un vario standard du commerce avec un clavier de commande déporté .
 
Sebos38

Sebos38

Ouvrier
jettes un œil à ceci , ca parle de ce que tu cherches
il y a un rapport avec mode local ou remote ,
il faudrait que la led "local" soit éteinte , si toutefois il y a bien un voyant "local" sur ton panneau de controle

 
Sebos38

Sebos38

Ouvrier
voir pdf , est ce que ton vario ressemble à ca ?
si oui , voir page 29
cordialement
sebastien
 

Fichiers joints

  • NOWFOREVER MANUAL E-100.pdf
    630.2 KB · Affichages: 41
P

Pickyinter

Nouveau
Bonsoir, merci pour vos réponses ci joint la photo du contrôleur, je n'ai aucune info sur son mode de fonctionnement habituellement j'active simplement les interrupteurs rouge et vert mais lorsque j'ai cherché à réduire la vitesse pour pinoler j'ai toucher au panneau à gauche et peut être la j'ai pris la main sur mach3.

BOITIER VARIO 3.jpeg
 
Sebos38

Sebos38

Ouvrier
Peut être,
Dans ce cas ce serait bien que tu trouves une doc sur ce variateur,
Bonne soirée
 
P

Pickyinter

Nouveau
Bonjour, Oui je vais me rapprocher des chinois après les fêtes du nouvel an toutefois ta doc parait assez proche il faut effectivement que j'arrive à éteindre la led "Local" mais je n'arrive pas à entrer une valeur dans P0 00.
 
P

Pickyinter

Nouveau
Bonjour,
Je reviens vers vous j'ai enfin trouvé le manuel de VFD MK100-2S2-2G-DK , je vous rappel mon problème suite à quelques manip sur le clavier du VFD j'ai perdu la connection avec Mach3 (une cde M3 S8000 ne fonctionne pas) je dois avoir mis le VFD en local d'ailleurs la led local clignote je souhaite donc revenir à un pilotage à partir de Mach3 (je n'ai pas modifié les paramètres de Mach3 cela fonctionnait auparavant)
Ci dessus les paramètres P0 du VFD (à priori je n'ai pas modifier les autres paramètres)
P00001
0010
0022
0032
0040
0050
006100
0070
008400
0090
010400
0110
012400
0130,0
0140,0
0156,0
0161
01710,0
01810,0
0191
0200
0210
0221
0230
0240
0250
0260
0270
Lien manuel MK100

Merci d'avance pour vos conseils
 
Sebos38

Sebos38

Ouvrier
salut ,
il faudrait essayer de modifier le paramètre P0-02 : le mettre à 1 et voir si, la led s'éteint .
si ca ne fait rien remets le comme avant ( à 2).
 
Sebos38

Sebos38

Ouvrier
p0-03 à 2 me parait OK , c'est l'entrée Analogique de fréquence qui est sélectionnée , AI1
sur laquelle devrait etre branchée ta carte de controle , elle envoie un signal de tension au vario
 
P

Pickyinter

Nouveau
Salut
j'ai passé P0-02 à 1 la led est allumée en continu
J'ai lancé sur Mach3 une cde S8000 M3
La broche a commencé à tourner lentement puis arrêt
sur le VFD ERR10 Fréquence convertisseur surcharge
J'ai remarqué auparavant à l'allumage du VFD la valeur 400.0 s'affichait la fréquence j'imagine maintenant 0.02 clignote et la led V est allumé
 
P

Pickyinter

Nouveau
j'ai passé P0-02 à 1 la led LOCAL est allumée en continu
 
Sebos38

Sebos38

Ouvrier
ca veut dire que quand c'est allumé tu es en remote , pas en local
1644692027771.png
 
Sebos38

Sebos38

Ouvrier
concernant le defaut ERR10 , je ne pense pas qu'il soit lié au parametre P0-02 , mais dans le doute remets le à 2 et verifies
 
P

Pickyinter

Nouveau
P0-02 à 2 la led LOCAL clignote
Sur mach3 la cde S8000 M3 la broche ne tourne pas
Pas d'erreur
 
Sebos38

Sebos38

Ouvrier
est ce que tu avais modifié ce parametre P0-01 ?
car en reglage usine c'etait 2 ( V/F control ) et pas 0 .
peut etre que ca n'a rien à voir avec le défaut , mais bon , d'habitude sur mes variateurs( quelque soit la marque , je suis en V/F , ce qui veut dire controle tension/ Fréquence )
1644692702707.png
 
Sebos38

Sebos38

Ouvrier
P00-02 à 0 , led eteinte , tu demarres bien par le panneau de controle ? ou y a til toujours le defaut ?
 
P

Pickyinter

Nouveau
P0-01 (2)
P0-02 (1)
P0-03 (2)
L a commande Mach3 SNNNN M3 fonctionne pas d'erreur, je vais contrôlé la vitesse réelle la broche mais déjà bien avançé
Merci pour ton aide
Je cherche aussi pourquoi à l'allumage du VFD 0.02 CLIGNOTE et le voyant V (volt) est allumé alors qu'auparavant j'avais 400.0 d'affiché.
 
Sebos38

Sebos38

Ouvrier
A mon avis l erreur était dû au paramètre p0-01
Pour l affichage de la fréquence au lieu de la tension , il faut que tu trouves comment allumer Hz au lieu de V, enfin je pense...
En tout cas c est bien que tu aies pu trouver la documentation, bien qu elle soit pas évidente à déchiffrer...
Bonne soirée
Sébastien
 
P

Pickyinter

Nouveau
Oui je vais regarder
encore merci et bonne soirée
Jean-Pierre
 

Sujets similaires

P
Réponses
20
Affichages
546
Pickyinter
P
O
Réponses
26
Affichages
1 620
Charly85
C
LHM
Réponses
4
Affichages
413
LHM
A
Réponses
8
Affichages
667
V
G
Réponses
3
Affichages
569
dh42
B
Réponses
19
Affichages
1 373
B
M
Réponses
4
Affichages
1 059
stef1204
stef1204
Haut