Mach3 coordonnées

  • Auteur de la discussion Ffb
  • Date de début
F

Ffb

Nouveau
Bonjour à tous,

Voilà 3 ans que j’utilise des CNC 3 axes, d’une petite prête à monter à une plus grosse et precise depuis 6 mois. J’ai un souci depuis que j’utilise mach3, je n’arrive pas à garder les coordonnées machines.
Je m’explique, au démarrage, j’arrive à mettre les axes sur zero en position « au fond, à droite et haute ». J’ai bien les 3 coordonnées machines sur zéro. Je réactive les 3 axes « home » pour le homing dans input. Je fais le homing, mes axes vont bien devant, à gauche et haute. Mes 3 axes ce mettent à zero. Cependant et c’est la le soucis, j’ai aussi les coordonnées machines que se remettent également à zero. Du coup je me retrouve avec les coordonnées machines aux mêmes endroits que les coordonnées home. Heureusement que j’enlève le gcode G28 sinon ca tape.
J’ai la doc technique de mach3 et en français, mais ça reste très légé en explication.
Quelqu’un aurait une idée du soucis ?
 
D

dh42

Compagnon
Salut

Le homing, référencement en français, c'est justement fait pour mettre les coord machine à 0 en allant chercher les contacts home ("ref" sur la VF de Mach3) qui sont en bout d'axe.

Pour le G28, sur Mach3, il n’envoie pas nécessairement au 0 machine mais aux coordonnées (machine) renseignées dans Homing/limits.

Sur cette image par exemple, mon G28 est réglé pour envoyer les axes à -1,-1,-1 en coord machine, sachant que mes contacts home sont tous en position + maxi de chaque axe (au fond, à droite et en haut), donc les coord machine, dans mon cas, vont de 0 à -xxx pour chaque axe ... donc mes axes se positionnent 1mm avant le contact home (qui est donc à 0 en coord machine) quand je fais un G28

Sans titre-1.jpg

Je fais le homing, mes axes vont bien devant, à gauche et haute.

Donc dans ton cas, le home Z est bien au + maxi de l'axe comme pour moi (pour le Z c'est incontournable) mais par contre pour X et Y tes contacts sont au - maxi de ces 2 axes si je comprend bien ?, donc elles vont de 0 pour soft min à +xxx pour soft max.

Si tu veux que ton G28 renvoi les axes 1mm avant ton contact home pour le Z, il te faudra régler ton G28 à -1 pour Z

Pour X et Y, si tu veux que la position parking soit au fond à droite, soit à l'opposé de la position des contact home, il faut mettre X et Y du G28 à une valeur positive qui correspond à la course de tes axes ; si tu as une course de 500mm en X, ton G28 en X devra être à 500 ... ou un peu moins pour ne pas taper en buté.

++
David
 
  • Réagir
Reactions: Ffb
S

Squal112

Compagnon
Bonjour à tous,

Voilà 3 ans que j’utilise des CNC 3 axes, d’une petite prête à monter à une plus grosse et precise depuis 6 mois. J’ai un souci depuis que j’utilise mach3, je n’arrive pas à garder les coordonnées machines.
Je m’explique, au démarrage, j’arrive à mettre les axes sur zero en position « au fond, à droite et haute ». J’ai bien les 3 coordonnées machines sur zéro.
Il faut déjà distinguer les coordonnées machines (G53) qui se mettent à jour lors des POM (Prise Origine Machine).
Ces dernières sont données lors du référencement des axes (avec le bouton adhoc) et ne sont pas sensé changer (sauf changement de position des contacts de référencement ou ajout d'un offset dans le menu "Motor Home/SoftLimits).

Des coordonnées pièces (G54, G55, jusqu'à G59), qui sont utilisées pour définir le zéro pièce avant de lancer un programme.

Je réactive les 3 axes « home » pour le homing dans input.
Pourquoi désactiver les axes ?
La fonction Homing/Référencer les axes sert justement à ça.

Je fais le homing, mes axes vont bien devant, à gauche et haute. Mes 3 axes ce mettent à zero. Cependant et c’est la le soucis, j’ai aussi les coordonnées machines que se remettent également à zero. Du coup je me retrouve avec les coordonnées machines aux mêmes endroits que les coordonnées home.
Lors du homing (référencement des axes), le zéro machine (G53) est situé en bas à gauche de ta table (règle de la main droite)
Selon que la machine est un portique ou une fraiseuse "classique" il faut donc paramétrer cela correctement.
Il est bien normal que tes coordonnées machine (G53) passent à 0, 0, 0 lors du référencement c'est justement fait pour ça, indiquer à la machine ou elle se trouve.

Ce que tu appelle coordonées home, c'est justement le X0, Y0, Z0 machine (G53)

Heureusement que j’enlève le gcode G28 sinon ca tape.
J’ai la doc technique de mach3 et en français, mais ça reste très légé en explication.
La commande G28 est un retour au origines machine.
Donc par défaut G53 X0 Y0 Z0, mais comme le mentionne @dh42 cette position est modifiable dans le menu qu'il t'indique.

Personnellement comme le G28 est appelé en fin de programme, sur ma machine je m'en sert pour ramener la table proche de ma porte (X250, Y250, Z0)
 
F

Ffb

Nouveau
Bonsoir,
Merci à vous pour vos réponses. Donc je dois régler comme sur le fichier joint alors.
réglage CNC.png

Pour le G28, il était déjà tout à -10 mais comme ca allait chercher à gauche et en avant, les moteurs se mettaient en secu et le compteur continuait de tourner sur l’ordi. J’avoue que les tutos m’ont induits en erreur pour le zéro coordonnées machines et qui disaient notamment de déconnecter les fins de courses. Du coup quels intérêts il y a d’aller le setting et de jouer avec « to dro » ?
Le bouton « ad hoc » c’est ou ?
settings mach3.png


Autre question : peut éloigner les axes des capteurs fin de courses après homing ?

Merci beaucoup pour vos reponses
 
S

Squal112

Compagnon
Déjà avec un screenset Mach3FR ce serait plus simple ^^
Je comprendrais jamais que des gens utilisent encore le screen Mach3 d'origine.

J'ai jamais vu/utilisé de bouton "To DRO" à la rigueur le "GOTO ZERO" qui normalemement appel juste une commande G28 (qui n'est rien de plus qu'un G0 G53 X0 Y0 tapé dans le MDI).
Quand au bouton "TO GO" je ne saurais te dire, d'ailleurs il n'existe pas dans le screenset FR.

Par contre les coordonnées machines (repère G53) sont celles correspondant au homing (POM). quand tu clique sur le bouton "REF ALL HOME", c'est uniquement lui qui sert au référencement des axes.
Le bouton "Machine Coord's" bascule seulement entre le repère machine (G53) et ton repère pièce par défaut (G54).
Le bouton "Soft Limits" quand a lui active les limites logicielles (paramétrées dans le menus Motor Home/SoftLimits)

Dans les limites (logicielles), tu devrait avoir :
X : Soft Max 1190 - Soft Min 0 ou + pour ne pas déclencher le fin de course
Y : Soft Max 2490 - Soft Min 0 ou + pour ne pas déclencher le fin de course
Z : Soft Max -188 - Soft Min 0 ou - pour ne pas déclencher le fin de course

Voila qui devrait t'aider.
G53 et G28.jpg


Autre question : peut éloigner les axes des capteurs fin de courses après homing ?
Oui, soit en appelant un G28 (après avoir reglé les coordonnées de ce dernier), soit en modifiant le script du bouton de référencement (REF ALL HOME) avec l'éditeur MachScreen par exemple.

Voila ce qu'il faut ajouter sous les RefCombination :
Sleep(100)
Code("G53 G0 X... Y...") - remplacer les [...] par la valeur du déplacement désiré.
 
F

Ffb

Nouveau
Bonjour bonjour,
Ok parfait, j’enregistre ces paramètres alors. Merci beaucoup pour vos précisions. Merci pour le decalage après homing. Concernant le ref all home, j’ai le X qui ne bouge pas et dont je dois faire seul depuis le diagnostic. Chaque fin de course est sur entrée séparée de la carte.
 
S

Squal112

Compagnon
Bonjour bonjour,
Ok parfait, j’enregistre ces paramètres alors. Merci beaucoup pour vos précisions. Merci pour le decalage après homing.
Pas de quoi :wink:

Concernant le ref all home, j’ai le X qui ne bouge pas et dont je dois faire seul depuis le diagnostic.
Il faut verifier que le X ne soit pas déjà en contact avec le capteur de référencement lors des POM, sinon c'est normal qu'il ne bouge pas.
Essaye en déplaçant la table en milieu de chaque axe avant de lancer le REF ALL HOME.

Et surtout change de Screenset pour la version FR qui en plus d'être en français, et beaucoup plus stable.

Chaque fin de course est sur entrée séparée de la carte.
Ce n'est pas un problème, beaucoup de machines sont cablées ainsi.
 
D

dh42

Compagnon
Salut,

Dans l'idéal, il faut installer la version 3.043.062 de mach3 (en anglais) qui est la plus stable et fiable, puis mettre le screenset de la version française.

La version 100% française de Mach3 est malheureusement buguée (V3.043.066) et pose pas mal de problèmes (mais curieusement, pas à tous le monde)

Il existe des tas de screenset différents, par exemple le Swiss-U qui est en français il me semble ... sinon tu peux aussi te faire ton propre screenset en fonction de tes gouts et surtout, de ce dont tu as besoin.

Quelques précisions sur le homing, les coord machine et pièce.


++
David
 
F

Ffb

Nouveau
Hello, merci encore.
Pour le homing, non même si c’est à l’opposé du capteur, fonctionne pas avec ref all home. Bizarre.
Le screenset c’est bon, mais ici nous sommes biling (SXM).
Je cherche également les bon paramètres velocity et acceleration pour le réglage moteur nema34, 12Nm, closeloop. (Photo non contractuelle). Ca fonctionne bien mais si vous avez cet info…
Bonne soirée
IMG_1057.jpeg
 

Sujets similaires

K
Réponses
12
Affichages
2 665
D
A
Réponses
3
Affichages
2 163
MegaHertz
MegaHertz
tristan12
Réponses
19
Affichages
1 756
Dardar88
Dardar88
F
Réponses
2
Affichages
856
Dardar88
Dardar88
Haut