capteur broche de tour

  • Auteur de la discussion el patenteux
  • Date de début
E
el patenteux
Compagnon
6 Août 2016
846
  • Auteur de la discussion
  • #1
Bonjour a tous.
Je veux installer un capteur pour la vitesse de broche de mon tour.
Je voudrais savoir ce qui est le plus simple a installer,je sais que certain utilise des ''hall sensor'' d'autre utilise des capteur+ 1 disque avec une fente.
Un capteur de proximité peut-il faire?
Aussi faut-il qu'il soit npn ou pnp ou peu importe?

Merci de votre aide!

Fred
 
remi30132
remi30132
Compagnon
8 Août 2016
639
nimes
le capteur a effet hall est un capteur détecte une variation champ magnétique (passage d'un aiment)
tu peux utiliser un capteur barrage qui détecte un obstacle entre l’émetteur et le récepteur IR(typiquement les cellule de portail électrique)
le capteur reflex qui indique si on lui renvoie son faisceau infra rouge (généralement via un catadioptre)
le capteur inductif qui donne une indication si il y a proximité d'un élément métallique (capteur ABS avec bague cranté)

l'ensemble de ces capteurs peuvent convenir il fait choisir celui qui est le plus facile a mettre en place.

la différence entre pnp et npn est la tension pour l’état
pnp : 0v a l’état repos et V+ a l’état actif
npn : +V a l’état repos et 0V a l’état actif
 
E
el patenteux
Compagnon
6 Août 2016
846
  • Auteur de la discussion
  • #3
Oui je me demandais ce que l'entré sur ma carte s'attend a recevoir comme signal.
Pour ce qui est de mach3 je crois qu'ont peut lui dire que le signal qu'il recoit présentement représente tel rpm......oui,non?
C'est un nouveau monde pour moi le tournage et franchement a date je trouve mach3 turn plus ou moin friendly use,
y-a-t-il quelque chose de plus simple?
Le fait de devoir toujours jongler entre la page manuelle et celle pour les programmes rend les parametrage,origines, et retouches ardues.
D'ailleur je n'ai toujours pas trouver la facon de calibrer le step/per de facon automatique comme dans mach3 mill.
 
remi30132
remi30132
Compagnon
8 Août 2016
639
nimes
Désolé mais je connais pas du tout mach3, mes compétences sont dans elec industrielle générale.
 
E
el patenteux
Compagnon
6 Août 2016
846
  • Auteur de la discussion
  • #5
Bon j'ai tester avec un capteur de proximité standard et il semble que ca ne lis pas assez rapidement
A la louche, jusqu'a 60 rpm la lumiere sur le sensor clignote mais un peu plus vite et le capteur ne lis plus rien.
Je vais probablement aller avec ce genre de capteur:


La chose que je me demmande,sur ma carte (mach3 usb) j'ai 4 input et 4 output,si je mets le signal sur le input1 alors
dans les parametrages de mach3 turn je ne pourrais pas me servir du input ''index'' je devrai me servir du input 1 absolument
ou y'a de quoi que j'ai pas compris?
 
dh42
dh42
Compagnon
4 Sept 2009
5 835
Près de St Etienne (42)
Salut,

si je mets le signal sur le input1 alors
dans les parametrages de mach3 turn je ne pourrais pas me servir du input ''index'' je devrai me servir du input 1 absolument
ou y'a de quoi que j'ai pas compris?
Si ; dans le ports&pins/input signals, tu met le n° de pin utilisé en entrée sur la carte dans le "pin number" de la ligne index (le1 si tu utilise l'entrée 1 de la carte) ; pour le port#, tu met le n° de port utilisé par ta carte, par exemple sur les Rnr USB, c'est le port 3 (ça devrait être le même n° de port que pour le reste)

++
David
 
B
big bloc
Ouvrier
7 Oct 2008
274
perso j avais utilise un npn ma carte etait une // je sais qu il peut y avoir des soucis avec l usb ça marche pas mal , à vide je n ai jamais essaye sur mon tour , je vais passer a linux , qui gere les codeurs(donc +precis) pour revenir a ton sujet ça fonctionne bien au moins a blanc
 
E
el patenteux
Compagnon
6 Août 2016
846
  • Auteur de la discussion
  • #8
Ok merci pour les infos.
Je croyais que ca devait etre absolument pnp puisque la carte s'attend a recevoir du +0-10v
A moin que......
 
B
big bloc
Ouvrier
7 Oct 2008
274
bonsoir je viens de voir ton message , mon capteur qui fonctionnait sous mach3 et maintenant linux , c est du NPN . j'avais essaye avec le kit que tu indique et ça ne donnait rien
1585927561591.png


on le voit en action ici , depuis j ai la vitesse de broche qui s affiche :wink:
 
Dernière édition:
J
Julien
Apprenti
25 Jan 2008
208
Metz
Bonjour,
je profite du post pour une petite question sur la gestion de la broche:
Quand on le démarre en manuel elle se met à la vitesse qu'on a défini dans le fichier .ini (DEFAULT_SPINDLE_SPEED = ...)
Ensuite on ajuste la vitesse avec les boutons plus ou moins.

Ce qui est dommage c'est que si on arrête puis redémarre la broche elle se remet à la vitesse par défaut au lieu de garder la dernière... y a t il moyen de changer ce comportement?

Merci
 
B
big bloc
Ouvrier
7 Oct 2008
274
pas encore essayé .. c est vrai que ça peut etre penible
 
Haut