Cambam wrapper plugin

  • Auteur de la discussion FR3Dprint
  • Date de début
F
FR3Dprint
Apprenti
29 Nov 2014
90
  • Auteur de la discussion
  • #1
Bonjour

je teste actuellement le wrapper disponible avec CAMBAM. J'ai suivi et regardé tous les tutos dispos sur le web et en particulier ceux de David.
Malheureusement je n'arrive à rien de rien. voir ci-dessous:

==> Le GCODE est généré avec le PP Mach3-CV_Wrapper
WRAP1.JPG


Le GCODE généré est wrappé comme ci-dessous:
WRAP2.JPG


Voici le résultat (sur CAMBAM, idem Mach3). Le Wrap est compressé. En admettant qu'il soit correct, tout ce que je vois c'est le déplacement de l'outil sur son axe... comme si l'axe A ne tournait pas.
WRAP3.JPG


Il semble que personne n'a déjà eu ce soucis. C'est pas de bol... Si quelqu'un a une idée, d'avance merci.
 
C
check
Ouvrier
23 Sept 2014
396
Pour que ta visualisation sur mach3 soit correcte il faut rentrer ta valeur de rayon sur l'axe A voir l'onglet Setting Alt+6 dans mach 3 valeur à mettre en haut à droite.
 
F
FR3Dprint
Apprenti
29 Nov 2014
90
  • Auteur de la discussion
  • #4
merci de ta réponse. je viens d'ajouter mon diamètre dans "rotation diameters A,B,C" (je prends A je suppose) dans "Settings". Toujours pas de visu. Au passage g essayé le Gcode que tu avais posté dans ton post, et c'est pareil. G un soucis de paramétrage dans Mach3 je pense.
 
C
check
Ouvrier
23 Sept 2014
396
Dans le post auquel j'ai participé j'ai mis 2 copy d'ecran avec les paramètres mach3 que j'ai utilisé
 
F
FR3Dprint
Apprenti
29 Nov 2014
90
  • Auteur de la discussion
  • #6
oui mais comme je n'ai pas exactement la même version la présentation diffère et ce n'est pas simple. Au final c'est pas mieux:
wrap4.JPG
 
C
check
Ouvrier
23 Sept 2014
396
dans cncwrapper je coche reverse angle et je mets la valeur du rayon dans Z soit 15 dans ton cas
 
F
FR3Dprint
Apprenti
29 Nov 2014
90
  • Auteur de la discussion
  • #8
oui, j'ai essayé aussi... sans succès.
 
dh42
dh42
Compagnon
4 Sept 2009
5 777
Près de St Etienne (42)
Salut,

Dans Wrapper, Zbase doit avoir la même valeur que surface pièce et reversed doit être coché (sinon tu a une effet miroir)

Dans Mach3, Config/toolpath, tu dois cocher Y axis (l'axe d'alignement de ton 4ieme axe) et A-Rotation enabled et dans rotation diameter, tu dois avoir 0 (coord Z de l'axe de rotation de l'axe)

Le GCode wrappé ne peux pas être visualisé dans Cambam mais uniquement dans Mach3.

++
David
 
F
FR3Dprint
Apprenti
29 Nov 2014
90
  • Auteur de la discussion
  • #10
Merci David. Je vais tester cette conf car je ne sais plus si je l'ai déjà fait. D'ici ce soir, quelqu'un aurait l'amabilité de me transmettre un gcode wrappé que je puisse tester mach3 indépendamment de cambam et son plugin. Ça aidera a localiser le problème.
 
dh42
dh42
Compagnon
4 Sept 2009
5 777
Près de St Etienne (42)
Salut,

Un fichier en PJ wrappé avec CB V1.0 et le post pro "RotaryY" fourni d'origine avec la V1.0 (ne nécéssite pas le plugin wrapper)

A vue de nez, ton Gcode sur le message plus haut est "presque" OK, si ce n'est le Ø d'enroulement qui n'est pas bon (à cause de baseZ qui est à 0 au lieu de 15) .. comme tu peux le voir sur ton code à la ligne G1 F300.00 Z29.600 ; l'usinage commence à 29.6 alors qu'il devrait être à 14.6

le fait que "Reverse Angle" ne soit pas coché fait un effet miroir sur Mach3

Sans titre-2.jpg


le résultat sur Mach3 avec le fichier en PJ

Sans titre-1.jpg


++
David
 
Fichiers joints
F
FR3Dprint
Apprenti
29 Nov 2014
90
  • Auteur de la discussion
  • #12
Bon j'ai une utre version sur un autre PC et qui ressemble à la tienne. J'ai donc recopié ta conf. Rien. J'ai touché ici ou là... et miracle:
WRAP5.JPG


J'arrive même à en faire d'autres ! reste plus qu'à trouver le paramètre que j'ai touché et à réussir à faire ça quelque soit la version de Mach3... Merci à vous 2 pour votre aide. J'ai encore du TAF pour tout comprendre mais au moins je sais que ça fonctionne. Aller j’éteins tout pour ce soir.
 
F
FR3Dprint
Apprenti
29 Nov 2014
90
  • Auteur de la discussion
  • #14
Bonjour,

petit retour de ce que j'observe et qui fonctionne à l'import dans Mach3 (reste à valider l'usinage):

Dans CAMBAM wrapper:
Diamètre = diamètre du cylindre à graver
Z-Baze = distance // au zéro. Si je ne mets 0, la distance est celle du dégagement réservé pour l'outil.
Reverse Angle = indispensable pour ne pas avoir l'effet mirroir. Ceci vient du sens de l'enroulement fait par le plug-in. Donc a cocher d'office.

Dans Mach 3:
Onglet Settings Alt6 / Axis inhibits : n'est pas coché pour A (le 4eme axe), sinon l'enroulement ne se fait pas et n'est donc pas affiché. Rotation Onglet Settings Alt6 / Diameters: vaut le diamètre du cylindre à graver. Sinon l'enroulement est fait au plus juste. Donc un diamètre plus faible.
General config / A-Axis is angular : à cocher (mais j'ai pas encore tester sans donc quel effet ?)
Toolpath / Y-Axis : à cocher (cocher X-Axis si l'enroulement est fait selon Y dans le plug-in j'imagine)
Toolpath / A-Rotation Enabled : à cocher sinon le 4eme axe ne tournant pas Mach3 affiche toute la gravure "écrasée" puisque un des 2 axes ne fonctionnera pas
Toolpath / Use diameter for feedrate : à cocher... je sais pas pourquoi mais tout le monde le fait :)
 
dh42
dh42
Compagnon
4 Sept 2009
5 777
Près de St Etienne (42)
Salut,

Pour Z base, ça dépend de ta façon de travailler dans CB

- si ta surface pièce est à 0 dans tes op d'usinage, Zbase devra valoir 0 dans Wrapper aussi, si comme dans ton dessin surface pièce est au rayon, Zbase devra valoir le rayon.

Onglet Settings Alt6 / Diameters: vaut le diamètre du cylindre à graver.
Tu dois utiliser une vielle version de Mach3, car dans setting, j'ai "rotation radius" pour chaque axe rotatif. (ou la VF, car il semble que le traducteur se soit planté et est mis Diamètre au lieu de Rayon)

Si tu travaille avec le 0 en Z à l'axe de rotation, alors cette valeur doit être à 0, ou à 0.0001 par exemple. Si tu travaille avec le 0 à la surface du brut, cette valeur devra valoir le rayon de la pièce.

0 désactive complètement la compensation de la vitesse en fonction du rayon(*) ; c'est un bug, d'ou la nécéssité de mettre une faible valeur proche de 0 pour ne pas désactiver la compensation lorsque l'on travail avec le 0 à l'axe.

(*) Comme on donne des vitesses d'avance en mm/min, Mach3 calcule en permanence à quelle vitesse doit tourner le 4ième axe pour que la vitesse d'avance à la surface de la pièce reste constante quelque soit la position en Z ; par exemple si tu a une V d'avance demandée de 500 mm/min, quand tu sera à +50 (donc un Ø de 100) ta pièce devra tourner à 1.5Tr min pour avoir 500mm/min à la surface ; si tu creuse dans la pièce est que ton Z descend à +30 (donc un Ø de 60), l'axe A tournera plus vite (2.65 tr/min) pour conserver les 500mm/min à la surface en cours d'usinage.

Si tu met le Ø ou le rayon dans "rotation radius" alors que tu travaille avec le 0 au centre, tes vitesses d'avance seront à l'ouest.
Onglet Settings Alt6 / Axis inhibits : n'est pas coché pour A (le 4eme axe), sinon l'enroulement ne se fait pas et n'est donc pas affiché.
Oui, si coché ça désactive le fonctionnement de l'axe.

General config / A-Axis is angular : à cocher (mais j'ai pas encore tester sans donc quel effet ?)
Oui, à cocher, sinon l'axe A sera géré comme un axe linéaire (comme XYZ)

Toolpath / A-Rotation Enabled : à cocher
Oui

oolpath / Use diameter for feedrate : à cocher... je sais pas pourquoi mais tout le monde le fait
Oui, ça dit à Mach3 s'il doit compenser la V d'avance en se basant sur un Ø ou un rayon ; je ne sais pas si ça influe en fraisage rotatif mais c'est utilisé en tournage car un Gcode de tournage peut être fournis avec des valeurs X au rayon ou au Ø.

++
David
 
F
FR3Dprint
Apprenti
29 Nov 2014
90
  • Auteur de la discussion
  • #16
Merci David. Voilà qui détaille d'avantage le parametrage et permet de centraliser les infos. Ça aidera sûrement...
 
Haut