Cablage laser sur shield uno et grbl 1,1

  • Auteur de la discussion sergent61
  • Date de début
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #1
Bonjour, je viens vers vous car j'ai un soucis de câblage sur ma machine, sur ma cnc je souhaite mettre un laser. J'ai passer ma machine en grbl 1,1 et activé la ligne du laser en 1. J'ai brancher mon laser sur les end stop z - et z + (j'ai vue ça sur une doc de convertion de machine), ça ne fonctionnent pas donc je pense que mon cablage n'est pas bon. Mon laser à juste deux fils rouge noir.

Ou doit ton brancher le laser?
 
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #2
Personne ? j'ai essayer plusieurs schema sur le net aucun fonctionnent? Le laser s'allume quand je le branche sur le 5 volt et gnd
 
pinou29
pinou29
Compagnon
18 Mar 2009
2 877
Toulon ( Var )
Bonjour.
Voir les articles de l'ami jpbbricole comme ici:
et la suite.
Bernard.
 
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #4
Je te remercie pour ce lien, qui malheureusement est axé grbl usinage et non laser. Ma machine en cnc fraiseuse fonctionne, mais pas en laser.
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 249
Corsier-sur-Vevey (Vaud)
Bonsoir sergent61
J'ai brancher mon laser sur les end stop z - et z +
C'est exacte, avec GRB1.1, la commande de la puissance du LASER ou de la vitesse de la broche se fait sur end stop z- et ou z+, ils sont en parallèles. Mais c'est seulement la commande, M3 S500, pour démarrer à puissance moyenne (S0 à S1000 (PWM)) ET M5 pour arrêter.
Il n'y a pas la puissance nécessaire à commander un laser il faut interfacer.
Regardes ici.

Cordialement
jpbbricole
 
Dernière édition:
pinou29
pinou29
Compagnon
18 Mar 2009
2 877
Toulon ( Var )
Bonsoir.
J'ai un peu cherché ces posts cet après-midi mais pas assez.
Merci.
Bernard.
 
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #7
Mais c'est seulement la commande, M3 S500, pour démarrer à puissance moyenne (S0 à S1000 (PWM)) ET M5 pour arrêter.
J'ai essayer donc branchez mon laser sur z+ fil rouge et z- fil noir. J'ai mis m3 s500 dans laser grbl (connecté bien
sur). Je n'ai rien du tous...
 
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #8
Tu parle de pwm mais c quoi au juste ça
 
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #9
Voici mon laser et le cablage

IMG_20200406_133332.jpg


IMG_20200406_133339.jpg
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 249
Corsier-sur-Vevey (Vaud)
Bonjour sergent61
J'ai essayer donc branchez mon laser sur z+ fil rouge et z- fil noir.....
Cela ne peut pas marcher, Z+ et Z-, les 2 vont sur la broche D11 de l'Arduino. Il faudrait brancher le fil rouge sur Z+ ou Z- et le noir sur GND. Mais, il n'y a pas assez de puissance sur les sorties de l'Arduino et tu risques de le griller. Un interface de puissance est nécessaire.
Tu parle de pwm mais c quoi au juste ça
C'est une façon de pulser le courant afin de faire varier la vitesse d'un moter ou "l'intensité ou l'impacte" d'un LASER. Avec GRBL, c'est réglé pas la commande S0 à S1000.

Cordialement
jpbbricole
 
S
speedjf37
Compagnon
15 Oct 2009
2 223
indre et loire
Bonjour,

Il faudrait les infos du laser (modèle et schéma de branchement)
Une diode laser est pilotée en courant ( sinon destruction) la régulation est peut être intégrée dans le boitier.

Un laser pilotable en puissance a un connecteur de commande en plus de celui d'alimentation.

Comme l'a dit jpbbricole l'arduino ne peut pas alimenter directement le laser

JF
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 249
Corsier-sur-Vevey (Vaud)
Bonjour JF
1586335161074.png

Mon LASER de 1,5W fonctionne comme ceci, IC1 est un ULN2803 très courant.

Cordialement
jpbbricole
 
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #15
Ca marchera avec un mosfet ?? pk justement j'en ai un. est je vais bien trouver une alimentation pour ca
 
S
speedjf37
Compagnon
15 Oct 2009
2 223
indre et loire
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #17
Juste une question @jpbbricole si je n'ai pas çà est il normale que mon laser ne fonctionne pas? Car je voudrais au moin valider mon cablage et la pour l'instant j'ai fait : noir sur gnd et rouge sur Z+ mais rien et idem avec Z-

Un mosfet marchera lui ? sinon j'ai aussi pwm avec potard
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 249
Corsier-sur-Vevey (Vaud)
Bonjour sergent61
pour l'instant j'ai fait : noir sur gnd et rouge sur Z+ mais rien et idem avec Z-
Comme ceci, les 2 fils sont en court-circuit.
Un mosfet marchera lui ?
Oui.
sinon j'ai aussi pwm avec potard
Ça fonctionne aussi, à condition de délivrer un signal PWM de 5V.

Faire un des montage proposés, a l'avantage de pouvoir commander l'intensité, l'allumage et l'extinction du LASER via le G-Code.

Cordialement
jpbbricole
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 249
Corsier-sur-Vevey (Vaud)
Bonjour sergent61
Pourtant tu indique ce branchement plus haut donc court circuit ou non ?
Mes explications allaient dans le sens, ces 2 broches sont "ensemble" donc en court-circuit entre elles.
la puissance du LASER ou de la vitesse de la broche se fait sur end stop z- et ou z+, ils sont en parallèles
Z+ et Z-, les 2 vont sur la broche D11 de l'Arduino
A+
Cordialement
jpbbricole
 
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #21
Donc brancher le fil noir sur le gnd et le fil rouge sur Z+ ou Z- devrait fonctionné, ce n'est pas mon cas ca ne fonctionnent pas
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 249
Corsier-sur-Vevey (Vaud)
Salut sergent61
Donc brancher le fil noir sur le gnd et le fil rouge sur Z+ ou Z- devrait fonctionné, ce n'est pas mon cas ca ne fonctionnent pas
Non!,
Il a été dit plusieurs fois, ci-dessus qu'il n'y avait pas assez de puissance sur une sortir d'Arduino et qu'il fallait ajouter un étage de puissance.
Il n'y a pas la puissance nécessaire à commander un laser il faut interfacer.
Mais, il n'y a pas assez de puissance sur les sorties de l'Arduino et tu risques de le griller. Un interface de puissance est nécessaire.
Comme l'a dit jpbbricole l'arduino ne peut pas alimenter directement le laser
Donc il te faut un interface de puissance comme expliqué ici et .

Cordialement
jpbbricole
 
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #23
Ok, j'ai "enfin" compris dsl ... il faut obligatoirement un intermédiaire. Je vais essayer le mofet car j'en ai un.
 
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #24
Bon alors sans surprise ça ne fonctionne pas...

IMG_20200409_140310_1.jpg


IMG_20200409_140306.jpg


IMG_20200409_140244.jpg
 
pinou29
pinou29
Compagnon
18 Mar 2009
2 877
Toulon ( Var )
Bonjour.
Peut-être qu'à force d'essais un peu "n'importe comment" le laser est mouru :-D?
Bernard.
 
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #26
Donc le + du mofet sur z+
Le fil - du mofet sur GND

Et les alim externe sur le mofet et l'autre le laser, j'ai mon étage de puissance. Mais rien.

Y-a-t-il une fonction à activé dans le grbl 1.1 pour si je fais m3 s500 je n'ai rien du tous.

Frustrant l'histoire lol
 
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #28
J'ai chinté le mofet et ça marche en direct.

Pour le coût le câble et bon pour vous?
 
sergent61
sergent61
Apprenti
3 Sept 2018
212
  • Auteur de la discussion
  • #30
Je crois avoir essayé cet aprem et il me semble que non. Mais il faut que je refaire. ses pour être sur
 
Haut