aide pour un retrofit d'un portique de fraisage

  • Auteur de la discussion Bobby79
  • Date de début
Bobby79

Bobby79

Apprenti
20190123_184711.jpg

Voilà une photo plus exploitable
 
Bobby79

Bobby79

Apprenti
Current setting
1=on
2=on
3=off
Soit
Peak current 5.14A
Rms current 4.28A

4= off = half current au repos

5=on
6=off
7=on
8=on
Soit
Microstep = 8
Pas par tour = 1600

Que je règle sur 400 / 800 / 1600 ou 2000
Ça ne change rien
La seul chose est que dans mon reglage mach 3 pour les pas par mm ça me chane les côté sur la visu mach3 ce qui est tout à fait normal vu que l on change le nombre de pas par tour mais sachant que mon moteur ne réagit pas au reglage je me retrouve avec des cote farfelu vu que mon moteur ne tien pas compte du reglage du driver
 
S

speedjf37

Compagnon
Que je règle sur 400 / 800 / 1600 ou 2000
Ça ne change rien


Bonjour,

Petit détail les modifications des switchs ne sont prises en compte qu'au moment de la mise sous tension du driver.

Faire les modifs hors tension puis alimenter le driver.
Attention aux étiquettes qui parfois ne sont pas dans le sens des switchs.

JF
 
Bobby79

Bobby79

Apprenti
Ok merci pour l information très importante

Je vais essayé alors car ce n est pas ce que j ai fait

Merci beaucoup pour cette information précieuse

Du coup j espère que ça la pas détérioré mon driver
 
V

vres

Compagnon
La seul chose est que dans mon reglage mach 3 pour les pas par mm ça me chane les côté sur la visu mach3 ce qui est tout à fait normal vu que l on change le nombre de pas par tour mais sachant que mon moteur ne réagit pas au reglage je me retrouve avec des cote farfelu vu que mon moteur ne tien pas compte du reglage du driver

Je ne comprend pas, si tu doubles la résolution sur le driver tu dois aussi doubler la résolution sur Mach3.
Si tu ne changes pas de résolution dans mach3 le moteur tourne moins vite.
 
Bobby79

Bobby79

Apprenti
Je change la résolution dans mach3 mais vu que le moteur ne prend pas en compte les reglage du driver je me retrouve avec par exemple 400mm de course sur la visu mach3 alors que mon Y a fait un déplacement de 800mm

Mais je vais essayer en redémarrant tout à zéro avec les réglages du driver à l arrêt sans tension peut être le problème était la je vous tien au jus des demain matin

Bonne nuit à tous
 
V

vres

Compagnon
Mais je vais essayer en redémarrant tout à zéro avec les réglages du driver à l arrêt sans tension peut être le problème

Oui, c'est surement la bonne solution.
Ca n'explique pas ton problème de saccade.
 
Bobby79

Bobby79

Apprenti
Je vais faire l essai de suite et je vous donne des nouvelles dans une petite heure
 
ingenieu59

ingenieu59

Compagnon
Bonjour,

moi, je vois un problème , le port USB , le remettre correctement dans son logement .
 
Bobby79

Bobby79

Apprenti
Donc reglage
Microstep 1600
Soit (360÷1.8)x8÷5=320

15483221620224303993964068779294.jpg

Voilà la photo
15483224791537134759792784288408.jpg
du déplacement du X
Course de l'axe X sur ma machine est de 1000mm
Course donné sur la visu mach3 = un peut plus de 500mm sachant que la course total sans les capteur de fin de course est toujours un peut supérieur à 1000mm

Je ne comprend pas
 
Bobby79

Bobby79

Apprenti
Le port USB est seulement l alim de la bob en 5v
La bon est bien alimenté
Donc le problème ne vient pas de ça

La carte est piloté par le pc via port parallèle DB25
 
ingenieu59

ingenieu59

Compagnon
En es tu sûr, parce que ce n' est pas non plus une super bob . Moi, je vois une fiche mal enclenchée . Tu fais ça à ta voiture, et tu es bon pour le garage .

Est-ce que tu avais fait un test dans le vide pour savoir comment réagiraient les moteurs avec cette bob , comme on voit beaucoup sur youtube , sur une table ( avant de faire l' installation définitive ).
 
S

speedjf37

Compagnon
déplacement du X
Course de l'axe X sur ma machine est de 1000mm
Course donné sur la visu mach3 = un peut plus de 500mm sachant que la course total sans les capteur de fin de course est toujours un peut supérieur à 1000mm

Bonjour,

Une Vab au pas de 10mm ?

Donc les micro pas sont actifs !!!

JF
 
V

vres

Compagnon
déplacement du X
Course de l'axe X sur ma machine est de 1000mm
Course donné sur la visu mach3 = un peut plus de 500mm sachant que la course total sans les capteur de fin de course est toujours un peut supérieur à 1000mm

Si sans rien changer dans Mach3, tu passes en 3200pas/tour sur le driver tu as toujours le même déplacement ?
 
Bobby79

Bobby79

Apprenti
C exactement ça vis à bille de 10mm par tour

Ça doit être un vis à double filet car de sommet à sommet il y a bien 5mm
 
Bobby79

Bobby79

Apprenti
Problème trouvé un truc le plus bête possible j était fixé sur mais 5mm de pas de vis alors que en réalité elle fait 10mm par tour

Quel serais le meilleur reglage pour une vis avec un pas par tour aussi gros ?
 
Bobby79

Bobby79

Apprenti
Et donc pour répondre à cncserv effectivement mes côté change lorsque je passe à 3200 pas sur le drivers c ça qui ma alerté

Puis j ai mesuré avec le comparateur et j ai bien 10mm par tour de vis
 
S

speedjf37

Compagnon
Problème trouvé un truc le plus bête possible j était fixé sur mais 5mm de pas de vis alors que en réalité elle fait 10mm par tour

Quel serais le meilleur réglage pour une vis avec un pas par tour aussi gros ?

Les micro pas ne changeront pas la précision de positionnement.
Ils améliorent seulement le mouvement en supprimant les grosses vibrations entre les pas.

Maintenant que tu connais la résolution de base soit 10mm/tour et 200 pas moteur , 1 pas =10/200=0.05mm tu peux essayer différents micropas.

1/4 ou 1/8 pas sont souvent suffisants pour un fonctionnement doux des moteurs.

Les résolutions supérieures pénalisent la vitesse max de déplacement soit par la vitesse d'horloge du circuit de pilotage , soit par la vitesse max des opto-coupleurs en entrée des drivers.

Bon essais !

JF
 
Bobby79

Bobby79

Apprenti
Bonjour à tous

Après quelques mois à retrofiter ma machine je peut vous dire aujourd'hui que elle est prête à 99%

Et je suis plutôt fier de moi car grace à toutes vos aide précieuse.... je suis enfin arriver à terme sur ce projet très instructif ...

Bon forcément quelques petit souci par ci et par la au fur et à mesure mais grâce au forum j ai réussi à régler tout ça au fur et à mesure

Aujourd'hui il me reste la broche qui ne fonctionne pas car le variateur est en cause

Il est parti chez le réparateur pour une petite révision et normalement après ça les premier usinage vont commencer

Me reste à acheter un palpeur d outil pour être au top et ma fois c sera terminé

Hâte de recevoir le variateur pour effectzur les premier test et ce sera probablement dans un futur projet de retrofit que l on se retrouvera très certainement

Merci à

- @CNCSERV
- @speedjf37
- @effix
- @rom
- @ingenieu59
- @cr-_-

15528341565476252883154255869568.jpg
 
Haut