1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Aide sur TB6560 et LinuxCNC

Discussion dans 'Electronique spécifique CNC' créé par dacrasy, 9 Mars 2013.

  1. dacrasy

    dacrasy Nouveau

    Messages:
    4
    Inscrit:
    9 Mars 2013
    Aide sur TB6560 et LinuxCNC
    Bonjour,

    J'essaie de CNCiser une mini fraiseuse Proxxon MF70 que je vais utiliser sous LinuxCNC.
    Aujourd'hui, tout est monté mais je n'arrive pas à la faire fonctionner.

    J'ai acheté un kit sur la bay avec :
    - Une alim 24V.
    - Une carte TB6560 HY-TB4DV-M de chez http://www.hyu68.com, modifiée suivant les conseils de ce site (http://www.civade.com/post/2010/10/04/Faut-il-jeter-votre-controleur-pas-à-pas-chinois-pour-CNC-à-base-de-TB6560-acheté-à-50%24-sur-Ebay-TB3-TB4).
    - 4 moteurs NEMA 23 de chez http://www.longs-motor.com.

    Sans parler pour le moment de la configuration de LinuxCNC, je ne comprends pas ma situation lorsque je branche mes moteurs :
    1/ Les moteurs X, Y ou spare sont bloqués quand ils sont branchés sur la prise X sur la carte alimentée ET branchée par la prise parallèle au PC. J'imagine que c'est parcequ'ils sont alimentés. Quand la prise parallèle est pas branché, les rotations sont libre.
    2/ Lorsque je branche mon moteur de l'axe Z sur cette même prise, sa rotation est libre.
    3/ Lorsque je branche n'importe quel moteur sur les prises Y ou Z de ma carte (alimentée), les moteurs sont libre en rotation.
    4/ Lorsque je branche le moteur en spare sur la prise en C, sa rotation est libre.

    Quelqu'un pourrait me dire ce que l'on pourrait conclure de ces essais?
    Personnellement, je dirais que le moteur en Z est mort et qu'il y a un problème sur ma carte sur les axes Y et Z.
    Des idées???

    Merci.
     
    Dernière édition par un modérateur: 16 Avril 2015
  2. dacrasy

    dacrasy Nouveau

    Messages:
    4
    Inscrit:
    9 Mars 2013
  3. dacrasy

    dacrasy Nouveau

    Messages:
    4
    Inscrit:
    9 Mars 2013
    Aide sur TB6560 et LinuxCNC
    Problème résolu.
    Je suis allé dans le bios et modifié l'adresse du port parallèle (378) et je l'ai également mi en unidirectionnel.

    Pour info, c'est sur un Thinkpad R31.
     
  4. dacrasy

    dacrasy Nouveau

    Messages:
    4
    Inscrit:
    9 Mars 2013
    Aide sur TB6560 et LinuxCNC
    J'avais oublié, j'ai également modifié le .HAL de ma config afin d'activer les axes Y et Z.
     
Chargement...

Partager cette page