En cours Réglage vitesse moteur p.a.p avec minuterie

  • Auteur de la discussion gaston83
  • Date de début
G

gaston83

Compagnon
Bonsoir à tous,

Après toutes ses péripéties et grâce à vos aides respectifs... surtout Speedjf37 ... c'est fini en terme d'ingénierie.

Tout fonctionne avec une Due donc on va pas chercher plus loin (la mega à la poubelle) et je ferais une photo de l'ensemble.

Merci à tous... :partyman: :drinkers:
 
G

gaston83

Compagnon
hé non, elles étaient dans un carton, sous d'autres cartons dans la dépendance...
 
S

speedjf37

Compagnon
Bonsoir,

@gaston83
un test pour l'eeprom !




le début du test avec une MEGA2560
4096
Address: 0, value: 100
Address: 1, value: 12
Address: 2, value: 0
Address: 3, value: 0
Address: 4, value: 0
Address: 5, value: 0
Address: 6, value: 10
Address: 7, value: 0
Address: 8, value: 67
Address: 9, value: 0
Address: 10, value: 0
Address: 11, value: 122
Address: 12, value: 67
Address: 13, value: 0

le début du test avec une UNO
1024
Address: 0, value: 100
Address: 1, value: 0
Address: 2, value: 0
Address: 3, value: 0
Address: 4, value: 3
Address: 5, value: 0
Address: 6, value: 30
Address: 7, value: 0
Address: 8, value: 44
Address: 9, value: 1

Cordialement JF
 
S

speedjf37

Compagnon
j'ai déjà testé avec ça que @pascalp m'a envoyé. ça fonctionne avec la Mega Pro, la Leonardo mais pas la Mega que je voulais me servir... que dalle, elle veut rien savoir. J'ai même repiqué le firmware de la Mega pro que j'ai téléversé... rien du tout.
J'ai bien compris !
Mais si tu peux tester avec ce que j'ai mis au #94 et mettre le début du retour liaison série .....

JF
 
G

gaston83

Compagnon
voilà...

testadresse.JPG




et ça , c'est la mega Pro.

testadresse_mega pro.JPG
 
S

speedjf37

Compagnon
Ok merci Gaston

L'eeprom est bien visible avec ces 4096 octets mais l'écriture n'est pas fonctionnelle !
La carte peut toujours servir pour test (sans eeprom).


J'ai mis à jour le Github avec ce que je considère comme la version 1.00 (première version fonctionnelle).

J'ai renommé le .ino en menu_shield_timer_stepper.ino et ajouté des commentaires

Il faudra changer le nom du dossier !

@gaston83
Si tu veux des changements/modifs c'est le moment !

Je vais faire une version pour @Andoche avec le menu

JF
 
G

gaston83

Compagnon
Merci à toi...

Avec ce que tu as déjà fait, le système me convient bien. A part le coup d'être obligé d'appuyer trois fois consécutivement sur Up ou sur Down, ça fonctionne.
Je n'arrive pas à voir (dans le code) les lignes qui tripotent les boutons. Je pourrais essayer de bidouiller pour éviter ces trois coups... je présume que c'est dans clavier.h ?

EDIT:

ben là, elle me fait mentir, cette bourrique... J'appui qu'une fois , ça fonctionne... par contre la Pause ne fonctionne pas. A moins que tu ais fait la modif entre temps ....
 
Dernière édition:
G

gaston83

Compagnon
Ce sont les fonctions R et S pour démarrer et arrêter qui demandent trois appuis. La pause P ne fonctionne qu'à moitié. C'est à dire quelle arrête la minuterie mais pas le moteur .
 
P

pascalp

Compagnon
L’affichage dans les menus me pose soucis. Il n'y a pas que les valeurs numériques mais aussi des "résidus" venant de l'affichage précédent.
Dans la version beta, il n'y avait pas ce problème de remise à zéro de la zone avant affichage.
shieldkeypad_2560_stepper_20211116_162206_crop_1024.jpg


Mon "banc test" minimaliste !
 
Dernière édition:
G

gaston83

Compagnon
La pause fonctionne... :smt023 mais le coup de l'appui 2 ou 3 fois sur la touche, ce n'est pas systématique, dés fois oui, des fois non :smt017
 
G

gaston83

Compagnon
Voilà la bestiole...

 
S

speedjf37

Compagnon
L’affichage dans les menus me pose soucis. Il n'y a pas que les valeurs numériques mais aussi des "résidus" venant de l'affichage précédent.
Dans la version beta, il n'y avait pas ce problème de remise à zéro de la zone avant affichage.

@pascalp
Bien vu merci pour le retour !

Correction en gras ci dessous (Git update)

else if( btn == btnRIGHT )
{
Menu_Rang_Mem = Menu_Rang;// correction info fantômes
Menu_Rang ++;

btn=0;
//Serial.println(" Menu_Rang ++") ;
}

Voilà la bestiole...
Merci Gaston , ça fait plaisir de voir la finalité du projet :smt038
Quel rapport de vitesse entre le moteur et le tambour ?


Mon "banc test" minimaliste !
Tu as réussi à faire encore plus léger que moi !!!:eek:
 
G

gaston83

Compagnon
et voilà... ça fonctionne super. J'ai mis les des photos du résultat dans le bon Forums
 
S

speedjf37

Compagnon
Gaston,

Tu pourrais donner les paramètres optimum utilisés ?
 
G

gaston83

Compagnon
Les paramètres par défaut dans Eeprom/

// valeurs par defaut
// Serial.println("!memory.d.initialized") ;
memory.d.initialized = true;
memory.d.Timer1_heu = 0;
memory.d.Timer1_min = 0;
memory.d.Timer1_sec = 30;
memory.d.Timer1_vit = 300;
memory.d.aff = 0;
memory.d.liai_mult = 1;
memory.d.liai_div = 1;
memory.d.mot_pas = 3200;
memory.d.mot_sens = 0;
memory.d.mot_vitmin = 500;
memory.d.mot_vitmax = 8000;
memory.d.mot_accel = 4000;
memory.d.mot_vit = 6000;
 
S

speedjf37

Compagnon
Bonjour Gaston ,

"V-Tamb" ne fait pas partie de mon code donc il y a eu des modifs.
Peux tu publier le code qui à affiché cela ?

Ps) Je n'avais pas finalisé l'affichage moteur/sortie avec le ratio */

JF
 
G

gaston83

Compagnon
Bon, ma foi... je viens de relancer pendant 3 heures, et ça a fonctionné ... affichage normal :smt017
 
G

gaston83

Compagnon
le code...
 

Fichiers joints

  • menu_shield_timer_stepper.rar
    413.3 KB · Affichages: 14
P

pascalp

Compagnon
Ligne 186, l'affichage "vit" est devenu "V-Tamb" pour, je suppose vitesse-tambour
 

Sujets similaires

Moi33
Réponses
3
Affichages
2 613
speedjf37
S
zygo4619
Réponses
34
Affichages
32 171
zygo4619
zygo4619
V
Réponses
62
Affichages
3 069
vibram
V
Mcar
Réponses
65
Affichages
5 426
Mcar
U
Réponses
85
Affichages
4 323
Hubert86
H
shodan47
Réponses
7
Affichages
8 606
shodan47
shodan47
M1M1HRC10
Réponses
7
Affichages
37 409
M1M1HRC10
M1M1HRC10
F
Réponses
14
Affichages
1 411
franckapik
F
G
Réponses
65
Affichages
7 361
rokag3
R
01power
Réponses
3
Affichages
10 717
01power
01power
V
Réponses
62
Affichages
36 712
Dardar88
Dardar88
V
Réponses
7
Affichages
1 453
vibram
V
V
Réponses
4
Affichages
1 995
wika58
wika58
Haut