Autres PAP piloté par Arduino

  • Auteur de la discussion gaston83
  • Date de début
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 968
FR-28360
Il faut éviter le Pas entier c'est ingérable, a chaque impulsion le moteur délivre sont couple max, mais il n'y pas de couple résistant car le moteur est a vide. C'est un peu comme quand on soulève le saladier en plastique alors que l'on pense qu'il est en porcelaine.

stepper.setSpeed(vitMpap); //Réglage de la vitesse du moteur en pas par seconde

stepper.runSpeed();
Après appeler ces fonctions à chaque boucle est-il judicieux ? il faudrait peut-être les appeler seulement quand vitMpap change.

Est-Il aussi indispensable de rappeler runSpeed() après chaque changement de vitesse ? setSpeed() ne suffit pas ?
 
Dernière édition:
gégé62
gégé62
Compagnon
26 Fev 2013
2 983
Harnes (Pas de Calais)
question bête car je n'ai pas tout lu, es-tu certain du raccordement entre moteur et driver ?
 
gaston83
gaston83
Compagnon
17 Fev 2016
1 534
FR-71520
  • Auteur de la discussion
  • #63
Il faut éviter le Pas entier c'est ingérable
Ok, ce sont des subtilités que je ne connaissais pas... et que par ailleurs je n'ai vu aucune trace, aucun écrit ni article relatant ce genre de problème sur la pas entier. Merci en tout cas de cette information. Cela va m’empêcher de taper sur la clavier comme un fondu... à essayer de chercher l'introuvable...:smt023

Après en terme de programmation, là j'ai besoin de l'aide de tous... faire un Blink çà va, mais après...


es-tu certain du raccordement entre moteur et driver ?
Oui, gégé je suis sûr du raccordement. Avant de :smt021 sur le clavier j'ai tout essayé en terme de connexion.

Bonne soirée à tous...
Georges
 
Dernière édition:
gaston83
gaston83
Compagnon
17 Fev 2016
1 534
FR-71520
  • Auteur de la discussion
  • #64
Je viens de faire un essais avec un ULN2804 en unipolaire. J'admets que cela fonctionne bien (au pas entier) , que le moteur vibre beaucoup moins mais le couple est nettement moins bon.
C'est un choix...
 
Dernière édition:
gaston83
gaston83
Compagnon
17 Fev 2016
1 534
FR-71520
  • Auteur de la discussion
  • #65
Bonsoir à tous,
On continue... nouvelle étape... MACH3 ....:7dance:
Hé, fallait bien y arriver...

Ben, çà marche... j'avais un vieux portable équipé d'un port //, j'ai branché PUL et DIR la masse et "faï tira Marius", comme on dit chez nous, le moteur tourne. :tumbsupe:
J'en suis pas encore revenu !!:shock:
 
Dernière édition:
Haut