Moteurs à pas qui se bloquent

  • Auteur de la discussion Mortaurat
  • Date de début
M
Mortaurat
Nouveau
Bonjour,
J'ai décidé de passer ma CNC qui tournait sur Mach3 en GRBL.
J'ai pour cela acheté un contrôleur GRBL avec drivers intégrés (http://s3.amazonaws.com/s3.image.sm...r_Board_User_Manual-English-V1.0-20200612.pdf).

Au niveau du contrôle offline tout se passe bien lorsque je fais de petits pas (1mm). Mais lorsque je fais des pas de 1cm, parfois le moteur se bloque quelques secondes.

concernant l'alimentation, j'ai la même que celle lorsque j'utilisais Mach3 donc pas de soucis.

J'ai ensuite pensé aux drivers intégrés, qui n'étaient peut être pas assez puissant. Une des ref de mes moteurs est 42H48403. Il tire 1.8A selon la spec (http://www.longkangtech.com/product_detail.php?ProId=60), et mes drivers peuvent encaisser 2A selon la spec du contrôleur.

J'ai lu sur le forum que les blocages de moteurs peuvent être dus à des impulsions trop courtes. J'imagine qu'il faudrait modifier celà dans le firmware de mon contrôleur.
Celà vous semble il cohérent comme piste, si oui, avez vous une idée de comment modifier celà ?
 
E
el patenteux
Compagnon
J'imaginne que les rampes d'accélérations et les step/mm ne sont tout simplement pas réglés.
En d'autre termes les ordres que tu envois se trouvent a etre démesurés et les moteurs décrochent tout simplement.
 
M
Mortaurat
Nouveau
Merci à vous.
C'est probable que ca soit le cas.
Je vais tester ce soir et je vous dis :)
 

Sujets similaires

A
Réponses
5
Affichages
1 368
jpbbricole
jpbbricole
taratata
Réponses
4
Affichages
2 125
taratata
taratata
F
Réponses
39
Affichages
5 596
dh42
L
Réponses
2
Affichages
1 626
lacedemone
L
horsot
Réponses
332
Affichages
68 209
Pascal76
P
Haut