HAAS ST15 - post pro Fusion 360 - perçage

Laurent_CNC
Compagnon
26 Avril 2012
536
  • Auteur de la discussion
  • #1
Bonjour à tous,

Je veux utiliser les fonctions de FAO de Fusion pour générer des programmes pour mon tour HAAS ST15.
Le post pro ST15 existe et la programmation d'usinage extérieur fonctionne vraiment bien.

La ou j'ai un problème c'est pour l'usinage d'intérieur à l'aide de forêts ou de fraises.

Je n'ai pas d'outils tournants et j'ai bien supprimé la ligne qui correspond à l'axe C dans la définition de ma machine.
Mais quand je veux faire un simple pointage au foret à centrer ou un perçage, le code généré demande à ma machine de mettre en rotation l'outil et pas la pièce.
(G154 et autres)
Ce qui bien sûr provoque un plantage du programme.

Je n'ai pas trouvé ou dire à Fusion d'utiliser, certe une fonction de perçage, mais en faisant tourner la broche et pas l'outil...

Je souhaite percer un pré-trou pour ensuite aléser à l'outil.
Visuellement, sur Fusion, tout va bien, mais en décortiquant le programme... c'est pas bon.

Quelqu'un peut il m'aider comprendre mon erreur ?

Merci d'avance,
bien cordialement,
Laurent
 
zygo4619
Nouveau
15 Août 2014
48
correze
Bonjour,

Ton ST15 possède un axe y ?
Si ce n'est pas le cas, télécharge le post pro pour ST 15 et pas pour ST 15Y
sinon, fait un test avec le post pro générique fourni d'origine sur fusion "haas turning", je l'utilise quotidiennement sur un SL20 ça fonctionne parfaitement
 
Laurent_CNC
Compagnon
26 Avril 2012
536
  • Auteur de la discussion
  • #3
Bonjour,
Non, pas d'axe Y justement.
OK, je regarde aux post pro et je dis quoi, merci d'avoir regardé !
 
Laurent_CNC
Compagnon
26 Avril 2012
536
  • Auteur de la discussion
  • #5
Bon ben ça semble être un bug du post pro HAAS ST15.
J'ai bien la version ST15 et pas la ST15Y et il génère une mise en route d'un outil tournant dont le tour n'est pas équipé.

Avec la version standard, le programme est "normal" en enclenchant une rotation de broche classique.

Je vais faire un essai sur le tour maintenant et je tiens au courant.
 
zygo4619
Nouveau
15 Août 2014
48
correze
tout a fait, j'ai jeté un oeil dessus, le post pro ST15 pilote un axe C, ce qui doit impliquer une rotation d'outil, tu peux le mettre en commentaire je pense, ça devrait fonctionner, a voir, je ne suis pas rentré dans le détail, j'ai toujours travaillé avec le générique

tu me diras, bon courage
 
Laurent_CNC
Compagnon
26 Avril 2012
536
  • Auteur de la discussion
  • #7
Quel con.... si j'vous jure.

En utilisant le post pro générique, ça doit fonctionner.
Ca me plantait par que j'ai déclaré un outil non configuré dans la machine...

Donc, ça va probablement fonctionner mais pas avec le post pro ST15, ce qui est dommage quand même.

Je vous confirme ça lundi, là, c'est bon.

Bises aux filles et bon WE
 
zygo4619
Nouveau
15 Août 2014
48
correze
Pas de soucis, l'essentiel c'est que tu y arrives !
Il n'y a pas de différence majeure entre le post pro générique et celui du st15 ceci dit, les tours haas de séries sl et st fonctionnants tous plus ou moins sur la même base de ce que j'ai pu voir

je ne sais pas de quelles filles tu parles, mais je n'y manquerais pas !
Bon week end
 
Laurent_CNC
Compagnon
26 Avril 2012
536
  • Auteur de la discussion
  • #9
C'EST BON !!!

Ça ce passe dans la gestion de l'outil.
Quand tu déclares un outil de type foret ou autre, il faut penser a décocher Live Tool... tout simplement...

Merci de l'aide, c'est cool de pouvoir compter sur le fofo !

Capture.JPG
 
Haut