connection leadshine / carte UCCBB1 / UCCNC

  • Auteur de la discussion fred3347
  • Date de début
F

fred3347

Ouvrier
Bonjour a tous,
Etant novice en CNC; Je redirige mon précèdent post ici , afin que vous puissiez m'aider a connecter mon Driver CSD508 leadshine a ma carte UCCBB1 . Je voudrais faire mes premiers essais et faire tourner le moteur , Je galère a paramétrer l'axe X dans mon logiciel UCCNC.
les alims sont OK de tout les cotés, le moteur ronronne aussi ........ Est ce que mon câblage driver / carte est il correct????? ( fil vert et blanc)
Mon problème et de que je rentre le DIR PIN (O2) et le PORT (1) dans l'interface du setup , celui ci revient a zéro des que je valide........ je ne comprend pas pourquoi ?
Mauvais paramétrage???? mauvais câblages????
help me please !!! :lol:

Fred

IMG_4567.JPG


IMG_4568.JPG


setup x.PNG
 
S

schum22

Compagnon
Salut,

Tu ne veux pas faire l'expérience sur Mach3, juste pour vérifier?
 
F

fred3347

Ouvrier
pourquoi pas dans un deuxième temps,
il y a bien des utilisateurs UCCNC qui vont me secourir j'espere :smt039
 
A

Arkan

Nouveau
Si ça peut aider, voici le plan de câblage que j'ai utilisé pour mes drivers
Je ne connais pas les tiens, je ne sais pas a quoi correspond le câblage "Feedback"

Pour le paramétrage dans UCCNC je vois pas pourquoi cela ne fonctionne pas, a par mettre le chiffre et validé par la touche "Entrée du clavier"
Je ne connais pas assez mais peut être vérifier sur quel "Port" est connecté ta carte "UCCBB1" au niveau de l'UC300 ?
(Les ports 2. et 3. sont des connecteurs LPT de type standard. Les ports 1. , 4. , 5. sont des connecteurs LPT de type entrée.)

Si ça peut te mettre sur une piste :wink:
Sinon je vais laisser les Pro y répondre :)




Drivers.jpg

Tu peux mettre comme sur mon plan la sortie "0V" sur PUL- et Dir-
Ensuite sortie 01 vers PUL+ et 02 vers DIR+

Si tu veux utiliser la sortie "5V" dans ce cas tu connecte sur PUL+ et DIR+
Ensuite pour la sortie 01 vers PUL- et 02 vers DIR-
 
F

fred3347

Ouvrier
merci de ton aide , maintenant c'est bon , je n'avais pas saisi le bon port dans le setup
par contre je suis en liaison Ethernet , et j'ai vu qu il faillait un câble de type croisé , c'est certainement pour cela que je suis toujours en mode demo non?
 
A

Arkan

Nouveau
oui c'est bien ça, et si tu utilise un cable rj45 droit tu peux passer par un routeur
 
C

Coyote94

Compagnon
Oui pour le câble il te faut un croisé en direct, ce lui de droite
IMG_6771.jpeg

Et ton câblage ne me semble pas bon : les « -« doivent être connectés sur le 0v du « dc out »
 
F

fred3347

Ouvrier
ok ,
quand je branche mon câble Ethernet croisé ,je reste en mode démo et normalement ma carte doit être reconnue non ? ,je ne comprend pas pourquoi elle n'apparait pas dans mon paramètre réseau , j'ai fait les MAJ des pilotes .........
avez vous une idée ?




1703596699307.png
ar n'ap
 
Dernière édition:
C

Coyote94

Compagnon
Mais je ne comprends pas un truc : quelle est ta carte contrôleur ?
À ma compréhension la UCBB1 n’est pas une carte de contrôle, elle se connecte à une carte de contrôle par un ou les 2 ports LPT donc pas de câble ethernet.
 
F

fred3347

Ouvrier
je viens de trouver la solution a mon problème, , j'ai repotassé la notice et après avoir rentré les coordonnés IP , je suis sortie du mode demo et mon moteur tourne :roxxx:
 
Dernière édition:
S

schum22

Compagnon
Dans l'idéal pour commencer à travailler il faut tout connecter à un routeur qui fait tout le boulot.
Par exemple pour ceux qui sont (ou étaient) chez Orange, une vieille Livebox V2 par exemple est parfaite pour ça (vous pouvez aussi utiliser des vieux routeur Linksys ou autre).
Vous la connectez juste en alimentation électrique (oubliez le câble ADSL) et elle vous gèrera toute seule votre mini LAN (votre réseau local dédié à votre CNC).

Vous branchez sur ses ports réseau (4 à disposition) votre PC dédié Mach3 (ou u UCCNC), votre AXBB-E (ou UC300ETH) ou CSMIO, votre carte Pokeys.. et vous pouvez commencer à bricoler sans vous soucier de la configuration réseau.
La Livebox donnera à tous votre réseau en IP dynamique des adresse en 192.168.1.10, 192.168.1.11 ......
Quand vous maitriserez mieux l'architecture, vous pourrez passer en IP fixe en configurant votre PC manuellement, votre AXBB-E via le logiciel dédié....


Perso j'ai mon mini LAN "CNC" sur un switch réseau dédié (tout en IP fixe) et seul mon PC communique à la livebox en direct via un second réseau en Wifi (pour les mises à jour par exemple).
 
J

jf62

Compagnon
Bonjour
J'ai aussi le problème le connexion en mode run avec l' AXBB-E et il semble bien que cela vienne du PC (mini pc industriel fanless) avec un pc de bureau ou un portable pas de soucis, question de puissance?
 

Sujets similaires

V
Réponses
3
Affichages
1 002
vibram
V
D
Réponses
11
Affichages
1 012
danyell
D
S
Réponses
10
Affichages
2 138
sweex59
S
01power
Réponses
3
Affichages
13 813
01power
01power
Haut