Cnc 6040 et usb ( resolu)

eric356
Apprenti
16 Décembre 2010
221
belgique
  • Auteur de la discussion
  • #1
Bonjour à tous,
Il y a 8 ans j'ai acheté une 6040 chinoise comme beaucoup d'autres ici,
J'en suis super content pour l'utilisation que j'en fait.
Il y a 2 ans j'ai planté le Pc qui fesait tourner la machine et depuis que j'ai changé de Pc la machine ne fonctionne plus comme avant, problèmes d'interférences lorsque la broche tourne....
Comme la machine fonctionnait avec l'autre Pc j'ai fait pleins de petites choses pour isoler et mettre à la terre la machine et la commande, mais ce n'est pas encore le top,
Comme j'en ai marre de chercher, je vais changer de pc et passer via un pc plus moderne que mon Pentium 4....
Qui dit nouveau Pc dit usb et non lpt...
Y a-t-il ici quelqu'un qui aurait modifié la commande d'une 6040 pour passer en usb ?
Et qu'est-ce qui est le mieux à faire, changer la carte ou une interface uc100 est suffisante ?
Et pour le pc ? Portable ou tour ?
Merci de vos retours
Éric
 
Dernière édition:
pierrelucas
Apprenti
8 Juillet 2019
54
Bonjour,
Bah pour le pc, n'import, ils sont tous assez puissant.
Mieux vaut un pc dédié d'ailleurs.
Pour l'usb,c'est vrai que souvent c'était en port série, dommage.
Normalement si tu changes que la carte, ca devrait fonctionner ( tout a reparametrer), mais possible que les connexions des drivers soient a refaire si non identique.
 
dh42
Compagnon
4 Septembre 2009
5 241
Près de St Etienne (42)
Salut,

J'ai installé un UC100 sur une 6040 qui était en port //

++
David
 
eric356
Apprenti
16 Décembre 2010
221
belgique
  • Auteur de la discussion
  • #5
Super David
il me semblait bien avoir vu cet article
super intéressant, l'interface UC100 est commandée, j'ai mis la derniere version de Mach3 et je reparametrerai le tout des que j'aurai recu l'interface,
j'ai aussi commandé une manivelle, cela me permettra de ne plus commander la machine du clavier,
la suite dans quelques semaines suivant la poste….
 
dh42
Compagnon
4 Septembre 2009
5 241
Près de St Etienne (42)
Salut,
j'ai mis la derniere version de Mach3 et je reparametrerai le tout des que j'aurai recu l'interface,
Attention, la toute dernière est buguée (3.043.066) ; si tu veux éviter les arrachage de cheveux, il vaut mieux mettre la précédente (3.043.062). Rien n’empêche ensuite d'y mettre le screenset FR si tu veux les écrans en français (les menus et les fenêtres de réglages resteront en anglais par contre, mais ce n'est pas vraiment un problème car tu ne t'en sert que pour les réglages de base de la machine)

++
David
 
eric356
Apprenti
16 Décembre 2010
221
belgique
  • Auteur de la discussion
  • #8
Salut,


Attention, la toute dernière est buguée (3.043.066) ; si tu veux éviter les arrachage de cheveux, il vaut mieux mettre la précédente (3.043.062). Rien n’empêche ensuite d'y mettre le screenset FR si tu veux les écrans en français (les menus et les fenêtres de réglages resteront en anglais par contre, mais ce n'est pas vraiment un problème car tu ne t'en sert que pour les réglages de base de la machine)

++
David
Heuuu je n'arrive pas à trouver le lien pour télécharger la 062 ,
j'ai fouillé sur plusieurs sites de cn mais rien n'y fait tous les liens ramènes vers la dernière version ….
quelqu'un aurait-il le lien?
eric
 
eric356
Apprenti
16 Décembre 2010
221
belgique
Des news :
j'ai bien reçu l'interface uc100 et j'ai donc installé la version win10
avec le patch.
j'ai récupèré mon ancien fichier de config mais apparement les deux versions de mach ont des différences car le programme ne se lançait pas …. j'avais un écran blanc...
rien de grave j'ai remis les paramètres manuellement,
et puis hop rien ne fonctionnait , j'ai réinstallé le programme de l'uc100 et ses drivers ,
redémarré le pc et hop tout tourne niquel .
enfin presque il me reste à tester un programme avec la broche qui tourne ...
j'ai hate d'avoir une version mach3.fr qui ne bugue pas , l'interface était plus sympa que ce que j'ai installé mais bon c'est du détail.
encore un peu de patience et je pourrai installer la manivelle

eric
 
dh42
Compagnon
4 Septembre 2009
5 241
Près de St Etienne (42)
Salut,

Quand tu a un écran blanc au lancement d'une version de Mach3, c'est simplement qu'il ne trouve pas le screenset qui a été associé au profil machine. (le nom du screenset à utiliser est sauvé dans le fichier .xml de ton profil machine)

Par défaut Mach3 (EN) cherche le screenset d'origine (fichier 1024.set dans le dossier d'insta de Mach3) ; Mach3FR par contre cherche le fichier mach3fr-fraisage.set (au même endroit)

Si tu installe la 062 (anglaise) par dessus la 066 (française), il suffit alors, quand tu est sur l'écran blanc (ou l'écran par défaut), de choisir le screenset que tu veux utiliser (menu View/loadscreen) ... ça ne change pas les réglages "machine", juste le screenset.


si tu n'a pas/plus le screenset FR (le marron) et son set d'images, tu peux le télécharger sur ce post

++
David
 
Dernière édition:
Haut