Arrêt intempestif de la broche

  • Auteur de la discussion Christian67
  • Date de début
C
Christian67
Ouvrier
13 Mai 2012
273
Kogenheim
  • Auteur de la discussion
  • #1
Bonjour,

Hier après midi, j'ai lancé la découpe de pièces dans du contre plaqué.
La broche s'est arrêté, sans raison apparente, à deux reprises.
Une première fois tout au début, une deuxième après environ 40mn. La broche s'arrête, mais en roue libre, c'est à dire sans que le variateur ne la freine pas.
A chaque fois, j'ai tapé l'arrêt d'urgence de la machine, et j'ai relancé le programme là où il s'était arrêté, sans soucis.
Je dois avouer que je n'ai pas pris le temps de bien noter ce qu'indiquait l'inverter, et c'est ennuyeux.

Une piste à me donner ?
Merci d'avance.

Christian.
 
osiver
osiver
Compagnon
7 Sept 2013
12 043
Une piste à me donner ?
Il faudrait donner les caractéristiques (modèle) du variateur, il est possible qu'il enregistre les dernières erreurs.
De plus, il faudrait savoir si le variateur qui s'est arrêté de lui-même (en erreur) ou une commande d'arrêt lui a été envoyée.
En fait, connaître la configuration de la machine ... :shock:

En tout cas si le problème se répète, lire les indications du variateur et noter les conditions d'utilisation de la machine :spamafote:
 
C
Christian67
Ouvrier
13 Mai 2012
273
Kogenheim
  • Auteur de la discussion
  • #3
Il s'agit d'un inverter ASKPOWER A131 pour broche de 2.2kW.
Je viens d'en trouver le manuel et, de mémoire, le message d'erreur était OU -u, ce qui correspondrait à "Acceleration overvoltage".
 
osiver
osiver
Compagnon
7 Sept 2013
12 043
Il était en phase d'accélération lorsqu'il s'est mis en erreur ?
 
C
Christian67
Ouvrier
13 Mai 2012
273
Kogenheim
  • Auteur de la discussion
  • #5
Non, du tout, en régime établi à 22000 tr/mn
 
osiver
osiver
Compagnon
7 Sept 2013
12 043
Ok, il semble que ça peut aussi venir d'une surtension côté secteur.
Vous avez une tension secteur élevée ?
 
C
Christian67
Ouvrier
13 Mai 2012
273
Kogenheim
  • Auteur de la discussion
  • #7
Pas que sache, je n'ai pas de soucis de ce coté là.
Est ce que les inverters sont sensibles sur les sur-tension ?
 
osiver
osiver
Compagnon
7 Sept 2013
12 043
Pas particulièrement mais il y a des limites et comme ils ont beaucoup de contrôles et d’alarmes.
C'est nouveau, ce défaut ? Je veux dire la machine a fonctionné un certain temps (semaines, mois) avant, sans souci ?
Vous devriez relever et poster les paramètres, il y en a peut-être un qui coince :eek:
 
M
moissan
Compagnon
13 Mar 2012
11 794
FR-16 angouleme
la tolerance sur la tension d'alimentation est certainement programable ... et il arrive que les parametre par defaut soit trop serré donc produisent trop facilement une erreur

premiere chose a faire trouver le parametre a modifier pour elargir la tolerance

autre chose a faire : brancher un truc pour informer emc2 d'un arret de la broche et pour qu'il arrête instantanément les avance et éviter de casser la fraise ... même si le problème de surtension est résolu , un arrêt automatique d'emc2 protègera de toute autre arrêt du moteur
 
C
Christian67
Ouvrier
13 Mai 2012
273
Kogenheim
  • Auteur de la discussion
  • #10
La broche est installée sur cette fraiseuse depuis début novembre 2016, et totalise depuis une 40ène d'heures de marche.
Rien n'a changé dans son paramétrage, sauf le fait que se soit LinuxCNC qui pilote sa vitesse et son ordre de marche (décembre 2016).
Vous pensez que l'erreur vienne d'un problème de tension de l'alimentation ?
Moi j'aurai plutôt pensé à la tension du pilotage de vitesse (d'où le terme "accelération". Les autres erreurs possibles sont "décélération overvoltage/undervoltage", "steady state overvoltage/undervoltage") mais je me trompe sans doute.

Pour informer LinuxCNC de la rotation ou non de la broche, il faut un capteur et une entrée sur la BoB. Or, je n'ai plus d'entrée disponible sur cette BoB. De plus, si la broche est à l'arrêt, c'est trop tard. Il faut informer LinuxCNC dès la baisse notable de vitesse, et ça, je ne vois pas comment faire simplement la détection.
 
osiver
osiver
Compagnon
7 Sept 2013
12 043
Moi j'aurai plutôt pensé à la tension du pilotage de vitesse (d'où le terme "accelération". Les autres erreurs possibles sont "décélération overvoltage/undervoltage", "steady state overvoltage/undervoltage")
Ce n'est pas ça, le sens. Pour résumer simplement, ça concerne ce qu'il se passe sur les sorties du variateur lors des changements de régime. Le plus souvent lors d'une décélération avec une inertie importante, le moteur se comporte comme un générateur.
Par contre votre remarque suggère quelque chose. Comment sont commandés la vitesse et la mise en route de la broche ? Il se pourrait que des "parasites" génèrent des a coups dans la commande. La reprise avant arrêt peut être un point délicat avec les variateurs.

Encore une fois, vous devriez nous poster les paramètres.
Pour informer LinuxCNC de la rotation ou non de la broche, il faut un capteur et une entrée sur la BoB. Or, je n'ai plus d'entrée disponible sur cette BoB.
Ce n'est sans doute pas la cause du souci mais se protéger d'un arrêt intempestif est une bonne chose.
Pour le capteur, il est possible d'utiliser un des contacts du relais d'état du variateur avec le paramètre adéquat.
Pour l'entrée sur la BOB, il faudrait éventuellement inclure le relais de sortie du var dans une chaîne de butées hardware. Mais il faudrait en savoir plus sur cette machine et son câblage/configuration.
 
C
Christian67
Ouvrier
13 Mai 2012
273
Kogenheim
  • Auteur de la discussion
  • #12
Merci pour ces explications.
Ce matin, 1 heure de fraisage, et pas de soucis.
La mise en route de la fraiseuse se fait via un relais commandé par la Bob, et la vitesse via un convertisseur fréquence/tension. La fréquence est prise sur une sortie de la BoB, la tension générée (0-10v) vient en entrée de l'inverter. L'inverter est programmé pour prendre en compte ces deux moyens de pilotage.
Comme dit, je n'ai jamais eu de problème à part hier, à 2 reprises.
Si effectivement, les messages d'erreur concernent des sur ou sous-tension de l'alimentation, on ne peut rien y changer.
 
osiver
osiver
Compagnon
7 Sept 2013
12 043
La mise en route de la fraiseuse se fait via un relais commandé par la Bob, et la vitesse via un convertisseur fréquence/tension. La fréquence est prise sur une sortie de la BoB, la tension générée (0-10v) vient en entrée de l'inverter
Ça semble OK.
Pour moi, ce serait en tout cas une bonne chose de stopper la machine en cas de défaut du variateur :wink:
 
Haut