1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Décalage dans les déplacements

Discussion dans 'Mach' créé par Renald, 30 Janvier 2016.

  1. Renald

    Renald Nouveau

    Messages:
    33
    Inscrit:
    30 Janvier 2016
    Décalage dans les déplacements
    Bonjour, j'ai installé la version de mach3. J'ai configuré les moteurs pas à pas

    avec l'utilitaire du logiciel Référencement des axes pour trouver

    mon bon pas pour les déplacements. J'ai obtenu comme résultat pour l'axe des X : un pas de 79,2079 avec une vitesse de déplacement de 1999,8 et une accélération de 90 et le délais de direction est à 5.

    J'ai fait un petit fichier .tap que je fais exécuter avec mach3.

    Mon fichier fait en sorte que l'axe des X se déplace sur une distance de 300mm

    et le répète 500 fois.

    J'ai placé une règle sur la table de mon CNC pour vérifié que le déplacement est correct.


    Ce qui se produit à l'occasion c'est que mon axe peut aller plus loin que 300mm

    et ne pas revenir sur le point de départ de ma règle. Ou le déplacement ne se rend pas

    à 300mm et revient en dehors du point de départ de ma règle. il y a un décalage.


    Ce que je trouve sur internet c'est que ce qui se produirait c'est que j'aurais une perte

    de pas. Pourtant mon pas a été configurer par mach3 comme mentionné plus haut.


    J'ai comme driver des DM860A et j'ai ajuster les pulsations de celui-ci à 400.


    J'utilise un ordinateur avec un processeur de 2GHZ et 2 Gig de Ram,


    J'utilise des vis sans fin avec un pas de 5mm.


    Selon vous que dois-je faire ou vérifier pour qu'il ne se produise plus de perte de pas?


    Si vous avez besoin d'informations supplémentaire cela va me faire plaisir de vous les transmettre.


    Rénald
     
  2. bequet gilles

    bequet gilles Compagnon

    Messages:
    778
    Inscrit:
    21 Mai 2012
    Localité:
    Cergy Pontoise
    Décalage dans les déplacements
    bonjour

    ça peux etre une perte de pas mais avant verifie que ta vis a bille est bien bloquée en translation car dans ce cas il y a
    peut etre un peu de jeu auquel viendrait peut etre s' ajouter la flexibilité longitudinale de l' amortisseur de couple si
    tu en as installé un.

    a+ gilles
     
  3. Renald

    Renald Nouveau

    Messages:
    33
    Inscrit:
    30 Janvier 2016
  4. Renald

    Renald Nouveau

    Messages:
    33
    Inscrit:
    30 Janvier 2016
  5. bequet gilles

    bequet gilles Compagnon

    Messages:
    778
    Inscrit:
    21 Mai 2012
    Localité:
    Cergy Pontoise
    Décalage dans les déplacements
    re

    a quelle vitesse d' avance travailles tu? est ce qu' a une vitesse plus faible tu as toujours ces ecarts ,
    une vitesse de pres de 2000 avec des pap ça commence a etre eleve qu' as tu comme moteurs?

    a+ gilles
     
  6. Renald

    Renald Nouveau

    Messages:
    33
    Inscrit:
    30 Janvier 2016
    Décalage dans les déplacements
    Merci pour la réponse. Mes moteurs sont des Stepper Motor Nema 23 425oz.
    Je travaille maintenant avec à une vitesse d'avance de 1250mm/min.
    à cette vitesse de déplacement j'ai encore le problème.

    Rénald
     
  7. Renald

    Renald Nouveau

    Messages:
    33
    Inscrit:
    30 Janvier 2016
    Décalage dans les déplacements
    Les fils qui acheminent le 12Volt à mon contrôleur du moteur (DM860A) ne sont
    pas blindé. Est-ce qu'il y une possibilité que cela influence les fréquences?
    Mais pour tous les axes je n'utilise pas de fils blindé et je n'ai pas de problème
    avec l'axe de Y et l'axe des Z.

    Rénald
     
  8. bequet gilles

    bequet gilles Compagnon

    Messages:
    778
    Inscrit:
    21 Mai 2012
    Localité:
    Cergy Pontoise
    Décalage dans les déplacements
    re bonsoir

    j' ai blindé mes fils quand je suis passé en 48 volts avant (en 24v) je n' avais pas de pb ,les parasites me déclenchaient
    des interruptions de fin de course mais jamais de perte de pas.
    mes contrôleurs sont des 2m542 ils supportent jusqu' a 50v ,je ne sais pas ce que les tiens peuvent supporter comme tension ,sur internet il semblerait que tes controleur de moteurs (dm860 ) sont fait pour travailler entre 24 et 80v et tu dis
    " le 12Volt à mon contrôleur du moteur (DM860A) " dans cas meme si tu a bien reglé ton courant il manque peut etre de couple ,

    a+ gilles
     
  9. Renald

    Renald Nouveau

    Messages:
    33
    Inscrit:
    30 Janvier 2016
  10. Renald

    Renald Nouveau

    Messages:
    33
    Inscrit:
    30 Janvier 2016
    Décalage dans les déplacements
    Mon problème de dépassement est occasionnel. Je peux faire des gravures qui demande 8 heures d'usinage et je n'ai pas de problème. D'autre fois je fais des gravures de 1 heure et il se produit un décalage. Je ne comprend pas du tout ce qui peut occasionné ce décalage ou perte de pas.
    J'ai fabriqué 2 CNC et le problème se retrouve sur les 2 CNC.
     
  11. Renald

    Renald Nouveau

    Messages:
    33
    Inscrit:
    30 Janvier 2016
    Décalage dans les déplacements
    Dans mon message précédent je mentionnais que j'ai fabriqué 2 CNC. Un a comme matériel:
    1. 4 pcs Nema 34 stepper motor 1600 oz.in bipolar

    2. 4 pcs Stepper Driver DM860A Up to7.8A, 24-80VDC, DM860A

    3.4 pcs Power Supply 350W-60VDC

    4. 1 pc Breakout Board

    Et l'autre a comme matériel:
    1. 3 PCS Nema 23 Stepper Motor dual shaft with 425oz-in holding torque.

    2. 3 PCS Stepper Driver DM542A replacing M542.

    3. 1 PCS Power Supply-----350W,36VDC,9.7A.

    4. 1 PCS DB25 Breakout Board

    Et j'ai le même problème sur les 2 CNC.

     
  12. biscotte74

    biscotte74 Compagnon

    Messages:
    2 382
    Inscrit:
    28 Novembre 2012
    Localité:
    Annemasse
  13. bequet gilles

    bequet gilles Compagnon

    Messages:
    778
    Inscrit:
    21 Mai 2012
    Localité:
    Cergy Pontoise
    Décalage dans les déplacements
    bonjour

    si tu as le pb sur tes 2 machines et que c' est aléatoire (est ce que c" est vraiment aléatoire? ) ça devient difficile a analyser.
    est ce que c' est en réalisant la même piece sur tes 2 machines dans ce cas on pourrait suspecter
    un pb dans le programme .
    était tu présent lors du phénomène parce que sur ma cnc quand il y a une perte de pas cela s' entend .
    désolé mais dans l' immédiat je n' ai pas d' idée précise je reflechis.

    a+ gilles
     
  14. Renald

    Renald Nouveau

    Messages:
    33
    Inscrit:
    30 Janvier 2016
    Décalage dans les déplacements
    le phénomène se produit sur différentes gravures. Les CNC ne sont pas chez-moi les 2. Un est
    chez une amie. Hier j'étais chez mon amie et je fesais un test sur une gravure de 40 minutes
    et le décalage c'est produit à 4 reprises.sur 4 pièces différentes mais jamais au même endroit.
    Après le deuxième décalage j'ai fait une pièce sans problème et les 2 pièces suivante il y a eu un décalage.

    Je te remercie du temps que tu me consacre.

    Rénald
     
  15. Renald

    Renald Nouveau

    Messages:
    33
    Inscrit:
    30 Janvier 2016
Chargement...
Articles en relation
  1. blacline
    Réponses:
    3
    Affichages:
    1 664
  2. calagan57
    Réponses:
    18
    Affichages:
    631
  3. jejeaudio
    Réponses:
    70
    Affichages:
    2 592
  4. c.phili
    Réponses:
    9
    Affichages:
    397
  5. biscotte74
    Réponses:
    1
    Affichages:
    354

Partager cette page