reglage Fusion 360 et CNC

dji54
Nouveau
31 Août 2019
10
  • Auteur de la discussion
  • #1
Bonjour à tous,

je suis novice dans le monde de la Cnc.
j'ai acheté un Cnc 3018 pro et je rencontre un problème.
Lorsque je crée avec fusion 360 une étape d'usinage (photo 001),
fusion me dit que l'étape 2 par exemple durera 1h50 environ or quand le lance le G-code dans Grblcontrol Candle (Bcnc plante sur mon pc portable).
il me dit que ça va durée 1h15 et met en faite 3h13 pour faire cette étape.(photo 002).

je cherche donc à savoir comment réglée tous ça et avoir des estimations de temps plus juste.

j'ai fait des captures d'écran de ma config.

Réglage de l'outil dans fusion 360 (photo 003)
Grblcontrol Candle (photo 004)
paramètre de grb l'photos 005)
les réglages Machine dans Fusion 360 (photos 006 à 018)

je ne comprend où je me suis tromper.

Merci de votre aide

001.jpg


002.jpg


003.jpg


004.jpg


005.jpg


006.jpg


007.jpg


008.jpg


009.jpg


010.jpg


011.jpg


012.jpg


013.jpg


014.jpg


015.jpg


016.jpg


017.jpg


018.jpg
 
zygo4619
Nouveau
15 Août 2014
47
correze
Bonjour,

Dans la photo 6, onglet kinetics, il faut définir les vitesses max de chaque axe, les valeurs sont elles bonnes ?
Dans la photo 14, machining time, il faut régler le temps de changement d'outil en fo,ction de celui de la machine

Chez moi, les calculs de temps sont assez proches de la réalité de cette manière

en espérant t'avoir aidé
 
MegaHertz
Compagnon
31 Août 2017
929
Bonjour,

Plus du double du temps ? C'est vraiment surprenant.

Tu devrais tester les avances sur la console de contrôle :
G01 F10 X30

Vérifies que ta machine parle bien en millimètres et que le déplacement soit relatif.
Normalement ta machine devrait mettre 3 minutes pour ce déplacement.
3 minutes c'est long mais ça te permet une évaluation assez précise s'il y'a erreur.

Est ce que tu as beaucoup de trajets en G0 ?
Comme dit zygo, il faudrait que la vitesse maxi définie soit celle du G0 et là grbl et Fusion devraient te donner les mêmes temps.

Dans Fusion tu peux lui interdire le G0 et lui définir une vitesse maxi.
Il y'a deux intérêts à le faire :

1/ L'énergie c'est 1/2 de mV2.
En réduisant un peu la vitesse à vide on réduit beaucoup les risques de sauter des pas quand il y'a de la masse sur la table.

2/ Un G01 se fait en interpolé alors qu'un G00 se fait à la vas y que je te pousse
Avec un G0 on peut avoir des collisions pas prévues parce que rien ne garantit que la machine aille en ligne droite.
 
MegaHertz
Compagnon
31 Août 2017
929
Je suis au travail, je ne peux pas lancer Fusion.
De mémoire c'est dans les settings de chaque étape d'usinage.
 
franck67
Compagnon
22 Décembre 2011
1 040
Je suis au travail, je ne peux pas lancer Fusion.
De mémoire c'est dans les settings de chaque étape d'usinage.
je vais jeter un oeil , merci

edit : je n'ai pas trouvé , j'attends donc que tu puisses lancer fusion afin de me renseigner , merci
 
Dernière édition:
zygo4619
Nouveau
15 Août 2014
47
correze
Je ne sais pas si c'est de ça que parle Megahertz, mais dans certaines stratégies de parcours, tu as une case a cocher ou pas "allow rapid ract", qui autorise les retraits d'outils en G0, voir photo :

allow retract.jpg
 
franck67
Compagnon
22 Décembre 2011
1 040
ca je connais , si c'est ca alors ok ce n'est pas ce que j'esperais
 
CNCSERV
Compagnon
27 Décembre 2007
4 984
FR-28360
Bonjour,
Avec des accélérations à 30mm.s-² ce n'est pas surprenant. L'accélération a une influence directe sur la vitesse en courbe.
 
MegaHertz
Compagnon
31 Août 2017
929
Bonjour,

J'ai failli oublier...
C'est dans le dernier onglet des réglages d'une OP : High feed rate mode
Quand j'avais un étau bien lourd sur la machine je mettais Always use high feed qui remplace tous les G0 par des G1 et permet de définir la vitesse.
Comme l'a mentionné Zigo, il faudra également décocher Allow rapid retract si tu veux être sûr qu'il n'y ait aucun G0 en Z.

Sans titre.png
 
MegaHertz
Compagnon
31 Août 2017
929
Si tu connais un peu la programmation C ou javascript il y'a encore plus radical :
Remplacer dans le postproc les endroits ou on ajoute du G0 par des G01 F1000 (ou la vitesse que tu veux)

Dans la définition machine tu inscris que 1000 est la vitesse maxi et là tu n'auras vraiment que du G01 partout même si tu oublies de faire les réglages.

Méfies toi des Leads et Transitions.
Ces petits arrondis ne servent pas toujours mais quelquefois ça génère des collisions non détectées.
Jettes toujours un oeil à la simulation de près avec la vue du brut : ça évite les mauvaises surprises sur les entrées et sorties d'outil.
 
dji54
Nouveau
31 Août 2019
10
bonjour à tous,
effectivement fusion ne semble pas prendre en compte les accélérations et décélérations.
ma Cnc étant petite et lente j'ai mis le machining time à 70% et là les temps sont plus dans le réel.
Je vais attendre que Autodesk re-travaille les estimations de temps en prenant bien tous les paramètres en compte.
merci à tous pour votre aide.
 
dji54
Nouveau
31 Août 2019
10
Bonjour,
Avec des accélérations à 30mm.s-² ce n'est pas surprenant. L'accélération a une influence directe sur la vitesse en courbe.
comment on fait pour calculer le paramètres d'accélération? je peux l'augmenter sans risque?
 
Haut