carte NVCM 5 axes controle des sorties

  • Auteur de la discussion geronimos
  • Date de début
G
geronimos
Nouveau
4 Fev 2020
6
  • Auteur de la discussion
  • #1
Bonjour,
Je suis nouveau sur le forum et dans la fabrication de machine cnc.
Je suis en train de fabriquer une découpe palma cnc en 2500x1250.
La partie fabrication est terminée. Je viens de recevoir ma carte NVCM5V2.1. La connexion des moteurs et de entrées, je n'ai pas eu de problème.
Cependant les sorties, c'est une autre histoire!!!
Je n'arrive pas à alimenter une sortie....

1580856595781.png


Voila ma configuration. Ensuite j'utilise le code M666 qui permet d'activer la sortie 4 pendant 2s. quand je regarde la partie diagnostic, j'ai bien le voyant output2 qui clignote pendant 2s, mais je n'ai aucune tension de sortie.... et j'en peux plus...

Je dois oublier quelque chose. Quelqu'un peut m'aider svp.
Cordialement
 
G
geronimos
Nouveau
4 Fev 2020
6
  • Auteur de la discussion
  • #2
Bonjour,
Je réponds a ma propre question! J'ai enfin trouvé!!!!
Enfaite j'ai pris le manuel du NVEM qui complète celui du NVCM.

Dans le manuel du NVEM on trouve ça:
1580896336350.png



J'ai donc fait un montage simple avec un relais:

1580896403945.png


et les réglages de la sortie comme ça:
1580896912649.png


En lançant ma macro m666.... MIRACLE!
J'espère que ça pourra aider les autres qui galère avec ça!

Maintenant, il ne me reste plus qu'à trouver une méthode pour utiliser plusieurs sorties/relais avec la même alimentation.
Si quelqu’un a une idée je suis preneur.

1580896406277.png
 
G
geronimos
Nouveau
4 Fev 2020
6
  • Auteur de la discussion
  • #3
Voici mon montage qui marche parfaitement
1580898660880.png


J'utilise comme alimentation celle d'un pc. Elle peut produire du 12v, 5v et du 3.3v. Elles ont une masse commune.
Le 12V alimente la carte NVCM (fil bleu de la gaine rouge)
Le 5V alimente le VCC du module relais.
Et les sortie de la carte pilote les différents relais.

Exemple de ma photo : la sortie OT4 pilote le relais 7.

1580898390028.png
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 854
FR-28360
Bonjour,
Attention les sorties sont faites avec des opto-coupleurs de seulement 50mA.
Tu as raison de les relayer.
 
G
geronimos
Nouveau
4 Fev 2020
6
  • Auteur de la discussion
  • #5
Bonsoir, j'ai un nouveau problème....
Maintenant quand je branche ma carte NVCM toutes les sorties sont actives.... je n'arrive pas à les commander... avez vous eu déja le cas?
Cordialement
 
G
geronimos
Nouveau
4 Fev 2020
6
  • Auteur de la discussion
  • #6
Bonjour,
Je vierns de régler le problème. J'ai commencé avec une NVCM résultat "error de triggered"
J'ai changé pour une NVEM résultat "error de triggered" et inconnectable!
Résultat finale je renvoi ces chinoiseries pour quelques choses de plus stable.... des subjections?
 
dh42
dh42
Compagnon
4 Sept 2009
5 780
Près de St Etienne (42)
Salut,

Quelques pistes

++
David
 
Haut