temporisation avis des pros

  • Auteur de la discussion Anonymous
  • Date de début
A
Guest
  • Auteur de la discussion
  • #1
Salut, j'ai besoin d'une tempo pour ma cn, le but est de fermer un contact, via un relai pendant 2-3s lors de la mise en route de la broche.
J'ai fais un petit schéma à base de 555, mais étant novice en électronique j'aurais voulu avoir l'avis des "pros".
Le déclenchement de la minuterie se fera à l'aide du 2eme contact de mon relai de mise en marche de la broche, ce contact est appelé K1 sur le schéma. Voir la pièce jointe tempo.pdf
 
Nico91
Nico91
Compagnon
9 Mai 2009
3 411
FR-91
Salut Chris, bon c'est pas encore moi la cador en électronique qui vais te conseillé, j'en suis au même stade que toi :lol:

Je voulais juste savoir quel était le soft que tu utilisais pour tes schémas :oops:
 
W
wintereivax
Ouvrier
7 Sept 2008
340
Suisse - Vaud
Salut,

A mon humble avis ca doit être EAGLE, dont la version freeware, est limité à des pcb de 18 par 10 cm pour le plaçage des éléments et 2 couches de signaux.

Tu peux la télécharger ici

A++

Xavier
 
A
Guest
  • Auteur de la discussion
  • #4
Effectivement c'est eagle, mais je n'aime pas la dernière version, je préférais la 4, enfin c'est pas important.
Je viens de finir le montage, ça marche impeccable, j'ai juste ajouter une diode sur les bornes du relai.
Par contre quelqu'un saurait il me faire le typon, je m'en sort pas avec eagle 6.
 
W
wintereivax
Ouvrier
7 Sept 2008
340
Suisse - Vaud
Salut,

Sans problème. balance le fichier (met le dans un .zip) et oublie par les bibliothèque particulière...

Par contre niveau version il me semble que c'est la version 5.6 et pas seulement 6. ou alors je suis pas à jour ^^

A++

Xavier
 
f6bqi
f6bqi
Compagnon
26 Sept 2008
817
FR-81150
Bonsoir,
dans le schéma, la résistance de 330 lié avec une capa de 10µ ne permet pas d'obtenir 1,5 seconde
pour 1.5 seconde avec 10µ il faut une résistance de 150K.
nota: tout relais utilisé dans un montage doit avoir un dispositif de suppression (diode, transorb )
Cordialement
Michel
 
D
Diafan
Nouveau
27 Juin 2008
21
Rennes
Bonjour,

Oui, le schéma avec le 555 est bon.

Juste trois remarques:

- J'espère que ce que tu nommes "-12V" est en réalité la masse (0V). Parce qu'entre -12V et +12V il y a 24V, tension supérieure à celle que supporte le 555.

- Je mettrais une diode (cathode vers le +12V) sur la bobine du relais pour atténuer la surtension générée à la coupure de la commande. Sinon, le 555 risque de mourir avant l'âge.

- Avec les valeurs du schéma (10µF et 330 ohms), la turée de la tempo est de moins de 4 mS. Il y a sûrement un loup quelque part.
Tempo en secondes = R x C x 1,1

Patrice

Edit: je n'ai pas été assez rapide. F6bqi m'a précédé!
 
A
Guest
  • Auteur de la discussion
  • #8
Merci à vous, effectivement -12v c'est en fait 0v, pour la résistance et le condo, les valeurs n'avaient pas été définies, j'ai fait avec ce que j'avais en stock, 220 uF pour le condo et 1.5k (je suis plus sûr,j'ai fais plusieurs essais..) pour la résistance, j'ai aussi mis une diode sur la bobine du relai.
Pour le typon, merci de ta proposition, mais j'ai fini par tout câbler sur une plaque d'essai, en tout cas merci Wika58 pour avoir fais les essais, cela marche super bien et c'est suffisamment petit pour entrer dasn le boîtier de commande, pour le coup entre la minuterie, le relai de démarrage, la commande du compte-tout et l'éclairage, c'est plein comme un oeuf.

Dernier point, on peut simplifier la minuterie, j'ai viré la partie commande par le contact du relai.Les fils sont soudés ensembles et la remise à 0 se fait par coupure du 12v de l'alim.
 
A
Guest
  • Auteur de la discussion
  • #9
2 photos de la "bête" terminée, bon c'est sûr que cela mériterais un montage sur CI, mais j'ai fais avec les moyens du bords, à la rentrée, si j'ai le temps je ferais peut être quelque chose de plus "pro".

Donc on voit le relai translucide qui alimente le moteur, le relai bleu est le relai temporisé, les fils du potentiomètre se raccordent sur le bornier bleu, la prise avec les fils marron et rouge est l'alim 12v et enfin les fils marron et bleus avec les cosses isolées vont sur le moteur de la fraiseuse.

Pour résumer le fonctionnement, au démarrage de la fraiseuse, via la carte de mdog et du logiciel mach3, le relai temporisé ferme les contact de marche/arrêt du potar de la X2 pendant 2 s, cela permet de démarrer à une vitesse déterminée sans que la carte se mette en sécurité, c'est utile sur mach3 quand on utilise l'option "multipasses" car pour se servir de cette fonction on est obligé d'insérer un code M30 juste avant la fin du programme ,et le M30 a pour fâcheuse habitude d'éteindre la broche, avec cette carte plus de soucis au redémarrage du cycle suivant

t_001_179.jpg


t_002_682.jpg
 
W
wintereivax
Ouvrier
7 Sept 2008
340
Suisse - Vaud
Salut,

Je dois prochainement faire un lot de PCB en double couche au labo de mon uni. Apparemment le tien à l'air d'être "simple".

Si tu arrives à mettre un pdf (menu impression d'eagle, puis réglage et enfin clique sur le 3ème bouton, "PDF...", pour enregistrer directement en PDF), je peux surement trouver un petit bout de plaque où caser ton modèle. Enfin à toi de voir ^^

A bientot,

Xavier
 
f6bqi
f6bqi
Compagnon
26 Sept 2008
817
FR-81150
Bonjour chris74,
Pour vous rassurer concernant la méthode de circuit imprimé que vous avez utilisée. je l'ai toujours utilisé à mon travail et pour moi pour des prototypes ou des exemplaires uniques et ceci sans problèmes. Les capacités parasites de câblage sont moindres que sur un PCB et le temps de passage entre l'étude au circuit fini est très rapide.
Nota: Au lieu de décaper les fils pour les souder, il est préférable d'utiliser du fil pour "wraping" qui permet de souder directement le fil sans le décaper en mettant le bout de la panne directement sur le point à souder.
Cordialement
Michel

carte_ci 001.jpg


carte_ci 002.jpg
 
A
Guest
  • Auteur de la discussion
  • #12
wintereivax a dit:
Salut,

Je dois prochainement faire un lot de PCB en double couche au labo de mon uni. Apparemment le tien à l'air d'être "simple".

Si tu arrives à mettre un pdf (menu impression d'eagle, puis réglage et enfin clique sur le 3ème bouton, "PDF...", pour enregistrer directement en PDF), je peux surement trouver un petit bout de plaque où caser ton modèle. Enfin à toi de voir ^^

A bientot,

Xavier
Une telle proposition ne se refuse pas, je mets le pdf enligne, merci à toi.

f6bqi quand j'aurais la même dextérité que toi pour monter des circuits sur plaques d'essai, c'est sûr que je pourrais me passer de pcb.............j'en suis malheureusement encore pas là et ma plque fait quand même très "brouillon" Voir la pièce jointe pcb tempo.pdf
 
W
wintereivax
Ouvrier
7 Sept 2008
340
Suisse - Vaud
chris74 a dit:
wintereivax a dit:
Salut,

Je dois prochainement faire un lot de PCB en double couche au labo de mon uni. Apparemment le tien à l'air d'être "simple".

Si tu arrives à mettre un pdf (menu impression d'eagle, puis réglage et enfin clique sur le 3ème bouton, "PDF...", pour enregistrer directement en PDF), je peux surement trouver un petit bout de plaque où caser ton modèle. Enfin à toi de voir ^^

A bientot,

Xavier
Une telle proposition ne se refuse pas, je mets le pdf enligne, merci à toi.

f6bqi quand j'aurais la même dextérité que toi pour monter des circuits sur plaques d'essai, c'est sûr que je pourrais me passer de pcb.............j'en suis malheureusement encore pas là et ma plque fait quand même très "brouillon"
Salut,

J'allais partir imprimer les PCB ce matin, quand je suis arrivé devant l'atelier : quelle ne fut pas ma surprise de voir un sympathique panneau "nous sommes en vacances" ! Bref l'atelier est fermé jusqu'au 17 aout ! En tout ca va leur faire 1 mois de vacances ! J'en reviens pas.

Je suis désolé de t'avoir proposé quelque chose que je ne peux malheureusement pas immédiatement faire. Si ça te va d'attendre 2 semaines, je te les fabrique & envoie le 17 sans fautes, promis-juré. D'ailleurs si entre-temps tu as dessiné un nouveau PCB, hésite pas à l'envoyer...

A++

Xavier
 
A
Guest
  • Auteur de la discussion
  • #14
Pas de soucis, je suis aussi en vacances pendant la même période, je te recontacte dès mon retour le 16 août.
 
W
wintereivax
Ouvrier
7 Sept 2008
340
Suisse - Vaud
Salut,

Et voila le fin mot de la fin, ou plutot la photo ^^

La suite en MP pour l'adresse de l'envoi.

A++

Xavier

temporisation.JPG
Et voila les 2 PCBs
 
A
Guest
  • Auteur de la discussion
  • #17
Bon j'ai assemblé le circuit hier, et ça n'a pas marché..............curieux ,le prototype fonctionnait parfaitement.Après quelques recherches j'ai réussi à le faire fonctionner, mais je ne m'explique pas pourquoi, je livre la solution, si des balaises en électronique pouvaient m'éclairer.

De plus les pistes que j'ai déssiné sont trop fines pour la partie 220v, lors d'un démarrage à pleine charge elles ont fondu, donc prévoyez plus gros en section ou faite comme moi, doublez les avec un fil.D'une façon générales, mes pistes sont trop fines, on peut facilement les agrandir ,surtout qu'il y a de la place, les soudures en seront facilitées.

Je rappelle le fonctionnement:
-ordre de mise sous tension de la broche via la touche F5 ( sous mach3) du clavier
-envois du 12vf sur la carte
-les 2 relais se collent
-le relais temporisé se soupe au bout de 2 à 3 s, le temps que la broche est démarrée.Le rôle de ce relai est de shunter la sécurité de sur intensité de la carte lors du démarrage.
-lorsqu'on arrête la broche via le pc ou le programme, la disparition du 12v doit couper les 2 relais, et tout doit pouvoir se remettre en route sans autre manip

tempo.jpg
le circuit qui ne fonctionne pas

tempo modif.jpg
le circuit modifié
 
A
Guest
  • Auteur de la discussion
  • #18
J'ai aussi remarqué autre chose, c'est que si l'arrêt d'urgence est percuté, puis relaché, la broche s'arrête, normal, il est aussi possible de redémarrer via le pc sans avoir besoin de remettre le potentiomètre à 0, normal aussi car on shunte les sécurités de la carte, par contre lors de cette manip, la broche redémarre progressivement, et non d'un coup comme lorsqu'on fait un arrêt "normal", via le programme, sans toucher a l' A-U. L'idée m'est donc venu de brancher l'A-U sur le contact inutilisé du relai de puissance.
Ainsi tous les démarrages se font en douceur.

tempo modif 2.jpg
Avec démarrage progressif
 
f6bqi
f6bqi
Compagnon
26 Sept 2008
817
FR-81150
bonjour,
Pouvez vous me confirmer que :
au repos => pas de tension +12V sur la carte
en fonctionnement => alimentation de la carte ?

Maintenant à quoi sert le condo sur la pin 2 du 555

Michel
 
jcma
jcma
Compagnon
2 Nov 2008
1 658
Mulhouse - Haut-Rhin
Bonjour,

chris74, ton strap (en rouge) semble curieux, il court-circuite l'alimentation.

Je comprend le schema ainsi:
La borne 2 est la borne de declenchement. En la mettant a la masse on declenche la temporisation. A la mise sous tension le condensateur est decharge = cour-circuit. La temporisation demarre. Le condensateur va se charger et empecher une nouvelle temporisation lorsque le delai est ecoulé.

@+
Jean-Charles
 
A
Guest
  • Auteur de la discussion
  • #21
Pour jcma, effectivement tu as raisons, j'ai pas dessiné le strap au bon endroit :oops: :oops:
Je joint la photo modifiée.
f6bi, effectivement au repos pas de tension, en fonctionnement présence du 12v, pour le condo, pas la moindre idée, je n'ai fais que recopier des schémas de tempos trouvés sur le net.
Ne pas tenir compte non plus des polarités des condos, seul Es1 est polarisé c'est un chimique de 220uf, Es2 et Es5 sont des 10nf.

Normalement, le 1er schéma est le bon, il a d'ailleurs parfaitement fonctionné sur le prototype, le 2eme schéma avec le pont à la masse est sensé "retarder" l'ouverture du relai à la disparition du signal sur la pin 2, c'était pas ce qui m'intéressais, j'ai dû faire une erreur sur le typon ou quelque chose dans le genre.................
tempo modif.jpg
 
f6bqi
f6bqi
Compagnon
26 Sept 2008
817
FR-81150
je confirme ce qu'a écrit JCMA la commande de trigger se fait par un front descendant.
Le montage risque de fonctionner de façon erratique car la tension d'alimentation du 555 n'est pas fixée et le pulse sur la patte 2 est trop court.
Le schéma original est correct. le contact du relais tire à la masse la capa pour générer l'impulsion et décharge la capa au repos .
michel
 
A
Guest
  • Auteur de la discussion
  • #23
f6bqi a dit:
je confirme ce qu'a écrit JCMA la commande de trigger se fait par un front descendant.
Le montage risque de fonctionner de façon erratique car la tension d'alimentation du 555 n'est pas fixée et le pulse sur la patte 2 est trop court.
Le schéma original est correct. le contact du relais tire à la masse la capa pour générer l'impulsion et décharge la capa au repos .
michel
Le seul pb c'est que le schéma original ne fonctionne pas avec le typon que j'ai dessiné.............une idée pourquoi ?

J'ai fais une vingtaine d'essai, et aucun loupé, coup de chance ?
 
jcma
jcma
Compagnon
2 Nov 2008
1 658
Mulhouse - Haut-Rhin
Bonsoir,

f6bqi a raison, le probleme vient surement de la valeur du condensateur C1.
J'ai simulé ton circuit modifié avec LT Spice en utilisant 12K pour R1 et 220uF pour C2 (Pour avoir les 3s de tempo). La tempo ne demarre a la mise sous tension que lorsque l'on utilise un valeur de C1 superieure a 10nF (11nF pour ma simulation).
D'apres mes simulations, il faut que ce condensateur soit d'un valeur superieure a celui qui est branché sur la borne 5-CON (C3 sur ton schema), pour que cela marche.

Ton premier schema devrais lui aussi marcher, j'ai reverifié les typons par rapport a ton premier schema et je n'ai pas trouvé d'erreur.

@+
Jean-Charles
 
A
Guest
  • Auteur de la discussion
  • #25
Ok je vous remercie de vous interreser à mon pb, encore une question, la valeur de 11 nf est elle impérative ou est ce que je peut prendre plus haut ? Parce que j'ai juste un petit magasin d'électronique par chez moi et je sais pas si il aura.

J'ai aussi trouvé un autre schéma ou il est indiqué 10nf pour C3 et 1 nf pour C1....................
 
f6bqi
f6bqi
Compagnon
26 Sept 2008
817
FR-81150
bonjour,
La valeur de 11nF est théorique et ne signifie juste qu'un élément de calcul.
La valeur à prendre pour moi est de 0.1µF.
Ci joint le schéma que je ferais si j'avais eu ce problème à résoudre. il faut prendre en compte le temps de mise en fonctionnement du 555
Je ne suis pas un fana du 555 pour faire ce genre de manip et préfère de loing les ci serie HCmos qui ont une grande immunité aux parasites en utilisation industrielle.
Bonne journée
Michel

mono_555.GIF
120K+22µF =2.9S
 
jcma
jcma
Compagnon
2 Nov 2008
1 658
Mulhouse - Haut-Rhin
Bonjour,

Oui, la valeur de 11nF est théorique, c'etait juste pour dire que C1 doit etre superieur a C3.

J'ai compris ce qui se passe en regardant le schéma interne du 555. Le condensateur C3 est en entrée du comparateur qui déclenche la temporisation. Avec les valeurs du schéma, a la mise sous tension il faut environ 0.25ms pour que celui ci soit opérationnel. Le condensateur C1 se chargeant plus vite que lui, le comparateur ne voit rien et la temporisation ne démarre pas.
Le fonctionnement erratique de ton montage vient du fait que suivant la tolérance de tes composants le temps de charge de C1 peut etre bon ou pas.
Sans tout refaire, essaye simplement avec les 0.1uF (100nF) preconisé par f6bqi et qui sont largement suffisants. Autre solution, changer la resistance de 10K par une 100K, cela multiplie par 10 le temps de charge de C1.

@+
Jean-Charles
 
W
wintereivax
Ouvrier
7 Sept 2008
340
Suisse - Vaud
Hello,

Dommage que ton circuit ne fonctionne pas aussi bien que voulu.

Effectivement, pour les pistes, la meilleure solution c'est de mettre le plus possible de cuivre, surtout si tu as de l'espace.

Par contre, est-ce que le PCB ? Avec Eagle, il faut faire gaffe de pas mettre un "mirror" en trop lorsque l'on fait un PDF. Dans ton cas, il semblerait que ca ait marché au moins un moment, donc ca devrait être bon.

A++

Xavier

PS: je te redis si j'ai une place sur du cuivre lors de mon prochain passage à l'atelier...
 
A
Guest
  • Auteur de la discussion
  • #29
Alors résultat des courses.J'ai viré mon strap, remis ma résistance de 10 k, et remplacé le condo de 10nf par un de 100nf, et bien CELA MARCHE........................Encore merci pour l'aide apporté et un grand merci à wintereivax pour ces circuits imprimés.
 
J
j.f.
Compagnon
22 Déc 2007
6 443
19
f6bqi a dit:
...il est préférable d'utiliser du fil pour "wraping" ...
Je fais un petit hors sujet...

Le wire wraping avait eu son heure de gloire en électronique amateur au début des années 80. Je n'en ai plus entendu parler depuis. Ca se pratique toujours ? Je trouve que c'était presque plus pratique que les plaques à trous avec les ponts de soudure... On pouvait placer les composants où on voulait, et modifier / corriger facilement.
 
Haut