Résolu Mach3 plasma fenêtre de périphérique de sortie

  • Auteur de la discussion PseudoNyme
  • Date de début
P

PseudoNyme

Nouveau
Bonjour, j'ai un petit soucis en ouvrant Mach3 Plasma. Je vous explique, quand j'ouvre Mach3 Fraisage ou autre la fenêtre des périphériques de sortie s'affiche et je peux valider la carte que j'utilise cependant pour Mach3 Plasma cette fenêtre n'apparait pas ce qui fait que ma carte ne se connecte pas avec lui. J'aimerai savoir si vous avez déjà eu le problème et si il est possible d'afficher cette fenêtre.

Merci d'avance. PseudoNyme
 
D

dh42

Compagnon
Salut,

Vas dans le menu Function Cfg's/Reset Device Sel..., puis relance Mach3, le sélecteur de périphérique devrait apparaitre.

++
David
 
P

PseudoNyme

Nouveau
Salut,

Vas dans le menu Function Cfg's/Reset Device Sel..., puis relance Mach3, le sélecteur de périphérique devrait apparaitre.

++
David

Merci de votre aide rapide et efficace. Problème résolut. Ceci dit, une petite question, vu vos compétences ça ne devrait pas vous posez de problème dans ce domaine. Est-ce possible d'avoir un post processeur, pour CamBam, en remplacement du précédent, qui gère le palpage de la taule avant chaque début de coupe? Encore merci de votre aide si précieuse.

Cordialement. PseudoNyme
 
D

dh42

Compagnon
essais avec celui-la (prudemment, je ne peux pas le tester)

++
David
 

Fichiers joints

  • Plasma_2.zip
    768 bytes · Affichages: 4
P

PseudoNyme

Nouveau
Bonjour et merci pour le fichier je ferais l essais a la fin de la semaine car je suis en déplacement encore un grand merci je vous tiendrai au courant après exécution. Cordialement. PseudoNyme
 
P

PseudoNyme

Nouveau
Bonjour monsieur après exécution de votre fichier Jai 2 souci un double palpage avant allumage de la torche et l'arrêt de la machine a la ligne 44 (G77 H8900)merci encore de vous donner la peine de bien vouloir m'aider .Cordialement. PseudoNyme.
 
P

PseudoNyme

Nouveau
a chaque départ de coupe ou juste au début du programme ?



le code G77 est inconnu de Mach3, je ne vois pas comment CamBam pourrait sortir ce code car il ne le connais pas non plus :smt017 peut être as tu fait ton Gcode avec un autre soft ?

++
David
Bonjour Monsieur, avec votre fichier la machine exécute un double palpage uniquement au début du programme, allume la torche, exécute la découpe puis la machine s'arrête a la ligne n°44 (G77). Vu le Gcode elle exécute un seul palpage avant chaque découpe.

325310800_2415392548625625_4215377525039372429_n.jpg


325294277_683777846551261_977849395972629091_n.jpg
 
P

PseudoNyme

Nouveau
le problème du g code g77 ne viendrai pas du fait qu'il ny ai pas de petit tiret entre fin de coupe et torche off ?
 
D

dh42

Compagnon
Salut,

Bon, ça devrait être corrigé.

Il y avait bien un G77 dans le PP camBam, je ne sais pas d’où il est sorti, surement une bidouille que j'avais fait pour un autre soft de pilotage. Je l'ai viré et mis un M5 à la place (= arrêt torche)

Le double palpage au début devrait aussi avoir disparu.

++
David
 

Fichiers joints

  • Plasma_2.zip
    772 bytes · Affichages: 1
P

PseudoNyme

Nouveau
Bonjour monsieur, désolé de vous déranger a nouveau, problème avec le 2m fichier après création du gcode et envoie du fichier sur mach3 le gcode défile et sarrète ( photo mach3 ci jointe) et pas de figure a l'écran ,impossible d'exécuter le fichier ,alors que avec le fichier précédent la figure affichais bien juste le default de double palpage et g77 encore grand merci de m aider .Cordialement

325188767_856877235424580_4563384817644803817_n.jpg


324748946_3271295449848295_8047436716314067002_n.jpg


325025403_3292955524294461_1489235355807576562_n.jpg


325317243_3300346903609640_954616065198354714_n.jpg
 
D

dh42

Compagnon
re

OK, il manque la définition du mode d'arc utilisé ; 3ieme mouture en PJ :wink:

++
David
 

Fichiers joints

  • Plasma_2.zip
    814 bytes · Affichages: 1
P

PseudoNyme

Nouveau
bonjour monsieur merci pour le fichier je l exécute demain matin 6h et vous tiens au courant .cordialement
 
D

dh42

Compagnon
Sur la CN un dimanche dès 6h00 du mat ! ... ça c'est de la passion ! :lol: à 6h00, moi je serais à peine couché ! .. il est 23h30 et je n'ai même pas encore mangé (ni fait la bouffe, ce qui est pire !)

PS, oubli le "monsieur" :wink:

++
David
 
P

PseudoNyme

Nouveau
Bonjour,David plus on avance dans l âge plus on se lève de bonne heure je passe 90% de mon temps libre dans mon atelier .sans aucune prétention de ma pars j ai fabriquer toutes les machines qui constitue mon atelier (cnc ,tour a métaux ,tour a bois, cintreuse a profil ,table de souage rotative ,bakstand ,potence de levage .....etc la liste est très longue en faite je fabrique les machines dons jais besoins ce fait 40ans que je fabrique confectionne invente rénove répare presque touts sais la réputation que j ai dans mon petit village de campagne. mais dans la programmation je suis nul et ce même avec une formation robos Fanuc .Ce ci dit jais exécuté le fichier le problème est identique au précèdent désoler .Cordialement ,merci encore pour votre aide. Bon dimanche.
 
D

dh42

Compagnon
Re

Avec un réglage différent pour les arcs (tolérances)

attention j'ai changé le nom du PP, donc il faudra aussi le re-sélectionner dans ton fichier Cambam.

++
David
 

Fichiers joints

  • Plasma_3.zip
    814 bytes · Affichages: 1
P

PseudoNyme

Nouveau
Bonjour David, après avoir resélectionner le dossier et exécuté il semblerais ne plus avoir la partie de palpage avant caques début de coupe photos ci jointe. Merci cordialement.

316341894_3385289111729459_5559233048114770248_n.jpg


321069568_751622569967048_5926927951297869410_n.jpg
 
D

dh42

Compagnon
au vu de ta capture, il est certain que tu n'a pas sélectionné le bon post pro, apparemment c'est le PP fraisage par défaut.

tu dois sélectionner le PP Plasma_3 dans le dossier usinage, et comme tu peux voir sur la photo, le nom du PP est indiqué sur la 2ième ligne du Gcode, ce qui permet de vérifier si on utilise le bon PP.

Sans titre-1.jpg

++
David
 
P

PseudoNyme

Nouveau
le programme défile dans mach3 et s arrête ligne59 la photo avec la ligne 4 ces jute pour te montré le pospro3

325665304_904311997407401_643246837476489391_n.jpg


325607107_1246677482725717_232701362620600081_n.jpg


325868652_1605309699898395_3337885436616138258_n.jpg


325293276_1209317153328403_3588427560862759518_n.jpg
 
D

dh42

Compagnon
il faudrait que tu mettes ton fichier cambam (le .cb) et le fichier Gcode (.nc) de ton image, car la, je ne vois pas ou est le pb. Apparement c'est toujours un G3 qui le défrise, mais il semble avoir passé les autres en début de Gcode.

compresse les en .zip pour que le forum les accepte.

++
David
 

Sujets similaires

M
Réponses
14
Affichages
467
Mika2A
M
M
Réponses
53
Affichages
11 828
marcelou_bidou
M
D
Réponses
22
Affichages
19 187
ktm63
K
Haut